Subject: Question on Request message COPS-PR

From: "vijains" <[email-masked]>
Date: Wed, 25 Apr 2001 08:54:49 -0400

Hello,

 This question is regarding the Request Message in COPS-PR.

Q.When does the question of sending clientSI array arrise ?Because if the PEP is sending incarnation, configuration data to the PDP, only one ClientSI object can incapsulate the whole thing.

 An extract from the COPS-PR RFC 3084-

 "The format of the information encapsulated in one or more of the COPS 
 Named ClientSI objects is described in section 5."

 <Request> ::= <Common Header>
                               <Client Handle>
                               <Context = config request>
                               *(<Named ClientSI>)
                               [<Integrity>]

 Please clarify,
 Vijai

---

From: "Iliff, Tina" <[email-masked]>
Date: Wed, 25 Apr 2001 13:48:38 +0000

Vijai,

I am not sure if I understand your question but here is some more
information.  COPS-PR does not requires 0 or more NamedClientSI objects
within the REQ message.  Therefore, the PEP may not send any NamedClientSI
objects.  Another possibility is that the PEP may encapsulate each framework
PIB Notify PRC instance in it's own NamedClientSI object.  The true answer
depends on one's PEP implementation.  Does this help at all?

Tina Iliff

		-----Original Message-----
		From:	vijains [mailto:[email-masked]]
		Sent:	Wednesday, April 25, 2001 7:55 AM
		To:	[email-masked]
		Subject:	Question on Request message COPS-PR

		Hello,

		Q.When does the question of sending clientSI array arrise
?Because if the PEP is sending incarnation, configuration data to the PDP,
only one ClientSI object can incapsulate the whole thing.

		 "The format of the information encapsulated in one or more
of the COPS 
		 Named ClientSI objects is described in section 5."

		 Please clarify,
		 Vijai