Subject: SLA concept in Intserv/RSVP

From: Nguyen Thi Mai Trang <[email-masked]>
Date: Mon, 22 Apr 2002 19:06:46 +0200

Hi everybody,

I have a question about the notion of SLA (service level agreement) in Intserv/RSVP but I don't know where to post it
because the group Intserv is no longer active.

It seems that the notion SLA was born in Diffserv architecture. The SLA is necessary because network resources are
statically provisioned. It's very clear.

In Intserv/RSVP, I don't find the SLA/SLS (service level specification) concept in all concerning draft/RFCs . I
wonder if there is no SLA/SLS concept in Intserv/RSVP, how we can make policy decision in Intserv/RSVP.

Some clarifications:
In Intserv/RSVP, client uses RSVP to request resource in the routers. The routers verify if it has sufficiently
resources (Admission control) and the user has the right to request this amount of resource (Policy control) or not.
If both are positives, it makes the resource reservation for this flow. My question is that if there is no SLA/SLS,
how the network can answer (using COPS-RSVP for example) to the question "Does this client has the right to request
such a reservation ?" ?

Thank you very much,
Mai Trang

---

From: "Rawlins, Diana" <[email-masked]>
Date: Mon, 22 Apr 2002 17:31:54 +0000

Mai,

A policy server can contain these SLA policies. When a RSVP triggers a COPS
REQUEST, from the PEP (router) to the PDP (policy server) the DECISION
returned by the PDP reflects whether the resources requested by the RSVP
message is within the SLA. 

http://ietf.org/rfc/rfc2749.txt

Another means is that the SLA policy is provisioned into the RSVP router and
the policy, if present is used during local RSVP processing.

http://ietf.org/internet-drafts/draft-ietf-rap-rsvppcc-pib-01.txt

-Diana

-----Original Message-----
From: Nguyen Thi Mai Trang [mailto:[email-masked]] 
Sent: Monday, April 22, 2002 12:07 PM
To: [email-masked]
Cc: [email-masked]
Subject: SLA concept in Intserv/RSVP

Hi everybody,

I have a question about the notion of SLA (service level agreement) in
Intserv/RSVP but I don't know where to post it
because the group Intserv is no longer active.

It seems that the notion SLA was born in Diffserv architecture. The SLA is
necessary because network resources are
statically provisioned. It's very clear.

In Intserv/RSVP, I don't find the SLA/SLS (service level specification)
concept in all concerning draft/RFCs . I
wonder if there is no SLA/SLS concept in Intserv/RSVP, how we can make
policy decision in Intserv/RSVP.

Some clarifications:
In Intserv/RSVP, client uses RSVP to request resource in the routers. The
routers verify if it has sufficiently
resources (Admission control) and the user has the right to request this
amount of resource (Policy control) or not.
If both are positives, it makes the resource reservation for this flow. My
question is that if there is no SLA/SLS,
how the network can answer (using COPS-RSVP for example) to the question
"Does this client has the right to request
such a reservation ?" ?

Thank you very much,
Mai Trang