Subject: Question on DEC message encoding for COPS-PR

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Tue, 9 Aug 2005 16:16:45 +0200

In RFC3084, sect 4.3 we have an example on how to encode
the EPD part of a DECision message for the case of
one single example table.

We're wondering how to encode it if we have a simple
base table that is extended with anotehr table.
For example the frwkBaseFilterTable and the fwrkIpFilterTable.
The latter EXTENDS the former. So in case we have an entry
that has a matching EXTENDS row in the fwrkIpFilterTable, then
in the DEC message, we need to encode the PRID and the 
EPD for the corresponding entries in both tables.

Can someone describe in the form of a figure or list of things 
that we expect to see in the DEC message?

Thanks,
Bert

---

From: "Durham, David" <[email-masked]>
Date: Tue, 23 Aug 2005 11:31:25 -0700

In the case of EXTENDS, the data of the extended table is sent as a
separate PRID and EPD pair. It should still be treated as an atomic
transaction. So the sender is responsible for providing all EXTENDed
portions of the table along with the table being extended (otherwise the
receiver will assume default values). 

< Named Decision Data: Provisioning>::= <PRID(root table)> 
                                        <EPD (root table)> 
                                        <PRID(extending table)> 
                                        <EPD (extending table)> 

Hope this helps,
-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf
Of
> Wijnen, Bert (Bert)
> Sent: Tuesday, August 09, 2005 16:17
> To: Rap-wg (E-mail)
> Subject: Question on DEC message encoding for COPS-PR
> 
>