Subject: [Rfced-future] More points to consider

From: Nevil Brownlee <[email-masked]>
Date: Sun, 19 Apr 2020 14:33:24 +1200

Hi all:

Here are a few concerns I have about the RFC Series and the RSE:

1. Should we reconsider the goals of the RFC series,
     i.e. (mostly) a historical record of consensi reached about protocols?
     I believe that the archival nature of teh RFCs is one of their
     most important features.
   However, there's always room for improvements or changes, so it is
     important that we discuss - and agree on - how such changes should
     be suggested, discussed, and (if consensus is reached) implemented.

2. RSE relationships: where does the RFC Editor fit into IETF
     wrt the IAB, RSOC and the RPC (RFC Publication Centre)?
     Several posts to this lists have already touched on this,
     it's certainly one of the most important topics for the
     rfced-futures program.

3. IETF streams are the source of RFCs to be published.
     We currently have four streams (IESG, IRTF, Independent and IAB),
     each stream is responsible for developing Internet Drafts, deciding
     when consensus on them is reached, and when they've reached a state
     which will not cause lots of avoidable work for the RPC.
   At each IETF meeting since 2011 there's been a meeting of the
     Stream Managers.  Those meetings discussed whether each stream
     had any problems in its interactions with the RSE and RPC,
     and whether they had any suggestions for any changes in the
     way RFCs were published.  Clearly the Stream Managers meetings
     are already the obvious setting for such discussions.
  The notion of producing 'overview' documents for various protocols
    (e.g. TCP and DNS) appears fairly often.  I believe that such
    documents should be produced (and maintained) by the Managers
    of the relevant Stream -for IETF protocols that would be the IESG.
  Concerning non-native English writers, during the mid-2010s
    the RPC ran workshops for the authors of such Drafts.  They were
    much appreciated, but the RPC Staff involved reported that they
    required a lot of one-to-one discussion, and took a _lot_ ot time.

4. From time to time the RSE publishes RFCs, e.g. 8153 "Digital Preservation
     Considerations for the RFC Series," and the set of xml2rfc v3 RFCs.
     These were published in the IAB Stream, however, would it make sense
     to consider the RFC Series as a new (fifth) Stream?

Cheers, Nevil
-----------------------------------
Nevil Brownlee, Taupo, NZ

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 19 Apr 2020 10:15:51 +0100

Thanks Nevil,

I think that is helpful.

Just to clarify two points…

>     are already the obvious setting for such discussions.

I agree that communication between the stream managers is important for identifying and resolving issues before they become critical, and are helpful for setting direction.

These meetings were, I think, driven by the RSE and as far as I am aware the last time the stream managers met was by telechat in February 2019.

Of course, the stream managers have continued to communicate about various issues as necessary, there being no need to wait for a meeting in order to talk.

>    required a lot of one-to-one discussion, and took a _lot_ ot time.

Some working groups attempted to address this by setting up “language review teams” to assist non-native speakers. The MPLS WG is an example. This had mixed success.

Other document shepherds, WG chairs, and ADs took responsibility to perform or commission reviews focussing on readability and language use.

And some ADs have taken it upon themselves to return documents to working groups, pronouncing them “not good enough, yet,” and remembering that the documents are the product of the working group, not just the authors.

A

---

From: Martin J. Dürst <[email-masked]>
Date: Mon, 20 Apr 2020 10:12:04 +0900

>       it's certainly one of the most important topics for the

The mention of the RSOC here let me come up with a question: For the 
discussions here, is the RSOC in scope for discussion/proposals in this 
project or not? And to what extent?

Sorry if I overlooked something obvious.

Regards,   Martin.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 20 Apr 2020 11:17:08 +1000

I'd hope it is.

> On 20 Apr 2020, at 11:12 am, Martin J. Dürst <[email-masked]> wrote:
> 
> The mention of the RSOC here let me come up with a question: For the discussions here, is the RSOC in scope for discussion/proposals in this project or not? And to what extent?
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

--
Mark Nottingham   https://www.mnot.net/

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 20 Apr 2020 15:36:56 +1200

> I'd hope it is.

It must be. The whole question of oversight of the RFC Series, and how we prevent it descending into micro-management, is part of defining the role.

   Brian