Subject: Re: [Rfced-future] I-D Action: draft-thomson-rfced-model-01.txt

From: Brian E Carpenter <[email-masked]>
Date: Sun, 16 Aug 2020 16:25:30 +1200

Martin,

Thanks for the update.

I'm with you up to the end of Section 4. I fully agree that the *execution* of the production and publication process should continue to be contracted by the LLC, and oversight of the contract(s) is LLC business.

Then I start to disagree. Certainly, the notion that strategy and evolution should be done by a community process seems right. Using the IETF WG process seems reasonable, but we need some guarantee that all RFC Streams have a voice in that process, so I think the constitution of this community process must explicitly include a role for each stream. For clarity, I'm going to call it the RFC Series Advisory Working Group (RSAWG) from now on. I'd tend to make it a completely open group but with mandatory membership from each stream.

The previous RSE several times raised the question whether there should be an RFC Editor Stream of RFCs. There wouldn't be many such, but it would avoid the current "Band-Aid" solution of RFCs about the RFC series coming out as Informational documents from the IAB. So I suggest that we take the current opportunity for reform to add this missing series.

I do not believe that an "IAB Program" is a good basis for the strategy process. I believe it needs to be free-standing, solid in its own right, with equal ties to each entity that produces a document scheme. I believe we should relieve the IAB of this responsibility. Since the contracts will be adjudicated by the LLC, we no longer need the IAB to "approve the appointment of an organization to act as RFC Editor". Since the strategy will be set by the new RSAWG, we no longer need the IAB to approve "the general policy followed by the RFC Editor".

Since the RFC Series is a public good, the RSAWG does need an anchor and a final arbiter, and I believe we should solicit the ISOC Board for that.

One place where your model breaks is:

"The current process requires that the RFC Series Editor produce and maintain this material [the style guide]. This document proposes that the RFC Series Evolution program become responsible for ownership of this material."

I don't see how that works. Firstly, most of the expertise in developing or updating the style guide lies in the RPC. When technical (non-linguistic) questions arise, they need to consult the community (in my model, via the RSAWG). However, when linguistic or other publishing-related issues arise, they need expertise that the technical community doesn't have.

What we need, IMNSHO, is fairly clear and hasn't changed much, except that I would now call this person the RFC Series Advisor. They need expertise and experience in technical publishing. They convene the RSAWG (but it should have independent chairs). They do development work on the strategy documents. They bring their expertise to the RSAWG and to the RPC when needed. They are under a professional services contract with the LLC (which is highly unlikely to be full time).

I largely agree with what you say about tools development and support, except that IMHO the IAB has no necessary role in the picture.

Apart from that there is little point in commenting on the later parts of your draft since they are based on a structure I am strongly against. However, there is one factual error in section 8:

"This draft describes a model whereby the RFC Series Advisory Group and the RFC Series Editorial Board have no future..."

The RSEB is the editorial board for the Independent Stream under RFC8730, so it is completely out of scope here.

Regards
   Brian

On 10-Aug-20 14:39, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : A Proposed Model for RFC Editing and Publication
>         Author          : Martin Thomson
> 	Filename        : draft-thomson-rfced-model-01.txt
> 	Pages           : 16
> 	Date            : 2020-08-09
> 
> Abstract:
>    The finishing process for a document that is approved for publication
>    as an RFC currently involves a somewhat detailed and lengthy process.
>    The system that executes that process involves a number of different
>    actors, each bringing competency with different aspects of the
>    overall process.  Ensuring that this process functions smoothly is
>    critical to the mission of the organizations that publish documents
>    in the RFC series.
> 
>    This document proposes a framework for that system that aims to
>    provide clear delineations of accountability and responsibility for
>    each of the actors in this system.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-thomson-rfced-model/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-thomson-rfced-model-01
> https://datatracker.ietf.org/doc/html/draft-thomson-rfced-model-01
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-thomson-rfced-model-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 17 Aug 2020 11:27:03 +1000

Hi Brian,

I'm glad to see that we only disagree on relatively minor points.

I think that your main points are:

1. You don't want the IAB to host this.  This seems to be your principal objection.  We might need to discuss more on this point, because I'm not sure that I fully understand why you have such a strong objection.  I don't have any specific objection to asking the ISOC Board to act as a process backstop as an alternative, but I would be uncomfortable asking them to help resolve disputes as the first point of escalation.

2. You are concerned about style guide (and similar) maintenance.  I had imagined that this would follow the usual model for things that are ostensibly developed in working groups.  Those most invested in its maintenance would supply the work, but the product would be discussed and approved by the working group.  This is somewhat unique in that there are not multiple (competing) stakeholders, but I can't see how that would be a deal breaker.

3. You want to have a role for some individual in this process.  I'm opposed to that, especially if they are on the escalation path for disputes.

I think that the publication stream question is one best resolved secondarily.  If this creates a new body with new publication needs, then new streams naturally flow from that.

(I corrected the factual inaccuracy, thanks for catching that.  I got myself confused about the two bodies that advised the RSE: but it's RSAG and RSOC, not RSEB, confusing as that name is.)

On Sun, Aug 16, 2020, at 14:25, Brian E Carpenter wrote:
> Martin,
> 
> Thanks for the update.
> 
> I'm with you up to the end of Section 4. I fully agree that the 
> *execution* of the production and publication process should continue 
> to be contracted by the LLC, and oversight of the contract(s) is LLC 
> business.
> 
> Then I start to disagree. Certainly, the notion that strategy and 
> evolution should be done by a community process seems right. Using the 
> IETF WG process seems reasonable, but we need some guarantee that all 
> RFC Streams have a voice in that process, so I think the constitution 
> of this community process must explicitly include a role for each 
> stream. For clarity, I'm going to call it the RFC Series Advisory 
> Working Group (RSAWG) from now on. I'd tend to make it a completely 
> open group but with mandatory membership from each stream.
> 
> The previous RSE several times raised the question whether there should 
> be an RFC Editor Stream of RFCs. There wouldn't be many such, but it 
> would avoid the current "Band-Aid" solution of RFCs about the RFC 
> series coming out as Informational documents from the IAB. So I suggest 
> that we take the current opportunity for reform to add this missing 
> series.
> 
> I do not believe that an "IAB Program" is a good basis for the strategy 
> process. I believe it needs to be free-standing, solid in its own 
> right, with equal ties to each entity that produces a document scheme. 
> I believe we should relieve the IAB of this responsibility. Since the 
> contracts will be adjudicated by the LLC, we no longer need the IAB to 
> "approve the appointment of an organization to act as RFC Editor". 
> Since the strategy will be set by the new RSAWG, we no longer need the 
> IAB to approve "the general policy followed by the RFC Editor".
> 
> Since the RFC Series is a public good, the RSAWG does need an anchor 
> and a final arbiter, and I believe we should solicit the ISOC Board for 
> that.
> 
> "The current process requires that the RFC Series Editor produce and 
> maintain this material [the style guide]. This document proposes that 
> the RFC Series Evolution program become responsible for ownership of 
> this material."
> 
> I don't see how that works. Firstly, most of the expertise in 
> developing or updating the style guide lies in the RPC. When technical 
> (non-linguistic) questions arise, they need to consult the community 
> (in my model, via the RSAWG). However, when linguistic or other 
> publishing-related issues arise, they need expertise that the technical 
> community doesn't have.
> 
> What we need, IMNSHO, is fairly clear and hasn't changed much, except 
> that I would now call this person the RFC Series Advisor. They need 
> expertise and experience in technical publishing. They convene the 
> RSAWG (but it should have independent chairs). They do development work 
> on the strategy documents. They bring their expertise to the RSAWG and 
> to the RPC when needed. They are under a professional services contract 
> with the LLC (which is highly unlikely to be full time).
> 
> I largely agree with what you say about tools development and support, 
> except that IMHO the IAB has no necessary role in the picture.
> 
> Apart from that there is little point in commenting on the later parts 
> of your draft since they are based on a structure I am strongly 
> against. However, there is one factual error in section 8:
> 
> "This draft describes a model whereby the RFC Series Advisory Group and 
> the RFC Series Editorial Board have no future..."
> 
> The RSEB is the editorial board for the Independent Stream under 
> RFC8730, so it is completely out of scope here.
> 
> Regards
>    Brian
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 17 Aug 2020 14:20:59 +1200

Martin,

On the main points where we disagree:

> 1. You don't want the IAB to host this.

Correct. To be completely clear, I've been concerned since 1994 when I joined the IAB that it couldn't focus enough on the architecture of the Internet as such, and I still have that concern. This isn't the place to deconstruct the IAB's charter in general, but I believe it is desirable to remove as much as possible of an administrative nature from the IAB's remit. So let's remove the publishing business.

> 3. You want to have a role for some individual in this process.  I'm opposed to that, especially if they are on the escalation path for disputes.

I agree with the second half of that - by choosing the name Advisor, I intended to make it clear that this would be an outside expert with a skill set that "we" don't have. So the escalation path would be via the chairs of the new group. I wrote that the Advisor would *convene* the group in the sense of scheduling meetings, etc., since this would be day-job stuff for them, but presumably volunteer work for the chairs.

But frankly I think that *not* having an expert advisor would be a case of engineer hubris. My experience in the RSAG is that a publishing expert knows stuff (and where to find stuff) that we don't. There are a few members of the technical community with some relevant knowledge, of course, but that's no substitute for a professional. If we don't have an expert advisor *outside the contractor* we have lost a key element in controlling the strategy.

Would Elsevier or Springer design protocols? I hope not. So who are we protocol engineers to run a technical publisher?

Regards
   Brian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 17 Aug 2020 12:39:13 +1000

At a high level - I want to see broad participation, transparency and accountability in the body that we're talking about (naming later). I think Martin's draft largely accomplishes these. 

Some responses to the points Brian has made below.

> On 17 Aug 2020, at 12:20 pm, Brian E Carpenter <[email-masked]> wrote:
> 
> Martin,
> 

I think many share that concern; seeing how much time the IAB currently spends on appointments alone, I certainly do.

Personally, beyond that motivation I don't have any strong feeling about whether or not the IAB is the right party to oversee this body.  It would be good to choose something that has a real connection with the communities that are affected by it. It's also important to assure that the process has overall legitimacy -- e.g., with depth of the appeals chain, etc.

The ISOC Board might be sufficient. Are there alternatives, or additional bodies we can add? 

> Would Elsevier or Springer design protocols? I hope not. So who are we protocol engineers to run a technical publisher?

I agree that we will need -- at least from time to time -- to procure expert advice. Perhaps it's worth exploring two questions:

1. Is the role of the Advisor both prominent and well-understood enough to enshrine it in the structure of this body?
2. Should the role of the Advisor be conflated with the leadership of this body?

Cheers,

> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

--
Mark Nottingham   https://www.mnot.net/

---

From: Eliot Lear <[email-masked]>
Date: Mon, 17 Aug 2020 09:18:05 +0200

Just as a reminder:

This is one proposal.  Others are welcome.  If we don’t get others, this will be the one we focus on, as we move forward.  The chairs also intend to set a time table very shortly on this.

Eliot

> On 16 Aug 2020, at 06:25, Brian E Carpenter <[email-masked]> wrote:
> 
> Martin,
> 
> Thanks for the update.
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Aug 2020 08:48:47 +1200

Eliot,

That puts me in a small dilemma. I rather like the *structure* of Martin's draft and rather disagree with some of its major proposals.

Would you prefer to see an alternative draft which borrows heavily from his draft, or continued discussion on the list, or something else?

Regards
   Brian Carpenter

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 17 Aug 2020 23:04:30 +0200

> 2. Should the role of the Advisor be conflated with the leadership of this body?

Academia is a background where we know that having the right person on a position can be crucial (we give out lifetime tenures!).  So maybe I’m biased.

Re 1: Yes, I think that “Advisor" (if that is the new word for the RSE) should have a prominent role.  (Whether it is well-understood yet, I don’t know.)

Re 2: This is one of the questions that reminds one of a saying that unfortunately involves domestic violence.  I do believe that we will find better “Advisors” if that is a leadership role.

Grüße, Carsten

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 18 Aug 2020 09:30:43 +1000

Hi Carsten,

> On 18 Aug 2020, at 7:04 am, Carsten Bormann <[email-masked]> wrote:
> 

How often is tenure given to someone who then doesn't use that privilege well? I have anecdotes from friends and family who are in academia, it'd be interesting to compare notes.

> Re 1: Yes, I think that “Advisor" (if that is the new word for the RSE) should have a prominent role.  (Whether it is well-understood yet, I don’t know.)

Why?

> Re 2: This is one of the questions that reminds one of a saying that unfortunately involves domestic violence.

Sorry, I don't understand.

>  I do believe that we will find better “Advisors” if that is a leadership role.

Why?

---

From: Michael StJohns <[email-masked]>
Date: Mon, 17 Aug 2020 19:50:37 -0400

> This is one proposal.  Others are welcome.  If we don’t get others, this will be the one we focus on, as we move forward.  The chairs also intend to set a time table very shortly on this.

I've got one coming, but life keeps interrupting the writing.  I hope to 
have something posted by the end of the week if not sooner.

Mike

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 18 Aug 2020 10:14:21 +1000

I don't have any objection to you copying the text and modifying it to suit, or posting a draft that says "like X, but with Y".  I think that the reason Eliot is asking for something is so that we can have something written down.

That said, we seem to be doing a fine job of getting to the principles already, so as long as that continues, I don't personally need to see much more to understand what is being proposed.  It would help if it were more explicit, but I don't need it as much as before.

On Tue, Aug 18, 2020, at 06:48, Brian E Carpenter wrote:
> Eliot,
> 
> That puts me in a small dilemma. I rather like the *structure* of 
> Martin's draft and rather disagree with some of its major proposals.
> 
> Would you prefer to see an alternative draft which borrows heavily from 
> his draft, or continued discussion on the list, or something else?
> 
> Regards
>    Brian Carpenter
>

---

From: Eliot Lear <[email-masked]>
Date: Tue, 18 Aug 2020 08:50:05 +0200

Brian,

> On 17 Aug 2020, at 22:48, Brian E Carpenter <[email-masked]> wrote:
> 
> Eliot,
> 

Given that there are different schools of thought as to what people would like, I would expect to see alternative drafts.  As a matter of practicality, if we start from one draft from one perspective, then it is a safe assumption that much of that draft will find its way to the final product. If that is what people would like, then one draft it is, and we can issue track from there.  If we see multiple drafts, then we have text to take from both to establish common ground.

If you or anyone else would like to write a draft, then borrowing from Martin’s well laid out structure is fine, but certainly not required.  What is important is the motivation behind what is being proposed, selection, accountability, and transparency mechanisms that are expected.  

The chairs do not wish this process to drag on.  The time to write is now.  You can expect to see a proposed timeline from us on this matter Real Soon Now.

Eliot

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 21 Aug 2020 08:08:23 +0200

> How often is tenure given to someone who then doesn't use that privilege well? I have anecdotes from friends and family who are in academia, it'd be interesting to compare notes.

Well, I’m not suggesting we copy the tenure model here.
I was just using it to explain my bias towards finding and engaging excellent people.

But, to answer the question: In my university, surprisingly less frequent than one would think.  That requires doing the tenure process right (the question is not just “are all the bibliometrics indicators just right”, but also “is this a person that we could live with for the next couple decades”).  Since the people who are steering the tenure process mostly have been through it themselves, this is a bit of a self-sustaining virtuous cycle (or can be a vicious cycle – I’ve seen that as well).  It is one of the finer points of running a university to supply just the right amount of correcting nudges to the process...

>> Re 1: Yes, I think that “Advisor" (if that is the new word for the RSE) should have a prominent role.  (Whether it is well-understood yet, I don’t know.)

To get someone from the publishing world that can (and is motivated to) help us.

> Sorry, I don't understand.

Well, let’s just say that was a leading question.

>> I do believe that we will find better “Advisors” if that is a leadership role.

See my other message today.

Grüße, Carsten