Subject: [Rfced-future] Posted my draft

From: Michael StJohns <[email-masked]>
Date: Mon, 24 Aug 2020 13:34:35 -0400

See https://datatracker.ietf.org/doc/draft-stjohns-rfced-rseb/

My intent is to ignore comments for a few days rather than jump in and 
defend each comma and clause.

Basically, this mostly leaves intact the operation of the RFC Series 
Function while splitting the functions previously held by the IAB into 
two specific ones:  Strategic evolution of the series goes to a purpose 
built organization - the RFC Series Editorial Board, while the 
contractual nitty gritty of paying for things gets firmly homed under 
the LLC.

Enjoy - Mike

---

From: Eliot Lear <[email-masked]>
Date: Mon, 24 Aug 2020 19:36:09 +0200

Thank you, Mike.  Does anyone else have any other proposals coming in the short term?

Eliot

> On 24 Aug 2020, at 19:34, Michael StJohns <[email-masked]> wrote:
> 
> My intent is to ignore comments for a few days rather than jump in and defend each comma and clause.
> 
> Basically, this mostly leaves intact the operation of the RFC Series Function while splitting the functions previously held by the IAB into two specific ones:  Strategic evolution of the series goes to a purpose built organization - the RFC Series Editorial Board, while the contractual nitty gritty of paying for things gets firmly homed under the LLC.
> 
> Enjoy - Mike
> 
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 25 Aug 2020 07:49:02 +0200

> My intent is to ignore comments for a few days rather than jump in and defend each comma and clause.

I’ll try to avoid clause numbers and commas, then.

Summary: I have much less of a hard time imagining this structure to work than the other two that have been presented.

A few thoughts (but not many, as this is so close already):

I think we can live without the description of the previous RSE disaster as “IAB’s missteps” — that is behind us.

I’m not sure "the smooth functioning of the operation and evolution of the RFC Series” is covering the whole gamut (see my point “reputation”), but maybe that is just an issue of integrating with 8728.  (I wouldn’t mind having fostering reputation listed as an explicit objective, possibly using a different term if needed.)

(The ISE *is* a stream manager, and with ES, the RSE is as well, so there is a small terminology problem here with the I* stream managers and the managers of a stream.)

Do we have enough material in 3 how we plan to keep the RSEB and its members free of IT project management duties?

Grüße, Carsten

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 25 Aug 2020 14:19:47 +0200

Hi Mike,

Thanks for writing this down. I have some questions:

1) It is not fully clear to me who is responsible for making strategic decisions. Is that the RSEB or is the RSE having the final decisions and the RSEB is more advising the RSE?

2) Also related to the point above actually, why is it enough to have "at least one stream manager member and one At-Large member [...] to give their consent for any document to be published” instead of having the whole RSEB agreeing to it?

3) Why are the RSE and ISE the chair and vice-chair? These are the only two members which do not have a term limit and I would fine it actually an important feature especially for a chair and vice-chair to have a specified term length and ensure there is a way to “replace” that person if the community is not happy about decisions made.

Mirja

> On 24. Aug 2020, at 19:34, Michael StJohns <[email-masked]> wrote:
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 25 Aug 2020 13:48:42 +0100

Hi Mirja,

I think this discussion is making some progress towards discovering what we want to achieve.

Just pouncing on one thing, and asking a question for clarification...

> 3) Why are the RSE and ISE the chair and vice-chair? These are the only
>    two members which do not have a term limit

While what you say is true, there are two mitigating factors:
1. There is a 'convention' that the ISE agrees a two year term with the IAB as part of appointment. This ensures a degree of commitment to continuity on both sides which is (I think) important for the role. (The RSE was, of course, covered by a contract with duration and renewal terms).
2. In the case of the ISE, the IAB is allowed (should be encouraged!) to replace the ISE if they are underperforming or if there is significant disquiet from the community. (The RSE was subject to 'termination' per the contract.)

> and I would fine it actually an important feature especially for a
> chair and vice-chair to have a specified term length and ensure
> there is a way to “replace” that person if the community is not
> happy about decisions made.

I think there are a couple of things buried here:
- Do the chair/vice-chair make decisions are chair discussions?
- Is there a distinction between chair/vice-chair term length and
  RSE/ISE term length? (Agreeing that if the chair/vice-chair is by
  definition the RSE/ISE then there is no practical difference.)
- Would you expect that the need to replace the chair/vice-chair
   could ever not extend to the need to replace the RSE/ISE? In 
   other words, might the problem be limited to fulfilment of the
   chair/vice-chair role while other aspects of the RSE/ISE work 
   continued to be good? This might come down to whether you
   define being the chair/vice-chair as fundamental functions of
   the RSE/ISE or whether you say, "Oh we also need a chair/vice-
   chair, so let's make use of the RSE/ISE."

Best,
Adrian

---

From: Michael StJohns <[email-masked]>
Date: Wed, 26 Aug 2020 11:18:01 -0400

46 hours! :-)

> I think we can live without the description of the previous RSE disaster as “IAB’s missteps” — that is behind us.

There are two arguments in one here, the first is that the IAB should be 
trying to reduce its non-technical stuff, and the second is that there's 
a worked example of the problems with homing this at the IAB.   I 
probably would have left this out except for Mirja's question to Brian 
of "why you think the IAB is not a good choice?"

> I’m not sure "the smooth functioning of the operation and evolution of the RFC Series” is covering the whole gamut (see my point “reputation”), but maybe that is just an issue of integrating with 8…
I agree, but I think its sufficient for the discussion period.
> (The ISE *is* a stream manager, and with ES, the RSE is as well, so there is a small terminology problem here with the I* stream managers and the managers of a stream.)

Well, no.   The ISE and RSE are Stream editors, and that includes the 
duties that stream managers have.   The stream manager job is a lesser 
included occupation.

> Do we have enough material in 3 how we plan to keep the RSEB and its members free of IT project management duties?

I think so.  The contract management stuff is solely the purview of the 
LLC.  The day to day project management duties either stay with the LLC 
or devolve to a CM selected by the LLC.  The RSE OPTIONALLY may end up 
as the CM for the RPC and related tasks, but that's dependent on whether 
project management of that type is in the person's fulfilling the RSE 
role wheelhouse.  We may end up with an RSE who declines that piece, and 
another who embraces it. Or the LLC may choose to keep the role 
irrespective of the person filling the RSE role.

Mike

---

From: Michael StJohns <[email-masked]>
Date: Wed, 26 Aug 2020 11:34:52 -0400

> Thanks for writing this down. I have some questions:
De nada.
> 1) It is not fully clear to me who is responsible for making strategic decisions. Is that the RSEB or is the RSE having the final decisions and the RSEB is more advising the RSE?

In the final analysis, it's the RSEB as they have the approval authority 
over the Editorial series.   The model here is that we hire the RSE to 
do the drudgery of framing the strategy and writing it down, all the 
while working with RSEB to get something they're willing to sign off on.

It's also true that the majority of the RSEB minus the RSE may write 
something down and approve it without the RSE's sign off.

> 2) Also related to the point above actually, why is it enough to have "at least one stream manager member and one At-Large member [...] to give their consent for any document to be published” inste…

That's not what the note meant.  The majority of the RSEB has to sign 
off on a document.  It's just that a majority means 5 votes which 
generally means that those 5 will include one stream manager and one 
at-large member.  (It also means I can't do basic math because its 
possible to have RSE, ISE and three at large or RSE ISE and three stream 
managers sign off - I'll remove that next version.)   Generally that was 
meant to imply that the stream managers would always get a say.  If you 
count the RSE and ISE as stream managers (as Carsten suggest), they 
always do.

> 3) Why are the RSE and ISE the chair and vice-chair? These are the only two members which do not have a term limit and I would fine it actually an important feature especially for a chair and vice-…

The form of this is meant to parallel the form of most editorial 
boards.  In those the actual editors set the agenda and drive the 
process.   The RSE and ISE are there as de jure chairs because that's 
what I believe the roles require for this process to be successful.

With respect to replacement, Adrian has it right.   Fire the RSE if "the 
community is not happy about the decisions made" - or basically fail to 
renew the contract, or replace your stream manager, or talk to the 
Nomcom about the at-large members, or to the ISOC.  Or fire the ISE.  
The RSE can't make decisions in a vacuum, and the RSEB is accountable as 
the RSE or ISE.

I will note that the RSOC chair is still there and I'm part of the 
community that is not happy about the decisions made, so I'm not really 
sure that its a useful consideration.

Later, Mike

---

From: Michael StJohns <[email-masked]>
Date: Wed, 26 Aug 2020 11:44:01 -0400

> 2. In the case of the ISE, the IAB is allowed (should be encouraged!) to replace the ISE if they are underperforming or if there is significant disquiet from the community. (The RSE was subject to…

Yes, exactly.

> - Do the chair/vice-chair make decisions are chair discussions?

We're back into "who's in charge" and "just a contractor" implications 
when we have those discussions.  Instead consider "what makes the best 
sense for the conduct of the business of the RSEB and RSO"?  In this 
case, the RSE is hired with the intent that they're going to be the ones 
doing most of the donkeywork of documentation production, framing the 
strategy, explaining what can and can't be done, and mostly making sure 
progress is made.

>    definition the RSE/ISE then there is no practical difference.)
Yup.
>     chair, so let's make use of the RSE/ISE."

Yes.  Both of those.  We need a chair to make sure business is done, and 
it's pretty fundamental that the RSE has the most skin in the game in 
getting the business done.  Or to put it a third way - if the RSE's 
contract performance is dependent on the performance of the RSEB, then 
we will probably continue to have problems.

Last one:

For the cases where the RSE role is vacant, having the ISE step in and 
steer appears to make sense, rather than scrambling with the "would 
volunteers from the RSEB take one step forward to serve as chair" and 
watching them all take one step back.

Later, Mike

---

From: Mirja Kuehlewind <[email-masked]>
Date: Wed, 26 Aug 2020 18:08:52 +0200

Hi Mike, hi all,

> On 26. Aug 2020, at 17:18, Michael StJohns <[email-masked]> wrote:
> 
> There are two arguments in one here, the first is that the IAB should be trying to reduce its non-technical stuff, and the second is that there's a worked example of the problems with homing this at the IAB.   I probably would have left this out except for Mirja's question to Brian of "why you think the IAB is not a good choice?”

Just do make it clear what the intention of my question was. I’m well aware of some of the problems in the past, however, I’m uncertain if just taking the IAB out of the game and replacing it with another body solves these problems. I believe problems were cause by even larger structural issues and we need to ensure those are addressed as well. So despite me being on the IAB or not, I find it not very satisfying if someone just says “there have been problems with the IAB, so let remove the IAB”. I would rather like to better understand what you think the problems have been and how they are addressed by your proposal. I do have my own thoughts but I first would like to understand the thoughts of those people who have thankfully written down a proposal.

Mirja

---

From: Christian Huitema <[email-masked]>
Date: Wed, 26 Aug 2020 09:43:54 -0700

> Just do make it clear what the intention of my question was. I’m well aware of some of the problems in the past, however, I’m uncertain if just taking the IAB out of the game and replacing it with…

From my perspective, a lot of the past problems came from loading the
RSE function with not just expertise on publishing issues, but also
program management of the RPC and the transition to a new format. I am
not aware of any issue with the publishing expertise part. I observed a
lot of issues with the second part, with complaints that the transition
was taking too long and was impacting the productivity of the RPC. The
tension about program management would have been there whether the IAB
was in charge or some other body. I appreciate the growing consensus
that the RSE should have a technical advisory role, and that the program
management functions should be handled directly by the LLC.

-- Christian Huitema

---

From: Michael StJohns <[email-masked]>
Date: Fri, 28 Aug 2020 12:26:10 -0400

~48 hours

> Just do make it clear what the intention of my question was. I’m well aware of some of the problems in the past, however, I’m uncertain if just taking the IAB out of the game and replacing it with…

Hi -

I *really* don't think this is a useful conversation.   But you've asked 
for some reason..

1) The IAB actually hasn't been involved in the RFC stuff since it 
formed the RSOC.   It handed off authority and responsibility, and left 
it in a state of benign neglect.  That worked surprisingly well until 
the contractual relationship came under the purview of the LLC.  I'm not 
sure those are connected, but the timing is interesting.

2) Structurally, none of the existing I* boards with the exception of 
the LLC are set up to deal with personnel actions. To do those, you need 
a fiduciary relationship with the person being managed.  Right now the 
LLC is in full on deferral mode to the IAB for this and that was at 
least part of the problem - that the RSOC felt comfortable enough to 
make personnel decisions two levels removed from the actual body that 
would have to trigger the recompete.  It also felt comfortable enough 
that the IAB would support those decisions that they discussed them with 
the RSE prior to ever getting IAB sign off.

3) The IAB took action to reform the RSOC and AFAICT did so in a vacuum 
with respect to the RSE.  This appeared to be a fall out from the failed 
RFC++ BOF which - according to what I understand from the contract and 
various RFCs - shouldn't have happened in the way that it did, without 
RSE input.   In any event, the RSOC dropped I believe it was the three 
members that were both a) sympathetic to the RSE and b) had the most 
experience with the RFC series - a set of decisions that to this day I 
have failed to make sense of.

4) There needs to be a focus on the topic of publication that is neither 
apparent from the current IAB membership, nor would be consistent over 
the next say 6 or so IABs.  While an IAB program focused on the RFC 
series might provide useful input from the IAB's perspective it 
continues to be unclear whether it actually would be viable (interest 
wise) as a long term project.

5) You've indicated at least 3 or 4 times that the IAB is busy. Perhaps 
you should be looking to this not as losing authority, but as gaining 
time.    This isn't actually an architecture thing and I find it hard to 
place under the IAB's remit on that basis.

6) And the most important - the IAB took no actions to remediate the 
problems.  It's unclear that it has the structural ability to do so.

Later, Mike

---

From: Mirja Kuehlewind <[email-masked]>
Date: Sat, 29 Aug 2020 17:23:57 +0200

Hi Mike,

Thanks for writing this down. I find it actually very useful to have these points clearly listed. I think it does show that we actually do have some common views on the problems, at least regarding the contractural part and the oversight of that. 

My personal conclusion to that part is, I’d say, similar with some other views expressed already but probably different to your proposal, that the contractual PM work should be separated from the strategic part of the work, where the PM is directly managed and overseen by the LLC (now that we have it).

Further, I would like to quickly comment on two points below.

Regrading 5, I don’t think I very said that "the IAB is busy". However the time commitment people on the IAB make is quite variable and the people we usually select for the IAB are often quite busy with other things already. This is a separate problem but I don’t think this problem should finally guide our decision for the RFC model.

And regarding point 6, I actually would like to response as a member of the IAB even though I haven’t been an IAB member when most of the previous things happened. Probably not all things went ideal here but the IAB did take actions. After all the IAB asked the RSE to lead the discussion about how to organise the process we are currently performing and the IAB did, based on community advise, then establish this group. Not sure which actions you would have expected from the IAB but mostly finding a way to delegate to the right people is I would say one of the common approaches the IAB usually takes.

Mirja

> On 28. Aug 2020, at 18:26, Michael StJohns <[email-masked]> wrote:
> 
> ~48 hours
> 
> I *really* don't think this is a useful conversation.   But you've asked for some reason..
> 
> 1) The IAB actually hasn't been involved in the RFC stuff since it formed the RSOC.   It handed off authority and responsibility, and left it in a state of benign neglect.  That worked surprisingly well until the contractual relationship came under the purview of the LLC.  I'm not sure those are connected, but the timing is interesting.
> 
> 2) Structurally, none of the existing I* boards with the exception of the LLC are set up to deal with personnel actions. To do those, you need a fiduciary relationship with the person being managed.  Right now the LLC is in full on deferral mode to the IAB for this and that was at least part of the problem - that the RSOC felt comfortable enough to make personnel decisions two levels removed from the actual body that would have to trigger the recompete.  It also felt comfortable enough that the IAB would support those decisions that they discussed them with the RSE prior to ever getting IAB sign off.
> 
> 3) The IAB took action to reform the RSOC and AFAICT did so in a vacuum with respect to the RSE.  This appeared to be a fall out from the failed RFC++ BOF which - according to what I understand from the contract and various RFCs - shouldn't have happened in the way that it did, without RSE input.   In any event, the RSOC dropped I believe it was the three members that were both a) sympathetic to the RSE and b) had the most experience with the RFC series - a set of decisions that to this day I have failed to make sense of.
> 
> 4) There needs to be a focus on the topic of publication that is neither apparent from the current IAB membership, nor would be consistent over the next say 6 or so IABs.  While an IAB program focused on the RFC series might provide useful input from the IAB's perspective it continues to be unclear whether it actually would be viable (interest wise) as a long term project.
> 
> 5) You've indicated at least 3 or 4 times that the IAB is busy. Perhaps you should be looking to this not as losing authority, but as gaining time.    This isn't actually an architecture thing and I find it hard to place under the IAB's remit on that basis.
> 
> 6) And the most important - the IAB took no actions to remediate the problems.  It's unclear that it has the structural ability to do so.
> 
> Later, Mike
> 
> 
>> Mirja
>> 
>> 
>> 
>> 
>> 
> 
> --

---

From: Michael StJohns <[email-masked]>
Date: Sat, 29 Aug 2020 13:37:59 -0400

> My personal conclusion to that part is, I’d say, similar with some other views expressed already but probably different to your proposal, that the contractual PM work should be separated from the s…

I read this and I'm still not sure where you're drawing the line.   
Mostly, I think that the LLC gets to decide how the contractual work 
related to the RFC series is managed.   The document I wrote calls that 
a Contract Monitor and allows the LLC to figure out the how of the 
process.  That role is not necessarily either a manager or an overseer - 
but is subject to the negotiation between the LLC and the contractors.  
In the US at least, contractors do not have managers from the 
contracting organization, they have points of contact - at least 
according to the way the law is supposed to work.

The strategy needs to be both consistent and derived from actual needs 
of the community.  The model where we hire someone to help craft that 
strategy and write it down and we pay for that work is not inconsistent 
with those goals.  We just then need checks and balances - the role in 
which my document places the RSEB.

> Regrading 5, I don’t think I very said that "the IAB is busy". However the time commitment people on the IAB make is quite variable and the people we usually select for the IAB are often quite busy…

Sorry - I misread a comment by you and you are correct that you didn't 
say that.   But let me put it another way - the IAB was busy enough that 
it decided that putting together an RSOC was a better way of doing 
things than using their time.

> And regarding point 6, I actually would like to response as a member of the IAB even though I haven’t been an IAB member when most of the previous things happened. Probably not all things went idea…

Hind sight is 20/20, but I'm willing to take a stab.  I would have:

1) Suspended the RSOC pending an evaluation, returning RFC related 
functions to the IAB
2) Selected a panel of 3 or so people to do the evaluation, with at 
least one selected by folks like me who believed there was a problem, at 
least one selected by the RSOC not from their number, and at least one 
selected by the LLC from some of the more senior members of the 
community and given them access to all the data - including the 
purportedly "personnel" related data.
3) Had them provide a public report identifying issues (if any), 
suggested remediations, and explaining in the short run how we were 
going to move forward.  (Part of the latter did end up happening through 
the auspices of the RSOC - the temporary PM model, but really wasn't 
anything based on community consensus). I would have expected the group 
to reach out to the RSE in a similar model to the way the IAB did.

Basically, take actions specifically to deconflict the IAB from the 
analysis of problems that might be rooted in the IAB.

I will note also, that the previous IAB didn't even manage to follow its 
own procedures with the selection of the chairs for this current group,  
leaving your IAB to appoint the second chair that had been promised only 
after sufficient commentary from the community.

Later, Mike