Subject: [Rfced-future] Continuing on Issue 12: Is there an Executive Editor or an Advisor?

From: Eliot Lear <[email-masked]>
Date: Mon, 9 Nov 2020 11:57:56 +0100

Thank you to those who have commented on this issue.

What was proposed:

One possible resolution is that the expert exercises moral authority – as experts do – and provides guidance when asked by the RPC within the existing framework.  If the existing framework is found to be wanting, the advisor might point this out to strategy body.  It is then up to them to resolve through whatever processes they have.  They might seek guidance from the advisor to resolve issues.

There was quite a bit of objection to the term “moral authority”.

To remedy this, we can do something along these lines, recognizing that a bit of wordsmithing will still be necessary if this hits a draft:

> One possible resolution is that the expert provides guidance when asked by the RPC within the existing framework.  If the existing framework is found to be wanting, the advisor might point this out to strategy body.  It is then up to them to resolve through whatever processes they have.  They might seek guidance from the advisor to resolve issues.

This leaves several stated concerns open.  As I see it, it takes three forms:
Could we write a job description for the role such that it could be filled?
What is the title of the individual?
What is the contract period / how is this person treated?

Another way to look at this would be to view this person as a senior member of the RPC - with a slightly different function.  In that case, Martin’s text fits quite neatly:

> I think that I proposed something slightly different: we let the RPC proceed with a decision grounded in their own best judgment (which I would hope, but not insist, would involve some attempt at consultation).  Then we live with the consequences of mistakes if the eventual community position differs when consensus is reached.

That would simply leave open how this person takes on strategic work.  On their own initiative?  At the behest of the community?  Both?  Should I hope an issue on this?  Maybe we can start discussion here though?

Eliot

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 9 Nov 2020 10:27:43 -0500

This seems to assume that in almost all cases the stragic body knows 
what the issues are and what the reasonable paths are.  And that it can 
tell when it needs to ask for advice.

 From my time on the RSOC, what struck me early on was the number of 
things Heather was bringing up that would not have occurred to me.
I am concerned that the formulations proposed ignore the need for active 
participation in the strategy work by a respected expert in the domain.

Yours,
Joel

On 11/9/2020 5:57 AM, Eliot Lear wrote:
> One possible resolution is that the expert exercises moral authority – 
> as experts do – and provides guidance when asked by the RPC within the 
> existing framework.  If the existing framework is found to be wanting, 
> the advisor might point this out to strategy body.  It is then up to 
> them to resolve through whatever processes they have.  They might seek 
> guidance from the advisor to resolve issues.
> 
> To remedy this, we can do something along these lines, recognizing that 
> a bit of wordsmithing will still be necessary if this hits a draft:
> 
>> One possible resolution is that the expert provides guidance when 
>> asked by the RPC within the existing framework.  If the existing 
>> framework is found to be wanting, the advisor might point this out to 
>> strategy body.  It is then up to them to resolve through whatever 
>> processes they have.  They might seek guidance from the advisor to 
>> resolve issues.
> 
>   * Could we write a job description for the role such that it could be
>     filled?
>   * What is the title of the individual?
>   * What is the contract period / how is this person treated?
> 
> 
> Another way to look at this would be to view this person as a senior 
> member of the RPC - with a slightly different function.  In that case, 
> Martin’s text fits quite neatly:
> 
>> I think that I proposed something slightly different: we let the RPC 
>> proceed with a decision grounded in their own best judgment (which I 
>> would hope, but not insist, would involve some attempt at 
>> consultation).  Then we live with the consequences of mistakes if the 
>> eventual community position differs when consensus is reached.
> 
> That would simply leave open how this person takes on strategic work. 
>   On their own initiative?  At the behest of the community?  Both? 
>   Should I hope an issue on this?  Maybe we can start discussion here 
> though?
> 
> Eliot
> 
>

---

From: John C Klensin <[email-masked]>
Date: Mon, 09 Nov 2020 10:47:26 -0500

--On Monday, November 9, 2020 11:57 +0100 Eliot Lear
<lear=[email-masked]> wrote:

>...
> To remedy this, we can do something along these lines,
> recognizing that a bit of wordsmithing will still be necessary
> if this hits a draft:
> 
>> One possible resolution is that the expert provides guidance
>> when asked by the RPC within the existing framework.  If the
>> existing framework is found to be wanting, the advisor might
>> point this out to strategy body.  It is then up to them to
>> resolve through whatever processes they have.  They might
>> seek guidance from the advisor to resolve issues.

Eliot,

Time constraints make it impossible for me to communicate all of
my thoughts on this subject, which I assume some will consider
an act of mercy.  But...

Skipping over the "advisor", "executive editor", "managing
editor", etc., distinctions as part of a different topic...

If this person is to provide advice only when the RPC asks (and
whether they are nominally part of the RPC or separate), that
downgrades the role to that of a consultant on retainer who gets
involved only when someone internal decides there is a problem.
While I completely trust the current RPC and its leadership to
know when there is an issue and reach out for advice (and hope
they will be with us forever), that is not a good basis for a
long-term organizational plan.  As long as we don't get
ourselves into an extreme version of "the LLC decides what
contractors are allowed to say and to whom", "might point this
out to strategy body..." is essentially a no-op because anyone
participating (or even interested) constructively in the IETF
and associated activities ought to be able to point out anything
they like to whomever they like.

See Joel's recent comment for a different take on what may be
the same concern.

And, at the risk of repeating myself, expecting a/the strategy
body to make decisions assumes a great deal of subject matter
expertise in that body, starting with every single member
knowing what they don't know, no matter how strong their
opinions and gut feelings.  One option that might help would be
to make this person an ex-officio and voting member of the
strategy body who could be locked out of its meetings only when
their own job performance was being reviewed.

More on your other concerns later (unless others get to them
first), but creating a job that needs a senior person and then
treating the party involved as a junior one and / or someone who
is expected to stand by and be available on call gets you either
a candidate who is mostly retired but willing to pick up an
occasional on-demand task or someone who isn't really qualified.

best,
  john

---

From: Eliot Lear <[email-masked]>
Date: Mon, 9 Nov 2020 17:35:27 +0100

Hi Joel and John,

Thanks for your feedback.  Do you think you could take the modify the text in some way that would address the concerns you’re raising?  So for instance, perhaps you would s/when asked by the/to/ so that the sentence reads, “One possible resolution is that the expert provides guidance to RPC…”. What would you say about the relationship of this person to the strategic body?

Others should of course feel free to throw their own variants out there.

Eliot

> On 9 Nov 2020, at 16:27, Joel M. Halpern <[email-masked]> wrote:
> 
> This seems to assume that in almost all cases the stragic body knows what the issues are and what the reasonable paths are.  And that it can tell when it needs to ask for advice.
> 
> From my time on the RSOC, what struck me early on was the number of things Heather was bringing up that would not have occurred to me.
> I am concerned that the formulations proposed ignore the need for active participation in the strategy work by a respected expert in the domain.
> 
> Yours,
> Joel
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: John C Klensin <[email-masked]>
Date: Mon, 09 Nov 2020 12:31:28 -0500

--On Monday, November 9, 2020 17:35 +0100 Eliot Lear
<lear=[email-masked]> wrote:

> Hi Joel and John,
> 
> Thanks for your feedback.  Do you think you could take the
> modify the text in some way that would address the concerns
> you're raising?  So for instance, perhaps you would s/when
> asked by the/to/ so that the sentence reads, "One possible
> resolution is that the expert provides guidance to RPC…".
> What would you say about the relationship of this person to
> the strategic body?

Eliot,

I'm reluctant to even try to do that for the same reasons I had
problems with the way the interim meeting was summarized -- I
just see too many of the issues are interconnected and I think
there are fundamental differences of opinion within the group
who have been commenting that won't be resolved by circling
around and coming at the problem from different directions.  

As an example, unless the "strategy body" can be populated with
people with real (broad and in-depth) expertise in
publications-related areas (and that means the appointing body
has to have sufficient expertise to recognize an expert when
they see one), I think we are setting ourselves up for a replay
of the last few years -- a situation in which an expert,
independent of how we categorize or title to role, will
eventually get frustrated and leave (regardless of the "last
straw" cause).  I don't see that as speculation; I see it as
closer to "been there, tried that, have yet to learn from our
mistakes".  

I also see an interesting analogy: we need ADs with management,
even strategic management, skills and have found ADs who lacked
them problematic.  But we also expect in-depth subject matter
expertise (including knowing and accepting what they don't know
about other areas) and we assume the Nomcom and those who
provide feedback to be able to evaluate that (even if, on
occasion, they have not been good at evaluating management
potential).    If we can't populate a "strategy body" with a
comparable level of publications knowledge and skill --and
individual members who are willing to be educated in areas where
they are not expert-- we've better not give them final authority.

Similarly, a key requirement for the RS-whatever position is
that whomever has it has a good deal of respect from the
community and be, nor only able but willing to educate others on
issues and that we do _nothing_ to constrain them in that role.
Joh Postel had that respect (albeit partially for other reasons)
as did Bob Braden and Olaf Kolkman.   So did Heather, especially
once she settled in a bit.  In at least the publications area,
Glen Kowack did not and that may be why we keep forgetting him
in discussions of RFC Series management.   Getting that level of
respect  probably requires community buy-in for whomever gets
the position (we lucked out with Heather), not either a
"strategy body" isolated from the community making the decision
or a conventional RFP on which the LLC has ultimate decision
authority.

And, while I could figure out a way to adjust language a bit, I
fear that doing so would just paper over those issues (some of
which I'm probably an outlier about) and leave us with very
different expectations and assumptions about what the words mean.

best,
   john

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 9 Nov 2020 17:33:49 +0000

Perhaps something like a new sentence: The expert should also bring up new issues that the RPC hasn't considered, even if the solutions aren't yet known.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 10 Nov 2020 10:20:38 +1300

> the expert provides guidance when asked by the RPC within the existing framework.  If the existing framework is found to be wanting, the advisor might point this out to strategy body.  It is then up to them to resolve through whatever processes they have.  They might seek guidance from the advisor to resolve issues.

One of the reasons I used the (apparently obnoxious) term "thought leader" is because IMHO we need the advisor to have an active, not a reactive, role in bringing issues to the community and the strategy body, as a result of his/her own experience and expertise.

I think it needs more than one paragraph. To be precise, here's a slightly amended version of section 8 of my draft:

# Role of the RFC Series Advisor

This person will be a senior professional with deep knowledge of technical publishing.

The RSA will operate by providing expert advice to the RSAWG, and if requested to the RPC, on any relevant matters. For example, the RSA might be consulted about proposed changes to the style guide, RFC formatting in general, web presence, copyright matters, or archiving policy.

The RSA is expected to attend and facilitate all RSAWG meetings, and to participate in and facilitate RSAWG on-line discussions.

Further, the RSA is expected to ensure that RSAWG consensus is well documented and communicated to the community, the LLC, and the REP. This may include document authorship.

The RSA is expected to be active in proposing improvements to the RFC Series, in developing vision and policy documents, and in establishing community consensus for them.

Regards
   Brian

On 09-Nov-20 23:57, Eliot Lear wrote:
>   * Could we write a job description for the role such that it could be filled?

---

From: John C Klensin <[email-masked]>
Date: Mon, 09 Nov 2020 17:46:39 -0500

--On Tuesday, November 10, 2020 10:20 +1300 Brian E Carpenter
<[email-masked]> wrote:

>> the expert provides guidance when asked by the RPC within the
>> existing framework.  If the existing framework is found to be
>> wanting, the advisor might point this out to strategy body.
>> It is then up to them to resolve through whatever processes
>> they have.  They might seek guidance from the advisor to
>> resolve issues.
> 
> One of the reasons I used the (apparently obnoxious) term
> "thought leader" is because IMHO we need the advisor to have
> an active, not a reactive, role in bringing issues to the
> community and the strategy body, as a result of his/her own
> experience and expertise.
> 
> I think it needs more than one paragraph. To be precise,
> here's a slightly amended version of section 8 of my draft:
> 
> The RSA will operate by providing expert advice to the RSAWG,
> and if requested to the RPC, on any relevant matters. For
> example, the RSA might be consulted about proposed changes to
> the style guide, RFC formatting in general, web presence,
> copyright matters, or archiving policy.
> 
> The RSA is expected to attend and facilitate all RSAWG
> meetings, and to participate in and facilitate RSAWG on-line
> discussions.
> 
> Further, the RSA is expected to ensure that RSAWG consensus is
> well documented and communicated to the community, the LLC,
> and the REP. This may include document authorship.
> 
> The RSA is expected to be active in proposing improvements to
> the RFC Series, in developing vision and policy documents, and
> in establishing community consensus for them.

Brian, 

This appears to be much closer to what I'm looking for (I still
have problems with "advisor" and believe it will cause us
recruiting difficulties).  I think, however, that what you are
describing above makes the RSA a sort of Executive Director (at
least in the old sense in which, e.g., Bob Braden served the IAB
for many years) for the RSAWG.   Adjusting terminology (and
maybe the name of the RSAWG) to reflect that might considerably
mitigate the recruiting problem I anticipate with "advisor".

   john

---

From: Eliot Lear <[email-masked]>
Date: Tue, 10 Nov 2020 12:36:17 +0100

Ok.  So maybe the thing to do is to use Brian’s text below as the basis for discussion next week?

Eliot

---

From: Sarah Banks <[email-masked]>
Date: Tue, 10 Nov 2020 10:06:46 -0800

Hi,
    To "yes, and" to what Joel wrote, I'm deeply concerned with the role as written. On one hand, we want someone with senior-level skill and experience. On the other, we want them to be a secretary (documenting consensus and communication to the community). As an advisor, they're empowered with ... what, exactly? What I'm getting at is - I think we're going to have a very, very difficult path to hiring someone with this as the job description. Heather DID bring issues we didn't expect to the RSOC, and seemed to relish in resolving them. An advisor wouldn't be doing that. So what are they getting out of this?
    Separate but somewhat related, I'd share the feedback that with the current model, in the RSOC, and even through discussions with Heather, the costs, level of staffing and level of efforts required to move documents through the process was a topic of conversation. I am all for community consensus, but I'd urge folks to think through, as we consider different resolutions to the documented Issues, that we don't have a track record as a community of considering the amount of effort proposed changes take, or the amount of money that translates to. I'm not suggesting we do tackle those issues, but I am suggesting that a model that puts community consensus squarely in the middle would be presented with that challenge, since there IS a contract involved (despite who negotiates, signs, and administers it), and the costs associated with an SLA are real.

Thanks,
Sarah

> On Nov 10, 2020, at 3:36 AM, Eliot Lear <lear=[email-masked]> wrote:
>

---

From: Eliot Lear <[email-masked]>
Date: Thu, 12 Nov 2020 09:44:25 +0100

Sarah, thank you for engaging on this point.  I have a request:

> On 10 Nov 2020, at 19:06, Sarah Banks <[email-masked]> wrote:
> 
> Hi,
>    To "yes, and" to what Joel wrote, I'm deeply concerned with the role as written.

Could you (or others) perhaps take Brian’s words, make changes you think are appropriate, and attempt to come up with a role that you believe (a) accurately reflects what you believe the IETF needs and (b) is someone you believe we could find?  It’s a very tall order but that’s why we pay you those big bucks ;-). Seriously, it will help us move the ball forward to have more alternatives out there.  You can even start with the title.

> On one hand, we want someone with senior-level skill and experience. On the other, we want them to be a secretary (documenting consensus and communication to the community). As an advisor, they're empowered with ... what, exactly? What I'm getting at is - I think we're going to have a very, very difficult path to hiring someone with this as the job description. Heather DID bring issues we didn't expect to the RSOC, and seemed to relish in resolving them. An advisor wouldn't be doing that. So what are they getting out of this?

Why do we think that an advisor couldn’t do that?  My accountant brings issues to my attention all the time.  I would fire him if he didn’t.  We had a lovely conversation about crypto currencies this time around.

>    Separate but somewhat related, I'd share the feedback that with the current model, in the RSOC, and even through discussions with Heather, the costs, level of staffing and level of efforts requi…

Yes.  Someone comes up with a proposed idea they would like to see carried out, it is then somehow costed out by someone else, and someone has to say, “this is affordable” or “this is not”, and someone has to say, “go”.  I think the model we are aiming at is that the strategic body develops some initial idea, perhaps with the RS[EA], Jay or someone in the RPC costs it out, perhaps in consultation with the RS[EA], the LLC provides their initial views, the strategic body says, “go” and then the LLC has to decide to fund or not fund.

That all needs to be documented out, right?  Are there words you like in one of the drafts that comes close to this or would you (or anyone else) like to write some?

Eliot

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 13 Nov 2020 09:08:04 +1300

Sarah,

Sometimes terminology is everything. I take your point, and the point of Eliot challenging you to rewrite the job description. If there was consensus to call the revised role "Series Editor" I'd be fine with that too. But if the role isn't line management of the RPC, which seems to be the province of the LLC, and isn't content management, which seems to be the province of the stream managers, it's inevitably a role where facilitation, wise advice, and coordination are the daily grind. (What Eugenia Cheng calls a "congressive" role in her book x+y.)

Regards
   Brian