Subject: [Rfced-future] Issue 12: Is the expert an advisor (RSA) vs an executive editor (RSE)

From: Eliot Lear <[email-masked]>
Date: Tue, 3 Nov 2020 11:22:23 +0100

As we get ready for our IETF meting, I was wondering if I could solicit more conversation on this topic.  This is from my summary:

There is a split within the group over this topic.  Some people have made clear that they prefer an advisor, and others believe the role should be that of an executive editor, where the latter makes decisions.  We’ve had a bit of a discussion about what decisions would be made.  What, for instance, could the RPC management reasonably decide?  What authority and expertise might they lack?  Here we had a contribution from the RPC that described some of their activities.

One possible resolution is that the expert exercises moral authority – as experts do – and provides guidance when asked by the RPC within the existing framework.  If the existing framework is found to be wanting, the advisor might point this out to strategy body.  It is then up to them to resolve through whatever processes they have.  They might seek guidance from the advisor to resolve issues.

Tell me if you think this is unacceptable.

---

From: Russ Housley <[email-masked]>
Date: Tue, 3 Nov 2020 13:49:12 -0500

Eliot:

https://datatracker.ietf.org/doc/draft-levkowetz-xml2rfc-v3-implementation-notes/

This I-D is essentially the as-designed vs. the as-built discussion of the tools.  It includes "Heather's indication" regarding each of the many schema.  That would be the final word in one of these model, but the place to start the community discussion in the other.  It is still very unclear to me who calls consensus after the community discussion in the advisory model.

Russ

> On Nov 3, 2020, at 5:22 AM, Eliot Lear <lear=[email-masked]> wrote:
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Eliot Lear <[email-masked]>
Date: Tue, 3 Nov 2020 20:16:13 +0100

Hi Russ,

> On 3 Nov 2020, at 19:49, Russ Housley <[email-masked]> wrote:
> 
> Eliot:
> 

Others might see things differently, but I think it is at least assumed in the community model that the chairs call consensus.  Of course if there are two of them and they disagree, perhaps there’s less consensus than one thought ;-).

Eliot

---

From: Michael StJohns <[email-masked]>
Date: Tue, 3 Nov 2020 14:58:15 -0500

Hi Eliot -

> Others might see things differently, but I think it is at least assumed in the community model that the chairs call consensus.  Of course if there are two of them and they disagree, perhaps there’s…

But then we get into the question of who chooses the chairs or what to 
do if a chair (or chairs) gets overtaken by their day job in preference 
to making progress on the RFC issues.

Turtles all the way down...

Later, Mike

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 4 Nov 2020 09:36:25 +1300

>> Others might see things differently, but I think it is at least assumed in the community model that the chairs call consensus.  Of course if there are two of them and they disagree, perhaps there’…

fwiw I think Eliot is correct: the chairs call consensus.

> to making progress on the RFC issues.

We have that problem throughout the I*, by which I mean the IETF,
IAB, IRTF, Independent Series, and even the IETF LLC Board.

True, we still have to write down some rules about how the chairs are
appointed. That's clearly soluble, but it hasn't been solved.

What's the worst that could happen? A dispute between an author and the
RPC could be held up until the chairs can take enough time from their day
jobs to extract a consensus. So the RFC concerned would be delayed.
That's unlikely to be the end of the world.

> Turtles all the way down...

We're computer scientists, we can handle recursion.

Regards
    Brian

---

From: "Martin Thomson" <[email-masked]>
Date: Wed, 04 Nov 2020 13:53:58 +1100

> That's unlikely to be the end of the world.

I think that I proposed something slightly different: we let the RPC proceed with a decision grounded in their own best judgment (which I would hope, but not insist, would involve some attempt at consultation).  Then we live with the consequences of mistakes if the eventual community position differs when consensus is reached.

In other words, let the community provide input at the strategic level.  That means strategic timescales for resolution, and no need for high availability or rapid response on the part of chairs.

If there is a permanent advisor, then I would expect them to take a more active role in the preliminary decision-making.  Such a person could be well-suited to making a recommendation.

However, like Brian, I don't share Mike's apparent complete lack of faith in the ability of our consensus process to produce results.

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 3 Nov 2020 19:08:25 -0800

On Tue, Nov 3, 2020 at 6:54 PM Martin Thomson <[email-masked]> wrote:

> I think that I proposed something slightly different: we let the RPC
> proceed with a decision grounded in their own best judgment (which I would
> hope, but not insist, would involve some attempt at consultation).  Then we
> live with the consequences of mistakes if the eventual community position
> differs when consensus is reached.
>

It's worth noting that in our current practice, the RPC doesn't publish the
RFC without author (or in extremis, AD) signoff, so it takes a lot for a
dispute to become irreparable as opposed to delaying the publication of the
RFC.

In other words, let the community provide input at the strategic level.
> That means strategic timescales for resolution, and no need for high
> availability or rapid response on the part of chairs.
>

True, though given the time scales we are operating on here in general, it
doesn't seem like a crisis if we have to get the RFC WG to take a few
months to resolve some contentious issue.

-Ekr

> If there is a permanent advisor, then I would expect them to take a more
> active role in the preliminary decision-making.  Such a person could be
> well-suited to making a recommendation.
>
> However, like Brian, I don't share Mike's apparent complete lack of faith
> in the ability of our consensus process to produce results.
>
> --

---

From: Eliot Lear <[email-masked]>
Date: Wed, 4 Nov 2020 10:28:16 +0100

Hi Eric,

> On 4 Nov 2020, at 04:08, Eric Rescorla <[email-masked]> wrote:
> 
> It's worth noting that in our current practice, the RPC doesn't publish the RFC without author (or in extremis, AD) signoff, so it takes a lot for a dispute to become irreparable as opposed to delaying the publication of the RFC.

Yes.  There are two situations:

There is a dispute with an author
There is a question within the RPC itself about how to proceed.

You are describing the former case.  We have said that as things stand, we were going to leave it in the hands of the stream managers (in the case of the IETF it would be the AD) to make the final call, and not the RPC, presumably within the limits of the current approved format (e.g, one shouldn’t expect a stream manager to override the RPC in publishing an RFC in EBCDIC).

In the second case, as an author, I leave many editorial decisions to the RPC.  But they themselves might find decision points that need to be addressed.  In this case, I think where Martin is angling is that the RPC makes the call, and then perhaps informs the community of an ambiguity and how they handled it.  It’s then up to the community to address in the future.  That is- work doesn’t stop over whether a comma is used or not with a single adverb phrase, or the flowing of a particular diagram.

> One possible resolution is that the expert exercises moral authority – as experts do – and provides guidance when asked by the RPC within the existing framework.  If the existing framework is found…

Assuming there is such a person would this text be acceptable?  And if not, what would be?

Eliot

---

From: Christian Huitema <[email-masked]>
Date: Wed, 4 Nov 2020 07:54:16 -0800

On 11/4/2020 1:28 AM, Eliot Lear wrote:
>> If there is a permanent advisor, then I would expect them to take a
>> more active role in the preliminary decision-making.  Such a person
>> could be well-suited to making a recommendation.
>
> And that brings us back to whether we are discussing a decision maker
> or an advisor, and whether the text I put forth represents something
> that might be in some way acceptable, assuming the advisor is present.
>  As a reminder, here it is:
>
>> One possible resolution is that the expert exercises moral authority
>> – as experts do – and provides guidance when asked by the RPC within
>> the existing framework.  If the existing framework is found to be
>> wanting, the advisor might point this out to strategy body.  It is
>> then up to them to resolve through whatever processes they have.
>>  They might seek guidance from the advisor to resolve issues.
>

I would avoid "moral authority". Martin considers that given their
technical expertise, experts are well suited to making recommendations.
But these recommendations shall be grounded in technical expertise, not
a vague "moral authority".

-- ChristianHuitema

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 4 Nov 2020 10:36:57 -0800

On Wed, Nov 4, 2020 at 1:28 AM Eliot Lear <[email-masked]> wrote:

> It's worth noting that in our current practice, the RPC doesn't publish
> the RFC without author (or in extremis, AD) signoff, so it takes a lot for
> a dispute to become irreparable as opposed to delaying the publication of
> the RFC.
>
>
>    - There is a dispute with an author
>    - There is a question within the RPC itself about how to proceed.
>
>
> You are describing the former case.  We have said that as things stand, we
> were going to leave it in the hands of the stream managers (in the case of
> the IETF it would be the AD) to make the final call, and *not* the RPC,
> presumably within the limits of the current approved format (e.g, one
> shouldn’t expect a stream manager to override the RPC in publishing an RFC
> in EBCDIC).
>
> In the second case, as an author, I leave many editorial decisions to the
> RPC.  But they themselves might find decision points that need to be
> addressed.  In this case, I think where Martin is angling is that the RPC
> makes the call, and then perhaps informs the community of an ambiguity and
> how they handled it.
>

Yes. i think they make the call using some mechanism of their choice. Given
that this is ultimately only a suggestion.

> One possible resolution is that the expert exercises moral authority – as
> experts do – and provides guidance when asked by the RPC within the
> existing framework.  If the existing framework is found to be wanting, the
> advisor might point this out to strategy body.  It is then up to them to
> resolve through whatever processes they have.  They might seek guidance
> from the advisor to resolve issues.
>
>

Well, i don't think "moral authority" makes any sense. They're advising in
the form of expertise.

The right model here is effectively the situation we have with the LLC,
counsel where the LLC can consult counsel and take decisions based on that
but also that counsel is available to inform community decisions.

-Ekr

---

From: Eliot Lear <[email-masked]>
Date: Wed, 4 Nov 2020 20:31:41 +0100

Eric, Christian,

> 
> 
> I would avoid "moral authority”.

Fair points, both of you.  I only meant the term in that they have an expert basis for their views.  No need to use the term, tho.

Eliot

> Martin considers that given their