Subject: [Rfid] SLRRP and EPC RP

From: "Terry Ye" <[email-masked]>
Date: Fri, 18 Feb 2005 14:13:35 -0800

Hi, 

I am follwoing the SLRRP activities for a while and have a general question.
In the description of IETF BOF, we stated that the goal of SLRRP is to "develop an air-protocol-independent framework for RFID reader communications and management". However, we do have many handles in SLRRP that control directly the air interface  parameters of different air protocols. I guess a basic philosophy difference between SLRRP and RP1.0 is that SLRRP tries to control different air interface protocols (Gen2,  class1, etc.) directly while RP1.0 is to insulate the host from knowling the details of how  the reader and tags interact.

You have addressed this issue in some of the previous replies on the list, but I think it is fundamental for the interoperability of SLRRP and RP. While both philosophies have their reasonings, shouldn't we follow a layer-oriented approach, i.e., leave the lower-layer work to the lower-layer, and do what supposed to be done as a higher layer protocol?

Terry Ye

_______________________________________________
Rfid mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rfid

---

From: "P. Krishna" <[email-masked]>
Date: Mon, 21 Feb 2005 16:13:43 -0500

On Fri, 2005-02-18 at 17:13, Terry Ye wrote:
> In the description of IETF BOF, we stated that the goal of SLRRP is to "develop an air-protocol-independent framework for RFID reader communications and management". However, we do have many 
> handles in SLRRP that control directly the air interface  parameters of different air protocols. I guess a basic 
> philosophy difference between SLRRP and RP1.0 is that SLRRP tries to control different air interface protocols 
> (Gen2,  class1, etc.) directly while RP1.0 is to insulate the host from knowling the details of how  the reader 
> and tags interact.
> 
> You have addressed this issue in some of the previous replies on the list, but 
> I think it is fundamental for the interoperability of SLRRP and RP. 
> While both philosophies have their 
> reasonings, shouldn't we follow a layer-oriented approach, i.e., leave the lower-layer work to the 
> lower-layer, and do what supposed to be done as a higher layer protocol?
> 
> Terry Ye
> 
Hi Terry,
Good question. There is value to a layered approach. RP in its current
incarnation may have a place north of SLRRP. But there are other
protocols from EPCGlobal that you may want to consider like ALE and
EPCIS. 

You make a valid point that SLRRP "protocol" provides a lower-level
control of the reader operations (which include air-protocol, RF
parameters, tag filters, timeliness). In addition SLRRP also provides a
versatile and scalable interface for access operation requirements by
the applications - this is using the ACCESS command that creates/updates
access-specs at the reader.

RP on the other hand is a higher-level protocol to satisfy the basic tag
operations(read/write/kill) required by the application. There is no
low-level knowledge/control in the protocol.

As a side-note, we believe that a high-level protocol that directly
talks to/fro application need not be burdened by the intracies/details
of RF or the air protocol - as a matter of fact, a scalable solution
would address or deal with the abstraction of the physical world - not
deal with readers/readpoints etc. That is _not_ the goal of SLRRP. 

As a lower-level protocol that talks to readers, one should be aware of
and be able to manage the physical aspects of the device and its
environment. Thats what SLRRP tries to achieve.

One point I would like to make is that SLRRP protocol is but one of the
goals of this IETF working group - there are other equally important
problems that needs to be solved for a network for readers - like,
discovery, configuration, management, monitoring,
security/authentication of these readers. 

We hope to shed light on those problems too during the Bof meeting.

/Krishna