Subject: [Rfid] RE: draft-krishna-slrrp-02: SLRRP RNC API?

From: [email-masked]
Date: Fri, 24 Jun 2005 15:55:14 -0500

Is there any plan to standardize an API for the RNC side of SLRRP?
 
Rob Buck
"This message is intended only for the named recipient. If you are not the
intended recipient you are notified that disclosing, copying, distributing
or taking any action in reliance on the contents of this information is
strictly prohibited."  
_______________________________________________
Rfid mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rfid

---

From: "Scott Barvick" <[email-masked]>
Date: Tue, 28 Jun 2005 02:40:46 -0400

Rob,

I don't see the RNC API as something that gets standardized, at least not by this working group.  The RNC is a logical entity that we needed to give a name in the document so that we could refer to the entity at the "other end" of the SLRRP connection - the end that is not the reader interrogating tags.  SLRRP is just a point to point network interface between an RNC and a single reader.  It may be one reader supporting a single application or it may be in an array of hundreds of readers fully instrumenting a facility.   In these extremes or somewhere in the middle, the function of the RNC will be very different, from a thin shim that just sends SLRRP commands directly from a specific application to a fully functioning reader array controller that manages many facets of the reader array.  It also may run on many different types of devices.  We've heard examples of RNCs that would be application software, readers with lots of CPU and memory, dedicated control devices, and even routers with server blades.   All of this leads me to the conclusion that an RNC function is best left for specific products that use SLRRP to talk to readers and that no API to this function is possible to standardize.

Scott

-----Original Message-----
From: [email-masked] on behalf of [email-masked]
Sent: Fri 6/24/2005 4:55 PM
To: [email-masked]
Subject: [Rfid] RE: draft-krishna-slrrp-02: SLRRP RNC API?

Rob Buck

"This message is intended only for the named recipient. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited."