Subject: [Rfid] RE: draft-krishna-slrrp-02: Repeated Inventory Operations

From: [email-masked]
Date: Fri, 24 Jun 2005 16:09:08 -0500

If I issue an Inventory command, does it execute the previous access
commands?  If I then issue another inventory command does it re-execute the
same access commands?  If so, I don't see how you clear the list of access
commands.
 
I assume that 3.4.7 STOP_INVENTORY is used to terminate an inventory that's
operating for an extended period on possibly many tag operations defined by
multiple access commands?
 
Rob Buck
"This message is intended only for the named recipient. If you are not the
intended recipient you are notified that disclosing, copying, distributing
or taking any action in reliance on the contents of this information is
strictly prohibited."  
_______________________________________________
Rfid mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rfid

---

From: "P. Krishna" <[email-masked]>
Date: Sun, 26 Jun 2005 21:34:58 -0400

Hi Rob,

Access commands _dont_ result in instantaneous RF commands generated by the reader. Any access-related RF command is generated only post-inventory. 

Each access command from the RNC create access-specs at the reader. Each access-spec defines the follow-up access operation on the inventoried tags if they match the tag-spec. A parallel that I can draw to the access-specs is access-control lists (ACL) in a router. Basically, a ACL defines a set of operations/actions to be performed on a packet if the filter-spec (defined as a ternary pattern, starting offset) matches the packet contents. Packets as they arrive at the router are looked up, and if they match a filter-spec, the corresponding operation/action is performed on the packet.

Likewise, a reader performs inventory operation based on inventory parameters defined in the inventory command (this step is loosely equivalent to a packet arrival and lookup at the router). Inventory operation results in tags received by the reader on the air-side. If a tag matches one of the tag-spec, a followup access operation is performed. Examples of followup access operations include write, kill, lock, read user memory etc.

> If I issue an Inventory command, does it execute the previous access commands?  

Just want to get the terminology correct - the reader is not executing an access command - instead, it is checking the access-specs.

Yes, the access-specs are checked to see if the tag that was inventoried needs any further access operations to be performed.

If there is a need for access operation to be performed, then the corresponding air-protocol access operation is performed by the reader on that tag.

> If I then issue another inventory command

> does it re-execute the same access commands?  If so, I don't see how you clear the list of access commands.

Yes, the access-specs are looked up for subsequent inventory rounds. A STOP_ACCESS command deletes the access spec at the reader. Once the access-spec is deleted, that <tag-spec, op-spec> related operations are no longer performed by the reader.

> I assume that 3.4.7 STOP_INVENTORY is used to terminate an inventory that's operating for an extended period on possibly 

> many tag operations defined by multiple access commands?

Yes STOP_INVENTORY terminates the inventory operation.

Just to clarify, inventory operation is _not_ defined by access commands. Inventory operation is defined and started by the Inventory command. If there were access-specs defined, then there might have been access operations on tags that match the access-specs. 

/Krishna

"This message is intended only for the named recipient. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited."