Subject: [Rfid] SLRRP -> RRCP?

From: Margaret Wasserman <[email-masked]>
Date: Wed, 20 Jul 2005 21:05:12 -0400

Hi All,

I was talking to Scott Barvick off-line, and I made a comment that is 
probably better shared with the list...

To avoid later pain/confusion, I think it would be preferable to 
change the name of the SLRRP protocol to something that doesn't 
contain "marketing" terms like "Simple" or "Lightweight".  The IESG 
will not generally approve documents that include those words in the 
title or document name, as they are seen as marketing terms, not 
engineering terms.

I recently encountered this issue with an IPDVB WG protocol.  See the 
comments from David Kessens at:

https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=11634&rfc_flag=0

We were forced to rename the ULE protocol in the final stages, which 
was a bit painful.  Fortunately, we found a reasonable name that 
retained the commonly-used ULE acronym, or it would have been worse.

Given that David is one of the area directors for this effort, I 
doubt that we can slip a protocol past him that claims to be both 
"simple" and "lightweight".

In the interest of avoiding that problem if/when this group becomes a 
WG and wants to publish a SLRRP-inspired protocol, I'd suggest that 
we rename the protocol now, while it will have less impact on the 
effort.

How about "RFID Reader Control Protocol (RRCP)"?  It's not as easily 
pronounced, but it is more descriptive.

Margaret

_______________________________________________
Rfid mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rfid

---

From: "David Husak" <[email-masked]>
Date: Thu, 21 Jul 2005 12:31:17 -0400

For the record, the protocol was Simple, the reader was Lightweight:) 

If we've run afoul of current naming practice, I'm all for changing the
name now. We've already built some name equity for SLRRP (I will admit
that's entirely due to the provocative pronunciation), but if change is
inevitable, the sooner, the better.

I'm fine with RCP or RRCP... I'd also put R2CP, or even just R2C, in the
mix. It can have the double meaning of R-squared-C = RRC for RFID Reader
Control, as well as "Reader-to-Controller". The trailing 'P' has always
struck me as sort-of redundant or implied, since you'll typically hear
people say things like "... the XXXXP protocol."

Any other candidates out there?

Dave

------------------------
David J. Husak
Reva Systems Corporation
[email-masked] 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
On
> Behalf Of Marshall Rose
> Sent: Thursday, July 21, 2005 1:38 AM
> To: P. Krishna
> Cc: [email-masked]
> Subject: Re: [Rfid] SLRRP -> RRCP?
> 
> i think margaret raises a valid point, or more accurately two points:
> first, is that it's likely that the name will get changed; and,
> second, that it's probably better to change it earlier tather than
> later.
> 
> i think it's reasonable to start worrying about this now... ideally,
> i'd like to see a new name in the charter when it's approved!
> 
> /mtr
> 
> 
> 
>

---

From: "Howard Kapustein" <[email-masked]>
Date: Thu, 21 Jul 2005 14:12:07 -0400

>The trailing 'P' has always

But not unprecedented.
For instance, HyperText Transport Protocol has had some middling
success...

Not that I'm suggesting one way or the other, just that XXXXP isn't
necessarily bad.

	- Howard

P.S. Google for "rfc http hyper" and guess the 1st hit
http://www.faqs.org/rfcs/rfc2324.html
Another example of XXXXP

Also an example that truly anyone can get anything proposed as an
Internet-Draft :->

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of David Husak
Sent: Thursday, July 21, 2005 12:31 PM
To: Marshall Rose
Cc: [email-masked]
Subject: RE: [Rfid] SLRRP -> RRCP?

Dave

------------------------
David J. Husak
Reva Systems Corporation
[email-masked] 

On

---

From: "David Husak" <[email-masked]>
Date: Thu, 21 Jul 2005 14:34:19 -0400

Howard, 

Remember, it's important to take the date of an RFC into consideration
when evaluating its merits:)

Dave

------------------------
David J. Husak
Reva Systems Corporation
[email-masked]

> From: Howard Kapustein [mailto:[email-masked]]
> Sent: Thursday, July 21, 2005 2:12 PM
> To: David Husak; Marshall Rose
> Cc: [email-masked]

---

From: "Howard Kapustein" <[email-masked]>
Date: Thu, 21 Jul 2005 15:08:31 -0400

I was wondering how many people would notice :-)

-----Original Message-----
From: David Husak [mailto:[email-masked]] 
Sent: Thursday, July 21, 2005 2:34 PM
To: Howard Kapustein
Cc: [email-masked]
Subject: RE: [Rfid] SLRRP -> RRCP?

Howard, 

Dave

------------------------
David J. Husak
Reva Systems Corporation
[email-masked]