Subject: [rip] Specific request processing

From: Nanda kishore <[email-masked]>
Date: Thu, 18 Mar 2004 15:35:45 +0530

Hi,

    In RIP, RIPng If we get a specific request for a particualr desination, RFC's say
that we should respond without doing split-horizon processing. Does that mean that
we should respond with only RIP route. 

Say there is a BGP/OSPF route for desination 210.1.1.0/24 and we got a specific request
for that destination

    Case 1: There is a RIP route with cost 4 which is inactive (Administrative distance)
    Case 2: There is no RIP route to the destination (BGP/OSPF's route is there with cost XYZ)

Which metric should we respond with. 

Regards
Nanda kishore
-----------------------
Senior Software Engineer
Huawei Technology India Pvt. Ltd.
Leela Galleria, 
Bangalore, India.
Ph. 25265596 (R)
      25217152 Ext 662 (O)

---

From: [email-masked]
Date: Thu, 18 Mar 2004 10:28:13 -0500

You should respond with whichever route the router will use for that
destination,
whether or not it is a RIP route. This is true for all queries.
Gary Malkin             Cheap, fast, good... 
508-870-1300 x254                Pick two! 

-----Original Message-----
From: Nanda kishore [mailto:[email-masked]]
Sent: Thursday, March 18, 2004 5:06 AM
To: [email-masked]; [email-masked]
Subject: [rip] Specific request processing

Hi,
 
    In RIP, RIPng If we get a specific request for a particualr desination,
RFC's say
that we should respond without doing split-horizon processing. Does that
mean that
we should respond with only RIP route. 
 
Say there is a BGP/OSPF route for desination 210.1.1.0/24 and we got a
specific request
for that destination
 
    Case 1: There is a RIP route with cost 4 which is inactive
(Administrative distance)
    Case 2: There is no RIP route to the destination (BGP/OSPF's route is
there with cost XYZ)

Regards
Nanda kishore
-----------------------
Senior Software Engineer

---

From: [email-masked]
Date: Thu, 18 Mar 2004 12:29:22 -0500

That is true, but there isn't anything that can be done about it.
Unfortunately,
OSPF allows larger metrics than RIP and there we're stuck with it. In a case
like that, the only thing you can do is respond with "no such route." Any
other
response would be open to too much interpretation.
 
Gary
 
-----Original Message-----
From: Nanda kishore [mailto:[email-masked]]
Sent: Thursday, March 18, 2004 11:04 AM
To: [email-masked]; [email-masked]
Subject: Re: [rip] Specific request processing

But the metric will be inconsistent.
For ospf / BGP metric may be more than 16 
How to respond send the metric in BGP say 123456
Wont' it be invalid in a rip response. ?.
 
Nanda kishore
-----------------------
Senior Software Engineer

----- Original Message ----- 
From: [email-masked] <mailto:[email-masked]>  
To: [email-masked] <mailto:[email-masked]>  ; [email-masked]
<mailto:[email-masked]>  ; [email-masked] <mailto:[email-masked]>  
Sent: Thursday, March 18, 2004 8:58 PM
Subject: RE: [rip] Specific request processing

-----Original Message-----
From: Nanda kishore [mailto:[email-masked]]
Sent: Thursday, March 18, 2004 5:06 AM
To: [email-masked] <mailto:[email-masked]> ; [email-masked]
<mailto:[email-masked]> 

Hi,

 

Regards
Nanda kishore
-----------------------
Senior Software Engineer

---

From: [email-masked]
Date: Thu, 18 Mar 2004 12:29:22 -0500

Gary
 
-----Original Message-----
From: Nanda kishore [mailto:[email-masked]]
Sent: Thursday, March 18, 2004 11:04 AM
To: [email-masked]; [email-masked]
Subject: Re: [rip] Specific request processing

Nanda kishore
-----------------------
Senior Software Engineer

-----Original Message-----
From: Nanda kishore [mailto:[email-masked]]
Sent: Thursday, March 18, 2004 5:06 AM
To: [email-masked] <mailto:[email-masked]> ; [email-masked]
<mailto:[email-masked]> 

Hi,

 

Regards
Nanda kishore
-----------------------
Senior Software Engineer