Subject: [rip] Version Number Processing

From: Joseph Scholefield <[email-masked]>
Date: Mon, 15 Mar 2004 10:59:25 -0500

Hello,

We have encountered a number of scenarios which are not too clearly
described in the RIP 2 Specification, RFC2453. We are concerned with how
a RIP Router should handle the reception of RIP Version 3 packets
(anything greater than 2).

Section 5 states
As a V1 Router:
 - Version 1 packets with MBZ with non-zero fields are to be ignored
 - Version >1 packets with MBZ with non-zero fields are not to be
ignored "simply because an MBZ field contains a value other than zero."

Does this hold true as a V2 Router?

So, does a version 2 router process, or drop, a version 3 RIP packet?
Should this packet be a Request, should a RIP Router then respond with a
Version 3 Response?

I have read through the RFC and have not come up with any clear answer
to the expected behavior. If you could direct me to specific quotes in
the RFC that will tell me what a router should do, I would appreciate
it.

Thanks,

Joe Scholefield

_______________________________________________
rip mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rip

---

From: [email-masked]
Date: Mon, 15 Mar 2004 11:13:59 -0500

Joe,

The reason the spec does not cover this case is that it
depends on the difference between V3 and V2.  If the V3
packet is completely backwards compatible with a V2 packet
(i.e., the only difference is in a field unused by V2),
then the V2 router could respond with a V2 packet.  The V3
router should be able to handle a V2 response.  Ideally,
it would remember that there is a V2 router on that
interface and use V2 on it thereafter.  If the V3 packet
is not backwards compatible, then the V2 router must drop
the V3 packet.  Unfortunately, since the V2 code is already
out there, it doesn't know which scenario is the correct
one, so its operation is implementation dependent.

Gary Malkin             Cheap, fast, good...
508-870-1300 x254                Pick two!

-----Original Message-----
From: Joseph Scholefield [mailto:[email-masked]]
Sent: Monday, March 15, 2004 10:59 AM
To: [email-masked]
Subject: [rip] Version Number Processing

Hello,

Section 5 states
As a V1 Router:

Thanks,

Joe Scholefield

---

From: [email-masked]
Date: Mon, 15 Mar 2004 11:13:59 -0500

Joe,

-----Original Message-----
From: Joseph Scholefield [mailto:[email-masked]]
Sent: Monday, March 15, 2004 10:59 AM
To: [email-masked]
Subject: [rip] Version Number Processing

Hello,

Section 5 states
As a V1 Router:

Thanks,

Joe Scholefield