Subject: RE: [rip] Specific request processing

From: [email-masked]
Date: Thu, 18 Mar 2004 10:28:13 -0500

You should respond with whichever route the router will use for that
destination,
whether or not it is a RIP route. This is true for all queries.
Gary Malkin             Cheap, fast, good... 
508-870-1300 x254                Pick two! 

-----Original Message-----
From: Nanda kishore [mailto:[email-masked]]
Sent: Thursday, March 18, 2004 5:06 AM
To: [email-masked]; [email-masked]
Subject: [rip] Specific request processing

Hi,
 
    In RIP, RIPng If we get a specific request for a particualr desination,
RFC's say
that we should respond without doing split-horizon processing. Does that
mean that
we should respond with only RIP route. 
 
Say there is a BGP/OSPF route for desination 210.1.1.0/24 and we got a
specific request
for that destination
 
    Case 1: There is a RIP route with cost 4 which is inactive
(Administrative distance)
    Case 2: There is no RIP route to the destination (BGP/OSPF's route is
there with cost XYZ)
 
Which metric should we respond with. 
 
Regards
Nanda kishore
-----------------------
Senior Software Engineer
Huawei Technology India Pvt. Ltd.
Leela Galleria, 
Bangalore, India.
Ph. 25265596 (R)
      25217152 Ext 662 (O)

---

From: Nanda kishore <[email-masked]>
Date: Thu, 18 Mar 2004 21:33:57 +0530

But the metric will be inconsistent.
For ospf / BGP metric may be more than 16 
How to respond send the metric in BGP say 123456
Wont' it be invalid in a rip response. ?.

Nanda kishore
-----------------------
Senior Software Engineer

  ----- Original Message ----- 
  From: [email-masked] 
  To: [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Thursday, March 18, 2004 8:58 PM
  Subject: RE: [rip] Specific request processing

  You should respond with whichever route the router will use for that destination,
  whether or not it is a RIP route. This is true for all queries.
  Gary Malkin             Cheap, fast, good... 
  508-870-1300 x254                Pick two! 

  -----Original Message-----
  From: Nanda kishore [mailto:[email-masked]]
  Sent: Thursday, March 18, 2004 5:06 AM
  To: [email-masked]; [email-masked]
  Subject: [rip] Specific request processing

  Hi,

      In RIP, RIPng If we get a specific request for a particualr desination, RFC's say
  that we should respond without doing split-horizon processing. Does that mean that
  we should respond with only RIP route. 

  Say there is a BGP/OSPF route for desination 210.1.1.0/24 and we got a specific request
  for that destination

      Case 1: There is a RIP route with cost 4 which is inactive (Administrative distance)
      Case 2: There is no RIP route to the destination (BGP/OSPF's route is there with cost XYZ)

  Regards
  Nanda kishore
  -----------------------
  Senior Software Engineer

---

From: Nanda kishore <[email-masked]>
Date: Thu, 18 Mar 2004 21:33:57 +0530

Nanda kishore
-----------------------
Senior Software Engineer

  -----Original Message-----
  From: Nanda kishore [mailto:[email-masked]]
  Sent: Thursday, March 18, 2004 5:06 AM
  To: [email-masked]; [email-masked]
  Subject: [rip] Specific request processing

  Hi,

  Regards
  Nanda kishore
  -----------------------
  Senior Software Engineer