Subject: Re: [Roll] [roll] #129: draft-ietf-roll-trickle-mcast-04 - Proactive and Reactive Forwarding should be mutually exclusive within the same MPL Domain?

From: KELLIL Mounir <[email-masked]>
Date: Tue, 3 Sep 2013 14:10:19 +0000

Dear Jonathan, all,
Thanks for the clarification regarding the proactive and Reactive Forwarding procedures, yet it is still not clear for me what happens if a forwarding node in a 'reactive forwarding only' mode receives a new MPL message ? Does it forward the message systematically (i.e., without receiving any associated control message)? If the answer is No, in this case it may happen that for LLNs with specific topologies (e.g., sparse networks) some nodes might not receive (all) the MPL messages. Maybe you have already considered this problem somehow?

Regards

Mounir

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de roll issue tracker
Envoyé : vendredi 30 août 2013 01:35
À : [email-masked]; [email-masked]; [email-masked]
Cc : [email-masked]
Objet : Re: [Roll] [roll] #129: draft-ietf-roll-trickle-mcast-04 - Proactive and Reactive Forwarding should be mutually exclusive within the same MPL Domain?

#129: draft-ietf-roll-trickle-mcast-04 - Proactive and Reactive Forwarding should be mutually exclusive within the same MPL Domain?

Comment (by [email-masked]):

 Date: Thu, 29 Aug 2013 14:34:38 +0000

 From: "Jonathan Hui (johui)" <[email-masked]>

 Subject: Re: [Roll] I-D Action: draft-ietf-roll-trickle-mcast-

 05.txt

 “This update attempts to address all of the open tickets.  A summary of  changes is below.  Please provide feedback on these changes.  Thanks.

 ...

 129:
 - Updated Section 4.2 to explicitly indicate that proactive and reactive  are not mutually exclusive.  Proactive and reactive techniques may be used  simultaneously within an MPL Domain.  For example, upon receiving a new  MPL Data messages when both proactive and reactive forwarding techniques  are enabled, an MPL Forwarder will proactively retransmit the MPL Data  Message a limited number of times and schedule further transmissions upon  receiving MPL Control Messages.”

 Thread: http://www.ietf.org/mail-archive/web/roll/current/msg08103.html
 Thread: http://www.ietf.org/mail-archive/web/roll/current/msg07947.html

-- 
---------------------------------------+------------------------------
 Reporter:  [email-masked]  |       Owner:  [email-masked]
     Type:  defect                     |      Status:  new
 Priority:  minor                      |   Milestone:
Component:  trickle-mcast              |     Version:
 Severity:  In WG Last Call            |  Resolution:
 Keywords:                             |
---------------------------------------+------------------------------

Ticket URL: <https://svn.tools.ietf.org/wg/roll/trac/ticket/129#comment:2>
roll <http://tools.ietf.org/wg/roll/>

_______________________________________________
Roll mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/roll

---

From: "Jonathan Hui (johui)" <[email-masked]>
Date: Tue, 3 Sep 2013 14:23:52 +0000

Hi Mounir,

MPL's reactive mode relies on MPL Control Messages to provide eventual consistency.  Using the Trickle algorithm, a device resets its MPL Control Message Trickle timer whenever it determines that a neighboring node has newer or older information.  When determining that a neighboring device has not received an MPL Data Message, a device will reset/start the Trickle timer to transmit the MPL Data Message.

Hope that helps.

--
Jonathan Hui

---

From: KELLIL Mounir <[email-masked]>
Date: Tue, 3 Sep 2013 14:52:03 +0000

Thanks Jonathan. I got it. 
Regards

Mounir

-----Message d'origine-----
De : Jonathan Hui (johui) [mailto:[email-masked]] 
Envoyé : mardi 3 septembre 2013 16:24
À : KELLIL Mounir
Cc : [email-masked]
Objet : Re: [Roll] [roll] #129: draft-ietf-roll-trickle-mcast-04 - Proactive and Reactive Forwarding should be mutually exclusive within the same MPL Domain?

Hi Mounir,

Hope that helps.

--
Jonathan Hui

On Sep 3, 2013, at 7:10 AM, KELLIL Mounir <[email-masked]> wrote:

> De : [email-masked] [mailto:[email-masked]] De la part 
> de roll issue tracker Envoyé : vendredi 30 août 2013 01:35 À : 
> [email-masked]; [email-masked]; [email-masked] Cc : 
> [email-masked] Objet : Re: [Roll] [roll] #129: 
> draft-ietf-roll-trickle-mcast-04 - Proactive and Reactive Forwarding should be mutually exclusive within the same MPL Domain?
> 
> "This update attempts to address all of the open tickets.  A summary of  changes is below.  Please provide feedback on these changes.  Thanks.
> 
> ...
> 
> 129:
> - Updated Section 4.2 to explicitly indicate that proactive and reactive  are not mutually exclusive.  Proactive and reactive techniques may be used  simultaneously within an MPL Domain.  For example, upon receiving a new  MPL Data messages when both proactive and reactive forwarding techniques  are enabled, an MPL Forwarder will proactively retransmit the MPL Data  Message a limited number of times and schedule further transmissions upon  receiving MPL Control Messages."
> 
> Thread: 
> http://www.ietf.org/mail-archive/web/roll/current/msg08103.html
> Thread: 
> http://www.ietf.org/mail-archive/web/roll/current/msg07947.html
> 
> --
> Ticket URL: 
> <https://svn.tools.ietf.org/wg/roll/trac/ticket/129#comment:2>

---

From: "roll issue tracker" <[email-masked]>
Date: Tue, 03 Sep 2013 22:16:15 -0000

#129: draft-ietf-roll-trickle-mcast-04 - Proactive and Reactive Forwarding should
be mutually exclusive within the same MPL Domain?

 From: KELLIL Mounir <[email-masked]>[[BR]]
 Date: Tue, 3 Sep 2013 14:10:19 +0000
 ...

 Dear Jonathan, all,

 Thanks for the clarification regarding the proactive and Reactive
 Forwarding procedures, yet it is still not clear for me what happens if a
 forwarding node in a 'reactive forwarding only' mode receives a new MPL
 message ? Does it forward the message systematically (i.e., without
 receiving any associated control message)? If the answer is No, in this
 case it may happen that for LLNs with specific topologies (e.g., sparse
 networks) some nodes might not receive (all) the MPL messages. Maybe you
 have already considered this problem somehow?

 Regards

 Mounir

 ---------------------------------------------------

 Hi Mounir,

 MPL's reactive mode relies on MPL Control Messages to provide eventual
 consistency.  Using the Trickle algorithm, a device resets its MPL Control
 Message Trickle timer whenever it determines that a neighboring node has
 newer or older information.  When determining that a neighboring device
 has not received an MPL Data Message, a device will reset/start the
 Trickle timer to transmit the MPL Data Message.

 Hope that helps.--Jonathan Hui

 --------------------------------------------------------

 From: KELLIL Mounir <[email-masked]>

 Regards

 Mounir[[BR]]
 [[BR]]
 Thread: http://www.ietf.org/mail-archive/web/roll/current/msg08119.html

Ticket URL: <http://trac.tools.ietf.org/wg/roll/trac/ticket/129#comment:3>
roll <http://tools.ietf.org/wg/roll/>

---

From: "roll issue tracker" <[email-masked]>
Date: Wed, 04 Sep 2013 19:29:30 -0000

Changes (by [email-masked]):

 * status:  new => closed
 * resolution:   => fixed

-- 
---------------------------------------+------------------------------
 Reporter:  [email-masked]  |       Owner:  [email-masked]
     Type:  defect                     |      Status:  closed
 Priority:  minor                      |   Milestone:
Component:  trickle-mcast              |     Version:
 Severity:  In WG Last Call            |  Resolution:  fixed
 Keywords:                             |
---------------------------------------+------------------------------

Ticket URL: <https://svn.tools.ietf.org/wg/roll/trac/ticket/129#comment:4>
roll <http://tools.ietf.org/wg/roll/>