Subject: [Roll] Applicability Statements Documents

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Thu, 26 Sep 2013 12:16:05 +0000

Dear all (especially to the authors),

As you know, we are dramatically lagging behind with regards to our applicability statements (AMI, home, industrial, ...). As a reminder:

Feb 2013        Submit first draft of RPL applicability statement for Home Automation applications to the IESG to be considered as an Informational RFC
Feb 2013        Submit first draft of RPL applicability statement for Building Automation applications to the IESG to be considered as an Informational RFC
Feb 2013        Submit first draft of RPL applicability statement for Industrial applications to the IESG to be considered as an Informational RFC

So we would really appreciate if the authors could give us an update on these WG documents, copying the list.

Many Thanks !

JP and Michael.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 27 Sep 2013 12:00:31 +0000

Dear all

We publish a refresher in August. Point is until we have more deployments, we can hardly do better than what we have.
In particular we cannot fill:

4.2<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#section-4.2>.  Layer-two features . . . . . . . . . . . . . . . . . . . . 28<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#page-28>

       4.2.1.  Need layer-2 expert here.  . . . . . . . . . . . . . . 28<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#page-28>

       4.2.2.  Security functions provided by layer-2.  . . . . . . . 28<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#page-28>

       4.2.3<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#section-4.2.3>.  6LowPAN options assumed. . . . . . . . . . . . . . . . 28<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#page-28>

       4.2.4<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#section-4.2.4>.  MLE and other things . . . . . . . . . . . . . . . . . 28<http://tools.ietf.org/html/draft-phinney-roll-rpl-industrial-applicability-02#page-28>

My suggestion is to drop that section and publish what we have as an informational RFC.
If 6TiSCH is formed, then we will have better information there to make a refined applicability statement for RPL over that particular MAC, which is today the industrial LLN of choice.

Cheers,

Pascal

From: [email-masked] [mailto:[email-masked]] On Behalf Of JP Vasseur (jvasseur)
Sent: jeudi 26 septembre 2013 14:16
To: Routing Over Low power and Lossy networks
Subject: [Roll] Applicability Statements Documents

Feb 2013

Submit first draft of RPL applicability statement for Home Automation applications to the IESG to be considered as an Informational RFC

Feb 2013

Submit first draft of RPL applicability statement for Building Automation applications to the IESG to be considered as an Informational RFC

Feb 2013

Submit first draft of RPL applicability statement for Industrial applications to the IESG to be considered as an Informational RFC

Many Thanks !

JP and Michael.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 27 Sep 2013 09:40:22 -0400

Pascal Thubert (pthubert) <[email-masked]> wrote:
    > We publish a refresher in August. Point is until we have more
    > deployments, we
    > can hardly do better than what we have.

    > 4.2.  Layer-two features . . . . . . . . . . . . . . . . . . . . 28
    > 4.2.1.  Need layer-2 expert here.  . . . . . . . . . . . . . . 28
    > 4.2.2.  Security functions provided by layer-2.  . . . . . . . 28
    > 4.2.3.  6LowPAN options assumed. . . . . . . . . . . . . . . . 28
    > 4.2.4.  MLE and other things . . . . . . . . . . . . . . . . . 28

Then I don't see how you can have a specification that be implemented.
Do you truly have no layer-2 security, or you just don't know what it is?

If you are targetting more than one layer-2, then you are approaching the
applicability statements wrong...  If you say here, "this applies to
[WirelessHART] and [ISA100], each of which specifies security mechanisms X
and Y", then you've said enough.

    > My suggestion is to drop that section and publish what we have as an

I don't think that this is going to fly with the IESG.
You might as well wait then.

    > If 6TiSCH is formed, then we will have better information there to make a
    > refined applicability statement for RPL over that particular MAC, which
    > is
    > today the industrial LLN of choice.

This is why I asked if 6tisch should adopt this document.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
IETF ROLL WG co-chair.    http://datatracker.ietf.org/wg/roll/charter/