Subject: [Roll] comments for draft-gnawali-roll-rpl-recommendations?

From: Omprakash Gnawali <[email-masked]>
Date: Fri, 13 Sep 2013 01:14:56 -0500

Dear ROLL WG,

I plan to update the draft-gnawali-roll-rpl-recommendations in the
next day or two. I would love to hear about any new/old/usual/unusual
experiences about RPL use so that I can collect those insights in this
draft to benefit everyone in the community.

Here is the URL to the current draft:
http://tools.ietf.org/html/draft-gnawali-roll-rpl-recommendations-03

Thank you.

- om_p

---

From: Ralph Droms <[email-masked]>
Date: Fri, 13 Sep 2013 14:06:32 -0400

Interesting and useful doc.

Unless explicitly noted, do the recommendations apply to both storing and non-storing modes?

Are your recommendations based on deployments, simulations, protocol analysis?  Do you have any references you can cite that provide the input for your recommendations?

- Ralph

On Sep 13, 2013, at 2:14 AM 9/13/13, Omprakash Gnawali <[email-masked]> wrote:

> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Omprakash Gnawali <[email-masked]>
Date: Sun, 15 Sep 2013 11:34:09 -0500

The recommendations are based on testbed experiments with TelosB motes
and unless otherwise noted, focused on non-storing mode. The
recommendations come from some published work and some unpublished
work I shared with this WG 2-3 yrs ago. Recommendation #10 is based on
numbers reported and survey of code.

There have been a lot of RPL deployments, would be great to collect
the experiences from them.

- om_p

---

From: Ralph Droms <[email-masked]>
Date: Tue, 17 Sep 2013 11:02:54 -0400

On Sep 15, 2013, at 12:34 PM 9/15/13, Omprakash Gnawali <[email-masked]> wrote:

> work I shared with this WG 2-3 yrs ago.

OK.  It would likely be helpful to cite some of those sources.

BTW, the reference for I-D.ietf-roll-routing-metrics seems broken:

   [I-D.ietf-roll-routing-metrics]

              Vasseur, J. and D. Networks, "Routing Metrics used for
              Path Calculation in Low Power and Lossy Networks",
              
Citing RFC 2119 is probably unnecessary.

In section 4, should the rate of dynamic changes in the network topology be considered in setting the maximum trickle interval?

In section 5, should the density of the mesh - some metric of the number of neighbors for each node (average, median, minimum, maximum) - be considered in setting the redundancy constant?

Do the recommendations in section 9 apply only to UDP-based uni-directional sensor data collection?  SEP 2.0 uses HTTP to the sensor nodes to collect data and control the operation of the nodes.  Would that scenario do better with a preference for route stability?

- Ralph

> Recommendation #10 is based on