Subject: [Roll] [draft-ietf-roll-nsa-extension] Section realignment - feedback request

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Mon, 10 Feb 2020 15:56:24 +0100 (CET)

Dear Ines, Dominique, Pascal, and all,

After discussing and amending the draft-ietf-roll-nsa-extension draft with
feedback from Rahul, a few points still remain which we would like some
additional feedback on.

I copy the relevant discussion below:

[RJ] Section realignment
It is better to explain CA Strict/Medium/Relax policies before explaining
the
CAOF because as a reader one needs to be familiar with these policies before
understanding the OF.

[AK] Thank you for this comment. We had a similar concern as well.
We are not sure what is best.
As the text is current structured, we introduce the CAOF first, mentioning
that different policies are possible and that a selection from the parent
set must be made.
We then describe the CAOF in terms of differences from/additions to MRHOF.
And finally we describe the policies.
To my mind, the policies are concrete, but they are also just examples, so
someone can devise different ones.
In that sense the CAOF is more "fixed" and the policies are more flexible.
Thus it makes sense to describe the CAOF first.

We are very open to changing the order, but we would like to have some
additional feedback that the order is problematic as it stands now.
We would like to hear any suggestions from the group on this topic.

[RJ] Ok, lets wait for feedback. I, for one, would like to see
policies explained first and then an OF using them. I find this the
only logical way.

[RJ] Rahul Jadhav
[AR] Aris Koutsiamanis

Thank you very much in advance.

Best,
Aris

---

From: <[email-masked]>
Date: Tue, 25 Feb 2020 09:54:40 +0000

Hello Aris, all,

Thanks for asking.
I've just reviewed version –06 of the draft, before reading the details of the email below.
It turns out that I was not shocked by the current ordering of sections. Probably because I'm already familiar with the topic.
However, at minimum, a forward reference to Sections 3.1-3.3 would be highly useful to newcomers to the draft. Probably right after "There are multiple alternative methods of selecting the AP node."
Reading the details of the email below and thinking about it, I believe that bringing sections 3.1-3.4 forward in the document, before Section 3 "Common Ancestor Objective Function", as Rahul suggests, would make even more sense.
Just be careful to call the CA-Strict, CA-Medium and CA-Relaxed things "methods" or "algorithm", not OF. Leave the "OF" term to the actual definition (as updates to MRHOF), and refer to the "algorithms" in the OF definition.
This is my personal opinion as a member of the WG.
More comments on the draft to come in a separate email.
Best regards,

Dominique

De : Remous-Aris Koutsiamanis <[email-masked]<mailto:[email-masked]>>
Date : Monday 10 February 2020 15:56
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Dominique Barthel <[email-masked]<mailto:[email-masked]>>, Pascal Thubert <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc : "Georgios Z. Papadopoulos" <[email-masked]<mailto:[email-masked]>>
Objet : [draft-ietf-roll-nsa-extension] Section realignment - feedback request

After discussing and amending the draft-ietf-roll-nsa-extension draft with feedback from Rahul, a few points still remain which we would like some additional feedback on.

[RJ] Section realignment
It is better to explain CA Strict/Medium/Relax policies before explaining the
CAOF because as a reader one needs to be familiar with these policies before
understanding the OF.

[AK] Thank you for this comment. We had a similar concern as well.
We are not sure what is best.
As the text is current structured, we introduce the CAOF first, mentioning that different policies are possible and that a selection from the parent set must be made.
We then describe the CAOF in terms of differences from/additions to MRHOF.
And finally we describe the policies.
To my mind, the policies are concrete, but they are also just examples, so someone can devise different ones.
In that sense the CAOF is more "fixed" and the policies are more flexible. Thus it makes sense to describe the CAOF first.

We are very open to changing the order, but we would like to have some additional feedback that the order is problematic as it stands now.
We would like to hear any suggestions from the group on this topic.

[RJ] Rahul Jadhav
[AR] Aris Koutsiamanis

Best,
Aris

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Remous-Aris Koutsiamanis <[email-masked]>
Date: Tue, 25 Feb 2020 17:18:33 +0100 (CET)

Hello Dominique and Rahul,

thank you both very much for the review and comments.

I am glad that there is consensus and both of you agree that the section
order should be reversed.
I had no real problem with either order but after reading it many times
maybe I have been desensitized a bit.

So I will make the change, no problem.

Also, since Dominique plans to send more comments, I think I will wait for
those as well so that I can do all the fixes/changes together, hopefully
before the next cutoff date.

Again, thanks a lot for the help.

Best,
Aris

On Tue, Feb 25, 2020 at 10:55 AM <[email-masked]> wrote:

> It turns out that I was not shocked by the current ordering of sections.
> Probably because I'm already familiar with the topic.
> However, at minimum, a forward reference to Sections 3.1-3.3 would be
> highly useful to newcomers to the draft. Probably right after "There are
> multiple alternative methods of selecting the AP node."
> Reading the details of the email below and thinking about it, I believe
> that bringing sections 3.1-3.4 forward in the document, before Section 3
> "Common Ancestor Objective Function", as Rahul suggests, would make even
> more sense.
> Just be careful to call the CA-Strict, CA-Medium and CA-Relaxed things
> "methods" or "algorithm", not OF. Leave the "OF" term to the actual
> definition (as updates to MRHOF), and refer to the "algorithms" in the OF
> definition.
> De : Remous-Aris Koutsiamanis <[email-masked]>
> À : "[email-masked]" <[email-masked]>,
> Dominique Barthel <[email-masked]>, Pascal Thubert <
> [email-masked]>, "[email-masked]" <[email-masked]>
> Cc : "Georgios Z. Papadopoulos" <[email-masked]>
> After discussing and amending the draft-ietf-roll-nsa-extension draft
> with feedback from Rahul, a few points still remain which we would like
> some additional feedback on.
>