Subject: Re: [Roll] FW: New Version Notification for draft-ietf-roll-dis-modifications-01.txt

From: <[email-masked]>
Date: Tue, 4 Feb 2020 15:31:28 +0000

Hello Abdussalam,

Sorry to respond so late, your mail below became hidden under the pile-up after IETF106.
You're right that draft-ietf-roll-dis-modifications-01.txt adds new behaviour to 6550, and so it looks that it should update 6550.
However, we already knew we wanted to do dis-modifications at the time we wrote 6550, therefore we put a sentence in there "unless a flag modifies this behaviour".
I would therefore think that, formally, 6550 is not updated by dis-modifications.
I will need to double check with our AD's on this, though.
Thanks for spotting this and letting us now!
Best regards,

Dominique

De : Roll <[email-masked]<mailto:[email-masked]>> on behalf of Abdussalam Baryun <[email-masked]<mailto:[email-masked]>>
Répondre à : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date : Monday 25 November 2019 07:43
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : Re: [Roll] FW: New Version Notification for draft-ietf-roll-dis-modifications-01.txt

Hi

I think this draft should update the RFC6550 but the draft did not mention updating,

AB

On Thu, Nov 21, 2019 at 11:03 AM <[email-masked]<mailto:[email-masked]>> wrote:
Hello all,

In light of the current discussions on adding flags and generally
improving the behavior of DIS messages, I've just republished the old
dis-modifications draft with Informational status.
The purpose is to provide the WG with the use cases that were described in
that draft.
Except for the issue date and version, the draft is unchanged from -00.
Best regards,

Dominique

Le 21/11/19 16:57, « [email-masked]<mailto:[email-masked]> » <[email-masked]<mailto:[email-masked]>>
a écrit :

>
>A new version of I-D, draft-ietf-roll-dis-modifications-01.txt
>has been successfully submitted by Dominique Barthel and posted to the
>IETF repository.
>
>Name:          draft-ietf-roll-dis-modifications
>Revision:      01
>Title:         DIS Modifications
>Document date: 2019-11-21
>Group:         roll
>Pages:         15
>URL:
>https://www.ietf.org/internet-drafts/draft-ietf-roll-dis-modifications-01.
>txt
>Status:
>https://datatracker.ietf.org/doc/draft-ietf-roll-dis-modifications/
>Htmlized:
>https://tools.ietf.org/html/draft-ietf-roll-dis-modifications-01
>Htmlized:
>https://datatracker.ietf.org/doc/html/draft-ietf-roll-dis-modifications
>Diff:
>https://www.ietf.org/rfcdiff?url2=draft-ietf-roll-dis-modifications-01
>
>Abstract:
>   This document augments RFC6550 with DIS flags and options that
>   allow a RPL node to better control how neighbor RPL routers respond
>   to its solicitation for DIOs.
>
>
>
>
>
>Please note that it may take a couple of minutes from the time of
>submission
>until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
>The IETF Secretariat
>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 11 Feb 2020 07:28:14 +0200

Hi Dominique,

Ok, however, I think any new RFC needs to mention its update to previous,
it's the user right not the IETF.

AB

On Tue, Feb 4, 2020 at 5:31 PM <[email-masked]> wrote:

> You're right that draft-ietf-roll-dis-modifications-01.txt adds new
> behaviour to 6550, and so it looks that it should update 6550.
> However, we already knew we wanted to do dis-modifications at the time we
> wrote 6550, therefore we put a sentence in there "unless a flag modifies
> this behaviour".
> De : Roll <[email-masked]> on behalf of Abdussalam Baryun <
> [email-masked]>
> Répondre à : "[email-masked]" <[email-masked]>
> À : "[email-masked]" <[email-masked]>
> On Thu, Nov 21, 2019 at 11:03 AM <[email-masked]> wrote:
>
>> Hello all,
>>
>> Le 21/11/19 16:57, « [email-masked] » <[email-masked]
>> >
>> a écrit :
>>
>> >
>> >until the htmlized version and diff are available at tools.ietf.org.
>> >
>> >The IETF Secretariat
>> >
>>
>>
>>
>> Ce message et ses pieces jointes peuvent contenir des informations
>> confidentielles ou privilegiees et ne doivent donc
>> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
>> recu ce message par erreur, veuillez le signaler
>> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
>> electroniques etant susceptibles d'alteration,
>> This message and its attachments may contain confidential or privileged
>> information that may be protected by law;
>> [email-masked]