Subject: [rtcweb] Genart last call review of draft-uberti-rtcweb-rfc8829bis-02

From: Joel Halpern via Datatracker <[email-masked]>
Date: Sun, 27 Mar 2022 10:49:05 -0700

Reviewer: Joel Halpern
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-uberti-rtcweb-rfc8829bis-02
Reviewer: Joel Halpern
Review Date: 2022-03-27
IETF LC End Date: 2022-04-05
IESG Telechat date: Not scheduled for a telechat

Summary: This document is ready for publication as a Proposed Standard. 
However, there are some issues that should be considered before final approval.

Major issues: None

Minor issues:
    I found myself confused as a reader about one aspect of this document  The
    document seems to describe both the Interface to the JSEP and the details
    of what the underlying system must do in response to JSEP operations.  The
    later is described very well and clearly.  The former is described quite
    vaguely.  I suspect that the assumption is that the required parameters are
    described in the W3C documents.  But it is hard to tell, and the only
    formal reference is a vague citation in the introduction to an outdated W3C
    specification.  A little more clarity on how an implementor is supposed to
    know what actual interface objects, methods, and parameters they need to
    provide would be helpful.  Also, the reference should be updated to
    whatever is the current W3C specification.
Nits/editorial comments:

---

From: Sean Turner <[email-masked]>
Date: Mon, 28 Mar 2022 22:47:34 -0400

> On Mar 27, 2022, at 13:49, Joel Halpern via Datatracker <[email-masked]> wrote:
> 
> Reviewer: Joel Halpern

Will check on updating the reference. I would be floored if we couldn’t point to it.

The basic idea here is that the W3C WebRTC spec is API and this is the protocol spec.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 28 Mar 2022 23:08:37 -0400

Thanks Sean.  I finally concluded that was the intent.  And I think 
technically it says so.
If you could look at making that more clear early, it would probably 
help those readers who are not as familiar with the cited W3C API.

Yours,
Joel

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 29 Mar 2022 12:39:30 +0000

Hi,

A couple of comments:

First, in general, if we are going to update the reference version, we need to verify that we don't break anything.

Second, most of the RTCWEB RFCs referencing the WebRTC spec seem to reference *without* a version (i.e., https://www.w3.org/TR/webrtc/). Many RFCs also reference to RFC 8825 for WebRTC, and RFC 8825 also reference WebRTC without a version.

So, is there a reason why we would use a version in JSEP, while not in other RFCs? Note that often the WebRTC reference is Normative.

I do understand that JSEP is very closely linked to WebRTC, why there might be a need to reference a given version. But, then again, we need to make sure that updating the version does not break anything.

Regards,

Christer

________________________________
From: Gen-art <[email-masked]> on behalf of Joel M. Halpern <[email-masked]>
Sent: Tuesday, March 29, 2022 6:08:37 AM
To: Sean Turner <[email-masked]>
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; RTCWeb IETF <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [Gen-art] Genart last call review of draft-uberti-rtcweb-rfc8829bis-02

Yours,
Joel

On 3/28/2022 10:47 PM, Sean Turner wrote:
> Will check on updating the reference. I would be floored if we couldn't point to it.
>

_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art