Subject: [RTG-DIR] Routing Directorate Review of draft-ietf-mpls-tp-data-plane-03

From: Ross Callon <[email-masked]>
Date: Mon, 14 Jun 2010 12:18:01 -0400

I have been selected as the Routing Directorate reviewer for draft-ietf-mpls-tp-data-plane. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://www.ietf.org/iesg/directorate/routing.html

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document:       draft-ietf-mpls-tp-data-plane-03
Reviewer:       Ross Callon
Review Date:    June 14, 2010
IETF LC End Date: June 14, 2010
Intended Status: Standards Track

Summary: This document is basically ready for publication, but has minor editorial nits that should be considered prior to publication.

Comments: This draft is easy to read, and is quite well done. I have only editorial nits and one question that the authors should consider.

Major Issues:  None

Minor Issues:

Section 3.2, first two paragraphs:  It is clear from the first paragraph that the lowest level LSP occurs at level 0 (thus we could n from zero, rather than from one). However, the second sentence begins:

   Note that the MPLS label stack associated with an MPLS-TP section at
   layer n consists of n labels, in the absence of stack optimisation mechanisms.

Should this really specify that a stack at level n consists of n+1 labels? Alternatively, should we be counting LSPs starting at n=1 in the first paragraph?

Nits:

Section 2, page 5, first full paragraph on this page, first sentence:

   At an LSR, S-PE, or T-PE, further processing occurs to determine the
   context of a packet occurs when a swap operation is interrupted by TTL expiry.

There seems to be a grammatical error, the word "occurs" should only occur once. This would seem to read better if the first occurrence of "occurs" were deleted.

Section 4, third paragraph (page 9):

        When the the control message is carried over a section or an LSP,...

First of all the word "the" occurs twice in succession.

It seems to me that the term "section" was defined in section 3.2 to include either an underlying data link or an LSP at the next lower level. Thus the phrase "section or LSP" seems to be redundant -- although clear.

---

From: Ross Callon <[email-masked]>
Date: Mon, 14 Jun 2010 12:32:26 -0400

The "[email-masked]" address bounced, so I am resending with the authors and WG chair addresses explicitly spelled out, and with one typo in my original email fixed.   Ross.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ross Callon
Sent: 14 June 2010 12:18
To: Adrian Farrel; [email-masked]
Cc: [email-masked]'; [email-masked]
Subject: [RTG-DIR] Routing Directorate Review of draft-ietf-mpls-tp-data-plane-03

Major Issues:  None

Minor Issues:

Section 3.2, first two paragraphs:  It is clear from the first paragraph that the lowest level LSP occurs at level 0 (thus we count n from zero, rather than from one). However, the second sentence begins:

Nits:

---

From: Ross Callon <[email-masked]>
Date: Wed, 23 Jun 2010 00:46:14 -0400

Ahh, of course. A layer 0 LSP does not have an MPLS label. It might be provided by optical cross-connects, or a TDM infrastructure. 

Thanks, Ross

-----Original Message-----
From: Dan Frost [mailto:[email-masked]] 
Sent: 21 June 2010 07:03
To: Ross Callon
Cc: Adrian Farrel; [email-masked]; [email-masked]'; [email-masked]; Loa Andersson; George Swallow
Subject: Re: [RTG-DIR] Routing Directorate Review of draft-ietf-mpls-tp-data-plane-03

Hi Ross,

Ross Callon <[email-masked]> writes:
> [...]
> Minor Issues:
>
> Section 3.2, first two paragraphs: It is clear from the first
> paragraph that the lowest level LSP occurs at level 0 (thus we count n
> from zero, rather than from one). However, the second sentence begins:
>
>    Note that the MPLS label stack associated with an MPLS-TP section
>    at layer n consists of n labels, in the absence of stack
>    optimisation mechanisms.
>
> Should this really specify that a stack at level n consists of n+1
> labels? Alternatively, should we be counting LSPs starting at n=1 in
> the first paragraph?

We have been through this text at some length and believe it is
correct.  A walk-through was posted to the list and may be helpful:

  http://www.ietf.org/mail-archive/web/mpls-tp/current/msg03835.html

>    At an LSR, S-PE, or T-PE, further processing occurs to determine
>    the context of a packet occurs when a swap operation is interrupted
>    by TTL expiry.
>
> There seems to be a grammatical error, the word "occurs" should only
> occur once. This would seem to read better if the first occurrence of
> "occurs" were deleted.
>

We will fix these.

> It seems to me that the term "section" was defined in section 3.2 to
> include either an underlying data link or an LSP at the next lower
> level. Thus the phrase "section or LSP" seems to be redundant --
> although clear.

It's redundant in a sense, but whether one views an LSP as a section or
not is a matter of perspective, specifically with respect to the layer
of hierarchy under consideration.  We retain the phrase "section or LSP"
to cater to the practical fact that LSPs are often not viewed as
sections.

Thanks!

-d

---

From: Dan Frost <[email-masked]>
Date: Mon, 21 Jun 2010 12:03:15 +0100

Hi Ross,

We will fix these.

Thanks!

-d