Subject: [RTG-DIR] Rtgdir early review of draft-ietf-babel-hmac

From: Michael McBride <[email-masked]>
Date: Wed, 19 Sep 2018 23:46:18 +0000

I have been selected to do a routing directorate "early" review of draft-ietf-babel-hmac.

Document: draft-ietf-babel-hmac-00
Reviewer: Mike McBride
Review Date: 19-09-2018

Intended Status: Standards Track

Comments:

I only found a few nits. Great job with the draft, especially being a 00. The nits that should be considered:

1.      Add a Terminology section to include HMAC, Babel, PC, etc

2.      1.1 Applicability Section: "The protocol defined in this document assumes that all interfaces on a given link are equally trusted and share a small set of symmetric keys (usually just one, two during key rotation)." Consider changing it to: "...(Typically one key. Two keys during a key rotation)." Otherwise it can read as "just one or two during key rotation".

3.      4.2 Packet Transmission Section: "A Babel node may delay actually sending TLVs by a small amount...". Consider giving an example of a small amount.

Sound reasonable?

mike

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 19 Sep 2018 20:17:02 -0400

Hi Mike,

Thanks for the review. OK if I forward to the babel WG mailing list?

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]

On Wed, Sep 19, 2018 at 7:46 PM Michael McBride <[email-masked]>
wrote:

> I have been selected to do a routing directorate “early” review of
> draft-ietf-babel-hmac.
>
>
>
> 2.      1.1 Applicability Section: “The protocol defined in this document
> assumes that all interfaces on a given link are equally trusted and share a
> small set of symmetric keys (usually just one, two during key rotation).”
> Consider changing it to: “…(Typically one key. Two keys during a key
> rotation).” Otherwise it can read as “just one or two during key rotation”.
>
> 3.      4.2 Packet Transmission Section: “A Babel node may delay actually
> sending TLVs by a small amount…”. Consider giving an example of a small
> amount.
>
>
>
> Sound reasonable?
>
>
>
> mike
>

---

From: Michael McBride <[email-masked]>
Date: Thu, 20 Sep 2018 01:52:59 +0000

Yes, sorry I forgot to include the wg. Thanks.

Mike
Sent from HUAWEI AnyOffice
From: Donald Eastlake
To: Michael McBride;
Cc: [email-masked]; [email-masked]; babel-chairs;
Subject: Re: Rtgdir early review of draft-ietf-babel-hmac
Time: 2018-09-19 17:17:24

Hi Mike,

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]<mailto:[email-masked]>

On Wed, Sep 19, 2018 at 7:46 PM Michael McBride <[email-masked]<mailto:[email-masked]>> wrote:
I have been selected to do a routing directorate “early” review of draft-ietf-babel-hmac.

Comments:

2.      1.1 Applicability Section: “The protocol defined in this document assumes that all interfaces on a given link are equally trusted and share a small set of symmetric keys (usually just one, two during key rotation).” Consider changing it to: “…(Typically one key. Two keys during a key rotation).” Otherwise it can read as “just one or two during key rotation”.

3.      4.2 Packet Transmission Section: “A Babel node may delay actually sending TLVs by a small amount…”. Consider giving an example of a small amount.

Sound reasonable?

mike