Subject: [RTG-DIR] RtgDir Review: draft-ietf-lsr-isis-rfc5306bis

From: Manav Bhatia <[email-masked]>
Date: Fri, 7 Dec 2018 16:14:54 +0530

Hi,

I have done a routing directorate review of this draft.

https://datatracker.ietf.org/doc/draft-ietf-lsr-isis-rfc5306bis/

The Routing Directorate seeks to review all routing or routing-related
drafts as they pass through IETF last call and IESG review, and sometimes
on special request. The purpose of the review is to provide assistance to
the Routing ADs. For more information about the Routing Directorate, please
see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it
would be helpful if you could consider them along with any other IETF Last
Call comments that you receive, and strive to resolve them through
discussion or by updating the draft.

Document: draft-ietf-lsr-isis-rfc5306bis

Reviewer: Manav Bhatia

Review Date: 7 Dec 2018

Intended Status: Proposed Standard

Summary:

No issues found. This document is ready for publication.

Comments:

I have a minor comment on whether the authors could add some text that
explains that the current mechanism only works when the restarting router
comes up in a short amount of time, which is basically for as long as the
Holdtimer does not expire on its neighbors. However, some restarts can take
longer, and this adds support for such restarts.

Thanks, Manav

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 7 Dec 2018 16:58:33 +0000

(draft alias corrected)

Manav –

Thanx for the review.

I think your comment is on the mark – though implementers  have been known to bypass the existing limitation by signaling a long holdtime prior to restart even in the absence of PR bit. Suppose we added the following text at the end of Section 2.2.3:

“Use of the PR bit provides a means to safely  support restart periods which are significantly longer than standard holdtimes.”

??

   Les

From: rtg-dir <[email-masked]> On Behalf Of Manav Bhatia
Sent: Friday, December 07, 2018 2:45 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [RTG-DIR] RtgDir Review: draft-ietf-lsr-isis-rfc5306bis

Hi,

The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Reviewer: Manav Bhatia

Review Date: 7 Dec 2018

Summary:

Comments:

I have a minor comment on whether the authors could add some text that explains that the current mechanism only works when the restarting router comes up in a short amount of time, which is basically for as long as the Holdtimer does not expire on its neighbors. However, some restarts can take longer, and this adds support for such restarts.

Thanks, Manav

---

From: Manav Bhatia <[email-masked]>
Date: Fri, 14 Dec 2018 04:51:48 +0530

Hi Les,

That should help.

Cheers, Manav
On Fri, Dec 7, 2018 at 10:28 PM Les Ginsberg (ginsberg)

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Fri, 14 Dec 2018 01:26:49 +0000

THanx Manav.

V1 of the draft has been posted addressing your comment.

   Les

> -----Original Message-----
> From: Manav Bhatia <[email-masked]>
> Sent: Thursday, December 13, 2018 3:22 PM
> To: Les Ginsberg (ginsberg) <[email-masked]>
> Cc: [email-masked]; [email-masked]; draft-ietf-lsr-isis-
> [email-masked]
> Subject: Re: [RTG-DIR] RtgDir Review: draft-ietf-lsr-isis-rfc5306bis
> 
> Hi Les,
> 
> That should help.
> 
> Cheers, Manav
> > I think your comment is on the mark – though implementers  have been
> known to bypass the existing limitation by signaling a long holdtime prior to
> restart even in the absence of PR bit. Suppose we added the following text
> at the end of Section 2.2.3:
> >
> >
> >
> > “Use of the PR bit provides a means to safely  support restart periods which
> are significantly longer than standard holdtimes.”
> >
> >
> >
> > ??
> >
> >
> >
> >    Les
> >
> >
> >
> >
> >
> > The Routing Directorate seeks to review all routing or routing-related drafts
> as they pass through IETF last call and IESG review, and sometimes on special
> request. The purpose of the review is to provide assistance to the Routing
> ADs. For more information about the Routing Directorate, please see
> http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir
> >
> >
> >