Subject: [RTG-DIR] Rtgdir telechat review of draft-ietf-dmm-ondemand-mobility-15

From: Jonathan Hardwick <[email-masked]>
Date: Thu, 24 Jan 2019 15:03:04 -0800

Reviewer: Jonathan Hardwick
Review result: Has Nits

Hi there

I have done a routing directorate review of this draft.
https://datatracker.ietf.org/doc/draft-ietf-dmm-ondemand-mobility/

The Routing Directorate seeks to review all routing or routing-related drafts
as they pass through IETF last call and IESG review, and sometimes on special
request. The purpose of the review is to provide assistance to the Routing ADs.
For more information about the Routing Directorate, please see
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would
be helpful if you could consider them along with any other IETF Last Call
comments that you receive, and strive to resolve them through discussion or by
updating the draft.

Document: draft-ietf-dmm-ondemand-mobility-15
Reviewer: Jon Hardwick
Review Date: 24 Jan 2019
Intended Status: Informational

Comments
-----------

The document was easy to read and absorb.

I found this sentence from the abstract a bit misleading: "This document
describes a solution for taking the application needs into account..."  The
word "solution" made me expect that the document would go into detail about how
an IP stack could request the different sorts of IP address from the network. 
In fact, you are proposing an API.  I would recommend changing to "This
document proposes an API that an application can use to inform the IP stack of
its requirements for session continuity and/or IP address reachability".

On a related point, is there any work you can refer to that provides a
mechanism for implementing this API?

The boilerplate in section 2 is out of date.  Please see RFC 8174 for the
latest boilerplate.

On page 6, I spotted a stray ")" in this sentence:

   It is outside the scope of this specification to define how the host
   requests a specific type of prefix and how the network indicates the
   type of prefix in its advertisement or in its reply to a request).

---

From: "Moses, Danny" <[email-masked]>
Date: Mon, 28 Jan 2019 12:23:46 +0000

Hi Jonathan,

Thanks for the review and comments.
Please see my response and actions below.

1.      Change ‘solution’ to ‘API’ in the Abstract.

I agree that ‘solution’ is misleading. The draft actually introduces the new concept of influencing the level of the network’s mobility service, and provides a suggestion for API implementation. So, I am changing the wording to:

‘…This document defines a new concept of enabling applications to influence the network’s mobility service (session continuity and/or IP address reachability) on a per-Socket basis, and suggests extensions to the networking stack’s API to accommodate this concept.’

2.      On a related point, is there any work you can refer to that provides a mechanism for implementing this API?

There are currently two other drafts; (1) defining extensions to DHCPv6 for requesting a specific service (and for the network to provide responses), and (2) defining extensions to Router Advertisement message through which the network can indicate the type of mobility service associated with a provisioned IP prefix.

3.      The boilerplate in section 2 is out of date.  Please see RFC 8174 for the latest boilerplate.

Yes, we have received this comment and the new revision will fix section 2.

4.      On page 6, I spotted a stray ")" in this sentence.

Thank you. Will be removed in the next release.

Thanks,

Danny

-----Original Message-----
From: Jonathan Hardwick [mailto:[email-masked]]
Sent: Friday, January 25, 2019 01:03
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Rtgdir telechat review of draft-ietf-dmm-ondemand-mobility-15

Review result: Has Nits

Hi there

The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs.

For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Reviewer: Jon Hardwick

Review Date: 24 Jan 2019

Comments

-----------

I found this sentence from the abstract a bit misleading: "This document describes a solution for taking the application needs into account..."  The word "solution" made me expect that the document would go into detail about how an IP stack could request the different sorts of IP address from the network.

In fact, you are proposing an API.  I would recommend changing to "This document proposes an API that an application can use to inform the IP stack of its requirements for session continuity and/or IP address reachability".

On a related point, is there any work you can refer to that provides a mechanism for implementing this API?

The boilerplate in section 2 is out of date.  Please see RFC 8174 for the latest boilerplate.

---------------------------------------------------------------------
A member of the Intel Corporation group of companies

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

---

From: Jonathan Hardwick <[email-masked]>
Date: Mon, 28 Jan 2019 15:24:24 +0000

That’s fine, thanks Danny.
On (2) I was suggesting that you add some informative references to this work in the draft, but it’s not essential so I will leave that up to you.

Cheers
Jon

From: Moses, Danny <[email-masked]>
Sent: Monday, 28 January, 2019 12:24 PM
To: Jonathan Hardwick <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Rtgdir telechat review of draft-ietf-dmm-ondemand-mobility-15

NOTE: Message is from an external sender

Hi Jonathan,

  1.  On a related point, is there any work you can refer to that provides a mechanism for implementing this API?

  1.  The boilerplate in section 2 is out of date.  Please see RFC 8174 for the latest boilerplate.

  1.  On page 6, I spotted a stray ")" in this sentence.

Thanks,

Danny

-----Original Message-----
From: Jonathan Hardwick [mailto:[email-masked]]
Sent: Friday, January 25, 2019 01:03
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Rtgdir telechat review of draft-ietf-dmm-ondemand-mobility-15

Review result: Has Nits

Hi there

Reviewer: Jon Hardwick

Review Date: 24 Jan 2019

Comments

-----------