Subject: [RTG-DIR] RtgDir review: draft-ietf-idr-bgp-ls-flex-algo-05.txt

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 16 Nov 2020 16:56:43 -0500

Hello,

I have been selected as the Routing Directorate reviewer for this draft.
The Routing Directorate seeks to review all routing or routing-related
drafts as they pass through IETF last call and IESG review, and sometimes
on special request (in this case, WG last call). The purpose of the review
is to provide assistance to the Routing ADs. For more information about the
Routing Directorate, please see
http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it
would be helpful if you could consider them along with any other WG Last
Call comments that you receive, and strive to resolve them through
discussion or by updating the draft.

Document: draft-ietf-idr-bgp-ls-flex-algo-05.txt
Reviewer: Andy Malis
Review Date: Nov. 16, 2020
WG LC End Date: Nov. 23, 2020
Intended Status: Standards Track

Summary:

I have some minor concerns about this document that I think should be
resolved before publication.

Overall, the draft is straightforward and easy to follow. In particular, I
appreciated the summary of draft-ietf-lsr-flex-algo as a part of the
introduction.

Once the comments below have been addressed, it should be ready to be
forwarded to the IESG for approval.

Major Issues:

No major issues found.

Minor Issues:

While at least one early implementation has been publicly disclosed, an
early IANA allocation is required for the Flex Algorithm Exclude SRLG TLV
so that early implementations can interoperate.

It would also be helpful for the reader if Section 5 (IANA Considerations)
contained the URL reference to the IANA "BGP-LS Node Descriptor, Link
Descriptor, Prefix Descriptor, and Attribute TLVs" registry at
https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv
.

Nits:

idnits ran clean except for two out-of-date references.

There are some English language nits with the text, such as "distribute
manner" should be "distributed manner", "This definition provisioned"
should be "This definition is provisioned", "constraint based" should be
"constraint-based", "Flexible Algorithm is called so as it allows" should
be "Flexible Algorithm is so called as it allows", "The operations" should
be "The operation", and so on (and this is just on pages 1-3). I recommend
a language cleanup pass on the draft before forwarding it to the IESG.

Cheers,
Andy

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Tue, 17 Nov 2020 03:32:21 +0000

Hi Andy,

Thanks for your review.

The authors have already requested the IDR WG chairs for early allocation for the pending codepoints on behalf of the WG [1].

Also, ack on the inclusion of the URL for the IANA registry pointer. Will include that in the next update.

Thanks,
Ketan

[1] https://mailarchive.ietf.org/arch/msg/idr/4JlklIa30OqS5Rw3Z8tf5hXM59A/

-----Original Message-----
From: Andrew G. Malis <[email-masked]> 
Sent: 17 November 2020 03:27
To: <[email-masked]> <[email-masked]>
Cc: Routing Directorate <[email-masked]>; [email-masked]; [email-masked]
Subject: RtgDir review: draft-ietf-idr-bgp-ls-flex-algo-05.txt

Hello,

I have been selected as the Routing Directorate reviewer for this draft.
The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request (in this case, WG last call). The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other WG Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Summary:

I have some minor concerns about this document that I think should be resolved before publication.

Overall, the draft is straightforward and easy to follow. In particular, I appreciated the summary of draft-ietf-lsr-flex-algo as a part of the introduction.

Once the comments below have been addressed, it should be ready to be forwarded to the IESG for approval.

Major Issues:

No major issues found.

Minor Issues:

While at least one early implementation has been publicly disclosed, an early IANA allocation is required for the Flex Algorithm Exclude SRLG TLV so that early implementations can interoperate.

It would also be helpful for the reader if Section 5 (IANA Considerations) contained the URL reference to the IANA "BGP-LS Node Descriptor, Link Descriptor, Prefix Descriptor, and Attribute TLVs" registry at https://www.iana.org/assignments/bgp-ls-parameters/bgp-ls-parameters.xhtml#node-descriptor-link-descriptor-prefix-descriptor-attribute-tlv