Subject: [saag] E2MD BOF

From: Cullen Jennings <[email-masked]>
Date: Wed, 17 Mar 2010 19:55:56 -0600

The E2MD BOF is wrestling with some complicated issues around putting personal data about individuals in DNS (names, phones numbers etc). They are considering various approaches to constrain access to the private data. The leading contender as far as I can tell is to only run the DNS with the private data in a walled garden and make sure no one that should not see the data can query a server in the walled garden. One or two people have mentioned you might want to encrypt the private data and control access to the keys but that idea has not received much discussion. It seems to me like a possibility worth exploring a little. 

If anyone is interested or has spend time thinking about privacy of data in DNS, input from folks on this list would be valuable and I hope at least a few security folks can show up at the BOF. 

Thanks, Cullen

Mailing list archive at http://www.ietf.org/mail-archive/web/e2md/index.html

---

From: Samuel Weiler <[email-masked]>
Date: Thu, 18 Mar 2010 23:49:11 -0400 (EDT)

Cullen,

I suggest taking this question to the DNSEXT WG.  AFAIK, the DNSEXT 
agenda in Anaheim still has two minutes left open, which is about all 
the WG will tolerate of this.  :-)

-- Sam

On Wed, 17 Mar 2010, Cullen Jennings wrote:

> The E2MD BOF is wrestling with some complicated issues around 
> putting personal data about individuals in DNS (names, phones 
> numbers etc). They are considering various approaches to constrain 
> access to the private data. The leading contender as far as I can 
> tell is to only run the DNS with the private data in a walled garden 
> and make sure no one that should not see the data can query a server 
> in the walled garden. One or two people have mentioned you might 
> want to encrypt the private data and control access to the keys but 
> that idea has not received much discussion. It seems to me like a 
> possibility worth exploring a little.
>
> If anyone is interested or has spend time thinking about privacy of 
> data in DNS, input from folks on this list would be valuable and I 
> hope at least a few security folks can show up at the BOF.
>
> Thanks, Cullen
>