Subject: Re: [saag] How to reference ECDSA?

From: Dan Brown <[email-masked]>
Date: Wed, 17 Nov 2010 12:50:51 -0500

> Greetings again. When a draft references ECDSA, there are three choices:
> - FIPS 186-3
> - X9.62
> - SECG SEC 1
> What do people think are the relative advantages and disadvantages of each?
>
> --Paul Hoffman, Director
> --VPN Consortium

FIPS 186-3 does not fully specify ECDSA signature generation and verification, but rather refers to ANS X9.62.  So, FIPS 186-3 is less direct than ANS X9.62, which is a possible disadvantage.

Not only do X9.62 & SEC 1 fully specify ECDSA signature generation and verification, but they also specify encoding of ECDSA signatures in ASN.1, which is used in other IETF groups such as PKIX.  Such a specified encoding may be an advantage.

By contrast, FIPS 186-3 does not specify an encoding for ECDSA.  But it does have a means to represent integers as bit string (Section C.2) which could be used to build a bit string representation of an ECDSA signature if unique parsing is ensured.

An alternative is IEEE 1363, which specifies ECDSA (under the name ECSSA with primitives ECSP-DSA and ECVP-DSA), and, like FIPS 196-3, has integer to bit conversions, which could be used to build representations of ECDSA signatures.

Some other possible minor advantages of the SEC 1 specification are that it is free, it is a hyperlinked PDF, it currently provides more extensive and up-to-date security considerations (than the alternative standards), and it is focused on ECC (some users of ECDSA are likely to want to other ECC algorithms).

Best regards,

        Dan

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 17 Nov 2010 10:21:14 -0800

>Some other possible minor advantages of the SEC 1 specification are that it is free, it is a hyperlinked PDF, it currently provides more extensive and up-to-date security considerations (than the al…

These do sound like good advantages. Could you respond to Pasi's note about incompatibilities between SEGG and X9.62?

--Paul Hoffman, Director
--VPN Consortium