Subject: [saag] How to reference ECDSA?

From: Paul Hoffman <[email-masked]>
Date: Tue, 16 Nov 2010 08:12:56 -0800

Greetings again. When a draft references ECDSA, there are three choices:
- FIPS 186-3
- X9.62
- SECG SEC 1
What do people think are the relative advantages and disadvantages of each?

--Paul Hoffman, Director
--VPN Consortium

---

From: "Dan Harkins" <[email-masked]>
Date: Tue, 16 Nov 2010 11:15:10 -0800 (PST)

> What do people think are the relative advantages and disadvantages of

  Implementations written according to one or the other are all inter-
operable so in that sense it doesn't matter but you have to purchase X9.62
so that's a big disadvantage in my opinion.

  Dan.

---

From: Jon Callas <[email-masked]>
Date: Tue, 16 Nov 2010 11:59:36 -0800

> What do people think are the relative advantages and disadvantages of each?

The disadvantage of X9.62 is that the more important it is that someone read the actual document, the less likely they will. There's a distinct unwillingness for people to pay for standards documents. That means that once someone learns that X9.62 is the same thing as FIPS 186-3, they'll go to that one because they can pull it up in their web browser.

The disadvantage of FIPS is that it's from the USG, and there are people with histamine reactions to that, as well.

The disadvantage of SECG is most people haven't heard of them, so you won't get someone's attention the way that you would with either ANSI or NIST. Also, you run into the whole EC patent morass, and will have to fight the inevitable patent-fear problem. The SECG statement on patents will do everything to intensify that fear.

I would say you're best off going with FIPS 186-3.

	Jon