Subject: Re: [saag] How to reference ECDSA?

From: Pasi Eronen <[email-masked]>
Date: Wed, 17 Nov 2010 18:51:32 +0200

I don't think one can actually implement ECDSA based on only FIPS 186-3.
For e.g. ECDSA signature verification, FIPS 186-3 Section 6.4 simply says
"ECDSA digital signature shall be verified as specified in ANS X9.62".

SECG SEC 1 looks like it has all the details, but the details are not exactly
the same as in X9.62. For example, the point-to-octet-string conversion
are not 100% compatible, as was noted here:

http://www.ietf.org/mail-archive/web/ipsec/current/msg02510.html

I agree with Dan and Jon that having to pay for X9.62 is a big disadvantage,
though.

Best regards,
Pasi

On Tue, Nov 16, 2010 at 18:12, Paul Hoffman <[email-masked]> wrote:
> Greetings again. When a draft references ECDSA, there are three choices:
> - FIPS 186-3
> - X9.62
> - SECG SEC 1
> What do people think are the relative advantages and disadvantages of each?
>
> --Paul Hoffman, Director
> --VPN Consortium
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
>

---

From: Dan Brown <[email-masked]>
Date: Thu, 18 Nov 2010 11:47:35 -0500

Regarding hybrid representation of EC points.

More generally, a goal of SECG has been to reduce the number of options, compared to, say, ANSI or ISO or IEEE, because this goal may promote interop.  So, a SEC1 version of algorithm XYZ should comply with other specifications of algorithm XYZ.

In the case of octet string reps of EC points, this goal is met, when compared to ANSI or IEEE.

ECDSA signatures do not depend on point to octet string reps, but ECC public keys generally do.   

Certified ECC key formats are already covered in PKIX, but certainly other IETF may still need their own formats, such as for ephemeral keys in ECDH.

Anyway, the ANSI hybrid format octet string for an EC point differs only by some bits from the SEC1 formats.  With some guidance such bits could be ignored by generous receiving implementations that do not understand them.   

Indeed, SEC1 Section 2.3.3 could probably be amended to accept headers 06 and 07 the same way as header 04.

Best regards,

Dan

----- Original Message -----
From: Pasi Eronen [mailto:[email-masked]]
Sent: Wednesday, November 17, 2010 11:51 AM
To: Paul Hoffman <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [saag] How to reference ECDSA?

Best regards,
Pasi

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.