Subject: [saag] FW: New Version Notification for draft-sheffer-ietf-ciphertext-format-00.txt

From: Yaron Sheffer <[email-masked]>
Date: Wed, 18 Nov 2020 13:54:29 +0200

Gleb, Yoav and I just submitted this individual draft. It addresses the problem I discussed at HotRFC (see slides [1]).

Enterprises often generate very large amounts of application-level encrypted data, stored at rest. The enterprise needs to be able to discover/detect encrypted data, often contained in petabyte-scale "data lakes". The data is often moved around or duplicated, and so the next challenge is to attribute the encrypted data, i.e. understand which organization owns it. Our proposal adds very small, binary metadata, to enable such detection and attribution of data.

We would appreciate your comments. Please reach out to the authors if you'd like to join this effort.

Thanks,
	Yaron

[1] https://datatracker.ietf.org/meeting/109/materials/slides-109-hotrfc-generic-ciphertext-format-00

On 11/18/20, 12:24, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-sheffer-ietf-ciphertext-format-00.txt
    has been successfully submitted by Yaron Sheffer and posted to the
    IETF repository.

    Name:		draft-sheffer-ietf-ciphertext-format
    Revision:	00
    Title:		A Generic Ciphertext Format
    Document date:	2020-11-18
    Group:		Individual Submission
    Pages:		9
    URL:            https://www.ietf.org/archive/id/draft-sheffer-ietf-ciphertext-format-00.txt
    Status:         https://datatracker.ietf.org/doc/draft-sheffer-ietf-ciphertext-format/
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-sheffer-ietf-ciphertext-format
    Htmlized:       https://tools.ietf.org/html/draft-sheffer-ietf-ciphertext-format-00

    Abstract:
       This document defines a format for encrypted data, that allows to
       detect such data in large data stores, and associate it back to the
       system where it was created and the key with which it was encrypted.
       This allows organizations to extend the concept of data governance to
       encrypted data, and to manage such data even when encrypted by
       multiple systems and cloud providers.

       We intend to standardize this format through the IETF, and the
       document is organized as an Internet Draft.

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.

    The IETF Secretariat

---

From: Michael Richardson <[email-masked]>
Date: Wed, 18 Nov 2020 21:56:07 -0500

I missed your hotrfc.
I read the slides and scanned the content.
My only comment is: begs for CBOR with a CDDL definition.
Might cost 1 byte on average, maybe 2 bytes worse case.

If you really want it a fixed header, then declare that the integers are
always using a particular encoding, this still wins in upward compatible.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 19 Nov 2020 05:50:17 +0100

> My only comment is: begs for CBOR with a CDDL definition.

See RFC 8710 for an example of how to do this with minimum impact.

Grüße, Carsten