Subject: [SAM] XCAST at IETF 76 in Hiroshima

From: "John Buford" <[email-masked]>
Date: Mon, 8 Dec 2008 09:07:53 -0500

Dear XCAST-team,

Please comment to the RG mailing list regarding what
XCAST-related activities we could cover at a SAM RG
meeting if we scheduled it at IETF 76.

Thanks,
John
_______________________________________________
SAM mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/sam

---

From: Marc Manthey <[email-masked]>
Date: Mon, 8 Dec 2008 20:15:40 +0100

> meeting if we scheduled it at IETF 76.

hello

i am curious if  some of them might read this too

https://sourceforge.net/project/memberlist.php?group_id=30760

> As I wrote on the BBS in linux-xcast6 of sourceforge, we don't have
> patches for Mac OS X. I heard some want to try but currently I think
> nobody working on porting XCAST6 on Mac.

>>  What does a universal P2P overlay protocol mean in detail? Is it  
>> similar to the common API by Dabek et al. ("Towards a Common API  
>> for Structured Peer-to-Peer Overlays", 2003)?
>
> Probably general p2p overlay protocol is not directly targeted  
> within the RG, but p2p/overlay multicast issues may do. There are  
> some current efforts within the P2PSIP WG, not sure what about  
> P2PRG...
>
>>  Btw: It makes sense to have an interface definition between ALM  
>> 'stack' and application. But this should be a part of a common  
>> group membership framework maybe borrowed from IGMP/MLD. That could  
>> be also an outcome of SAM RG.
>
> Re: group member management seems a good item to work on, maybe we  
> can work out something within the group...

regards

marc
--
Les Enfants Terribles - WWW.LET.DE
Marc Manthey 50672 Köln - Germany
Hildeboldplatz 1a
Tel.:0049-221-3558032
Mobil:0049-1577-3329231
mail: [email-masked]
PGP/GnuPG: 0x1ac02f3296b12b4d
jabber :[email-masked]
IRC: #opencu  freenode.net
twitter: http://twitter.com/macbroadcast
web: http://www.let.de

Opinions expressed may not even be mine by the time you read them, and  
certainly don't reflect those of any other entity (legal or otherwise).

Please note that according to the German law on data retention,  
information on every electronic information exchange with me is  
retained for a period of six months.

---

From: Nobuo Kawaguchi <[email-masked]>
Date: Tue, 09 Dec 2008 09:22:05 +0900

Dear John and SAM members,

We have been implementing XCAST2.0 Engine which
get a XCAST marked packet from a router and
perform a routing/forwarding task for XCAST. 
And it is now almost working. In the next year, 
we are planning to deploy it to the academic
network of Japan called SINET3.

So, I hope we can present our deployment status 
in the IETF76 at Hiroshima, Japan.

Also, SAMTK is now under pre-release stage.
We are now integrating SAMTK with XCAST with DVTS.

yours,

Nobuo Kawaguchi

---

From: Eiichi Muramoto <[email-masked]>
Date: Tue, 09 Dec 2008 20:22:31 +0900

John-san

I would like to have demo at IETF 76 too.

Ettikan-san will update you at CCNC2009

Regards,
Eiichi Muramoto

On Mon, 8 Dec 2008 09:07:53 -0500

-- 
Eiichi Muramoto <[email-masked]>

---

From: "John Buford" <[email-masked]>
Date: Tue, 9 Dec 2008 06:45:30 -0500

Muramoto-san, Nobuo,

Thanks.  Can you tell me, is the SINET3 deployment
related to the WIDE testbed deployment work done before?
I am wondering if there is any activity in WIDE that might also
be reported, since WIDE is the host of IETF 76.

Also, is there any work in PUCC (http://www.pucc.jp/PUCC/English/)
related to ALM?

Regards,
John

---

From: Nobuo Kawaguchi <[email-masked]>
Date: Wed, 10 Dec 2008 10:56:40 +0900

John,

> Can you tell me, is the SINET3 deployment

Yes. We already have an experiment of XCAST Engine on 
last WIDE camp (Sep. 2008). SINET3 deployment is the next step.

And for PUCC, I don't have any information.

yours,

Nobuo Kawaguchi

---

From: Norihiro Ishikawa <[email-masked]>
Date: Wed, 10 Dec 2008 11:20:22 +0900

Dear John,

I am a BOD member of PUCC.

PUCC is developing P2P/overlay networking protocols including
multicast, device metadata and their applications.

So, the PUCC streaming protocol is essentially one of application layer 
multicast protocols.

One of main applications of PUCC is now home appliances control (from
mobile phones).

PUCC will do demonstrations at Sands Expo, CES 2009. If you
are interested in PUCC, please visit the PUCC booth.

In addition, 3 papers regarding PUCC will be presented at the
special session (Home Networks on P2P), CCNC 2009.

If you need more information about PUCC, please contact me
personally.

I hope this helps.

Best regards,

Norihiro Ishikawa

---

From: Marc Manthey <[email-masked]>
Date: Wed, 10 Dec 2008 03:37:52 +0100

> .... is developing P2P/overlay networking protocols including
> So, the..... streaming protocol is essentially one of application  
> layer
> multicast protocols.
>
> One of main applications of .... is now home appliances control (from
> mobile phones).

hello

have you seen Flash 10  multicast  demo recenly?

http://flickr.com/photos/15543694@N06/3044147140/sizes/l/

cu

Marc

---

From: "John Buford" <[email-masked]>
Date: Tue, 9 Dec 2008 21:59:07 -0500

Dear Norihiro,

Thanks very much for the information.

Best regards,
John Buford