Subject: Re: [scim] Two draft search proposals: X-Search and Token-Search

From: Phil Hunt <[email-masked]>
Date: Wed, 2 Jan 2013 13:09:47 -0800

Just a reminder, any comments appreciated. 

Phil

Sent from my phone.

On 2012-12-23, at 15:02, Phil Hunt <[email-masked]> wrote:

> The design team has developed to strawman proposals (draft-hunt-scim-tokensearch & draft-hunt-scim-xsearch) to solve 3 outstanding ticket items.  Both solutions are equivalent and are expressed as if they were independent specifications. The 3 items covered are:
> 
> 1 Ticket 25 - Ability to search for objects of multiple resource types
> 2.Ticket 29 - Ability to search without leaking confidential filter terms in the URL (POST search).
> 3.Ticket 31 - Ability to page through results without the result set changing between page requests.
> 
> The major difference between these specifications are that one creates a RESTful resource representation of the search operation and the other uses token parameters to represent a search result.  Depending on your point of view, one may seem simpler than the other. To give you a quick summary of the differences, a PDF is attached comparing the APIs.
> <comparison-token-rest.pdf>
> For now, let's not get into the details right away. Let's keep this simple. Which draft is closer to what you would like to see?   X-/Search or Token-Search
> 
> With the agreement of the chairs, we can then seek to refine one of the candidate proposals and then discuss what parts to include (if at all) in the main specification and what parts ot keep separate.
> 
> Links to the draft are:
> http://datatracker.ietf.org/doc/draft-hunt-scim-xsearch
> http://datatracker.ietf.org/doc/draft-hunt-scim-tokensearch
> 
> Thanks to everyone for your contributions and comments on this.
> 
> Happy holidays!
> 
> Phil
> 
> @independentid
> www.independentid.com
> [email-masked]
> 
> 
> 
> 
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 2 Jan 2013 21:16:45 +0000

> For now, let's not get into the details right away. Let's keep this simple. Which draft is closer to what you would like to see?

+1 for token search.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Sunday, December 23, 2012 5:03 PM
To: [email-masked] WG
Subject: [scim] Two draft search proposals: X-Search and Token-Search

Links to the draft are:

Happy holidays!

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Wed, 9 Jan 2013 19:31:58 +0000

Any other comments, thoughts on this?  We do need to decide what search extensions (if any) we make in the core spec for search as there are a number of tickets pending on that.

The key question is what part(s) of these extensions should be included in the core spec (if any). Please review and provide feedback.

Cheers,
Morteza

From: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, January 2, 2013 1:16 PM
To: Phil Hunt <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Two draft search proposals: X-Search and Token-Search

+1 for token search.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Sunday, December 23, 2012 5:03 PM
To: [email-masked]<mailto:[email-masked]> WG
Subject: [scim] Two draft search proposals: X-Search and Token-Search

Links to the draft are:

Happy holidays!

Phil

@independentid