Subject: [scim] Groups Member Type

From: Shelley <[email-masked]>
Date: Fri, 1 Feb 2013 13:37:08 -0600

As indicated in Section 8, the canonical types for Group members are
READ-ONLY. As such, how can consumers provide the type (i.e. "User" or
"Group")? Is it implied that IDs are unique across both users and groups in
order for service providers to fulfill this requirement?

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 4 Feb 2013 14:08:21 +0000

Good point.  It seems like this should say "immutable" rather than "read-only", since it can be set initially but not updated.  Thoughts from anyone else?  If this seems reasonable I'll open an issue to get this fixed.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shelley
Sent: Friday, February 01, 2013 1:37 PM
To: [email-masked]
Subject: [scim] Groups Member Type

As indicated in Section 8, the canonical types for Group members are READ-ONLY. As such, how can consumers provide the type (i.e. "User" or "Group")? Is it implied that IDs are unique across both users and groups in order for service providers to fulfill this requirement?

---

From: Shelley <[email-masked]>
Date: Mon, 11 Feb 2013 11:35:30 -0600

+1 to mark it as "immutable".

On Mon, Feb 4, 2013 at 8:08 AM, Kelly Grizzle
<[email-masked]>wrote:

>  Good point.  It seems like this should say “immutable” rather than
> “read-only”, since it can be set initially but not updated.  Thoughts from
> anyone else?  If this seems reasonable I’ll open an issue to get this fixed.
> ****
>
> ** **
>
> --Kelly****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Shelley
> *Sent:* Friday, February 01, 2013 1:37 PM
> *To:* [email-masked]
> *Subject:* [scim] Groups Member Type****
>
> ** **
>
> order for service providers to fulfill this requirement?****
>

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 11 Feb 2013 22:02:21 +0000

I opened ticket #35 to change this.

http://trac.tools.ietf.org/wg/scim/trac/ticket/35

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shelley
Sent: Monday, February 11, 2013 11:36 AM
To: Kelly Grizzle
Cc: [email-masked]
Subject: Re: [scim] Groups Member Type

+1 to mark it as "immutable".
On Mon, Feb 4, 2013 at 8:08 AM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:
Good point.  It seems like this should say "immutable" rather than "read-only", since it can be set initially but not updated.  Thoughts from anyone else?  If this seems reasonable I'll open an issue to get this fixed.

--Kelly

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Shelley
Sent: Friday, February 01, 2013 1:37 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [scim] Groups Member Type

---

From: Shelley <[email-masked]>
Date: Mon, 25 Feb 2013 10:38:41 -0600

Thanks, Kelly. Given that the ID may represent either a User or Group and
only the combination of "type" and "value" uniquely identify the reference,
should the canonical "type" attribute for group members be REQUIRED as
well? (Further, the majority of examples throughout the Protocol
specification only include a "value" and not "type", so it's ambiguous as
to whether these "values" represent Users or Groups.)

On Mon, Feb 11, 2013 at 4:02 PM, Kelly Grizzle
<[email-masked]>wrote:

>  I opened ticket #35 to change this.****
>
> ** **
>
> http://trac.tools.ietf.org/wg/scim/trac/ticket/35****
>
> ** **
>
> --Kelly****
>
> ** **
>
> *Sent:* Monday, February 11, 2013 11:36 AM
> *To:* Kelly Grizzle
> *Cc:* [email-masked]
> *Subject:* Re: [scim] Groups Member Type****
>
> ** **
>
> +1 to mark it as "immutable".****
>
> On Mon, Feb 4, 2013 at 8:08 AM, Kelly Grizzle <[email-masked]>
> wrote:****
>