Subject: [scim] Reference data type - issue #33

From: Kelly Grizzle <[email-masked]>
Date: Thu, 14 Feb 2013 15:16:17 +0000

Issue 33 now contains some proposed changes to formalize support for references in SCIM.  Full information is available in the issue tracker here: http://trac.tools.ietf.org/wg/scim/trac/ticket/33.  A brief description of the changes:

1)      A new "Reference" data type was added in section 3.1.7 of the core schema document. This defines a reference to another SCIM object.

2)      The User, Group, and Enterprise User schemas were modified to make use of the reference attribute. For User, this is used in the "groups" attribute. For Group, this is used in the "members" attribute. For Enterprise User, this is used in the "manager" attribute.

3)      A new "referenceTypes" sub-attribute was added in section 10 of the core schema document. This applies to the "attributes" and "subAttributes" definitions of the Schema resource, and allows the schema to specify which SCIM object types can be referenced for a given attribute.

4)      The examples in the API and core schema documents were updated to use references where appropriate.

Currently, the text says that references MUST be references to SCIM objects.  There was some discussion about extending this concept to allow referencing other external non-SCIM objects (eg - a Facebook user, etc...).  My inclination is to keep references targeted towards SCIM objects.  If we see use cases and decide that non-SCIM references are important, we could either augment the "reference" data type or add a new "URL" datatype that has metadata about the type of object to expect.

I've attached the diff and the full documents.  Please review these changes and respond with any comments or questions.

--Kelly

---

From: Erik Wahlström <[email-masked]>
Date: Sun, 24 Feb 2013 20:25:02 +0000

Hi,

+1 for the change in general but i kinda miss the $ref sub-attribute in section "3.2.  Multi-valued Attributes".

My inclination is to keep references targeted towards SCIM objects.  If we see use cases and decide that non-SCIM references are important, we could either augment the “reference” data type or add a new “URL” datatype that has metadata about the type of object to expect.

+1

/ Erik

On Feb 14, 2013, at 4:16 PM, Kelly Grizzle wrote:

Issue 33 now contains some proposed changes to formalize support for references in SCIM.  Full information is available in the issue tracker here:http://trac.tools.ietf.org/wg/scim/trac/ticket/33.  A brief description of the changes:

Currently, the text says that references MUST be references to SCIM objects.  There was some discussion about extending this concept to allow referencing other external non-SCIM objects (eg – a Facebook user, etc…).  My inclination is to keep references targeted towards SCIM objects.  If we see use cases and decide that non-SCIM references are important, we could either augment the “reference” data type or add a new “URL” datatype that has metadata about the type of object to expect.

I’ve attached the diff and the full documents.  Please review these changes and respond with any comments or questions.

--Kelly
<issue33.patch><draft-ietf-scim-api-01.html><draft-ietf-scim-core-schema-01.html>_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 25 Feb 2013 02:18:07 +0000

Thanks for the feedback, Erik.  Are you suggesting adding something like this to section 3.2 (perhaps after the "value" sub-attribute and the examples)?

$ref
                The Reference of the target Resource, if the attribute is a reference.

--Kelly

From: Erik Wahlström [mailto:[email-masked]]
Sent: Sunday, February 24, 2013 2:25 PM
To: Kelly Grizzle
Cc: [email-masked]
Subject: Re: [scim] Reference data type - issue #33

Hi,

My inclination is to keep references targeted towards SCIM objects.  If we see use cases and decide that non-SCIM references are important, we could either augment the "reference" data type or add a new "URL" datatype that has metadata about the type of object to expect.

+1

/ Erik

--Kelly