Subject: [scim] Schema URIs

From: Keith Hazelton <[email-masked]>
Date: Wed, 03 Apr 2013 17:40:22 -0500

I notice that up to now all published SCIM schema URIs are URNs, e.g., urn:scim:schema:core:1.0

We're contemplating some schema extensions for the higher ed and research space and our first choice would be to use URLs rather than URNs to identify our extensions.  Is this likely to cause us any problems? It would seem to be spec-conformant.

E.g. http://ciferproject.org/schema/ciferRegistry/1.0

        --Keith

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 03 Apr 2013 20:21:42 -0600

> e.g., urn:scim:schema:core:1.0

I don't see those documented anywhere. Also, a formal URN namespace
was never issued for 'scim':

https://www.iana.org/assignments/urn-namespaces/urn-namespaces.xml

Am I missing something?

> We're contemplating some schema extensions for the higher ed and 
> research space and our first choice would be to use URLs rather
> than URNs to identify our extensions.  Is this likely to cause us
> any problems?

No.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 4 Apr 2013 15:56:02 +0000

> Also, a formal URN namespace was never issued for 'scim': ... Am I missing something?

You're right.  This still needs to happen.

>> research space and our first choice would be to use URLs rather than 
>> URNs to identify our extensions.  Is this likely to cause us any 
>> problems?
>
> No.

I don't see any problems with this.  In section 4, the schema draft says: "Each schema extension must identify a URI used to identify the extension."  To me, this means that a URL or URN would be valid.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Wednesday, April 03, 2013 9:22 PM
To: Keith Hazelton
Cc: [email-masked]; scim WG; [email-masked] discussion
Subject: Re: [scim] Schema URIs

> I notice that up to now all published SCIM schema URIs are URNs, e.g., 

I don't see those documented anywhere. Also, a formal URN namespace was never issued for 'scim':

Am I missing something?

> research space and our first choice would be to use URLs rather than 
> URNs to identify our extensions.  Is this likely to cause us any 
> problems?

No.

Peter

- --
Peter Saint-Andre
https://stpeter.im/

_______________________________________________
scim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/scim

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 04 Apr 2013 10:03:17 -0600

> You're right.  This still needs to happen.

OK. I'm happy to provide some guidance on that -- it's really pretty
easy. See https://tools.ietf.org/html/rfc3406 and
https://datatracker.ietf.org/doc/draft-ietf-urnbis-rfc3406bis-urn-ns-reg/
for information about the process.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 4 Apr 2013 18:18:51 +0000

Thanks for the pointers, Peter.  Melinda just opened issue #41 to address this.

--Kelly

-----Original Message-----
From: Peter Saint-Andre [mailto:[email-masked]] 
Sent: Thursday, April 04, 2013 11:03 AM
To: Kelly Grizzle
Cc: Keith Hazelton; [email-masked]; scim WG; [email-masked] discussion
Subject: Re: [scim] Schema URIs

> You're right.  This still needs to happen.

OK. I'm happy to provide some guidance on that -- it's really pretty easy. See https://tools.ietf.org/html/rfc3406 and https://datatracker.ietf.org/doc/draft-ietf-urnbis-rfc3406bis-urn-ns-reg/
for information about the process.

Peter

- --
Peter Saint-Andre
https://stpeter.im/