Subject: [scim] Issue#25 consensus call

From: Leif Johansson <[email-masked]>
Date: Wed, 10 Apr 2013 20:26:08 +0200

Folks,

At Orlando we polled the room and there was clear consensus for closing
25 as suggested in the issue tracker.

This email serves as a confirmation for that consensus call - speak up now
if you disagree.

        Leif & Morteza

---

From: Phil Hunt <[email-masked]>
Date: Wed, 10 Apr 2013 11:33:04 -0700

+1

Phil

Sent from my phone.

On 2013-04-10, at 11:26, Leif Johansson <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Anthony Nadalin <[email-masked]>
Date: Wed, 10 Apr 2013 19:39:50 +0000

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Wednesday, April 10, 2013 11:33 AM
To: Leif Johansson
Cc: scim WG
Subject: Re: [scim] Issue#25 consensus call

+1

Phil

Sent from my phone.

On 2013-04-10, at 11:26, Leif Johansson <[email-masked]> wrote:

> This email serves as a confirmation for that consensus call - speak up 
> now if you disagree.
> 
>        Leif & Morteza

---

From: Chris Phillips <[email-masked]>
Date: Wed, 10 Apr 2013 21:16:07 -0400

I agree with the consensus call for closing as suggested in the issue
tracker.

C.

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 11 Apr 2013 16:08:39 +0000

I agree with everything in the proposal except for one thing:

  Queries MAY be performed against a SCIM:
  <list>
    <t>Resource (e.g. /Users/{userid}),</t>
    <t>Resource Type endpoint (e.g. /Users or /Groups), or</t>
    <t>Server Root (e.g. /).</t>
  </list>

IMO querying against the server root should be optional and that SP's should declare support in ServiceProviderConfig.  For directory-backed datastores, this will be easy to support.  However, if the SP is using a relational database backed datastore, this could be difficult to implement in a way that scales.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Wednesday, April 10, 2013 1:26 PM
To: scim WG
Subject: [scim] Issue#25 consensus call

Folks,

This email serves as a confirmation for that consensus call - speak up now if you disagree.

        Leif & Morteza

---

From: Leif Johansson <[email-masked]>
Date: Thu, 11 Apr 2013 18:19:39 +0200

> IMO querying against the server root should be optional and that SP's should declare support in ServiceProviderConfig.  For directory-backed datastores, this will be easy to support.  However, if t…
I suggest you update the ticket so that the proposal is clear - I
believe this was
already covered in Orlando though.

---

From: Phil Hunt <[email-masked]>
Date: Thu, 11 Apr 2013 09:29:32 -0700

Yes, I presented root search as optional. In the particular section below I was attempting to make clear what are now valid queries. However it missed the issue of whether the server supports it. 

Phil