Subject: [scim] Schemas Attribute

From: "builes,julian" <[email-masked]>
Date: Thu, 23 May 2013 15:04:18 +0000

Hi all,

After reading the core schema document, I find that I am a little confused about the intended usage of the schemas attribute.

According to section 5.1 (Common Schema Attributes) the 'schemas' attribute is optional: "It is not necessary to specify the schemas attribute if the Resource is fully defined in this document as the core schema is implicitly included."

But after reading further, section 5.2 ("schemas" attribute) states that this attribute is required: "Each String value must be a unique URI. This specification defines URIs for User, Group, and a standard "enterprise" extension. All representations of SCIM schema MUST include a non-zero value array with value(s) of the URIs supported by that representation. Duplicate values MUST NOT be included. Value order is not specified and MUST not impact behavior. REQUIRED."

So is schemas a required attribute?

--
Best Regards,
Julian Builes
Software Engineer
[email-masked]

CONFIDENTIALITY NOTICE This message and any included attachments are from Cerner Corporation and are intended only for the addressee. The information contained in this message is confidential and may constitute inside or non-public information under international, federal, or state securities laws. Unauthorized forwarding, printing, copying, distribution, or use of such information is strictly prohibited and may be unlawful. If you are not the addressee, please promptly delete this message and notify the sender of the delivery error by e-mail or you may call Cerner's corporate offices in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.

---

From: Samuel Erdtman <[email-masked]>
Date: Mon, 27 May 2013 07:13:04 +0200

When I have worked with implementing this I have interpreter schemas a
require attribute.

Other comments?

Best Regards
Samuel Erdtman

Sent from my iPhone

On 23 maj 2013, at 17:06, "builes,julian" <[email-masked]> wrote:

> schemas a require