Subject: Re: [scim] externalId - How to distinguish between client's tenants

From: Thorsten Roßner <[email-masked]>
Date: Thu, 16 May 2013 09:19:21 +0200

Hi again,

as there was no response to my question below I would like to know if
the question itself was unclear or if it is just outside the SCIM scope?

Thanks and best regards
Thorsten

Am 07.05.2013 10:22, schrieb Thorsten Roßner:

> Hi All,
>
> can someone please help me understanding the Common Schema's "externalId"?
>
> My current understanding:
>
> - The externalId for a resource can be stored - if provided - for each
> Service Consumer's tenant (or if a SC doesn't support tenants, the
> externalId is stored for each SC's instance). A single SCIM resource
> thereby can have multiple externalIds (depending on the number of
> consumer tenants or instances).
>
> The question that derives from my understanding:
>
> - How can the SP differentiate between tenants of an SC in order to
> respect the following quote from the specification: "The Service
> Provider MUST always interpret the externalId as scoped to the Service
> Consumer's tenant."?
>
> Or is the differentiation outside the scope of the SCIM spec?
>
> Thanks & cheers
> Thorsten
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 30 May 2013 19:42:39 +0000

Sorry for the delay, Thorsten.  The -01 revision of the api document discusses options for multi-tenancy in section 4, but does not require any particular mechanism - http://tools.ietf.org/html/draft-ietf-scim-api-01#section-4.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thorsten Roßner
Sent: Thursday, May 16, 2013 2:19 AM
To: [email-masked]
Subject: Re: [scim] externalId - How to distinguish between client's tenants

Hi again,

as there was no response to my question below I would like to know if the question itself was unclear or if it is just outside the SCIM scope?

Thanks and best regards
Thorsten