Subject: [scim] Multiple Primary Values

From: "builes,julian" <[email-masked]>
Date: Mon, 3 Jun 2013 17:01:01 +0000

Hi all,

The specs dictate that each multi-valued attribute MUST only contain ONE primary value. Is there a prescribed behavior when more than one is received by an implementation?

Should the request fail (e.g. Return a 400)?
Or should the implementation arbitrarily assume one of such values as primary?

--
Best Regards,
Julian Builes
Software Engineer
[email-masked]

CONFIDENTIALITY NOTICE This message and any included attachments are from Cerner Corporation and are intended only for the addressee. The information contained in this message is confidential and may constitute inside or non-public information under international, federal, or state securities laws. Unauthorized forwarding, printing, copying, distribution, or use of such information is strictly prohibited and may be unlawful. If you are not the addressee, please promptly delete this message and notify the sender of the delivery error by e-mail or you may call Cerner's corporate offices in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.

---

From: Anthony Nadalin <[email-masked]>
Date: Mon, 3 Jun 2013 19:37:32 +0000

I would assume fail since there is a MUST and with multiple there is no way to assume which is primary or to deterministic way to determine the primary given multiple

From: [email-masked] [mailto:[email-masked]] On Behalf Of builes,julian
Sent: Monday, June 3, 2013 10:01 AM
To: [email-masked]
Subject: [scim] Multiple Primary Values

Hi all,

--
Best Regards,
Julian Builes
Software Engineer
[email-masked]<mailto:[email-masked]>
CONFIDENTIALITY NOTICE This message and any included attachments are from Cerner Corporation and are intended only for the addressee. The information contained in this message is confidential and may constitute inside or non-public information under international, federal, or state securities laws. Unauthorized forwarding, printing, copying, distribution, or use of such information is strictly prohibited and may be unlawful. If you are not the addressee, please promptly delete this message and notify the sender of the delivery error by e-mail or you may call Cerner's corporate offices in Kansas City, Missouri, U.S.A at (+1) (816)221-1024.