Subject: [scim] Custom Resource Types

From: Shelley <[email-masked]>
Date: Wed, 12 Jun 2013 15:53:36 -0500

Is there any guidance in the specifications regarding providing additional
resource types? There is some documentation and some discussion/tickets
regarding schema extensions for existing resource types (i.e. User and
Group), but I wanted to confirm my assumptions about extending the core
resource to provide new resource types.

For example, if a new resource of type "Foo" is exposed at an endpoint
"/Foos", is the representation expected to look something like the
following, where the extended resource attributes are provided in the same
manner as extended attributes on existing resources?

POST /Foos
{
    "schemas": [
        "urn:scim:schemas:core:1.0",
        "urn:company:scim:schemas:extension:foo:1.0"
    ],
    "externalId": "foo-1234",
    "urn:company:scim:schemas:extension:foo:1.0": {
        "displayName": "Foo Bar",
        "bars": [
            {
                "value": "abc"
            },
            {
                "value": "xyz"
            }
        ]
    }
}

The SCIM core specification seems to describe the extension model with
respect to extending existing User and Group resources/endpoints, but isn't
as clear about creating new types or extending the "CoreResource" [1].

[1] http://www.simplecloud.info/

---

From: Likepeng <[email-masked]>
Date: Thu, 13 Jun 2013 07:44:35 +0000

Hello chairs and WG participants,

Some time ago, the authors revised the use case document and uploaded a new reversion:
http://www.ietf.org/id/draft-zeltsan-scim-use-cases-01.txt

The WG discussed this draft in Atlanta F2F meeting. There were proposals to combine the use case document with the scenario document, we did that. Also we resolved the comments from several reviewers, both offline comments and comments from the mailing list. We believe it is in a good shape now.

We would like to request the WG to review this document, and consider WG adoption.

Any feedback is welcome!

Thanks a lot.

Kind Regards
Kepeng

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 13 Jun 2013 14:09:48 +0000

Hi Shelley,

There is nothing currently in the spec that spells this out, but this seems like the correct way to define a new resource type to me.  You would also want to make sure that the /Schemas endpoint returns information about this resource type.

Issue 38 (http://tools.ietf.org/wg/scim/trac/ticket/38) addresses some clarifications around extensions.  I'll make a note in this issue that we should document an example of how to create a new resource type.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Shelley
Sent: Wednesday, June 12, 2013 3:54 PM
To: [email-masked]
Subject: [scim] Custom Resource Types

Is there any guidance in the specifications regarding providing additional resource types? There is some documentation and some discussion/tickets regarding schema extensions for existing resource types (i.e. User and Group), but I wanted to confirm my assumptions about extending the core resource to provide new resource types.

For example, if a new resource of type "Foo" is exposed at an endpoint "/Foos", is the representation expected to look something like the following, where the extended resource attributes are provided in the same manner as extended attributes on existing resources?

POST /Foos
{
    "schemas": [

The SCIM core specification seems to describe the extension model with respect to extending existing User and Group resources/endpoints, but isn't as clear about creating new types or extending the "CoreResource" [1].