Subject: [scim] PATCH and Meta.Attributes

From: Alexandre Santos <[email-masked]>
Date: Mon, 15 Jul 2013 14:51:36 -0700

In http://www.simplecloud.info/specs/draft-scim-core-schema-01.html#anchor2(5.1
Common Schema Attributes) says

attributes
The names of the attributes to remove from the Resource during a PATCH
operation.

Which suggests a simple list of strings, also indicated by the examples in
the usage of PATCH. However the XSD that defines the schema (
http://www.simplecloud.info/specs/schema/scim-core.xsd) defines the
attributes as multi valued attribute:

<xs:complexType name="meta">
<xs:sequence>
<xs:element name="created" type="xs:dateTime" minOccurs="0"/>
<xs:element name="lastModified" type="xs:dateTime" minOccurs="0"/>
<xs:element name="location" type="xs:string" minOccurs="0"/>
<xs:element name="version" type="xs:string" minOccurs="0"/>
<xs:element name="attributes" minOccurs="0">
<xs:complexType>
<xs:sequence>
<xs:element name="attribute" type="*tns:multiValuedAttribute*" minOccurs="0"
 maxOccurs="unbounded"/>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:sequence>
</xs:complexType>
 Should the xsd be changed, or am I missing something?

Thanks!

*Alexandre Santos*  | Sr. Development Engineer
*Ping**Identity*  |   www.pingidentity.com
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- -
*O:* 604.697.7056
*Email:* [email-masked]
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- -
*Connect with Ping*
Twitter: @pingidentity
LinkedIn Group: Ping's Identity Cloud
Facebook.com/pingidentitypage
*
*

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 16 Jul 2013 14:12:45 +0000

You are correct - this should be an xs:string rather than a multiValuedAttribute.  As of draft -01 XML is no longer supported, so we should probably just remove the xsd from the site.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandre Santos
Sent: Monday, July 15, 2013 4:52 PM
To: [email-masked]
Subject: [scim] PATCH and Meta.Attributes

In http://www.simplecloud.info/specs/draft-scim-core-schema-01.html#anchor2 (5.1 Common Schema Attributes) says

attributes
The names of the attributes to remove from the Resource during a PATCH operation.

Which suggests a simple list of strings, also indicated by the examples in the usage of PATCH. However the XSD that defines the schema (http://www.simplecloud.info/specs/schema/scim-core.xsd) defines the attributes as multi valued attribute:

<xs:element name="attribute" type="tns:multiValuedAttribute" minOccurs="0" maxOccurs="unbounded"/>

Thanks!

Alexandre Santos  | Sr. Development Engineer
PingIdentity  |   www.pingidentity.com<http://www.pingidentity.com/>
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
O: 604.697.7056
Email: [email-masked]<mailto:[email-masked]>
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Connect with Ping
Twitter: @pingidentity
LinkedIn Group: Ping's Identity Cloud
Facebook.com/pingidentitypage