Subject: [scim] Issue #38 - extensibility proposal

From: Kelly Grizzle <[email-masked]>
Date: Thu, 25 Jul 2013 02:37:46 +0000

I have a rough draft of the changes for issue #38.  This contains the following:

1)      A new ResourceType endpoint (section 10).

2)      The Schemas definition was changed to only include an id, name, description, and attributes.  Also removed the "schema" sub-attribute from every attribute definition (section 11).

3)      Added definitions in section 2.1 for Resource Type and Schema.

4)      Added meta.resourceType definition to section 5.1.

5)      Updated the definition for the "schemas" attribute slightly in section 5.2.

6)      Updated the Schema example to follow the new definition and added Resource Type example (sections 12.6 and 12.7).

7)      Changed the schema URNs to use 2.0 as the version and include the specific resource type.  For example, urn:scim:schema:core:1.0 changed to urn:scim:schema:core:2.0:User.

8)      Added meta.resourceType to all examples.

9)      Modified ServiceProviderConfig to indicate that "id" is not required since this is a singleton read-only resource.

I have not updated the API doc yet, but believe this will mostly entail updating the examples.

Please let me know your thoughts.

--Kelly

---

From: Leif Johansson <[email-masked]>
Date: Fri, 26 Jul 2013 15:52:02 +0200

> I have a rough draft of the changes for issue #38.  This contains the
Folks? Kelly needs review and a few +1s to proceed!

---

From: Phil Hunt <[email-masked]>
Date: Fri, 26 Jul 2013 09:08:12 -0700

+1

Phil

@independentid
www.independentid.com
[email-masked]

On 2013-07-24, at 7:37 PM, Kelly Grizzle <[email-masked]> wrote:

> 2)      The Schemas definition was changed to only include an id, name, description, and attributes.  Also removed the “schema” sub-attribute from every attribute definition (section 11).
> 5)      Updated the definition for the “schemas” attribute slightly in section 5.2.
> 9)      Modified ServiceProviderConfig to indicate that “id” is not required since this is a singleton read-only resource.
>  
> <draft-ietf-scim-core-schema-02.html><draft-ietf-scim-core-schema-02-from-1.diff.html>_______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Mark Diodati <[email-masked]>
Date: Fri, 26 Jul 2013 16:40:03 -0500

+1

Nice work!

Mark

*From:* Phil Hunt [mailto:[email-masked]]
*Sent:* Friday, July 26, 2013 11:08 AM
*To:* Kelly Grizzle
*Cc:* [email-masked]
*Subject:* Re: [scim] Issue #38 - extensibility proposal

+1

Phil

@independentid

www.independentid.com

[email-masked]

On 2013-07-24, at 7:37 PM, Kelly Grizzle <[email-masked]>
wrote:

I have a rough draft of the changes for issue #38.  This contains the
following:

2)      The Schemas definition was changed to only include an id, name,
description, and attributes.  Also removed the “schema” sub-attribute from
every attribute definition (section 11).

5)      Updated the definition for the “schemas” attribute slightly in
section 5.2.

6)      Updated the Schema example to follow the new definition and added
Resource Type example (sections 12.6 and 12.7).

7)      Changed the schema URNs to use 2.0 as the version and include the
specific resource type.  For example, urn:scim:schema:core:1.0 changed to
urn:scim:schema:core:2.0:User.

9)      Modified ServiceProviderConfig to indicate that “id” is not
required since this is a singleton read-only resource.

I have not updated the API doc yet, but believe this will mostly entail
updating the examples.

--Kelly

---

From: Chris Phillips <[email-masked]>
Date: Mon, 29 Jul 2013 11:15:56 -0400

+1

Chris.

From: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 24 July, 2013 10:37 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [scim] Issue #38 - extensibility proposal

--Kelly

---

From: "Salvatore D'Agostino" <[email-masked]>
Date: Mon, 29 Jul 2013 12:18:31 -0400

+1

From: Kelly Grizzle <[email-masked]>
Date: Wednesday, 24 July, 2013 10:37 PM
To: "[email-masked]" <[email-masked]>
Subject: [scim] Issue #38 - extensibility proposal

2)      The Schemas definition was changed to only include an id, name,
description, and attributes.  Also removed the "schema" sub-attribute from
every attribute definition (section 11).

5)      Updated the definition for the "schemas" attribute slightly in
section 5.2.

9)      Modified ServiceProviderConfig to indicate that "id" is not required
since this is a singleton read-only resource.

--Kelly