Subject: [scim] JSON Schemas

From: "Steven W. Moyer" <[email-masked]>
Date: Mon, 22 Jul 2013 09:59:57 -0400 (EDT)

In the proposed SCIM version 2.0 Schema specification, the XSD Schemas are replaced with JSON Schemas as shown in section 11.6.  The XSD files served a useful purpose in version 1.0 and 1.1 in that they provided a machine readable file that could be used for code generation.  I believe this would contribute to consistency between implementations and was wondering if the working group was planning on providing the core schemas as individual files in the new JSON format.

Thanks,

Steve

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 22 Jul 2013 15:25:00 +0000

100% agree.  IMO we should definitely try to get this in for 2.0.  I opened issue #44 to track this: http://trac.tools.ietf.org/wg/scim/trac/ticket/44.

Great suggestion!  Thanks Steve.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven W. Moyer
Sent: Monday, July 22, 2013 9:00 AM
To: [email-masked]
Subject: [scim] JSON Schemas

Thanks,

Steve
_______________________________________________
scim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/scim

---

From: "Steven W. Moyer" <[email-masked]>
Date: Mon, 22 Jul 2013 13:02:44 -0400 (EDT)

I have a couple more questions about the schema format:

1)  Is there a way to specify that a value contains an enumerated list (perhaps of another type)?  We'd like to provide some indication to our clients that we restrict the type fields to certain values (e.g. the type field for a phone number would only contain "daytime", "evening" and "fax").

2)  Has any attempt been made to make sure the SCIM schemas conform to the proposed standard at http://json-schema.org/?  It would be great if there was a consistent way to specify JSON schemas (similar to the consistency that XSD provided).

Thanks again!

Steve

----- Original Message -----
From: "Kelly Grizzle" <[email-masked]>
To: "Steven W. Moyer" <[email-masked]>, [email-masked]
Sent: Monday, July 22, 2013 11:25:00 AM
Subject: RE: [scim] JSON Schemas

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven W. Moyer
Sent: Monday, July 22, 2013 9:00 AM
To: [email-masked]
Subject: [scim] JSON Schemas

Thanks,

Steve

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 22 Jul 2013 18:37:44 +0000

> 1)  Is there a way to specify that a value contains an enumerated list...

Yes - see the "canonicalValues" attribute in section 10 of the schema document.  An example can be found in section 11.6.

> (perhaps of another type)

See the "referenceTypes" attribute in section 10 of the schema document.  This is used to denote which types of resources can be referenced if the attribute uses the "reference" data type.

> 2)  Has any attempt been made to make sure the SCIM schemas conform to the proposed standard at http://json-schema.org/?  

Phil Hunt mentioned this once but I don't know that anyone has looked into it.  I quickly scanned the spec and see that there might be some problems with the "id" attribute (see section 7  - http://json-schema.org/latest/json-schema-core.html#anchor25).  This seems like it would be something worth looking into, though.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven W. Moyer
Sent: Monday, July 22, 2013 12:03 PM
To: [email-masked]
Subject: Re: [scim] JSON Schemas

Thanks again!

Steve

----- Original Message -----
From: "Kelly Grizzle" <[email-masked]>
To: "Steven W. Moyer" <[email-masked]>, [email-masked]
Sent: Monday, July 22, 2013 11:25:00 AM
Subject: RE: [scim] JSON Schemas

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven W. Moyer
Sent: Monday, July 22, 2013 9:00 AM
To: [email-masked]
Subject: [scim] JSON Schemas

Thanks,

Steve

---

From: "Steven W. Moyer" <[email-masked]>
Date: Mon, 22 Jul 2013 15:35:00 -0400 (EDT)

I missed that the "canonicalValues" list was an enumeration, but now I'm wondering if it's possible to have one core schema provided with the IETF specification.  Since some of the values are optional and different organizations would have different enumerations for the email type, address type, etc fields, it might be hard to produce something that could be used to generate code.  Perhaps as a starting point?

While I asked whether you'd looked at the proposed JSON-Schema specification, I agree that there are holes (or at least use-cases) in that specification that the schema proposed for SCIM version 2.0 seems to fill (or allow for).  Maybe it's more a case of the JSON-Schema group expanding their specification to handle the issues you're seeing?

Thanks for all the help!

Steve

----- Original Message -----
From: "Kelly Grizzle" <[email-masked]>
To: "Steven W. Moyer" <[email-masked]>, [email-masked]
Sent: Monday, July 22, 2013 2:37:44 PM
Subject: RE: [scim] JSON Schemas

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven W. Moyer
Sent: Monday, July 22, 2013 12:03 PM
To: [email-masked]
Subject: Re: [scim] JSON Schemas

Thanks again!

Steve

----- Original Message -----
From: "Kelly Grizzle" <[email-masked]>
To: "Steven W. Moyer" <[email-masked]>, [email-masked]
Sent: Monday, July 22, 2013 11:25:00 AM
Subject: RE: [scim] JSON Schemas

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven W. Moyer
Sent: Monday, July 22, 2013 9:00 AM
To: [email-masked]
Subject: [scim] JSON Schemas

Thanks,

Steve