Subject: [scim] Clarification about read-only attributes

From: Shelley <[email-masked]>
Date: Tue, 2 Jul 2013 15:25:04 -0500

I've taken READ-ONLY to mean that the attribute may be set by service
providers, but that it may not be set by consumers (with the exception of
the group member type [1]).

Regarding the "display" sub-attribute, my understanding was that this, too,
falls into the second category such that it is only to be set by the
service provider. (Although, aside from group members and user groups, I've
found no value in using the "display" attribute for other multi-valued
attributes.)

[1] http://www.ietf.org/mail-archive/web/scim/current/msg00935.html

---------- Forwarded message ----------
> From: Andy Coulbeck <[email-masked]>
> To: [email-masked]
> Cc:
> Date: Tue, 2 Jul 2013 13:45:29 -0500
> Subject: [scim] Clarification about read-only attributes
> The SCIM core schema specification is apparently ambiguous about the
> semantics of READ-ONLY attributes. There are at least two possibilities:
>
> 1. A READ-ONLY attribute may be set in a POST, but not in a PUT or PATCH.
> 2. A READ-ONLY attribute may never be set (perhaps because it is
> dynamically assigned by the service provider).
>
> Some of the core schema attributes, (namely, the "id" attribute, meta
> attributes and the "groups" attribute) appear to fall in category 2.
> For custom attributes, and the "display" sub-attribute, it seems like they
> instead fall in category 1 -- since there is no other way to set an initial
> value.
>
> Do others agree that READ-ONLY attributes may be provided in a POST?
>
> Thanks,
> Andy
>

---

From: Phil Hunt <[email-masked]>
Date: Tue, 2 Jul 2013 13:57:05 -0700

Hmmm should we differentiate between read only vs immutable vs display?

Phil

On 2013-07-02, at 13:25, Shelley <[email-masked]> wrote:

> I've taken READ-ONLY to mean that the attribute may be set by service providers, but that it may not be set by consumers (with the exception of the group member type [1]).
> 
> Regarding the "display" sub-attribute, my understanding was that this, too, falls into the second category such that it is only to be set by the service provider. (Although, aside from group members and user groups, I've found no value in using the "display" attribute for other multi-valued attributes.)
> 
>> The SCIM core schema specification is apparently ambiguous about the semantics of READ-ONLY attributes. There are at least two possibilities:
>> 
>> 2. A READ-ONLY attribute may never be set (perhaps because it is dynamically assigned by the service provider).
>> 
>> Some of the core schema attributes, (namely, the "id" attribute, meta attributes and the "groups" attribute) appear to fall in category 2.
>> For custom attributes, and the "display" sub-attribute, it seems like they instead fall in category 1 -- since there is no other way to set an initial value.
>> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Thorsten Roßner <[email-masked]>
Date: Wed, 03 Jul 2013 09:08:05 +0200

+1, today it is too implicit.

Thorsten