Subject: Re: [scim] PATCH and Meta.Attributes

From: "Steven W. Moyer" <[email-masked]>
Date: Wed, 17 Jul 2013 17:53:17 -0400 (EDT)

If XML has been removed from the specification and the XSD schemas won't be representing the structure of the SCIM resources, is it really appropriate to use an XML schema name?  I've pulled this block from section 11.3 of the current schema specification:

{
  "schemas": ["urn:scim:schemas:core:1.0", "urn:scim:schemas:extension:enterprise:1.0"],
  "id": "2819c223-7f76-453a-919d-413861904646",
  "externalId": "701984",

And I'd propose that if we're providing JSON descriptions of the SCIM resource types at <baseURL>/Schemas, then the block should look more like:

{
  "schemas": ["<baseURL>/Schemas/User", "<baseURL>/Schemas/Enterprise"],
  "id": "2819c223-7f76-453a-919d-413861904646",
  "externalId": "701984",

ResourceType isn't mentioned in the schema specification, but I'd propose it should look something like the following (if it isn't in fact redundant with a URL style schema pointer):

  "meta":{
    "resourceType": ["User", "Enterprise"]

Steve

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 22 Jul 2013 15:20:15 +0000

>   "schemas": ["<baseURL>/Schemas/User", "<baseURL>/Schemas/Enterprise"],

The URL to access a schema is actually more like this: <baseURL>/Schemas/urn:scim:schemas:core:1.0.  I agree it would be nice if this were addressable in the schemas attribute, but more importantly it needs to be unique and consistent.  Given that baseURL is going to vary between service providers (and possibly tenants within a single service provider), this is not going to be consistent between different implementations.  In other words, Cisco cannot send its user to Salesforce because they have different baseURLs for their schemas.

Using the URN is nice because it is unique, can be registered, and therefore is consistent between implementations.  It also has the benefit that within a service provider you can use the URN to lookup the schema from the /Schemas endpoint.

> ResourceType isn't mentioned in the schema specification, but I'd propose it should look something like the
> following (if it isn't in fact redundant with a URL style schema pointer):
>
>  "meta":{

Agreed.  This was left out of the -01 drafts because issue 38 is planning on addressing this.  I am working on this and will send out a proposed draft soon.  The only difference between what I have in the draft and your example is that the draft uses a single-valued attribute rather than multi-valued.  More info to come soon on this.

--Kelly

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Steven W. Moyer
Sent: Wednesday, July 17, 2013 4:53 PM
To: [email-masked]
Subject: Re: [scim] PATCH and Meta.Attributes

{

{

  "meta":{

Steve
_______________________________________________
scim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/scim