Subject: Re: [scim] Issue #38 - extensibility proposal

From: Kelly Grizzle <[email-masked]>
Date: Wed, 7 Aug 2013 21:16:55 +0000

I have updated the API draft to include changes for issue #38.  This contains the following:

1)      Updated text to refer to Resource Type instead of Schema where relevant (section 3).

2)      Added Resource Type to the table of Defined endpoints (table 1 in section 3).

3)      Updated all examples to use fully-qualified URNs in the schemas attribute.  For example, urn:scim:schema:core:1.0 changed to urn:scim:schema:core:2.0:User.

4)      Updated all examples to include meta.resourceType.

5)      Added a schema for list/query responses using the URI: urn:scim:schemas:core:2.0:ListResponse.  Previously, this structure was just implied by the examples (section 3.2.2).

6)      Added a schema for a POST search request using the URI: urn:scim:schemas:core:2.0:SearchRequest.  Previously, this structure was just implied by referring to the list/query resource information (section 3.2.3).

7)      Added schemas for bulk requests and responses using the URIs: urn:scim:schemas:core:2.0:BulkRequest and urn:scim:schemas:core:2.0:BulkResponse.  The attributes for these were previously defined, but didn't have a schema associated with them (section 3.5).

8)      Added a schema for error responses using the URI: urn:scim:schemas:core:2.0:Error.  Previously, this structure was implied in the HTTP Response Codes section but not explicitly defined with a schema (section 3.9).

I have attached both the new API and core schema documents (which I sent previously).

Please let me know your thoughts.

--Kelly

From: Kelly Grizzle
Sent: Wednesday, July 24, 2013 9:38 PM
To: [email-masked]
Subject: Issue #38 - extensibility proposal

I have a rough draft of the changes for issue #38.  This contains the following:

1)      A new ResourceType endpoint (section 10).

2)      The Schemas definition was changed to only include an id, name, description, and attributes.  Also removed the "schema" sub-attribute from every attribute definition (section 11).

3)      Added definitions in section 2.1 for Resource Type and Schema.

4)      Added meta.resourceType definition to section 5.1.

5)      Updated the definition for the "schemas" attribute slightly in section 5.2.

6)      Updated the Schema example to follow the new definition and added Resource Type example (sections 12.6 and 12.7).

7)      Changed the schema URNs to use 2.0 as the version and include the specific resource type.  For example, urn:scim:schema:core:1.0 changed to urn:scim:schema:core:2.0:User.

8)      Added meta.resourceType to all examples.

9)      Modified ServiceProviderConfig to indicate that "id" is not required since this is a singleton read-only resource.

I have not updated the API doc yet, but believe this will mostly entail updating the examples.

Please let me know your thoughts.

--Kelly

---

From: Phil Hunt <[email-masked]>
Date: Tue, 13 Aug 2013 10:01:06 -0700

+1 to publish

Phil

@independentid
www.independentid.com
[email-masked]

On 2013-08-07, at 2:16 PM, Kelly Grizzle <[email-masked]> wrote:

> 7)      Added schemas for bulk requests and responses using the URIs: urn:scim:schemas:core:2.0:BulkRequest and urn:scim:schemas:core:2.0:BulkResponse.  The attributes for these were previously defined, but didn’t have a schema associated with them (section 3.5).
> 2)      The Schemas definition was changed to only include an id, name, description, and attributes.  Also removed the “schema” sub-attribute from every attribute definition (section 11).
> 5)      Updated the definition for the “schemas” attribute slightly in section 5.2.
> 9)      Modified ServiceProviderConfig to indicate that “id” is not required since this is a singleton read-only resource.
>  
> <draft-ietf-scim-api-02.html><draft-ietf-scim-api-02-from-1.diff.html><draft-ietf-scim-core-schema-02.html><draft-ietf-scim-core-schema-02-from-1.diff.html>_______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim