Subject: [scim] SCIM to SAML mapping

From: Erik Wahlström <[email-masked]>
Date: Thu, 1 Aug 2013 15:36:43 +0000

The Berlin meeting talked about a SCIM to SAML mapping. This is an old document from the 1.1 spec work that could potentially be used as a starting point for a SCIM to SAML mapping.

https://code.google.com/p/scim/source/browse/trunk/specs/draft-scim-saml2-binding-02.xml

And the mail thread where it was presented:
https://groups.google.com/forum/#!searchin/cloud-directory/saml/cloud-directory/jI_6WahZ8Ak/3_1zQYPQhbAJ

/ Erik

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Sat, 3 Aug 2013 01:25:48 +0000

Thanks for posting the link Erik. This is the document I referred to in the meeting.  It is not complete by any stretch of imagination but might be a good starting point.

Cheers,
Morteza

From: Erik Wahlström <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 1, 2013 5:36 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [scim] SCIM to SAML mapping

/ Erik

---

From: Leif Johansson <[email-masked]>
Date: Sat, 3 Aug 2013 11:41:04 +0200

> Thanks for posting the link Erik. This is the document I referred to in the meeting.  It is not complete by any stretch of imagination but might be a good starting point.

Anyone want to volunteer to pick it up?

> 
> Cheers,
> Morteza
> 
> From: Erik Wahlström <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Keith Hazelton <[email-masked]>
Date: Sat, 03 Aug 2013 09:14:57 -0500

I'll take a look at what's been done. Is it clear which problems would be made easier to address given a full SCIM to SAML mapping?

 --Keith (for the ciferproject.org Provisioning and Integration Team 
 https://spaces.internet2.edu/display/cifer/Provisioning+and+Integration+Team
_____________
On 08/03/13, Leif Johansson  wrote:
> 
> 
> 
> 
> 
> 
> 3 aug 2013 kl. 03:25 skrev "Morteza Ansari (moransar)" <[email-masked] <[email-masked]>>:
> 
> 
> 
> > From: Erik Wahlström <[email-masked] <[email-masked]>>
> > To: "[email-masked] <[email-masked]>" <[email-masked] <[email-masked]>>
> > [email-masked] <[email-masked]>

---

From: Alex Redston <[email-masked]>
Date: Mon, 05 Aug 2013 10:34:21 +0100

Disclaimer - This is more of an expression of concern than a reasoned 
argument, I have not read the proposals here in detail.

I'm starting to get a little concerned here - A while back a decision 
was taken to remove XML from the SCIM spec.

The decision to eliminate XML support seemed a sensible move to drive up 
adoption of SCIM as an interface through reduced barriers to support.

However when I see comments about using an "XPath-ish syntax" alarm 
bells start to go off.

  IT seems to me that there is an inherent separation here between a 
lightweight version of SCIM which is easy to adopt, uses JSON and a more 
robust standard - something that SPML once aspired to become and failed 
because at the time (pre-cloud) there was no inherent application for it 
other than interoperability between vendors, something which did not 
make sense commercially as a priority.

If we are going to start interoperating with another standard which is 
inherently XML then XML should be the format of SCIM - we are after-all 
deviating here from simple provisioning scenarios. If the SCIM was 
supported in XML then we would not be taking about XPath-esque syntaxes 
we could just use the actual XPath. XML support would also put to bed 
the increasingly complex scenarios around data vs metadata which always 
arise because JSON has no way to represent attributes.

Alex

Alex Redston

Technical Architect, Managing Director
Switch Research Limited

+44 1328 838821
+44 7973 320795

Alex Redston

Technical Architect, Managing Director
Switch Research Limited
Redston Systems Limited

+44 1328 838821
+44 7973 320795

Registered Office:
6 LANGDALE COURT
WITNEY
OXFORDSHIRE
UNITED KINGDOM
OX28 6FG

Company No. 02916682

---

From: Leif Johansson <[email-masked]>
Date: Mon, 05 Aug 2013 21:26:04 +0200

On 08/05/2013 11:34 AM, Alex Redston wrote:
> The decision to eliminate XML support seemed a sensible move to drive
> up adoption of SCIM as an interface through reduced barriers to support.
>
> lightweight version of SCIM which is easy to adopt, uses JSON and a
> more robust standard - something that SPML once aspired to become and
> failed because at the time (pre-cloud) there was no inherent
> application for it other than interoperability between vendors,
> something which did not make sense commercially as a priority.
>
> inherently XML then XML should be the format of SCIM - we are
> after-all deviating here from simple provisioning scenarios. If the
> SCIM was supported in XML then we would not be taking about
> XPath-esque syntaxes we could just use the actual XPath. XML support
> would also put to bed the increasingly complex scenarios around data
> vs metadata which always arise because JSON has no way to represent
> attributes.
>
>

Speaking as an individual: Since the mapping is at the
attribute-value-level the fact that
SAML uses XML really doesn't matter.

        Cheers Leif