Subject: [scim] [SCIM] schema files in JSON format

From: Kiran Ayyagari <[email-masked]>
Date: Sun, 22 Sep 2013 18:04:07 +0530

I was trying to create schema files for each resource type and found
that the normative example(section 12.7) of core User schema omits
several attributes. I am not sure if this was done intentionally.

I am attaching the schema files for User, Entrerprise user and Group
resources.
It would be great if they can be made available under the resources section
of
SCIM website.

Finally, should the 'employeeNumber' attribute of Enterprise user be made
a REQUIRED attribute?

-- 
Kiran Ayyagari
http://keydap.com

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 23 Sep 2013 13:17:45 +0000

These are great!  Thank you, Kiran.

I will attach these to issue #44 (http://trac.tools.ietf.org/wg/scim/trac/ticket/44).  I'm not sure whether these should somehow be included with the I-D's as well or if they should just go on the website.

Regarding employeeNumber, IMO this should be optional.  I can imagine a scenario where a new employee is onboarded and gets created with a manager, etc... but they do not yet have an employee number assigned.  REQUIRED is similar to a database NOT NULL constraint, and I think it is a bit too strong for this case.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Kiran Ayyagari
Sent: Sunday, September 22, 2013 7:34 AM
To: [email-masked]
Subject: [scim] [SCIM] schema files in JSON format

I am attaching the schema files for User, Entrerprise user and Group resources.
It would be great if they can be made available under the resources section of
SCIM website.
Finally, should the 'employeeNumber' attribute of Enterprise user be made
a REQUIRED attribute?

--
Kiran Ayyagari
http://keydap.com

---

From: Kiran Ayyagari <[email-masked]>
Date: Mon, 23 Sep 2013 19:53:06 +0530

On Mon, Sep 23, 2013 at 6:47 PM, Kelly Grizzle
<[email-masked]>wrote:

>  These are great!  Thank you, Kiran.****
>
> ** **
>
> I will attach these to issue #44 (
> http://trac.tools.ietf.org/wg/scim/trac/ticket/44).  I’m not sure whether
> these should somehow be included with the I-D’s as well or if they should
> just go on the website.****
>
> **
>
I have few more changes to these schemas will send them after updating

> **
>
> Regarding employeeNumber, IMO this should be optional.  I can imagine a
> scenario where a new employee is onboarded and gets created with a manager,
> etc… but they do not yet have an employee number assigned.  REQUIRED is
> similar to a database NOT NULL constraint, and I think it is a bit too
> strong for this case.****
>
> **
>
ok, makes sense

thanks Kelly

> **
>
> --Kelly****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Kiran Ayyagari
> *Sent:* Sunday, September 22, 2013 7:34 AM
> *To:* [email-masked]
> *Subject:* [scim] [SCIM] schema files in JSON format****
>
> ** **
>
> I was trying to create schema files for each resource type and found****
>
> several attributes. I am not sure if this was done intentionally.****
>
>
> resources.****
> It would be great if they can be made available under the resources
> section of****
>
> SCIM website.****
>
> Finally, should the 'employeeNumber' attribute of Enterprise user be made*
> ***
>
> a REQUIRED attribute?****
>
>
> --
> Kiran Ayyagari
> http://keydap.com ****
>

-- 
Kiran Ayyagari
http://keydap.com