Subject: [scim] Proposed resolution - root search optionality (ticket 42)

From: Phil Hunt <[email-masked]>
Date: Mon, 28 Oct 2013 11:46:49 -0700

Proposed text. Replace section 3.2.2.1 Query Endpoints with (ticket 42 - http://trac.tools.ietf.org/wg/scim/trac/ticket/42 ):

3.2.2.1 Query Enpoints

Resource Queries
A query MAY be performed against any specific resource endpoint or resource. For example:

Resource (e.g. /Users/{userid}),
Resource Type endpoint (e.g. /Users or /Groups)
Root Queries
A server MAY support queries at the server root (e.g. /) for the purpose of returning resources of more than one resource type.

A search against a server root indicates that ALL resources within the server SHALL be included subject to filtering. For example, a filter against 'meta.resourceType' could be used to restrict results to one or more specific resource types.

When processing search operations across endpoints that include more than one SCIM resource type (e.g. a search from the server root endpoint), filters MUST be processed in the same fashion as outlined in Section 3.2.2.2. For filtered attributes that are not part of a particular resource type, the service provider SHALL treat the attribute as if there is no attribute value. For example, a presence or equality filter for an undefined attribute evaluates as FALSE.

Please confirm if you agree with this subtle change which makes root searches optional to the server.

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Anthony Nadalin <[email-masked]>
Date: Mon, 28 Oct 2013 20:47:48 +0000

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Monday, October 28, 2013 11:47 AM
To: [email-masked] WG
Subject: [scim] Proposed resolution - root search optionality (ticket 42)

3.2.2.1 Query Enpoints

Resource Queries

  *   Resource (e.g. /Users/{userid}),
  *   Resource Type endpoint (e.g. /Users or /Groups)

Root Queries

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

---

From: Thorsten Roßner <[email-masked]>
Date: Tue, 29 Oct 2013 08:56:24 +0100

+1

> _Please confirm_ if you agree with this subtle change which makes root
> searches optional to the server.
>

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 29 Oct 2013 18:28:36 +0000

I like the text, but think that we should also consider adding a ServiceProviderConfig property that says whether this is supported or not.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anthony Nadalin
Sent: Monday, October 28, 2013 3:48 PM
To: Phil Hunt; [email-masked] WG
Subject: Re: [scim] Proposed resolution - root search optionality (ticket 42)

+1

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Monday, October 28, 2013 11:47 AM
To: [email-masked]<mailto:[email-masked]> WG
Subject: [scim] Proposed resolution - root search optionality (ticket 42)

3.2.2.1 Query Enpoints

Resource Queries

Root Queries

Phil

@independentid

---

From: Mark Diodati <[email-masked]>
Date: Tue, 29 Oct 2013 15:14:36 -0600

+1

---

From: Leif Johansson <[email-masked]>
Date: Tue, 29 Oct 2013 21:23:24 +0100

On 10/29/2013 07:28 PM, Kelly Grizzle wrote:
>
> I like the text, but think that we should also consider adding a
> ServiceProviderConfig property that says whether this is supported or not.
>
Propose text ?
>
>  
>
> --Kelly
>
>  
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf
> Of *Anthony Nadalin
> *Sent:* Monday, October 28, 2013 3:48 PM
> *To:* Phil Hunt; [email-masked] WG
> *Subject:* Re: [scim] Proposed resolution - root search optionality
> (ticket 42)
>
>  
>
> +1
>
>  
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Phil Hunt
> *Sent:* Monday, October 28, 2013 11:47 AM
> *To:* [email-masked] <mailto:[email-masked]> WG
> *Subject:* [scim] Proposed resolution - root search optionality
> (ticket 42)
>
>  
>
> Proposed text. Replace section 3.2.2.1 Query Endpoints with (ticket 42
> - http://trac.tools.ietf.org/wg/scim/trac/ticket/42 ):
>
> 3.2.2.1 Query Enpoints
>
>
>     Resource Queries
>
> A server MAY support queries at the server root (e.g. /) for the
> purpose of returning resources of more than one resource type.
>
> A search against a server root indicates that ALL resources within the
> server SHALL be included subject to filtering. For example, a filter
> against 'meta.resourceType' could be used to restrict results to one
> or more specific resource types.
>
> When processing search operations across endpoints that include more
> than one SCIM resource type (e.g. a search from the server root
> endpoint), filters MUST be processed in the same fashion as outlined
> in Section 3.2.2.2. For filtered attributes that are not part of a
> particular resource type, the service provider SHALL treat the
> attribute as if there is no attribute value. For example, a presence
> or equality filter for an undefined attribute evaluates as FALSE.
>
> _Please confirm_if you agree with this subtle change which makes root
> www.independentid.com <http://www.independentid.com>
>
> [email-masked] <mailto:[email-masked]>
>
>  
>
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Leif Johansson <[email-masked]>
Date: Tue, 29 Oct 2013 21:24:28 +0100

This looks like consensus to me.

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 29 Oct 2013 21:27:40 +0000

Schema doc section 9 (Service Provider Configuration Schema) - add the following attribute between the filter and changePassword attributes:

   rootSearch  A complex type that specifies root search configuration options.
      REQUIRED.

      supported  Boolean value specifying whether root search is supported.  REQUIRED.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Tuesday, October 29, 2013 3:23 PM
To: [email-masked]
Subject: Re: [scim] Proposed resolution - root search optionality (ticket 42)

--Kelly

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Anthony Nadalin
Sent: Monday, October 28, 2013 3:48 PM
To: Phil Hunt; [email-masked]<mailto:[email-masked]> WG
Subject: Re: [scim] Proposed resolution - root search optionality (ticket 42)

+1

3.2.2.1 Query Enpoints

Resource Queries

Root Queries

Phil

@independentid

scim mailing list

[email-masked]<mailto:[email-masked]>