Subject: [scim] Interest in an open source SCIM library

From: Keith Hazelton <[email-masked]>
Date: Fri, 04 Oct 2013 16:58:56 -0500

Are there parties interested in developing or collaborating on a full and open source SCIM library. There are a number of open source projects that could benefit from such a thing. 

 --Keith Hazelton

---

From: Madhu M <[email-masked]>
Date: Fri, 4 Oct 2013 18:03:02 -0400

There is an OpenSource library by UnboundID here:
https://code.google.com/p/scimsdk/

Were you looking for something different?

On Fri, Oct 4, 2013 at 5:58 PM, Keith Hazelton <[email-masked]>wrote:

> Are there parties interested in developing or collaborating on a full and
> open source SCIM library. There are a number of open source projects that
> could benefit from such a thing.
>
>  --Keith Hazelton
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>

-- 
Madhu Mahadevan
Sr. Technical Consultant @ okta.com
c: +1 (416) 451-4611
o: +1 (415) 578-5176
b: +1 (877) 273-4202,,1083942
t: @mmaha <http://twitter.com/mmaha>
---
Sponsor me and help raise money for United Way:
http://j.mp/support-united-way
---

---

From: David Langenberg <[email-masked]>
Date: Fri, 4 Oct 2013 16:29:47 -0600

There's a few issues with the unboundID software.  First off the UnboundID
stuff is triple licensed.  The projects Keith is talking about, and the one
I'm most involved with is Apache licensed.  While the first license --
GPLv2 can use Apache stuff, the reverse is not true.  Second, the LGPL,
while it seems to solve the problem really does not and furthermore still
would make issues for folks downstream when it comes to dealing with
derived works.  Third (Unbound ID License) requires downstream projects to
enforce US Export Restrictions and that is just not something we're
prepared to do.

Dave

-- 
David Langenberg
Identity & Access Management
The University of Chicago

---

From: Prabath Siriwardena <[email-masked]>
Date: Sat, 5 Oct 2013 10:47:44 +0530

WSO2 Charon http://wso2.com/projects/charon is an open source library with
Apache 2.0 license

Thanks & regards,
-Prabath

-- 
Thanks & Regards,
Prabath

Mobile : +94 71 809 6732

http://blog.facilelogin.com
http://RampartFAQ.com

---

From: "Brock Allen" <[email-masked]>
Date: Sat, 5 Oct 2013 21:06:21 -0400

I started working on an open source .NET SCIM v1.1 implementation. Given the
recent activity on v2 I stop working until v2 settled down.

Along these lines, I've not been watching too closely the v2 progress -
would you consider it sufficiently stable to go build something on, or do
you (meaning the collective group here) still foresee significant changes?

-Brock

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Prabath Siriwardena
Sent: Saturday, October 5, 2013 1:18 AM
To: [email-masked]
Cc: [email-masked]; grouper-dev
Subject: Re: [scim] Interest in an open source SCIM library

Thanks & regards,

-Prabath

On Sat, Oct 5, 2013 at 3:28 AM, Keith Hazelton <[email-masked]
<mailto:[email-masked]> > wrote:

 --Keith Hazelton

_______________________________________________
scim mailing list
[email-masked] <mailto:[email-masked]> 
https://www.ietf.org/mailman/listinfo/scim

-- 
Thanks & Regards,
Prabath

Mobile : +94 71 809 6732

---

From: Thorsten Roßner <[email-masked]>
Date: Mon, 07 Oct 2013 08:52:45 +0200

We are working on a MIT licenced Java (SE) implementation of SCIMv2 (
https://osiam.org/ or https://github.com/osiam ).

Our SCIM Schema and Connector (SCIM Client) are already available on
maven.org (http://search.maven.org/#search%7Cga%7C1%7Cosiam), the server
isn't currently designed to be a separate library but a SCIMv2 service.
But we are happy for any support to separate a SCIMv2 library from this
service.

Also, as already stated earlier on this list, we are looking for other
SCIM v2 implementations (Client or Server) that have a public instance
and could be used for automated interop-testing.

Cheers
Thorsten

Am 06.10.2013 03:06, schrieb Brock Allen:
>
> I started working on an open source .NET SCIM v1.1 implementation.
> Given the recent activity on v2 I stop working until v2 settled down.
>
>  
>
> Along these lines, I've not been watching too closely the v2 progress
> -- would you consider it sufficiently stable to go build something on,
> or do you (meaning the collective group here) still foresee
> significant changes?
>
>  
>
> -Brock
>
>  
>
>  
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf
> Of *Prabath Siriwardena
> *Sent:* Saturday, October 5, 2013 1:18 AM
> *To:* [email-masked]
> *Cc:* [email-masked]; grouper-dev
> *Subject:* Re: [scim] Interest in an open source SCIM library
>
>  
>
> WSO2 Charon http://wso2.com/projects/charon is an open source library
> with Apache 2.0 license
>
>  
>
> Thanks & regards,
>
> -Prabath
>
>  
>
> <mailto:[email-masked]>> wrote:
>
>     Are there parties interested in developing or collaborating on a
>     full and open source SCIM library. There are a number of open
>     source projects that could benefit from such a thing.
>
>      --Keith Hazelton
>

---

From: Erik Wahlström <[email-masked]>
Date: Mon, 7 Oct 2013 09:59:43 +0000

And as the osiam implementation already done, I would be happy to add any implementation to the list of implementations at www.simplecloud.info<http://www.simplecloud.info> page.

Just send me an mail.

/ Erik

On Oct 7, 2013, at 8:52 AM, Thorsten Roßner <[email-masked]<mailto:[email-masked]>> wrote:

We are working on a MIT licenced Java (SE) implementation of SCIMv2 ( https://osiam.org/ or https://github.com/osiam ).

Our SCIM Schema and Connector (SCIM Client) are already available on maven.org<http://maven.org> (http://search.maven.org/#search%7Cga%7C1%7Cosiam), the server isn't currently designed to be a separate library but a SCIMv2 service. But we are happy for any support to separate a SCIMv2 library from this service.

Also, as already stated earlier on this list, we are looking for other SCIM v2 implementations (Client or Server) that have a public instance and could be used for automated interop-testing.

Cheers
Thorsten

Am 06.10.2013 03:06, schrieb Brock Allen:
I started working on an open source .NET SCIM v1.1 implementation. Given the recent activity on v2 I stop working until v2 settled down.

Along these lines, I’ve not been watching too closely the v2 progress – would you consider it sufficiently stable to go build something on, or do you (meaning the collective group here) still foresee significant changes?

-Brock

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Prabath Siriwardena
Sent: Saturday, October 5, 2013 1:18 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; grouper-dev
Subject: Re: [scim] Interest in an open source SCIM library

WSO2 Charon http://wso2.com/projects/charon is an open source library with Apache 2.0 license

Thanks & regards,
-Prabath

On Sat, Oct 5, 2013 at 3:28 AM, Keith Hazelton <[email-masked]<mailto:[email-masked]>> wrote:
Are there parties interested in developing or collaborating on a full and open source SCIM library. There are a number of open source projects that could benefit from such a thing.

 --Keith Hazelton

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

--
Thanks & Regards,
Prabath

Mobile : +94 71 809 6732

http://blog.facilelogin.com<http://blog.facilelogin.com/>
http://RampartFAQ.com<http://rampartfaq.com/>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 7 Oct 2013 13:31:18 +0000

My guess is that most of the major changes have been completed.  There will still be quite a bit of churn on smaller issues, but IMO it is worth picking up again.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Brock Allen
Sent: Saturday, October 05, 2013 8:06 PM
To: 'Prabath Siriwardena'; [email-masked]
Cc: [email-masked]; 'grouper-dev'
Subject: Re: [scim] Interest in an open source SCIM library

Along these lines, I've not been watching too closely the v2 progress - would you consider it sufficiently stable to go build something on, or do you (meaning the collective group here) still foresee significant changes?

-Brock

Thanks & regards,
-Prabath

 --Keith Hazelton

--
Thanks & Regards,
Prabath

Mobile : +94 71 809 6732