Subject: [scim] Proposal for attribute indexing

From: Phil Hunt <[email-masked]>
Date: Mon, 28 Oct 2013 15:53:20 -0700

Please indicate your approval or comments with the following proposal for Ticket 47 ( http://trac.tools.ietf.org/wg/scim/trac/ticket/47 )

It is proposed that the following attribute is to be added to section 11 of the scim-core-schema draft to aid discovery of available searches for attributes:

indexed - One or more keyword values indicating the type of filters that MAY be used 
with the attribute. Valid values are the filter operators defined in section 3.2.2.2. 
For example, "eq" indicates the attribute and operator value must be identical for 
a match. To further values are defined:
* any - any filter may be used.
* none - no filter operator may be used with this attribute.
In section 9 of scim-core-schema, the service provider schema will have a new attribute as follows:

unindexedFilters - A Boolean value indicating whether searches filters using unindexed 
attributes are supported.
Additionally the following text is included in section 3.2.2.2 of the scim-api draft:

For any filter for which there is no index available and unindexed searching 
is not available, the server SHALL evaluate the the filter term as not matched.
Phil

@independentid
www.independentid.com
[email-masked]

---

From: Anthony Nadalin <[email-masked]>
Date: Tue, 29 Oct 2013 05:05:11 +0000

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Monday, October 28, 2013 3:53 PM
To: [email-masked] WG
Subject: [scim] Proposal for attribute indexing

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 30 Oct 2013 20:41:07 +0000

So ... would the value of the "indexed" attribute be an array of strings, or would it be a comma-separated string that contains the available indexes?  For example:

  "indexed": [ "eq", "sw" ]

Or:

  "indexed": "eq, sw"

A few other comments:

1)      The examples in sections 12.5 and 12.7 should be updated to include these new attributes.

2)      The name "indexed" throws me off a little bit ... it sounds more like a true/false boolean property.  Maybe change this to "indexes" or "filterOperators"?

3)       "To further values are defined" <-- Should "To" be "The" here?

4)      unindexedFilters - It seems like this should be a sub-attribute of the "filter" attribute in section 9.  Maybe change this to be a bit more specific (eg - "allowUnindexedFilters").

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Monday, October 28, 2013 5:53 PM
To: [email-masked] WG
Subject: [scim] Proposal for attribute indexing

@independentid

---

From: Phil Hunt <[email-masked]>
Date: Wed, 30 Oct 2013 15:10:37 -0700

+1  these seem like reasonable comments.

I am neutral on the array vs. comma separated list.  What's typical for what we have so far? 

Phil

@independentid
www.independentid.com
[email-masked]

On 2013-10-30, at 1:41 PM, Kelly Grizzle <[email-masked]> wrote:

> So … would the value of the “indexed” attribute be an array of strings, or would it be a comma-separated string that contains the available indexes?  For example:
>  
>   “indexed”: [ “eq”, “sw” ]
>  
> Or:
>  
>   “indexed”: “eq, sw”
>  
>  
> A few other comments:
> 2)      The name “indexed” throws me off a little bit … it sounds more like a true/false boolean property.  Maybe change this to “indexes” or “filterOperators”?
> 3)       “To further values are defined” <-- Should “To” be “The” here?
> 4)      unindexedFilters – It seems like this should be a sub-attribute of the “filter” attribute in section 9.  Maybe change this to be a bit more specific (eg – “allowUnindexedFilters”).
>  
> --Kelly
>  
> Please indicate your approval or comments with the following proposal for Ticket 47 (http://trac.tools.ietf.org/wg/scim/trac/ticket/47 )
>  
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 31 Oct 2013 14:07:13 +0000

I believe that arrays are more common.  This would be a little weird if using the "none" or "all" keywords, but seems like the right way to go still.

From: Phil Hunt [mailto:[email-masked]]
Sent: Wednesday, October 30, 2013 5:11 PM
To: Kelly Grizzle
Cc: [email-masked] WG
Subject: Re: [scim] Proposal for attribute indexing

Phil

@independentid

On 2013-10-30, at 1:41 PM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

Or:

  "indexed": "eq, sw"

A few other comments:

--Kelly

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Phil Hunt
Sent: Monday, October 28, 2013 5:53 PM
To: [email-masked]<mailto:[email-masked]> WG
Subject: [scim] Proposal for attribute indexing

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim