Subject: Re: [scim] Auto discovery of supported resource schemas

From: Steve Moyer <[email-masked]>
Date: Fri, 4 Oct 2013 17:50:07 -0400 (EDT)

It's my understanding (based on section 3 of the API document) that the ResourceType resources will be available at the ../v1/ResourceTypes end-point, so if you want a collection of all the ResourceType objects, you could query that URL.  If you only want to retrieve a single ResourceType, you'd use ../v1/ResourceTypes/User or ../v1/ResourceTypes/Group.  I would then expect that both the ResourceType's schema and any extensions it declares would be available at ../v1/Schemas/..  (but perhaps I'm missing something).

While we're discussing the ResourceType, I was wondering if there was a logical reason that it doesn't have an "id" attribute.  Should one be added?  Or should we use the name as the endpoint?  For consistency, I'd prefer we add an id since every other object defined in the SCIM specifications has one.

Steve

---

From: Kiran Ayyagari <[email-masked]>
Date: Sun, 6 Oct 2013 09:59:24 +0530

On Sat, Oct 5, 2013 at 3:20 AM, Steve Moyer <[email-masked]> wrote:

> It's my understanding (based on section 3 of the API document) that the
> ResourceType resources will be available at the ../v1/ResourceTypes
> end-point, so if you want a collection of all the ResourceType objects,

I didn't find any desciption about this endpoint in the section 3.2.1 the
the table in section 3 mentions it

> you could query that URL.  If you only want to retrieve a single
> ResourceType, you'd use ../v1/ResourceTypes/User or
> ../v1/ResourceTypes/Group.  I would then expect that both the
> ResourceType's schema and any extensions it declares would be available at
> ../v1/Schemas/..  (but perhaps I'm missing something).
>
> While we're discussing the ResourceType, I was wondering if there was a
> logical reason that it doesn't have an "id" attribute.  Should one be
> added?  Or should we use the name as the endpoint?  For consistency, I'd
> prefer we add an id since every other object defined in the SCIM
> specifications has one.
>
yes, I agree it should be consistent with the other schema definitions

>
> Steve
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>

-- 
Kiran Ayyagari
http://keydap.com