Subject: [scim] Table of default attribute schema values for index, returned, mutability values for SCIM WG meeting

From: Phil Hunt <[email-masked]>
Date: Thu, 7 Nov 2013 13:39:46 -0800

As discussed, here is a first cut of default values for tickets 10, 35, 47

These are not final. I am assuming we will make corrections.  Please let me know if I missed any attributes.

Thanks!

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 8 Nov 2013 18:06:12 +0000

Looks pretty good, Phil.  I think you have User.groups and Group.members flipped, though.  User.groups should be readOnly and Group.members should be readWrite.

It might also be good to be more specific on the Group.members sub-attributes.  I know there have been questions in the past about this since the "type" sub-attribute is immutable.

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Thursday, November 07, 2013 1:40 PM
To: [email-masked] WG
Subject: [scim] Table of default attribute schema values for index, returned, mutability values for SCIM WG meeting

Thanks!

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

---

From: Leif Johansson <[email-masked]>
Date: Fri, 08 Nov 2013 19:36:38 +0100

On 11/08/2013 07:06 PM, Kelly Grizzle wrote:
>
> Looks pretty good, Phil.  I think you have User.groups and
> Group.members flipped, though.  User.groups should be readOnly and
> Group.members should be readWrite.
>
>  
>
> It might also be good to be more specific on the Group.members
> sub-attributes.  I know there have been questions in the past about
> this since the "type" sub-attribute is immutable.
>
>  
>
>
I uploaded that deck just now - all slides are now online.

---

From: Phil Hunt <[email-masked]>
Date: Fri, 8 Nov 2013 10:57:46 -0800

You are right. Thought i think there was some discussion that group.member values cannot change only added or removed. 

Which reminds me we should clarify what immutable means on multi valued cases. 

Phil

> On Nov 8, 2013, at 10:36, Leif Johansson <[email-masked]> wrote:
> 
>> It might also be good to be more specific on the Group.members sub-attributes.  I know there have been questions in the past about this since the “type” sub-attribute is immutable.
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim