Subject: [scim] Issue 35 - mutability

From: Phil Hunt <[email-masked]>
Date: Thu, 7 Nov 2013 10:55:43 -0800

My apologies, I realized that my todos for this week were not complete.  Issue 35, attribute mutability is as follows:

Proposed amendement:

In section 10, the list of attributes for schema is amended as follows.
REMOVED:

readOnly  A Boolean value that specifies if the attribute is
            mutable.
ADDED:

mutability  A single keyword indicating what types of modifications an attribute MAY
            accept as follows:
       readOnly  - The attribute MAY NOT be modified
       readWrite - The attribute MAY be updated and read at any time.
       immutable - The attribute MAY be defined at Resource creation. 
                   The attribute MAY NOT be updated.
       writeOnly - The attribute MAY be updated at any time. The attributes value 
                   MAY NOT be returned [ex the value is a stored hash]

I propose that we go through the list of attributes and default values for returnability, mutability, etc this week at IETF88 (tomorrow).

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Phil Hunt <[email-masked]>
Date: Thu, 7 Nov 2013 11:02:40 -0800 (PST)

Regarding immutable attributes.  I believe we had some discussion on the phone as to whether "PUT" (swapping the record) counts as resource creation.

I have no opinion, but we should decide for clarity/interop reasons.  I propose we discuss this tomorrow.

Phil

@independentid
www.independentid.com
[email-masked]

On 2013-11-07, at 10:55 AM, Phil Hunt <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim