Subject: Re: [scim] extended objects and searching

From: Kelly Grizzle <[email-masked]>
Date: Mon, 4 Nov 2013 20:21:31 +0000

I believe that the decision was to make the ResourceType be single-valued and correspond the endpoint from which the object was retrieved.  Each instance of this resource type can optionally include schemas from the schemaExtensions defined for the resource type.  It seems like the right way to achieve what you are looking for is to search on the "schemas" attribute.   For example:

  GET /Users?filter=schemas eq "urn:scim:schemas:extension:enterprise:2.0:User"

Does that sound right?

--Kelly

From: [email-masked] [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Monday, October 28, 2013 12:56 PM
To: [email-masked] WG
Subject: [scim] extended objects and searching

Kelly,

At one point we had a discussion about extensions (e.g. EnterpriseUser).  In draft 02, it seems that meta.resourceType only points to the main type of the object (e.g. User).  Were we going to multi-valued so that for example, a User with EnterpriseUser would be both "User" and "EnterpriseUser"?  The reason I ask, is we are looking for a way to search for those Users that are EnterpriseUser objects.

This is all related to Ticket 38...
http://trac.tools.ietf.org/wg/scim/trac/ticket/38

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

---

From: Phil Hunt <[email-masked]>
Date: Mon, 4 Nov 2013 13:46:24 -0800

I think if we formalize it, that will work.

Phil

@independentid
www.independentid.com
[email-masked]

On 2013-11-04, at 12:21 PM, Kelly Grizzle <[email-masked]> wrote:

> I believe that the decision was to make the ResourceType be single-valued and correspond the endpoint from which the object was retrieved.  Each instance of this resource type can optionally include schemas from the schemaExtensions defined for the resource type.  It seems like the right way to achieve what you are looking for is to search on the “schemas” attribute.   For example:
>  
>   GET /Users?filter=schemas eq “urn:scim:schemas:extension:enterprise:2.0:User”
>  
> Does that sound right?
>  
> --Kelly
>  
> www.independentid.com
> [email-masked]
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 5 Nov 2013 14:49:34 +0000

Right on.  I opened ticket #51 to address this - http://tools.ietf.org/wg/scim/trac/ticket/51.

From: Phil Hunt [mailto:[email-masked]]
Sent: Monday, November 04, 2013 3:46 PM
To: Kelly Grizzle
Cc: [email-masked] WG
Subject: Re: [scim] extended objects and searching

Phil

@independentid

On 2013-11-04, at 12:21 PM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

Does that sound right?

--Kelly

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Phil Hunt
Sent: Monday, October 28, 2013 12:56 PM
To: [email-masked]<mailto:[email-masked]> WG
Subject: [scim] extended objects and searching

Kelly,

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim