Subject: Re: [scim] Clarification on body request for DELETE

From: Erik Wahlström <[email-masked]>
Date: Tue, 3 Dec 2013 13:31:59 +0000

Well, it’s thing compared to my late reply :)

http://trac.tools.ietf.org/wg/scim/trac/ticket/39
The ticket #39 talks about this. I’ve had a small chat with Alexandre who registered that ticket. He said that both 200 with a text saying body should be empty and 204 worked, but he preferred 200.

I kinda prefer a 204. It’s more in line with HTTP spec, but it is a breaking change so we should really think it through.

Any thoughts? 200 och 204.

/ Erik

On 01 May 2013, at 23:10, Shelley <[email-masked]<mailto:[email-masked]>> wrote:

Apologies for the delayed reply to this thread regarding the DELETE response [1], but +1 to returning a 204.

[1] http://www.ietf.org/mail-archive/web/scim/current/msg00980.html

On Wed, Mar 27, 2013 at 1:10 PM, <[email-masked]<mailto:[email-masked]>> wrote:
---------- Forwarded message ----------
From: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
To: Alexandre Santos <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Wed, 27 Mar 2013 18:10:28 +0000
Subject: Re: [scim] Clarification on body request for DELETE
The SCIM API spec is not entirely clear here.  According to RFC 2616, the DELETE operation should work like this:

   A successful response SHOULD be 200 (OK) if the response includes an
   entity describing the status, 202 (Accepted) if the action has not
   yet been enacted, or 204 (No Content) if the action has been enacted
   but the response does not include an entity.

I can’t think of anything interesting for SCIM to return in a response body, so my vote would either be a 200 with an empty response (or just a message) or a 204 with no response body.  Perhaps we should open an issue to clarify this.  Thoughts?

--Kelly

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Shelley <[email-masked]>
Date: Tue, 3 Dec 2013 08:31:18 -0600

204 does seem more inline with the HTTP spec. What value would a message
body provide in this scenario? Either way may be a breaking change since
the SCIM spec isn't entirely prescriptive about the DELETE response. For
what it's worth, we are currently returning 204 in our 1.1 SP
implementation.

On Tue, Dec 3, 2013 at 7:31 AM, Erik Wahlström <
[email-masked]> wrote:

> The ticket #39 talks about this. I’ve had a small chat with Alexandre who
> registered that ticket. He said that both 200 with a text saying body
> should be empty and 204 worked, but he preferred 200.
>
>  I kinda prefer a 204. It’s more in line with HTTP spec, but it is a
> breaking change so we should really think it through.
>
>  On 01 May 2013, at 23:10, Shelley <[email-masked]> wrote:
>
> On Wed, Mar 27, 2013 at 1:10 PM, <[email-masked]> wrote:
>
>> From: Kelly Grizzle <[email-masked]>
>> To: Alexandre Santos <[email-masked]>, "[email-masked]" <
>> [email-masked]>
>> Cc:
>> I can’t think of anything interesting for SCIM to return in a response
>> body, so my vote would either be a 200 with an empty response (or just a
>> message) or a 204 with no response body.  Perhaps we should open an issue
>> to clarify this.  Thoughts?
>>
>>
>>
>> --Kelly
>>
>>
> [email-masked]