Subject: [scim] Fwd: New Version Notification for draft-hunt-http-rest-redirect-00.txt

From: Phil Hunt <[email-masked]>
Date: Wed, 15 Jan 2014 16:03:41 -0800

In the SCIM working group, the issue came up as to what to do about HTTP Redirects for RESTful services (of which SCIM is one). On Leif's suggestion, I put together a quick draft covering the topic to raise to the HTTPbis working group as this seems to apply to all RESTful services.

I also note that there is an existing draft http://datatracker.ietf.org/doc/draft-reschke-http-status-308/, which I have referenced in this draft.

Phil

@independentid
www.independentid.com
[email-masked]

Begin forwarded message:

> From: [email-masked]
> Subject: New Version Notification for draft-hunt-http-rest-redirect-00.txt
> Date: 15 January, 2014 3:52:44 PM PST
> To: Phil Hunt <[email-masked]>, "Phil Hunt" <[email-masked]>
> 
> 
> A new version of I-D, draft-hunt-http-rest-redirect-00.txt
> has been successfully submitted by Phil Hunt and posted to the
> IETF repository.
> 
> Name:		draft-hunt-http-rest-redirect
> Revision:	00
> Title:		HTTP Redirect Codes for RESTful Services
> Document date:	2014-01-16
> Group:		Individual Submission
> Pages:		5
> URL:            http://www.ietf.org/internet-drafts/draft-hunt-http-rest-redirect-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-hunt-http-rest-redirect/
> Htmlized:       http://tools.ietf.org/html/draft-hunt-http-rest-redirect-00
> 
> 
> Abstract:
>   This specification clarifies the use of HTTP redirect codes when used
>   with RESTful services.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 16 Jan 2014 07:42:56 -0800

Assuming you are refering to the 308 redirect draft. What is the current reference for 308?

REST services need redirects that do not convert to GET. That would corrupt the operation. 

Phil

> On Jan 16, 2014, at 7:21, Mark Baker <[email-masked]> wrote:
> 
>> On Thu, Jan 16, 2014 at 4:10 AM, Julian Reschke <[email-masked]> wrote:
>>> On 2014-01-16 01:03, Phil Hunt wrote:
>>> 
>>> In the SCIM working group, the issue came up as to what to do about HTTP
>>> Redirects for RESTful services (of which SCIM is one). On Leif's
>>> suggestion, I put together a quick draft covering the topic to raise to
>>> the HTTPbis working group as this seems to apply to all RESTful services.
>>> 
>>> I also note that there is an existing draft
>>> http://datatracker.ietf.org/doc/draft-reschke-http-status-308/, which I
>>> have referenced in this draft.
>>> 
>>> Phil
>>> ...
>> 
>> 
>> -1
> 
> +1 to your -1
> 
>> 
>> a) You reference an outdated spec.
>> 
>> b) You have statements about the existing redirection codes that are in
>> conflict with the relevant specs.
> 
> c) you specify a protocol that is known to be incompatible with
> deployed implementations and inconsistent with REST and Web
> architecture in significant ways
> 
>> 
>> What problem are you trying to solve here?
> 
> News to me, but SCIM is apparently an IETF WG;
> 
> https://datatracker.ietf.org/wg/scim/charter/
> 
> IMO, this draft doesn't bode well for the ability of the group to meet
> its (REST-oriented) charter, or for implementations to be deployed
> while interoperating properly with existing Web infrastructure.
> 
> Mark.

---

From: Phil Hunt <[email-masked]>
Date: Thu, 16 Jan 2014 08:00:17 -0800

Thanks.  2616 should be changed. 

I am open to broadening applicability to all non-browser HTTP services. 

Phil

> On Jan 16, 2014, at 7:50, Julian Reschke <[email-masked]> wrote:
> 
>> On 2014-01-16 16:42, Phil Hunt wrote:
> No, I'm referring to citing RFC 2616.
> 
> Yes. For some value of "Rest services"; I'd recommend to avoid that term altogether; just define an HTTP based service that makes sense and uses HTTP properly.
> 
> 
> Best regards, Julian
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 16 Jan 2014 08:15:04 -0800

Thanks. I believe http://tools.ietf.org/search/draft-ietf-httpbis-p2-semantics-25 does cover the issue. 

Though

Phil

> On Jan 16, 2014, at 8:03, Julian Reschke <[email-masked]> wrote:
> 
>> On 2014-01-16 17:00, Phil Hunt wrote:
> The point being that the definitions of the redirect codes have been rewritten a lot in HTTPbis.
> 
> Optimally, there is no need to have an additional document *at all*.
> 
>> ...
> 
> Best regards, Julian