Subject: [scim] Consistency of value/$ref sub-attributes

From: Phil Hunt <[email-masked]>
Date: Wed, 8 Jan 2014 12:17:54 -0800

SCIM User schema defines the multi-valued "groups" attribute as complex with sub attributes "value" and "$ref", but the SCIM Enterprise User schema defines single valued "manager" attribute as complex with sub attributes "managerId" and "$ref". Seems like it would have been better to be consistent regarding sub attributes for attributes that reference other resources (e.g. user, groups, etc.) and always have their sub attributes be "value" for the id and "$ref" for the URI.

Should we make this consistent for any attributes like this to have a value with an "id" and a $ref being the URI to said resource?

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kiran Ayyagari <[email-masked]>
Date: Thu, 9 Jan 2014 08:54:19 +0530

On Thu, Jan 9, 2014 at 1:47 AM, Phil Hunt <[email-masked]> wrote:

> SCIM User schema defines the multi-valued "groups" attribute as complex
> with sub attributes "value" and "$ref", but the SCIM Enterprise User schema
> defines single valued "manager" attribute as complex with sub attributes
> "managerId" and "$ref". Seems like it would have been better to be
> consistent regarding sub attributes for attributes that reference other
> resources (e.g. user, groups, etc.) and always have their sub attributes be
> "value" for the id and "$ref" for the URI.
>
> Should we make this consistent for any attributes like this to have a
> value with an "id" and a $ref being the URI to said resource?
>
> +1

> Phil
>
> @independentid
> www.independentid.com
> [email-masked]
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>

-- 
Kiran Ayyagari
http://keydap.com