Subject: [scim] id's for Multi-Valued Attributes

From: David Moebius <[email-masked]>
Date: Fri, 10 Jan 2014 12:05:44 +0100

Hi,

this is a proposal to add id's to every single Multi-Valued Attribute.

Why?

For example I want to change my primary email address. Since it is a multi
valued attribute I can't just change the value. Instead I need to delete my
old primary address and add a new email address which is set to primary =
true.

We think it would be easier if I just could sent an email value and the id
in which the value should be set.

What do you think about this?

by David

---

From: Phil Hunt <[email-masked]>
Date: Fri, 10 Jan 2014 08:44:15 -0800

Did you consider "type"?

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-01-10, at 3:05 AM, David Moebius <[email-masked]> wrote:

> For example I want to change my primary email address. Since it is a multi valued attribute I can't just change the value. Instead I need to delete my old primary address and add a new email address which is set to primary = true.
> 
> We think it would be easier if I just could sent an email value and the id in which the value should be set.
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: David Moebius <[email-masked]>
Date: Fri, 10 Jan 2014 17:51:48 +0100

Hi,

what do you mean with your question?
I don't think the type gives us any trouble with this approach or do I
don't see something?

David

2014/1/10 Phil Hunt <[email-masked]>

---

From: Phil Hunt <[email-masked]>
Date: Fri, 10 Jan 2014 09:03:07 -0800

Why do you feel you need an identifier when you already have type?

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-01-10, at 8:51 AM, David Moebius <[email-masked]> wrote:

> I don't think the type gives us any trouble with this approach or do I don't see something?
> 
> David
> 
> 
>

---

From: David Moebius <[email-masked]>
Date: Mon, 13 Jan 2014 09:28:28 +0100

Hi,

ok, that you mean. As we understand the type is not enough.
>From our understanding of the scim spec it is (and should) possible to have
several mail addresses of the same type.

For example, in my company I also have at least 3 emailadresses of the type
work

As far as we understand it is not possible to have the same email address /
type companation nut everthing else is possible.

For example

OK
value: [email-masked] type work
value [email-masked] type work

NOT OK
value: [email-masked] type work primary true
value: [email-masked] type work primary false

That's why the type is not enough and at the moment we need the value and
the type (but not the primary status) to be able to identify a email or
similary any other multi valued attribut.

David

>> For example I want to change my primary email address. Since it is a
>> multi valued attribute I can't just change the value. Instead I need to
>> delete my old primary address and add a new email address which is set to
>> primary = true.
>>

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 13 Jan 2014 15:14:01 +0000

Hi David ... I definitely see how the unique IDs help.  In fact, this discussion arose at least once or twice before when trying to figure out how to best reference elements within a multi-valued attribute (specifically in the PATCH operation).

The problem with unique IDs is that SCIM was designed to fit on top of existing data stores (eg - a directory server, a relational database, a NoSQL database, etc...).  The reasoning here is that almost all existing SCIM service providers already have data models in place, but may or may not have an API to manage identities.  Unfortunately, many backing data stores do not have IDs for multi-valued list elements, and so we didn't want to make this a requirement in the API.  Another option would be using an index in the list to modify/remove values.  Likewise, this has issues that not all data stores support ordered values, and it is quite prone to concurrency problems.

The PATCH API dictates that unique values must be used and that if the "value" sub-attribute is not unique for a multi-valued attribute that the full value of the complex attribute should be used.  Definitely not ideal, but it prevents putting too many requirements on the backing data store.

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of David Moebius
Sent: Monday, January 13, 2014 2:28 AM
To: Phil Hunt
Cc: [email-masked]
Subject: Re: [scim] id's for Multi-Valued Attributes

Hi,

>From our understanding of the scim spec it is (and should) possible to have several mail addresses of the same type.

For example, in my company I also have at least 3 emailadresses of the type work

As far as we understand it is not possible to have the same email address / type companation nut everthing else is possible.

For example

OK
value: [email-masked]<mailto:[email-masked]> type work
value [email-masked]<mailto:[email-masked]> type work

NOT OK
value: [email-masked]<mailto:[email-masked]> type work primary true
value: [email-masked]<mailto:[email-masked]> type work primary false

That's why the type is not enough and at the moment we need the value and the type (but not the primary status) to be able to identify a email or similary any other multi valued attribut.

David

2014/1/10 Phil Hunt <[email-masked]<mailto:[email-masked]>>
Why do you feel you need an identifier when you already have type?

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On 2014-01-10, at 8:51 AM, David Moebius <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

David

2014/1/10 Phil Hunt <[email-masked]<mailto:[email-masked]>>
Did you consider "type"?

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

On 2014-01-10, at 3:05 AM, David Moebius <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Why?

by David
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: David Moebius <[email-masked]>
Date: Mon, 13 Jan 2014 18:05:43 +0100

Hi Kelly,

thanks for your answer. Your answer describes very well why id's for the
multi valued attributes should not be considered.
Since this is not a very big problem we are ok with this.

by David

2014/1/13 Kelly Grizzle <[email-masked]>

>  Hi David … I definitely see how the unique IDs help.  In fact, this
> discussion arose at least once or twice before when trying to figure out
> how to best reference elements within a multi-valued attribute
> (specifically in the PATCH operation).
>
>
>
> The problem with unique IDs is that SCIM was designed to fit on top of
> existing data stores (eg – a directory server, a relational database, a
> NoSQL database, etc…).  The reasoning here is that almost all existing SCIM
> service providers already have data models in place, but may or may not
> have an API to manage identities.  Unfortunately, many backing data stores
> do not have IDs for multi-valued list elements, and so we didn’t want to
> make this a requirement in the API.  Another option would be using an index
> in the list to modify/remove values.  Likewise, this has issues that not
> all data stores support ordered values, and it is quite prone to
> concurrency problems.
>
>
>
> The PATCH API dictates that unique values must be used and that if the
> “value” sub-attribute is not unique for a multi-valued attribute that the
> full value of the complex attribute should be used.  Definitely not ideal,
> but it prevents putting too many requirements on the backing data store.
>
>
>
> --Kelly
>
>
>
> *From:* scim [mailto:[email-masked]] *On Behalf Of *David Moebius
> *Sent:* Monday, January 13, 2014 2:28 AM
> *To:* Phil Hunt
> *Cc:* [email-masked]
> *Subject:* Re: [scim] id's for Multi-Valued Attributes
>
>
>
> Hi,
>
> >From our understanding of the scim spec it is (and should) possible to
> have several mail addresses of the same type.
>
> As far as we understand it is not possible to have the same email address
> / type companation nut everthing else is possible.
>
> For example
>
> OK

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 13 Jan 2014 15:14:01 +0000

--Kelly

Hi,

For example

OK

NOT OK

David

Phil

@independentid

Hi,

David

Phil

@independentid

Hi,

Why?

by David