Subject: [scim] definition of Canonical Type's

From: David Moebius <[email-masked]>
Date: Tue, 7 Jan 2014 13:37:44 +0100

Hi to all and a happy new year :)

We have a question to the Canonical Type's of the mutli valued attributes.

Are the types descriped in
http://tools.ietf.org/html/draft-ietf-scim-core-schema-02#section-6.2 the
only types that are allowed or are these types the minimal set that has to
be supported and service consumers can introduce new types?

For example. By the Ims the types are aim, gtalk, icq, xmpp, msn, skype,
qq, and yahoo.
What if a user uses another Im. We don't even have the type "other".

We would be happy for a quick answer.

by David

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 7 Jan 2014 14:15:48 +0000

Hi David.  Feel free to extend these.  There is even a facility in the Schema for a service provider to expose which canonical types it supports.  See the "canonicalValues" sub-attribute here - http://tools.ietf.org/html/draft-ietf-scim-core-schema-02#section-11.

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of David Moebius
Sent: Tuesday, January 07, 2014 6:38 AM
To: [email-masked]
Subject: [scim] definition of Canonical Type's

Are the types descriped in http://tools.ietf.org/html/draft-ietf-scim-core-schema-02#section-6.2 the only types that are allowed or are these types the minimal set that has to be supported and service consumers can introduce new types?

For example. By the Ims the types are aim, gtalk, icq, xmpp, msn, skype, qq, and yahoo.
What if a user uses another Im. We don't even have the type "other".

by David

---

From: David Moebius <[email-masked]>
Date: Tue, 7 Jan 2014 15:59:53 +0100

Hy Kelly.

Thanks for the quick answer.
We will follow you suggestion and provide all described values but also
give the enduser the possibility to define his own types.

by David

2014/1/7 Kelly Grizzle <[email-masked]>

>  Hi David.  Feel free to extend these.  There is even a facility in the
> Schema for a service provider to expose which canonical types it supports.
> See the “canonicalValues” sub-attribute here -
> http://tools.ietf.org/html/draft-ietf-scim-core-schema-02#section-11.
>
>
>
> --Kelly
>
>
>
>
>
> *From:* scim [mailto:[email-masked]] *On Behalf Of *David Moebius
> *Sent:* Tuesday, January 07, 2014 6:38 AM
> *To:* [email-masked]
> *Subject:* [scim] definition of Canonical Type's
>
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>
>