Subject: [scim] draft-ietf-scim-api: use of PATCH with content-type application/json

From: Julian Reschke <[email-masked]>
Date: Fri, 17 Jan 2014 10:29:09 +0100

Hi there,

it seems that this draft uses application/json with a PATCH request. 
However, there are no PATCH semantics defined for this type.

You may want to have a look at draft-ietf-appsawg-json-merge-patch 
(which defines a new type for this purpose).

Best regards, Julian

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 21 Jan 2014 02:55:35 +0000

Thanks for the pointer, Julian.  The problem that I see with merge patch is that is does not have any way to add/remove elements to/from arrays without specifying the entire array value.  This was one of the primary use cases that drove SCIM to implement PATCH ... to be able to add or remove group members on large groups without having to replace the entire list.  This not only leads to very large requests, but also can have concurrency problems for groups that are modified often.

--Kelly

-----Original Message-----
From: scim [mailto:[email-masked]] On Behalf Of Julian Reschke
Sent: Friday, January 17, 2014 3:29 AM
To: [email-masked]
Subject: [scim] draft-ietf-scim-api: use of PATCH with content-type application/json

Hi there,

Best regards, Julian
_______________________________________________
scim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/scim

---

From: Julian Reschke <[email-masked]>
Date: Tue, 21 Jan 2014 09:01:34 +0100

> Thanks for the pointer, Julian.  The problem that I see with merge patch is that is does not have any way to add/remove elements to/from arrays without specifying the entire array value.  This was…

Well, right now you're doing something outside the specs. This *will* be 
raised as a problem once you last-call the document anyway, so you'll 
have to deal with it sooner or later.

An alternative format you can use is JSON Patch 
(http://tools.ietf.org/html/rfc6902).

Best regards, Julian