Subject: Re: [scim] Open Ticket Recommendations (Tickets 41 +)

From: Erik Wahlström <[email-masked]>
Date: Wed, 8 Jan 2014 15:35:13 +0000

+1 on everything a part from one thing :)

I will have a crack at ticket #43. I would like to remove the short hand version and clean that up a bit. Don’t want to wait :)

I can also compile some diff files for the following ticket.
- Ticket: 52 Minor textual changes
- Ticket: 53 Consumer vs Client
- Ticket: 54 Define core resource when referencing attributes

/ Erik

On 30 Dec 2013, at 22:28, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:

Final open ticket recommendations:

Ticket: 41 Add IANA considerations
Recommendation: Defer
Comment: still a todo

Ticket: 42 Make server root searches optional
Recommendation: Apply to draft
Comment: This has been discussed on list and at IETF 87/88. Should proceed with proposed text

Ticket: 43 Consider dropping short-hand notation for complex multi-valued attributes
Recommendation: defer / merge with 36
Comment: Seems to be related to ticket 36?

Ticket: 44 Add JSON Schemas for Core Schema Resources
Recommendation: Apply to draft
Comment: Seems straight forward.  Note: seems related to Ticket 40 (JSON format for defining a set of scim schema extensions)

Ticket: 45 LDAP Mapping
Recommendation: Defer
Comment: LDAP is more of an endpoint (client) rather than SCIM SP capable item. Would an LDAP Profile of SCIM (e.g. no complex attributes Users) be more appropriate?

Ticket: 46 Clarify error responses and allow non-HTTP error codes
Recommendation: Defer
Comment: Need proposal text. Seems tied in with Ticket 37

Ticket: 47 Attribute Indexing
Recommendation: Apply to draft
Comment: Item proposal reviewed and discussed at IETF88

Ticket: 48 Operations with Extended Schema Attributes
Recommendation:  Apply to draft
Comment: Seems like a straight forward clarification

Ticket: 49 Ends With filter missing
Recommendation: Apply to draft
Comment: Apply missing filter to draft

Ticket: 50 Filter semantics do not allow filtering on complex plural attributes (aka inner join)
Recommendation: Apply to draft
Comment:  A reasonable set of proposals was given at IETF88 -- consensus was around adding [subattr clause] notation.

Ticket: 51 Formalize searching by schema
Recommendation: Apply to draft
Comment:  Seems like a reasonable clarification (?)

Ticket: 52 Minor textual changes
Recommendation: Apply to draft
Comment: editorial issues.

Ticket: 53 Consumer vs Client
Recommendation: Apply to draft
Comment: editorial issues.

Ticket: 54 Define core resource when referencing attributes
Recommendation: Apply to draft
Comment: editorial issue

Ticket: 55 Redirection
Recommendation: Apply to draft (for now)
Comment: some limited discussion on list. Is this an item that should be elevated to the WG working on REST?

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Phil Hunt <[email-masked]>
Date: Wed, 8 Jan 2014 08:31:22 -0800

Erik,

Thanks for the great follow ups. Post the diffs to the tickets would be good. 

Cheers,

Phil

> On Jan 8, 2014, at 7:35, Erik Wahlström <[email-masked]> wrote:
> 
>> On 30 Dec 2013, at 22:28, Phil Hunt <[email-masked]> wrote:
>> 
>> www.independentid.com
>> [email-masked]
>> [email-masked]

---

From: Peter Gietz <[email-masked]>
Date: Wed, 08 Jan 2014 17:52:31 +0100

especially #45 is fine with me to
defer.

An LDAP Profile would be a good start (that's what I thought in
the first place).

I am still willing to do substantial work on that, but while
keeping my company going I didn't find substatial time to do so
yet unfortunately.

Cheers,

Peter

Am 30.12.2013 22:28, schrieb Phil Hunt:

Recommendation: Defer

Comment: still a todo

Ticket:
42 Make server root searches optional

Recommendation:
Apply to draft

Comment:
This has been discussed on list and at
IETF 87/88. Should proceed with proposed
text

Ticket:
43 Consider dropping short-hand notation
for complex multi-valued attributes

Recommendation:
defer / merge with 36

Comment:
Seems to be related to ticket 36?

Ticket:
44 Add JSON Schemas for Core Schema
Resources

Recommendation:
Apply to draft

Comment:
Seems straight forward.  Note: seems
related to Ticket 40 (JSON format for
defining a set of scim schema
extensions)

Ticket:
45 LDAP Mapping

Recommendation:
Defer

Comment:
LDAP is more of an endpoint (client)
rather than SCIM SP capable item. Would
an LDAP Profile of SCIM (e.g. no complex
attributes Users) be more appropriate?

Ticket:
46 Clarify error responses and allow
non-HTTP error codes

Recommendation:
Defer

Comment:
Need proposal text. Seems tied in with
Ticket 37

Ticket:
47 Attribute Indexing

Recommendation:
Apply to draft

Comment:
Item proposal reviewed and discussed at
IETF88

Ticket:
48 Operations with Extended Schema
Attributes

Recommendation:
Apply to draft

Comment:
Seems like a straight forward
clarification

Ticket:
49 Ends With filter missing

Recommendation:
Apply to draft

Comment:
Apply missing filter to draft

Ticket:
50 Filter semantics do not allow
filtering on complex plural attributes
(aka inner join)

Recommendation:
Apply to draft

Comment:
A reasonable set of proposals was given
at IETF88 -- consensus was around adding
[subattr clause] notation.

Ticket:
51 Formalize searching by schema

Recommendation:
Apply to draft

Comment:
Seems like a reasonable clarification
(?)

Ticket:
52 Minor textual changes

Recommendation:
Apply to draft

Comment:
editorial issues.

Ticket:
53 Consumer vs Client

Recommendation:
Apply to draft

Comment:
editorial issues.

Ticket:
54 Define core resource when referencing
attributes

Recommendation:
Apply to draft

Comment:
editorial issue

Ticket:
55 Redirection

Recommendation:
Apply to draft (for now)

Comment:
some limited discussion on list. Is this
an item that should be elevated to the
WG working on REST?

Phil

@independentid

www.independentid.com

[email-masked]

--

Peter Gietz, CEO

DAASI International GmbH
Europaplatz 3
D-72072 Tübingen
Germany

phone: +49 7071 407109-0
fax: +49 7071 407109-9
email: [email-masked]
web: www.daasi.de

Sitz der Gesellschaft: Tübingen
Registergericht: Amtsgericht Stuttgart, HRB 382175
Geschäftsleitung: Peter Gietz