Subject: [scim] Password updates and SCIM

From: Bill Mills <[email-masked]>
Date: Thu, 6 Feb 2014 19:44:22 -0800 (PST)

How does SCIM handle situations where something like password can set but shoudl not be displayed?  Is that just something handled in the schema that the password element exists but is returned empty?

Thanks,

-bill

---

From: Phil Hunt <[email-masked]>
Date: Thu, 6 Feb 2014 23:36:14 -0800

Bill,

Typically the password attribute would be marked in the schema with "returned" set to "never" and "mutability" set to "writeOnly". See tickets 10 and 35.

If the client requests the password attribute, nothing would be returned. Effectively meaning a client can only set a password if permitted by the service provider.

Because any attribute could have returnability or mutability set specifically, it is possible to get similar behaviour from other attributes such as ones you might define in an extension.  For example, you might make security questions as not returnable either (or for that matter anything stored as a hash).

These changes are planned to be included in the next draft.  

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-02-06, at 7:44 PM, Bill Mills <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim