Subject: [scim] Prelim changes for draft 03 for tomorrows call

From: Phil Hunt <[email-masked]>
Date: Tue, 11 Feb 2014 13:26:32 -0800

Please find attached the current spreadsheet on ticket plan and diffs for the new 03 drafts for tomorrows WG call.

Comments appreciated.  

Note: AFAIK, we need to publish this week for IETF London. (submission closes friday)

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Bill Mills <[email-masked]>
Date: Tue, 11 Feb 2014 14:14:50 -0800

This doesn't scan right...

"3.2.2.1.  Query Endpoints 

Queries MAY be performed against a SCIM resources or resource endpoints.  For example: "

-bill

--------------------------------
William J. Mills
"Paranoid" Yahoo!

On Tuesday, February 11, 2014 1:27 PM, Phil Hunt <[email-masked]> wrote:

Comments appreciated.  

Phil

@independentid
[email-masked]

---

From: Phil Hunt <[email-masked]>
Date: Tue, 11 Feb 2014 15:16:52 -0800

Bill,

Thanks! I'll fix tonight.

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-02-11, at 2:14 PM, Bill Mills <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Phil Hunt <[email-masked]>
Date: Wed, 12 Feb 2014 10:20:11 -0800

Some feedback from one of my co-workers,
> Hi Phil,
> 
> I have also done a quick review of the draft 03, and I do not have much to add:
> 
> SCIM core schema document:
> 
> OO1: There are some '\n' in the schema representation.
> 
> OO2: The mutability, uniqueness and returned values are not specified for each attributes (though we can find then in the schema representation), but rather each time the value is different from the default one. But these default values are not specified anywhere (I guess that mutability default is 'readWrite', uniqueness default is 'none', and returned default is 'default'). Perhaps, you could add some words like it is done in 3.1 about type, optional and readOnly to indicate the default behavior.
> 
> Olivier

I've added these changes plus some other minor edits from Erik.

Thanks everyone for the feedback!

Phil

@independentid
www.independentid.com
[email-masked]