Subject: [scim] Is externalId modifiable?

From: Phil Hunt <[email-masked]>
Date: Tue, 4 Feb 2014 10:01:12 -0800

Looking through the draft 2 schema, I see that externalId is marked readOnly.

Is the intent here that it be immutable (spec says it is set by client)?  I had been assuming it is a modifiable attribute and the client may update it any time.

While on the subject of "readOnly":  ticket 35 (discussed in Vancouver) adds a broader attribute quality - mutability. Mutability allows an attribute to be declared as: readOnly, writeOnly, immutable, or readWrite.  I am assuming that mutability replaces the meta-attribute readOnly and readOnly should be removed. Is this correct?

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Erik Wahlström <[email-masked]>
Date: Fri, 7 Feb 2014 14:40:04 +0000

Hi,

I agree, externalID could be updated by client if it want’s to. It only make sense to the client anyway. But I do not think it’s required. Some client’s don’t care keeping there own ID.

+1 on removing readOnly.

/ Erik

On 04 Feb 2014, at 19:01, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 7 Feb 2014 14:58:14 +0000

+1 for removing readOnly.

From: scim [mailto:[email-masked]] On Behalf Of Erik Wahlström
Sent: Friday, February 07, 2014 8:40 AM
To: Phil Hunt
Cc: [email-masked] WG
Subject: Re: [scim] Is externalId modifiable?

Hi,

I agree, externalID could be updated by client if it want's to. It only make sense to the client anyway. But I do not think it's required. Some client's don't care keeping there own ID.

+1 on removing readOnly.

/ Erik

Phil

@independentid

---

From: Mark Diodati <[email-masked]>
Date: Fri, 7 Feb 2014 09:01:56 -0600

+1

*From:* Kelly Grizzle [mailto:[email-masked]]
*Sent:* Friday, February 07, 2014 8:58 AM
*To:* Erik Wahlström; Phil Hunt
*Cc:* [email-masked] WG
*Subject:* Re: [scim] Is externalId modifiable?

*From:* scim [mailto:[email-masked] <[email-masked]>] *On
Behalf Of *Erik Wahlström
*Sent:* Friday, February 07, 2014 8:40 AM
*To:* Phil Hunt
*Cc:* [email-masked] WG
*Subject:* Re: [scim] Is externalId modifiable?

Hi,

I agree, externalID could be updated by client if it want's to. It only
make sense to the client anyway. But I do not think it's required. Some
client's don't care keeping there own ID.

+1 on removing readOnly.

/ Erik

On 04 Feb 2014, at 19:01, Phil Hunt <[email-masked]> wrote:

Looking through the draft 2 schema, I see that externalId is marked
readOnly.

Is the intent here that it be immutable (spec says it is set by client)?  I
had been assuming it is a modifiable attribute and the client may update it
any time.

While on the subject of "readOnly":  ticket 35 (discussed in Vancouver)
adds a broader attribute quality - mutability. Mutability allows an
attribute to be declared as: readOnly, writeOnly, immutable, or readWrite.
 I am assuming that mutability replaces the meta-attribute readOnly and
readOnly should be removed. Is this correct?

Phil

@independentid

www.independentid.com

[email-masked]

[email-masked]