Subject: [scim] inferring intent vs. explicit declaration....

From: Bill Mills <[email-masked]>
Date: Fri, 14 Feb 2014 09:19:46 -0800 (PST)

Something I'm not in love with in SCIM is that you have to infer actions from data changes.  Creation and deletion are explicit, PUT and PATCH get complicated.  

We have a model where an account might be suspended or reactivated, which is pretty basic and PUT/PATCH works fine, but we also might activate or deactivate a nmailbox or other features on the account and that means I have to have a possibly complex parser looking for state changes in the PUT data to trigger events.  There's also the use case where one side needs to signal the other side of an event, like a possible TOS violation or abuse event, a way to implement that would be adding events to a list and the PATCH operation is checked to see what data is going by.  

I'd like something simpler than doing a diff on the entire user state to get to the action needed.  Has this come up before?

-bill

---

From: Phil Hunt <[email-masked]>
Date: Fri, 14 Feb 2014 09:29:13 -0800

+1. 

I'd be curious to hear more about how people plan to use PUT. 

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-02-14, at 9:19 AM, Bill Mills <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim