Subject: [scim] querys with pr

From: David Moebius <[email-masked]>
Date: Fri, 14 Feb 2014 15:34:32 +0100

Hello,

one question about queriing with "pr" and the aspected behavior.

Setup:
I have 2 Users in my database.

1. a minimal User with just a few fields and no extension at all
2. a user who has extensions and the extension field "gender" is filled
with "male"
3. a user who has extensions and the extension field "gender" is filled
with "female"

Query:
I have a query
filter=not ( extension.gender pr "male")

Result:
With this query I get User 3 but not user 1 since user 1 doesn't has the
field gender at all.

Question:
Do you think this (sql) behavior is correct or should user 1 also be
returned.

By David

---

From: Phil Hunt <[email-masked]>
Date: Fri, 14 Feb 2014 09:19:35 -0800

David,

The filter doesn't look correct.

A correct one would be:
filter=not(extension.gender pr)

Should return record 1 since record 2 and 3 have a gender present.

A filter of:

filter=not(extension.gender pr or extension.gender eq "male")

Would return record 1 and 3 if I have my logic correct.

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-02-14, at 6:34 AM, David Moebius <[email-masked]> wrote:

> 2. a user who has extensions and the extension field "gender" is filled with "male"
> 3. a user who has extensions and the extension field "gender" is filled with "female"
> 
> Query:
> I have a query
> With this query I get User 3 but not user 1 since user 1 doesn't has the field gender at all.
> 
> Question:
> Do you think this (sql) behavior is correct or should user 1 also be returned.
> 
> By David
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim