Subject: [scim] extension part of the schemas while deleting them?

From: David Moebius <[email-masked]>
Date: Fri, 14 Feb 2014 16:02:40 +0100

Hi,

Ich I wan't to send an extension with a json string we need the urn of the
extension as part of the schema definition at top of the file.

If I want to delete a extension or a extensionfield I need to put the
extension in the meta attribute list.
Do I still need to set the extension urn in the schema list?

Reason for Yes!
I'm working with the extension and so I need to set the urn in the schema
list

Reason for No!
I'm not sending a actual extension object and so I don't need to send the
extension as part of the schema list.
(Actual when doing so. JBos telling us the Json file is not correct)

What is your suggestion?

David

---

From: Phil Hunt <[email-masked]>
Date: Fri, 14 Feb 2014 09:21:43 -0800

As long as extensionfield is sufficiently unique, you should not have to provide it.

Though a client that wants to ensure conflicts can't occur in the future might want to always use the fully qualified notation.

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-02-14, at 7:02 AM, David Moebius <[email-masked]> wrote:

> Hi,
> 
> Ich I wan't to send an extension with a json string we need the urn of the extension as part of the schema definition at top of the file.
> 
> If I want to delete a extension or a extensionfield I need to put the extension in the meta attribute list.
> I'm working with the extension and so I need to set the urn in the schema list
> 
> Reason for No!
> I'm not sending a actual extension object and so I don't need to send the extension as part of the schema list.
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim