Subject: [scim] ResourceTypes endpoint

From: Phil Hunt <[email-masked]>
Date: Wed, 5 Feb 2014 11:12:04 -0800

Should objects returned from ResourceTypes endpoint not have an "id".

From draft 02…

{
  "schemas": ["urn:scim:schemas:core:2.0:ResourceType"],
  "name": "User",
  "endpoint": "/Users",
  "description": "Core User",
  "schema": "urn:scim:schemas:core:2.0:User",
  "schemaExtensions": [
    {
      "schema": "urn:scim:schemas:extension:enterprise:2.0:EnterpriseUser",
      "required": true
    }
  ],
  "meta": {
    "resourceType": "ResourceType",
    "created": "2010-01-23T04:56:22Z",
    "lastModified": "2011-05-13T04:42:34Z",
    "version": "W\/\"3694e05e9dff595\""
  }
}

Should this item have a location of:
 "location":"https://example.com/v2/ResourceTypes/User"

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Leif Johansson <[email-masked]>
Date: Wed, 05 Feb 2014 20:21:50 +0100

> Should objects returned from ResourceTypes endpoint not have an "id".
consistency is always nice...
> From draft 02...
>       "schema":
> "urn:scim:schemas:extension:enterprise:2.0:EnterpriseUser",
>       "required": true
>     }
>   ],
>   "meta": {
> www.independentid.com <http://www.independentid.com>
> [email-masked] <mailto:[email-masked]>
>
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 6 Feb 2014 02:53:09 +0000

The reason the ID was left off of the configuration-related objects was to promote interoperability and normative definitions.  Currently, neither Schemas, ResourceTypes, or ServiceProviderConfigs have IDs.  ServiceProviderConfigs is a bit strange because it is really more of a singleton object.  ResourceTypes and Schemas both use names for their IDs so they can easily be exchanged between servers.  Not sure if this is a good thing or not, but that is the reasoning behind why it is the way that it is.

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Wednesday, February 05, 2014 1:22 PM
To: [email-masked]
Subject: Re: [scim] ResourceTypes endpoint

{

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

scim mailing list

[email-masked]<mailto:[email-masked]>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 5 Feb 2014 18:58:53 -0800

Hmmm. When i checked all the others, they had id's. Some used simple name others used the fully qualified schema name. Go figure. 

Phil

> On Feb 5, 2014, at 18:53, Kelly Grizzle <[email-masked]> wrote:
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 6 Feb 2014 14:27:25 -0800

Kelly,

I see more clearly what the issue is now.  Except in one case, all the examples had an "id". Reading the text, it says ResourceType and ServiceProviderConfig do not require ids.  The way I interpret that is that "id"s are still acceptable.

However, I think for consistency, it would be ok for ServiceProviderConfig not to have an id since it is a singleton (it is references by simply /ServiceProviderConfig ). But, ResourceTypes like other resources and is addressed as /ResourceTypes/{identifier}

Would it be ok, in an effort to be consistent, to allow use of {id}?  What I have done is leave the text in saying 'id' is not required, but the name is.  I've also said they are often the same. The examples can stay with the id and there is no requirement to upgrade. 

Will this work for everyone?

In these situations, sometimes it is hard to tell what is consistent and what is inconsistent.  8-)

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 7 Feb 2014 03:23:30 +0000

I'm happy with that. Sounds like a good plan. Thanks Phil.

--Kelly

On Feb 6, 2014, at 4:27 PM, "Phil Hunt" <[email-masked]<mailto:[email-masked]>> wrote:

Kelly,

Phil

@independentid

On 2014-02-05, at 6:53 PM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

--Kelly

From: scim [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Leif Johansson
Sent: Wednesday, February 05, 2014 1:22 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [scim] ResourceTypes endpoint

{

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

scim mailing list