Subject: [scim] consensus call on moving issues to extension drafts

From: Leif Johansson <[email-masked]>
Date: Sat, 08 Mar 2014 22:26:39 +0100

At the London meeting there was strong consensus for identifying the
issues that are represent proposed extensions to the core specifications
and do the following:

1. Close the issue with "no-fix"
2. Encourage anyone to write a draft describing the extended functionality.

Such drafts can either be processed as individual submissions or
considered as part of a possible re-charter discussion in the WG when
the core documents are done.

The following issues have been identified:

#11 - Define a very simple language for entitlements
#14 - Enhance password and login metadata
#15 - Add specification for soft delete and reanimation operation as an
extension of core spec
#20 - Insert a "person" resource into the model (schema)
#32 - Async / Workflow Support

In addition the following issues will also be closed as they do not
represent issues of the core specifications. Note that these issues
remain as milestones in our existing charter until the ADs say otherwise.

#4 - Bring the SAML binding up-to-date
#45 - LDAP mapping

Given the support this had in London we are looking for anyone that
disagrees with this plan.

        Cheers Leif & Morteza

---

From: Peter Gietz <[email-masked]>
Date: Mon, 10 Mar 2014 09:53:03 +0100

> #4 - Bring the SAML binding up-to-date

I am very sorry that I did not act on this yet. I may still write a 
draft, if not as WG submission then as individual.

Cheers,

Peter

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

-- 

Peter Gietz, CEO

DAASI International GmbH
Europaplatz 3
D-72072 Tübingen
Germany

phone: +49 7071 407109-0
fax:   +49 7071 407109-9
email: [email-masked]
web:   www.daasi.de

Sitz der Gesellschaft: Tübingen
Registergericht: Amtsgericht Stuttgart, HRB 382175
Geschäftsleitung: Peter Gietz

---

From: Phil Hunt <[email-masked]>
Date: Sat, 15 Mar 2014 11:01:55 -0700

Peter,

I closed the issue per the message from Leif on Mar 8 and the general discussion at IETF89.  I'm still assuming you will proceed to submit a separate draft rather than tracking this item against the existing drafts.

I seem to recall in the IETF89 meeting, someone mentioned they are finding it easier to extend LDAP implementations internally to support complex attributes for SCIM rather than use a mapping.

FWIW.  I think one-way mappings where LDAP is a provisioning end-point is a very useful draft to have.  In this case I would expect that read-after-write dual-mapping is not expected.

Phil

@independentid
www.independentid.com
[email-masked]

On 2014-03-10, at 1:53 AM, Peter Gietz <[email-masked]> wrote:

> I am very sorry that I did not act on this yet. I may still write a draft, if not as WG submission then as individual.
> 
> Cheers,
> 
> Peter
> 
>>

---

From: Leif Johansson <[email-masked]>
Date: Sun, 16 Mar 2014 11:00:56 +0100

>> #4 - Bring the SAML binding up-to-date

I declare consensus on this issue and will close the tickets accordingly.

	Cheers Leif

---

From: Peter Gietz <[email-masked]>
Date: Mon, 17 Mar 2014 14:21:40 +0100

Phil,

Thanks for this input and the implicit encouragement.

Peter

-- 

Peter Gietz, CEO

DAASI International GmbH        
Europaplatz 3                   
D-72072 Tübingen                
Germany                    

phone: +49 7071 407109-0
fax:   +49 7071 407109-9

---

From: Peter Gietz <[email-masked]>
Date: Mon, 17 Mar 2014 14:22:06 +0100

> I declare consensus on this issue and will close the tickets accordingly.
A wise decision anyway.

Cheers,

Peter

-- 

Peter Gietz, CEO

DAASI International GmbH        
Europaplatz 3                   
D-72072 Tübingen                
Germany                    

phone: +49 7071 407109-0
fax:   +49 7071 407109-9