Subject: [scim] Drop X-HTTP-Method-Override [was: Re: http://tools.ietf.org/html/draft-ietf-scim-api-02#section-3.12: "X-HTTP-Method-Override"]

From: Leif Johansson <[email-masked]>
Date: Wed, 19 Mar 2014 14:11:46 +0100

On 2014-02-19 01:07, Phil Hunt wrote:
> I have added a ticket:
> http://trac.tools.ietf.org/wg/scim/trac/ticket/65
> 
> Comments appreciated (either here on this thread), or directly on the ticket.  Especially from anyone who thinks we need to keep it.
> 

Based on the discussion in London and feedback from the HTTP community I
believe the appropriate solution is to drop X-HTTP-Method-Override from
the API spec.

In practice server implementations may choose to support such a feature
but it seems clear that it is orthogonal to the SCIM API and therefore
it will only add overhead to our specs.

Please respond with +1/-1 for this proposal!

	Cheers Leif

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 19 Mar 2014 13:24:51 +0000

+1 to drop

-----Original Message-----
From: scim [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Wednesday, March 19, 2014 8:12 AM
To: [email-masked]
Subject: [scim] Drop X-HTTP-Method-Override [was: Re: http://tools.ietf.org/html/draft-ietf-scim-api-02#section-3.12: "X-HTTP-Method-Override"]

> Comments appreciated (either here on this thread), or directly on the ticket.  Especially from anyone who thinks we need to keep it.

Based on the discussion in London and feedback from the HTTP community I believe the appropriate solution is to drop X-HTTP-Method-Override from the API spec.

In practice server implementations may choose to support such a feature but it seems clear that it is orthogonal to the SCIM API and therefore it will only add overhead to our specs.

	Cheers Leif

_______________________________________________
scim mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/scim