Subject: [scim] Ticket 65 HTTP Method Override

From: Phil Hunt <[email-masked]>
Date: Wed, 30 Apr 2014 12:21:48 -0700

Kelly,

You reported on the ticket that blackberry clients seem to need this feature.

Do we feel strongly enough that we need to support this?  Or are we better not to support it in hopes that Blackberry upgrades their browser.  :-)

If we do support it, someone needs to take on the deliverable to do an IANA registry draft for X-HTTP-Method-Override for which Julian informs us is not officially registered (despite being a defacto standard).

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 30 Apr 2014 22:00:55 +0000

I'm fine whether it is in the spec or not.  It is a common enough practice that service providers that wish to support it can do so.  The main issue would be client-side.  If the client can't send a PATCH and the server doesn't support the X-HTTP-Method-Override header, then there will be problems.  Blackberry is the only instance of a limited modern client that I have run into out in the wild, so I don't have a strong opinion either way.

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Wednesday, April 30, 2014 2:22 PM
To: [email-masked] WG
Subject: [scim] Ticket 65 HTTP Method Override

Kelly,

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>