Subject: Re: [scim] Ticket #3 - Exclude Attributes explicitly

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Fri, 25 Apr 2014 23:33:37 +0000

Continuing conversation on an old thread.

Without full text for the suggested change it is not clear to me what
SHOULD means in this context.  What¹s the behavior if the client ask for
it, but the server has not implemented it?  Does it mean server SHOULD
support exclude attribute and return error if a query includes excluded
attribute parameter if it doesn¹t OR does it mean server SHOULD support it
and if it doesn¹t it can ignore it and return the full set of attributes
back to the client?

I do worry about interoperability with adding another SHOULD which means
clients need to deal with it one way or another.  Looking at the ticket
and email it is not clear to me which SHOULD we are recommending.

Cheers,
Morteza

On 10/17/13, 11:07 AM, "Kelly Grizzle" <[email-masked]> wrote:

>+1
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>Phil Hunt
>Sent: Thursday, October 17, 2013 11:52 AM
>To: Thorsten Roßner
>Cc: [email-masked]
>Subject: Re: [scim] Ticket #3 - Exclude Attributes explicitly
>
>+1
>
>Phil
>
>@independentid
>www.independentid.com
>[email-masked]
>
>On 2013-10-17, at 3:57 AM, Thorsten Roßner <[email-masked]> wrote:
>
>> Hi all
>> 
>> from my perspective the ticket covers a very reasonable enhancement,
>> as long as it is a "SHOULD" in the standard.
>> 
>> It would not add complexity to simple SCIM implementations, while
>> clients that send a requests to a server that does not support the
>> attribute exclusion still should retrieve data they can work with...
>> if they do not perform some sort of strict schema validation against a
>> stripped-down schema.
>> 
>> What do you think?
>> 
>> Thanks
>> Thorsten
>> _______________________________________________
>> scim mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/scim
>
>_______________________________________________
>scim mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/scim
>_______________________________________________
>scim mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/scim

---

From: Phil Hunt <[email-masked]>
Date: Fri, 25 Apr 2014 17:11:23 -0700

I think if we support it has to be mandatory for those that implement search. Too complex to have options within options. 

FWIW. While I think must is important, am neutral on the feature.  

Phil

> On Apr 25, 2014, at 16:33, "Morteza Ansari (moransar)" <[email-masked]> wrote:
>