Subject: Re: [scim] Consensus call on issue #18 - patch semantics

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Tue, 15 Apr 2014 01:35:53 +0000

Bump…  Hard to imagine nobody in the WG has any thoughts on this topic :)

Cheers,
Morteza

From: Morteza Ansari <[email-masked]<mailto:[email-masked]>>
Date: Thursday, April 10, 2014 at 10:20 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [scim] Consensus call on issue #18 - patch semantics

In London we had a good discussion on patch operation (ticket #18) and Phil provided background information and walked the WG through a few options. In follow on discussions on the mailing list, survey Phil sent out, and the WG call we narrowed it down to two options.  Stay with the current patch semantics or change patch to a RFC6902-based model.

Phil has posted to the group the proposed text for 6902 “based” patch (and also documented in the tracker under issue #18).  The WG is making a consensus call as follows:

A. Do not change patch semantics and stay with what is currently documented in the spec
B. Adopt the 6902 based changes Phil has put together (as proposed on the list and documented in tracker)
C. Don’t care or need more information

Please provide your input before Apr. 18th.

Cheers,
Leif & Morteza

---

From: Phil Hunt <[email-masked]>
Date: Mon, 14 Apr 2014 18:58:49 -0700

My preference is B. 

Phil

> On Apr 14, 2014, at 18:35, "Morteza Ansari (moransar)" <[email-masked]> wrote:
> 
> From: Morteza Ansari <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Erik Wahlström <[email-masked]>
Date: Tue, 15 Apr 2014 09:45:55 +0000

+1 on B.
/ Erik

Sent from my iPad

On 15 apr 2014, at 03:59, "Phil Hunt" <[email-masked]<mailto:[email-masked]>> wrote:

My preference is B.

Phil

On Apr 14, 2014, at 18:35, "Morteza Ansari (moransar)" <[email-masked]<mailto:[email-masked]>> wrote:

Bump...  Hard to imagine nobody in the WG has any thoughts on this topic :)

Cheers,
Morteza

Phil has posted to the group the proposed text for 6902 "based" patch (and also documented in the tracker under issue #18).  The WG is making a consensus call as follows:

A. Do not change patch semantics and stay with what is currently documented in the spec
B. Adopt the 6902 based changes Phil has put together (as proposed on the list and documented in tracker)
C. Don't care or need more information

Cheers,
Leif & Morteza
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Melvin Laguren <[email-masked]>
Date: Tue, 15 Apr 2014 09:19:12 -0700

My vote is for B.

On Tue, Apr 15, 2014 at 2:45 AM, Erik Wahlström <
[email-masked]> wrote:

>  +1 on B.
> / Erik
>
> Sent from my iPad
>
> On 15 apr 2014, at 03:59, "Phil Hunt" <[email-masked]> wrote:
>
>   My preference is B.
>
> Phil
>
>   In London we had a good discussion on patch operation (ticket #18) and
> Phil provided background information and walked the WG through a few
> options. In follow on discussions on the mailing list, survey Phil sent
> out, and the WG call we narrowed it down to two options.  Stay with the
> current patch semantics or change patch to a RFC6902-based model.
>
>  Phil has posted to the group the proposed text for 6902 “based” patch
> (and also documented in the tracker under issue #18).  The WG is making a
> consensus call as follows:
>

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 16 Apr 2014 12:52:08 +0000

+1 for b.

From: scim [mailto:[email-masked]] On Behalf Of Melvin Laguren
Sent: Tuesday, April 15, 2014 11:19 AM
To: Erik Wahlström
Cc: [email-masked]; Morteza Ansari (moransar); Phil Hunt
Subject: Re: [scim] Consensus call on issue #18 - patch semantics

My vote is for B.

On Tue, Apr 15, 2014 at 2:45 AM, Erik Wahlström <[email-masked]<mailto:[email-masked]>> wrote:
+1 on B.
/ Erik

Sent from my iPad

Phil

Cheers,
Morteza

Cheers,
Leif & Morteza

---

From: Chris Phillips <[email-masked]>
Date: Thu, 17 Apr 2014 13:47:35 +0000

+1 for B

Chris.

From: "Morteza Ansari (moransar)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, 14 April, 2014 9:35 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Consensus call on issue #18 - patch semantics

Cheers,
Morteza

Cheers,
Leif & Morteza

---

From: Chuck Mortimore <[email-masked]>
Date: Fri, 18 Apr 2014 10:45:04 -0700

+1 for B.   No point re-inventing the wheel.

On Thu, Apr 17, 2014 at 6:47 AM, Chris Phillips
<[email-masked]>wrote:

>  +1 for B
>
>  Chris.
>
>
>   From: "Morteza Ansari (moransar)" <[email-masked]>

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Mon, 21 Apr 2014 23:52:01 +0000

Thanks everyone for your input, we have consensus on option B.  Phil, please publish the changes for option B and close this ticket.

Cheers,
Morteza

From: Chuck Mortimore <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 18, 2014 at 10:45 AM
To: Chris Phillips <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Consensus call on issue #18 - patch semantics

On Thu, Apr 17, 2014 at 6:47 AM, Chris Phillips <[email-masked]<mailto:[email-masked]>> wrote:
+1 for B

Chris.

Cheers,
Morteza

Cheers,
Leif & Morteza