Subject: Re: [scim] Ticket 65 HTTP Method Override

From: Leif Johansson <[email-masked]>
Date: Thu, 1 May 2014 09:26:12 +0200

It sure feels like bb needs to fix their browser... Or if tjhey feel strongly about it, turn up and spec out a standard http header.... and get others to play.

> 1 maj 2014 kl. 00:00 skrev Kelly Grizzle <[email-masked]>:
> 
> I’m fine whether it is in the spec or not.  It is a common enough practice that service providers that wish to support it can do so.  The main issue would be client-side.  If the client can’t send a PATCH and the server doesn’t support the X-HTTP-Method-Override header, then there will be problems.  Blackberry is the only instance of a limited modern client that I have run into out in the wild, so I don’t have a strong opinion either way.
>  
> --Kelly
>  
> From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
> Sent: Wednesday, April 30, 2014 2:22 PM
> To: [email-masked] WG
> Subject: [scim] Ticket 65 HTTP Method Override
>  
> Kelly,
>  
> You reported on the ticket that blackberry clients seem to need this feature.
>  
> Do we feel strongly enough that we need to support this?  Or are we better not to support it in hopes that Blackberry upgrades their browser.  :-)
>  
> If we do support it, someone needs to take on the deliverable to do an IANA registry draft for X-HTTP-Method-Override for which Julian informs us is not officially registered (despite being a defacto standard).
>  
> Phil
>  
> @independentid
> www.independentid.com
> [email-masked]
>  
>  
>  
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Julian Reschke <[email-masked]>
Date: Thu, 01 May 2014 10:04:42 +0200

On 2014-05-01 09:26, Leif Johansson wrote:
> It sure feels like bb needs to fix their browser... Or if tjhey feel
> strongly about it, turn up and spec out a standard http header.... and
> get others to play.
> ...

Is this about XMLHTTPRequest in the Blackberry browser? Is this a known 
bug? Has it been reported to Blackberry?

Best regards, Julian

---

From: Leif Johansson <[email-masked]>
Date: Thu, 1 May 2014 12:00:09 +0200

> 1 maj 2014 kl. 10:04 skrev Julian Reschke <[email-masked]>:
> 
> Is this about XMLHTTPRequest in the Blackberry browser? Is this a known bug? Has it been reported to Blackberry?
> 

who knows. not sure scim needs to care though...

---

From: Ian Glazer <[email-masked]>
Date: Thu, 1 May 2014 11:34:49 -0400

We've got out own problems to worry about; we don't need to clean up other
people's backyards for them.

-- 
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer <https://twitter.com/iglazer>

---

From: Leif Johansson <[email-masked]>
Date: Thu, 1 May 2014 19:16:42 +0200

thus I propose closinf with wontfix

> 1 maj 2014 kl. 17:34 skrev Ian Glazer <[email-masked]>:
> 
> We've got out own problems to worry about; we don't need to clean up other people's backyards for them.
> 
> 
> @iglazer

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 1 May 2014 17:30:56 +0000

Works for me.

From: Leif Johansson [mailto:[email-masked]]
Sent: Thursday, May 01, 2014 12:17 PM
To: Ian Glazer
Cc: Julian Reschke; [email-masked] WG; Phil Hunt; Kelly Grizzle
Subject: Re: [scim] Ticket 65 HTTP Method Override

1 maj 2014 kl. 17:34 skrev Ian Glazer <[email-masked]<mailto:[email-masked]>>:
We've got out own problems to worry about; we don't need to clean up other people's backyards for them.

On Thu, May 1, 2014 at 6:00 AM, Leif Johansson <[email-masked]<mailto:[email-masked]>> wrote:

> 1 maj 2014 kl. 10:04 skrev Julian Reschke <[email-masked]<mailto:[email-masked]>>:
>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

--
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer<https://twitter.com/iglazer>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 01 May 2014 19:54:06 +0200

> thus I propose closinf with wontfix

Does this imply removing the text about method override?

Best regards, Julian

---

From: Phil Hunt <[email-masked]>
Date: Thu, 1 May 2014 11:36:11 -0700

Yeah….I think Leif might have had it backward. The ticket is about removing text.  So I think he meant “fix”.  :-)

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Leif Johansson <[email-masked]>
Date: Thu, 01 May 2014 20:38:56 +0200

> Does this imply removing the text about method override?

sorry, I wasn't clear. Yes the proposal is to drop the text about method
override.

---

From: Leif Johansson <[email-masked]>
Date: Thu, 01 May 2014 20:39:11 +0200

> Yeah….I think Leif might have had it backward. The ticket is about removing text.  So I think he meant “fix”.  :-)

yeah, doh

---

From: Phil Hunt <[email-masked]>
Date: Thu, 1 May 2014 11:43:48 -0700

I can’t say yes quite yet. I will check with my colleagues.  

My reaction agrees with the point Kelly made on the call this week that if someone really needs it, the defacto standard technique should be sufficient without us having to specify it.  I’d rather have SCIM focus on the intended proper usage of HTTP.

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Erik Wahlström <[email-masked]>
Date: Thu, 1 May 2014 19:11:05 +0000

My worry is that it’s kinda used all over the place when it comes to existing user APIs. No time to dig up too many examples, but  here are two:

Googles user api.
https://developers.google.com/admin-sdk/directory/v1/guides/performance#patch

MS OData
http://msdn.microsoft.com/en-us/library/dd541471.aspx

I guess there is a good reason why it’s there. It can’t be just Blackberrys http client implementation? :)

/ Erik

On 01 May 2014, at 20:43, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

On May 1, 2014, at 10:30 AM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

Works for me.

From: Leif Johansson [mailto:[email-masked]]
Sent: Thursday, May 01, 2014 12:17 PM
To: Ian Glazer
Cc: Julian Reschke; [email-masked]<mailto:[email-masked]> WG; Phil Hunt; Kelly Grizzle
Subject: Re: [scim] Ticket 65 HTTP Method Override

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 1 May 2014 19:13:06 +0000

I have heard that some proxy servers may strip out certain HTTP methods, but I have no first-hand experience with this.

From: Erik Wahlström [mailto:[email-masked]]
Sent: Thursday, May 01, 2014 2:11 PM
To: Phil Hunt
Cc: Kelly Grizzle; Julian Reschke; Leif Johansson; Ian Glazer; [email-masked] WG
Subject: Re: [scim] Ticket 65 HTTP Method Override

My worry is that it's kinda used all over the place when it comes to existing user APIs. No time to dig up too many examples, but  here are two:

Googles user api.

MS OData

I guess there is a good reason why it's there. It can't be just Blackberrys http client implementation? :)

/ Erik

I can't say yes quite yet. I will check with my colleagues.

My reaction agrees with the point Kelly made on the call this week that if someone really needs it, the defacto standard technique should be sufficient without us having to specify it.  I'd rather have SCIM focus on the intended proper usage of HTTP.

Phil

@independentid

Works for me.

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Thu, 1 May 2014 20:09:20 +0000

We already had asked this question and the consensus was to remove it until Kelly reported the BB problem.  Given Kelly is OK with this after the conversation, I think it is safe to move forward and close this ticket as wontfix.

Cheers,
Morteza

From: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 1, 2014 at 10:30 AM
To: Leif Johansson <[email-masked]<mailto:[email-masked]>>, Ian Glazer <[email-masked]<mailto:[email-masked]>>
Cc: Julian Reschke <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Phil Hunt <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Ticket 65 HTTP Method Override

Works for me.

---

From: Phil Hunt <[email-masked]>
Date: Thu, 1 May 2014 13:10:45 -0700

You mean FIX to remove the functionality correct?

Phil

@independentid
www.independentid.com
[email-masked]

On May 1, 2014, at 1:09 PM, Morteza Ansari (moransar) <[email-masked]> wrote:

> From: Kelly Grizzle <[email-masked]>
> To: Leif Johansson <[email-masked]>, Ian Glazer <[email-masked]>
> Cc: Julian Reschke <[email-masked]>, "[email-masked]" <[email-masked]>, Phil Hunt <[email-masked]>

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Thu, 1 May 2014 21:53:00 +0000

I think we really made a mess of this question with all the overlapping emails, some very confusing!  Let me rephrase it:

We already discussed this ticket and the general consensus was to remove reference to "X-HTTP-Method-Override” from the API draft until Kelly reported the BB problem. Sounds like Kelly is OK with removing this section of the draft.  However given all the confusion on this, lets give the WG some time so if anyone has objection to removing this header reference can raise it.

So…  If you have any concerns with removing "X-HTTP-Method-Override” from the spec, please bring it up by Wed. May 6th.

Cheers,
Morteza

From: Phil Hunt <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 1, 2014 at 1:10 PM
To: Morteza Ansari <[email-masked]<mailto:[email-masked]>>
Cc: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>, Leif Johansson <[email-masked]<mailto:[email-masked]>>, Ian Glazer <[email-masked]<mailto:[email-masked]>>, Julian Reschke <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Ticket 65 HTTP Method Override

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On May 1, 2014, at 1:09 PM, Morteza Ansari (moransar) <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,
Morteza

Works for me.