Subject: Re: [scim] #23 (api): Clarify requirements for preserving case in attribute values

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Thu, 1 May 2014 22:04:08 +0000

Speaking as an implementor: +1, we have run into this with a few clients
already and it would be nice to clarify the text in the spec so there is
no room for multiple interpretation.

Cheers,
Morteza

On 5/1/14, 1:20 PM, "scim issue tracker" <[email-masked]> wrote:

>#23: Clarify requirements for preserving case in attribute values
>
>
>Comment (by [email-masked]):
>
> Server attribute schema includes the attribute "caseExact" which
>specifies
> whether an attribute is case sensitive.
>
> As scim is cross-domain, clients should expect that servers may choose
>not
> to preserve cast attributes where caseExact is false.
>
> I would support clarification text that stipulates that servers may alter
> case for case insensitive attributes.
>
>-- 
>-------------------------------------+------------------------------------
>-
> Reporter:                           |       Owner:  draft-ietf-scim-
>  [email-masked]      |  [email-masked]
>     Type:  defect                   |      Status:  new
> Priority:  major                    |   Milestone:
>Component:  api                      |     Version:
> Severity:  -                        |  Resolution:
> Keywords:                           |
>-------------------------------------+------------------------------------
>-
>
>Ticket URL: <http://trac.tools.ietf.org/wg/scim/trac/ticket/23#comment:2>
>scim <http://tools.ietf.org/scim/>
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 1 May 2014 15:15:48 -0700

How about this:

caseExact  A Boolean value that specifies if the String attribute
  is case sensitive. The server SHALL use case sensitivity when 
  evaluating filters. For attributes that are case exact, the server 
  SHALL preserve case for any value submitted. If the attribute is
  not case sensitive, the server MAY alter case for a submitted value. 

Is it appropriate to suggest that when a server alters case it should include that in any operation response (e.g. to a POST, PATCH, PUT)?

Phil

@independentid
www.independentid.com
[email-masked]

On May 1, 2014, at 3:04 PM, Morteza Ansari (moransar) <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 2 May 2014 14:04:06 +0000

+1 for the text.

IMO including text about returning the case-altered value in the response is overkill.

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Thursday, May 01, 2014 5:16 PM
To: Morteza Ansari
Cc: [email-masked]; [email-masked]; scim issue tracker
Subject: Re: [scim] #23 (api): Clarify requirements for preserving case in attribute values

How about this:

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On May 1, 2014, at 3:04 PM, Morteza Ansari (moransar) <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,
Morteza

On 5/1/14, 1:20 PM, "scim issue tracker" <[email-masked]<mailto:[email-masked]>> wrote:

Comment (by [email-masked]<mailto:[email-masked]>):

[email-masked]<mailto:[email-masked]>      |  [email-masked]<mailto:[email-masked]>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim