Subject: [scim] Ticket 3: excludedAttributes parameter proposal

From: Phil Hunt <[email-masked]>
Date: Thu, 1 May 2014 12:00:20 -0700

Regarding the proposal to have an excludedAttributes parameter.  We had a discussion on the call this week, and there was some agreement that while the parameter is not critical to the needs of the protocol, it is useful from the standpoint of developer and operational utility. For example, administrators attempting to query a SCIM endpoint directly may find it useful to specify which attributes they do not want far more easier than listing all attributes that could be returned to omit the one they do not returned.

There was also some value in using excludedAttributes when doing a multi-resourceType search.

The existing text on the “attributes” parameter:

Section 3.7 Additional retrieval query parameters
   Clients MAY request a partial resource representation on any
   operation that returns a resource within the response by specifying
   the URL query parameter 'attributes'.  When specified, each resource
   returned MUST contain the minimal set of resource attributes and MUST
   contain no other attributes or Sub-Attributes than those explicitly
   requested.  The query parameter attributes value is a comma separated
   list of resource attribute names in standard attribute notation
   (Section 3.8) form (e.g.  userName, name, emails).

Section 3.2.3 Query Resources Using HTTP POST
attributes  A multi-valued list of strings indicating the names of
      resource attributes to return in the response.  Attribute names
      MUST be in standard attribute notation (Section 3.8) form.  See
      additional retrieval query parameters (Section 3.7).  OPTIONAL.

Proposed text:

Section 3.7 Additional Operation Response Parameters

   For any SCIM operation where a resource representation is returned (e.g. GET),
   the attributes normally returned are defined as the minimum attribute set 
   plus the default attributes. The minimum attribute set are those attributes 
   whose schema have “returned” set to “always” (e.g. “id”). The default 
   attribute set are those attributes whose schema have “returned” set to 
   “default”.

   Clients MAY request a partial resource representation on any
   operation that returns a resource by specifying either the URL query parameter 
   “attributes” OR “excludedAttributes” as follows:

   attributes When specified, each resource returned MUST contain the minimal set 
      of resource attributes and MUST contain no other attributes or sub-attributes
      other than those explicitly requested.  The query parameter attributes value is a 
      comma separated list of resource attribute names in standard attribute notation
      (Section 3.8) form (e.g.  userName, name, emails).

   excludedAttributes When specified, each resourcereturned MUST contain the minimal 
      set of resource attributes and any attributes normally returned by “default” 
      minus those attributes listed in “excludedAttributes”. The query parameter 
      excludedAttributes value is a comma separated list of resource attribute names in 
      standard attribute notation (Section 3.8) form (e.g.  userName, name, emails).

Section 3.2.3 Query Resources Using HTTP POST
attributes  A multi-valued list of strings indicating the names of
      resource attributes to return in the response overriding the set
      of attributes that would be returned by default.  Attribute names
      MUST be in standard attribute notation (Section 3.8) form.  See
      additional operation response parameters (Section 3.7).  OPTIONAL.

excludedAttributes A multi-valued list of strings indicating the names
      of attributes to be removed from the default set of attributes to 
      be returned. “excludedAttributes” SHALL have no affect on attributes
      whose “returned” characteristic is “always” (Section 11 [core-schema]). 
      Attribute names MUST be in standard attribute notation (Section 3.8) form.
      See additional operation response parameters (Section 3.7).  OPTIONAL.

Does this work?

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 1 May 2014 19:06:13 +0000

Slight typo here: resourcereturned.

Otherwise, +1.

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Thursday, May 01, 2014 2:00 PM
To: [email-masked] WG
Subject: [scim] Ticket 3: excludedAttributes parameter proposal

The existing text on the "attributes" parameter:

   (Section 3.8<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.8>) form (e.g.  userName, name, emails).

      MUST be in standard attribute notation (Section 3.8<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.8>) form.  See

      additional retrieval query parameters (Section 3.7<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.7>).  OPTIONAL.

Proposed text:

   whose schema have "returned" set to "always" (e.g. "id"). The default

   attribute set are those attributes whose schema have "returned" set to

   "default".

   "attributes" OR "excludedAttributes" as follows:

      (Section 3.8<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.8>) form (e.g.  userName, name, emails).

      set of resource attributes and any attributes normally returned by "default"

      minus those attributes listed in "excludedAttributes". The query parameter

      standard attribute notation (Section 3.8<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.8>) form (e.g.  userName, name, emails).

      MUST be in standard attribute notation (Section 3.8<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.8>) form.  See

      additional operation response parameters (Section 3.7<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.7>).  OPTIONAL.

      be returned. "excludedAttributes" SHALL have no affect on attributes

      whose "returned" characteristic is "always" (Section 11 [core-schema]).

      Attribute names MUST be in standard attribute notation (Section 3.8<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.8>) form.

      See additional operation response parameters (Section 3.7<http://tools.ietf.org/html/draft-ietf-scim-api-04#section-3.7>).  OPTIONAL.

Does this work?

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>