Subject: [scim] Intent of externalId

From: Phil Hunt <[email-masked]>
Date: Sat, 21 Jun 2014 16:13:30 -0700

FYI… I am going through the drafts gradually now and will be asking “dumb” questions on things where intent may have changed over time or may no longer be clear.

On of those issues is externalId. Currently the spec states:
>  externalId  An identifier for the resource as defined by the client.
>       The "externalId" may simplify identification of the resource
>       between client and service provider by allowing the client to
>       refer to the resource with its own identifier, obviating the need
>       to store a local mapping between the local identifier of the
>       resource and the identifier used by the service provider.  Each
>       resource MAY include a non-empty externalId value.  The value of
>       the "externalId" attribute is always issued by the client and can
>       never be specified by the service provider.  The service provider
>       MUST always interpret the externalId as scoped to the client's
>       tenant.
What is meant by “allowing the client to refer to the resource with its own identifier”?  I am assuming what this means is to query for the resource using a filter.  OR do we mean that that both of the following URL are valid and return the same object?:

http://example.com/Users/{externalId}
http://example.com/Users/{id}

May I assume that externalId is only usable in a filter to refer to the resource?

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Leif Johansson <[email-masked]>
Date: Sun, 22 Jun 2014 01:24:10 +0200

On 2014-06-22 01:13, Phil Hunt wrote:
> FYI… I am going through the drafts gradually now and will be asking
> “dumb” questions on things where intent may have changed over time or
> may no longer be clear.
> 
>>       between client and service provider by *allowing the client to
>>       refer to the resource with its own identifier*, obviating the need
> What is meant by “allowing the client to refer to the resource with its
> own identifier”?  I am assuming what this means is to query for the
> resource using a filter.  OR do we mean that that both of the following
> URL are valid and return the same object?:
> 

Not sure I grok you fully but I don't think its reasonable for the
client-supplied id namespace to overlap the system id namespace so
I think you're right: externalId must be used in filters. However
the client should be able to expect a unique match.

> 
> Phil
> 
> @independentid
> www.independentid.com <http://www.independentid.com>
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> 
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>

---

From: Erik Wahlström <[email-masked]>
Date: Sun, 22 Jun 2014 20:10:36 +0000

Yes, I agree. It should be possible to use it in filters, but not as an part of an URI like http://example.com/Users/{externalId}

/ Erik

---

From: Phil Hunt <[email-masked]>
Date: Sun, 22 Jun 2014 15:03:50 -0700

Thanks! I will clarify the paragraph. 

Phil

> On Jun 22, 2014, at 13:10, Erik Wahlström <[email-masked]> wrote:
>