Subject: [scim] EnterpriseUser's URI

From: [email-masked]
Date: Sun, 15 Jun 2014 22:11:20 +0900

Hello,

I have a question about enterprise user extension.

In section 7 of schema document, enterprise user's URI is
 "urn:scim:schemas:extension:enterprise:2.0:EnterpriseUser".
But section 12 is
 "urn:scim:schemas:extension:enterprise:2.0:User",
and api document is 
 "urn:scim:schemas:extension:enterprise:2.0:User".

Which is right?

-
Takanori Ueda.

---

From: Phil Hunt <[email-masked]>
Date: Sun, 15 Jun 2014 13:08:24 -0700

Takanori,

Thanks for pointing this out.

It looks like one of the URIs was missed when we corrected in SCIM WG Ticket #63.

The ticket indicates it should be: urn:scim:schemas:extension:enterprise:2.0:User

I will re-open the ticket and indicate that Section 7 should be amended.

Phil

@independentid
www.independentid.com
[email-masked]

On Jun 15, 2014, at 6:11 AM, [email-masked] wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: [email-masked]
Date: Mon, 16 Jun 2014 09:57:24 +0900

Phil,

It understood. 
Thank you!

-
Takanori Ueda.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Jun 2014 13:15:05 +0200

On 2014-06-15 15:11, [email-masked] wrote:
> ...

Speaking of which, who's going to register the "scim" NIS? (see 
http://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml)

Best regards, Julian

---

From: Leif Johansson <[email-masked]>
Date: Mon, 16 Jun 2014 13:40:32 +0200

> http://www.iana.org/assignments/urn-namespaces/urn-namespaces.xhtml)

Good catch. We should probably use the urn:ietf:params namespace and
include this in the IANA section - cf
http://www.iana.org/assignments/params/params.xhtml

	Cheers Leif

---

From: Phil Hunt <[email-masked]>
Date: Mon, 16 Jun 2014 10:47:20 -0700

Is there a need to register the namespace for the scim registry that was established in:
 http://tools.ietf.org/html/draft-ietf-scim-core-schema-05#section-14

Draft 06 of the API will also register the JSON messages as part of the registry in section 14 above. I hope to have it out shortly.

Do we then need a separate namespace registration for the registry established in section 14?

I’m not sure we need to register with the IETF params namespace. AFAIK, SCIM schema is not really a protocol parameter. The parameters in the SCIM API do not use URIs and are not extensible (e.g. totalResults, startIndex, filter, attributes, ...).

ps. Regarding Takanori’s original post, I note we also have the same inconsistency for enterprise user between section 12, 7, and 14.2 (where enterpriseUser is registered).

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Jun 2014 20:53:12 +0200

>   http://tools.ietf.org/html/draft-ietf-scim-core-schema-05#section-14

Yes, you'll need to register the URN namespaces (or use something that 
doesn't need registration, such as a HTTP URI).

Best regards, Julian