Subject: [scim] URIs for schemas vs. api messages

From: Phil Hunt <[email-masked]>
Date: Mon, 16 Jun 2014 15:24:35 -0700

I am just going through all of the IANA issues and about to register the SCIM namespace.

Looking at how we are using URIs, I notice that we are using the same base URI of "urn:scim:schemas:core:2.0" for both core schema AND for API messages.

For example, for the search request:
urn:scim:schemas:core:2.0:SearchRequest

Shouldn’t the URI be something like:
urn:scim:messages:api:2.0:SearchRequest

If we follow this format, then all of the following URIs would change:
urn:scim:schemas:core:2.0:ListResponse 
urn:scim:schemas:core:2.0:SearchRequest
urn:scim:schemas:core:2.0:PatchOp
urn:scim:schemas:core:2.0:BulkRequest
urn:scim:schemas:core:2.0:BulkResponse
urn:scim:schemas:core:2.0:Error

The IANA registration for our URI would be to register “scim” as the base and establish a short name, sub-name, and version naming format of:

urn:scim:{shortname}:{subname}:{scimvers}

In the specs then, {shortname} would be “messages” or “schemas”, and {subname} would be {core} for core-schema, “extension” for the extension schema (e.g. enterprise user) and, uri:scim:messages:api:2.0 for the JSON messages in the SCIM 2 API running over HTTP.

Does this make sense? Or is there more history to this from SCIM 1?

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Phil Hunt <[email-masked]>
Date: Mon, 16 Jun 2014 16:20:22 -0700

One more thought. I think the designation of urn:scim:schemas was to be a base for all uris referenced in the schemas attribute. 

If this is the case maybe we should use urn:scim:schemas:messages for scim api messages?

Phil

> On Jun 16, 2014, at 15:24, Phil Hunt <[email-masked]> wrote:
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim