Subject: [scim] schema extension model question

From: Keith Hazelton <[email-masked]>
Date: Tue, 08 Jul 2014 20:11:50 +0000

Core Schema draft 06 specifies how to define schema extensions to base objects like user and group.  Is it permitted or not to define extensions to complex attributes within a base object, for example, to add custom sub-attributes to the complex attribute emails?

          -Keith Hazelton

---

From: Phil Hunt <[email-masked]>
Date: Tue, 8 Jul 2014 13:21:21 -0700

Keith,

I believe you may not.

The reason is that schema extensions attributes are always added in their own “bag” within the JSON representation.  This means you could in fact use the same attribute name, but it would get passed elsewhere.  For example see the enterprise User extension below:

{
  "schemas":
    [ "urn:scim:schemas:core:2.0:User",
      "urn:scim:schemas:extension:enterprise:2.0:User"],
  "id": "2819c223-7f76-453a-919d-413861904646",
  "externalId": "701984",
  "userName": "[email-masked]",
  "name": {
    "formatted": "Ms. Barbara J Jensen III",
    "familyName": "Jensen",
    "givenName": "Barbara",
    "middleName": "Jane",
    "honorificPrefix": "Ms.",
    "honorificSuffix": "III"
  },
 …<snip>… 
  "displayName": "Babs Jensen",

  "urn:scim:schemas:extension:enterprise:2.0:User": {
    "employeeNumber": "701984",
    "costCenter": "4130",
    "organization": "Universal Studios",
    "division": "Theme Park",
    "department": "Tour Operations",
    "manager": {
      "managerId": "26118915-6090-4610-87e4-49d8ca9f808d",
      "$ref": "/Users/26118915-6090-4610-87e4-49d8ca9f808d",
      "displayName": "John Smith”
    }

Phil

@independentid
www.independentid.com
[email-masked]

On Jul 8, 2014, at 1:11 PM, Keith Hazelton <[email-masked]> wrote:

>           —Keith Hazelton
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim