Subject: [scim] search case insensitiv

From: David Möbius <[email-masked]>
Date: Wed, 09 Jul 2014 11:01:54 +0200

Hello,

the normal search with scim is cas sensitive since we can't say it is
not. Is their any possibility to say to the server that we want to do a
case insensitive search?

by David

---

From: Phil Hunt <[email-masked]>
Date: Thu, 17 Jul 2014 11:03:53 -0700

David,

Sorry for not responding earlier, just getting through my emails from vacation now.

The discoverable server schema tells you whether a particular attribute is case sensitive or not and tells you how the filter will be compared (case exact or not).

See “caseExact” in http://tools.ietf.org/html/draft-ietf-scim-core-schema-06#section-10

At present there is no way for an attribute with “caseExact”:true to be compared in a case insensitive way.

Phil

@independentid
www.independentid.com
[email-masked]

On Jul 9, 2014, at 2:01 AM, David Möbius <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim