Subject: [scim] Another URN issue

From: Phil Hunt <[email-masked]>
Date: Thu, 7 Aug 2014 09:59:35 -0700

The example on page 19 of the API document is wrong.
   {
     "totalResults":100,
     "itemsPerPage":10,
     "startIndex":1,
     "schemas":["urn:scim:api:messages:2.0"],
     "Resources":[{
       ...
     }]
   }

Should be:
   {
     "totalResults":100,
     "itemsPerPage":10,
     "startIndex":1,
     "schemas":["urn:scim:api:messages:2.0:ListResponse"],
     "Resources":[{
       ...
     }]
   }

Note also. We’ve kept ListResponse for consistency reasons.  Should we change this to be “SearchResponse” so that it is consistent with the other URIs (e.g. urn:scim:api:messages:2.0:SearchRequest — only used in the POST search variant)?

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 7 Aug 2014 19:49:50 +0000

> We've kept ListResponse for consistency reasons.  Should we change this to be
> "SearchResponse" so that it is consistent with the other URIs

I would vote to keep ListResponse since this may be a response to a simple GET /Users without any search filters applied.

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Thursday, August 07, 2014 12:00 PM
To: SCIM WG
Subject: [scim] Another URN issue

   {

     "totalResults":100,

     "itemsPerPage":10,

     "startIndex":1,

     "Resources":[{

       ...

     }]

   }

Should be:

   {

     "totalResults":100,

     "itemsPerPage":10,

     "startIndex":1,

     "Resources":[{

       ...

     }]

   }

Note also. We've kept ListResponse for consistency reasons.  Should we change this to be "SearchResponse" so that it is consistent with the other URIs (e.g. urn:scim:api:messages:2.0:SearchRequest - only used in the POST search variant)?

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

---

From: Leif Johansson <[email-masked]>
Date: Thu, 07 Aug 2014 22:42:21 +0200

>      "schemas":["urn:scim:api:messages:2.0"],

Thats another urn that needs changing.

> Note also. We’ve kept ListResponse for consistency reasons.  Should we
> change this to be “SearchResponse” so that it is consistent with the
> other URIs (e.g. urn:scim:api:messages:2.0:SearchRequest — only used in
> the POST search variant)?
> 
> 
> Phil
> 
> @independentid
> www.independentid.com <http://www.independentid.com>
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> 
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>

---

From: Phil Hunt <[email-masked]>
Date: Thu, 7 Aug 2014 13:50:07 -0700

On it. I’m going through the docs top to bottom by hand and will make sure they are all good. Apologies.  It appears my xml editor search and replace is a bit buggy!

I will also revise to the new urn:ietf:params:scim namespace as well.  

Phil

@independentid
www.independentid.com
[email-masked]