Subject: [scim] address.display versus address.formatted

From: Steve Moyer <[email-masked]>
Date: Tue, 21 Oct 2014 11:53:10 -0400 (EDT)

Are the address.display attribute (inherited from SCIM Multi-Valued Attribute) and the address.formatted attribute (part of the address definition) ambiguous?  Can anyone provide insight into how they're being used?  Our current implementation sets address.formatted and ignores address.display but I'm curious to know how others are populating these fields.

Thanks,

Steve

--

“The mark of the immature man is that he wants to die nobly for a cause, while the mark of the mature man is that he wants to live humbly for one.” - Wilhelm Stekel

---

From: Phil Hunt <[email-masked]>
Date: Tue, 21 Oct 2014 09:16:37 -0700

+1

Thanks Steve.  Curious to hear what others have implemented too.

Phil

@independentid
www.independentid.com
[email-masked]

On Oct 21, 2014, at 8:53 AM, Steve Moyer <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Shelley <[email-masked]>
Date: Tue, 21 Oct 2014 14:45:56 -0500

Our implementation does the same thing, such that we ignore the address "
display" sub-attribute. Likewise, we do not support the "display" attribute
for several other multi-valued attributes since it seems to provide no
additional value beyond the "value" attribute:

   - addresses
   - emails
   - phoneNumbers
   - photos
   - roles

(We also currently ignore the ims, entitlements, and x509Certificates
attributes completely since we have no use cases for these, but would
likely ignore the "display" attribute for these attributes as well should
we add support for these attributes.)

On Tue, Oct 21, 2014 at 11:16 AM, Phil Hunt <[email-masked]> wrote:

> > Are the address.display attribute (inherited from SCIM Multi-Valued
> Attribute) and the address.formatted attribute (part of the address
> definition) ambiguous?  Can anyone provide insight into how they're being
> used?  Our current implementation sets address.formatted and ignores
> address.display but I'm curious to know how others are populating these
> fields.
> >
> > Thanks,
> >
> > Steve
> >
> > --
> >
> > “The mark of the immature man is that he wants to die nobly for a cause,
> while the mark of the mature man is that he wants to live humbly for one.”
> - Wilhelm Stekel
> >

---

From: Steve Moyer <[email-masked]>
Date: Wed, 22 Oct 2014 12:04:31 -0400 (EDT)

I should also have noted that we haven't implemented all the attributes (the ones we didn't need) yet. We do however have 2.5m users with an LDAP back-end currently available via both our v1 API (completely non-standard) and through the SCIM interface. We've got some additional restrictions (on userName and externalId) that are specific to our system but we're working towards being compliant with the specification when it's ratified. 

If address.formatted and address.display are essentially the same thing, I'd be happy to change my system to use display so that address is consistent with all the other multi-valued attributes. Can we drop address.formatted altogether? 

Steve 

-- 

----- Original Message -----

From: "Shelley" <[email-masked]> 
To: "Phil Hunt" <[email-masked]> 
Cc: "Steve Moyer" <[email-masked]>, [email-masked] 
Sent: Tuesday, October 21, 2014 3:45:56 PM 
Subject: Re: [scim] address.display versus address.formatted 

Our implementation does the same thing, such that we ignore the address " display " sub-attribute. Likewise, we do not support the " display " attribute for several other multi-valued attributes since it seems to provide no additional value beyond the " value " attribute: 

    * addresses 
    * emails 
    * phoneNumbers 
    * photos 
    * roles 

(We also current ly ignore the ims , entitlements , and x509Certificates attributes completely since we have no use cases for these, but would likely ignore the "display" attribute for these attributes as well should we add support for these attributes.) 

On Tue, Oct 21, 2014 at 11:16 AM, Phil Hunt < [email-masked] > wrote: 

+1 

Phil 

@independentid 
www.independentid.com 
[email-masked]

---

From: David Möbius <[email-masked]>
Date: Thu, 23 Oct 2014 09:40:46 +0200

In our system the address attribute has a formatted value but no 
display. If you send a address with a display value it will be ignored.

All other multi values have the display field, even if it contains just 
the normal value like the email address.

David

On 22.10.2014 18:04, Steve Moyer wrote:
> I should also have noted that we haven't implemented all the attributes
> (the ones we didn't need) yet.  We do however have 2.5m users with an
> LDAP back-end currently available via both our v1 API (completely
> non-standard) and through the SCIM interface.  We've got some additional
> restrictions (on userName and externalId) that are specific to our
> system but we're working towards being compliant with the specification
> when it's ratified.
>
> If address.formatted and address.display are essentially the same thing,
> I'd be happy to change my system to use display so that address is
> consistent with all the other multi-valued attributes.  Can we drop
> address.formatted altogether?
>
> Steve
>
> --
>
> while the mark of the mature man is that he wants to live humbly for
> one.” - Wilhelm Stekel
>
> ------------------------------------------------------------------------
> *From: *"Shelley" <[email-masked]>
> *To: *"Phil Hunt" <[email-masked]>
> *Cc: *"Steve Moyer" <[email-masked]>, [email-masked]
> *Sent: *Tuesday, October 21, 2014 3:45:56 PM
> *Subject: *Re: [scim] address.display versus address.formatted
>
> Our implementation does the same thing, such that we ignore the address
> "display" sub-attribute. Likewise, we do not support the "display"
> attribute for several other multi-valued attributes since it seems to
> provide no additional value beyond the "value" attribute:
>
>   * addresses
>   * emails
>   * phoneNumbers
>   * photos
>   * roles
>
> likely ignore the "display" attribute for these attributes as well
> should we add support for these attributes.)
>
> On Tue, Oct 21, 2014 at 11:16 AM, Phil Hunt <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     +1
>
>     www.independentid.com <http://www.independentid.com>
>     [email-masked] <mailto:[email-masked]>
>
>
>
>     On Oct 21, 2014, at 8:53 AM, Steve Moyer <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>      > Are the address.display attribute (inherited from SCIM
>     Multi-Valued Attribute) and the address.formatted attribute (part of
>     the address definition) ambiguous?  Can anyone provide insight into
>     how they're being used?  Our current implementation sets
>     address.formatted and ignores address.display but I'm curious to
>     know how others are populating these fields.
>      >
>      > Thanks,
>      >
>      > Steve
>      >
>      > --
>      >
>      > “The mark of the immature man is that he wants to die nobly for a
>     cause, while the mark of the mature man is that he wants to live
>     humbly for one.” - Wilhelm Stekel
>      >
>      > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>