Subject: [scim] Invalid JSON in example

From: Tomoya Usami <[email-masked]>
Date: Sun, 23 Nov 2014 17:33:24 +0900

Hi.

I found typo In draft-scim-core-schema-13 Section 3.2.1, It seems to be an invalid JSON data structure.

  PATCH /Users/2819c223-7f76-453a-919d-413861904646
  Host: example.com
  Accept: application/scim+json
  Content-Type: application/scim+json
  Authorization: Bearer h480djs93hd8
  If-Match: W/"a330bc54f0671c9"

  {
    "schemas": ["urn:ietf:params:scim:api:messages:2.0:PatchOp"],
    "Operations":[{
      "op":"add",
      "value":"{
        "emails":[
          {
            "value":"[email-masked]",
            "type":"home"
          }
        ],
        "nickname":"Babs"
    }]
  }

In the above example has invalid "value" attribute's value.
It is probably intended as follows?

   {
     "schemas": ["urn:ietf:params:scim:api:messages:2.0:PatchOp"],
     "Operations": [{
        "op": "add",
        "value": {
          "emails": [
            {
              "value": "[email-masked]",
              "type": "home"
            }
          ],
          "nickname": "Babs"
        }
      }]
   }

--
Tomoya Usami

---

From: Phil Hunt <[email-masked]>
Date: Sun, 23 Nov 2014 08:32:56 -0800

Tomoya,

Yes, the quotation before the curly brace is wrong ( “{ ).

Thanks,

Phil

@independentid
www.independentid.com
[email-masked]

> On Nov 23, 2014, at 12:33 AM, Tomoya Usami <[email-masked]> wrote:
> 
> Hi.
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim