Subject: [scim] agenda for Honolulu

From: Leif Johansson <[email-masked]>
Date: Mon, 03 Nov 2014 21:30:16 +0100

Right now we don't have any extension proposals to talk about in
Honolulu. What (if anything) should we cover in the room next week?

	Cheers Leif

---

From: Phil Hunt <[email-masked]>
Date: Mon, 3 Nov 2014 15:18:37 -0800

Leif,

While there are probably a dozen items I could list, here are my top 3 items...

1.  SCIM Notifications
2.  Password and other credential artifacts (e.g. strong auth, keys, etc)
3.  Possible session management and integration with OAuth - discussion

Regarding item 1, I’m happy to present some use case material on behalf of Morteza, Ian, and myself.

Item 2 - Bjorn - do you want to get together earlier next week and maybe develop a common presentation?

Item 3 - I’m not sure this belongs in SCIM WG, but it seems to be emerging now that SCIM is being seen as a “cloud directory”.  This might include integration and support of OAuth client credentials and potentially integration with SCIM as an identity profile provider.

I’m happy to lead #3 (as well as #1), but if someone else has thoughts already and would like to present, please advise.  I’m really just in the early phases of thinking in this area. However it has begun to emerge as an issue and seems like it is an emerging priority.

We also had several “schema extension” items as a working group that we pushed out to allow completion of the core schema draft. I’m interested in hearing if anyone has any priorities or urgent requirements here.  Oracle has already developed many extensions of its own, but I’m not sure these are priority for inter-op (e.g. a new Organization resourceType). They are all more “nice-to-haves”.  So I would support this work, just think they are lower on the priority list.

Phil

@independentid
www.independentid.com
[email-masked]

On Nov 3, 2014, at 12:30 PM, Leif Johansson <[email-masked]> wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Leif Johansson <[email-masked]>
Date: Tue, 4 Nov 2014 07:27:23 +0100

sounds like a plan!

> 4 nov 2014 kl. 00:18 skrev Phil Hunt <[email-masked]>:
> 
> Leif,
>

---

From: Phil Hunt <[email-masked]>
Date: Mon, 3 Nov 2014 22:43:09 -0800

Leif,

Just remembered a couple more:

* Async & Workflow processing.

* Tony mentioned Mark Wahl's provision on-demand (or JIT) draft that was submitted some time ago at IIW last week.  Would be great if someone from MS can talk about that some more. See: http://tools.ietf.org/html/draft-wahl-scim-jit-profile-02

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Leif Johansson <[email-masked]>
Date: Tue, 04 Nov 2014 09:47:25 +0100

Here is the current agenda draft that I'll post in a minute. I've listed
stuff where somebody has clearly said "I'll present X" - all
other topics are under "open mic" for now.

If anybody else wants to present (Björn?) we can always slice the 90
minutes up a bit differently between next steps and open mic.

	Cheers Leif

Agenda for SCIM IETF91

- Note Well & Agenda Bashing (5min)
- Core document status (5min)
- Next steps and future work (40min)

  + soft deletes (Morteza)
  + scim notifications (Phil)
  + scim and oauth (Phil)

- Recharter & Open Mic (30min)

---

From: Anthony Nadalin <[email-masked]>
Date: Tue, 4 Nov 2014 17:48:33 +0000

I'm just wondering the idea behind discussing notifications as this seems like a never ending discussion ?

-----Original Message-----
From: scim [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Monday, November 3, 2014 10:27 PM
To: Phil Hunt
Cc: [email-masked]; Leif Johansson
Subject: Re: [scim] agenda for Honolulu

sounds like a plan!

> 2.  Password and other credential artifacts (e.g. strong auth, keys, 
> etc) 3.  Possible session management and integration with OAuth - 
> discussion
>

---

From: Leif Johansson <[email-masked]>
Date: Tue, 04 Nov 2014 21:36:50 +0100

> I'm just wondering the idea behind discussing notifications as this seems like a never ending discussion ?

It will be time-boxed in our agenda so I'm not worried.