Subject: [scim] attribute externalId inconsistency

From: Remo Jongeneelen <[email-masked]>
Date: Mon, 10 Nov 2014 18:43:45 +0000

Hi,

In draft-scim-core-schema-12<https://tools.ietf.org/html/draft-ietf-scim-core-schema-12> there seems to be an inconsistency between the description of the Common Attribute 'externalId' and the example making use of it.

Section 3.1 describes it as:
externalId
      A String that is an identifier for the resource as defined by the
      provisioning client. ...

while the example in section 8.2 shows this attribute as an array of String, not as a String:

{
  "schemas": ["urn:ietf:params:scim:schemas:core:2.0:User"],
  "id": "2819c223-7f76-453a-919d-413861904646",
  "externalId": ["701984"],
   ...

I presume the sample is invalid by showing an array, is that correct?

Thanks in advance.

Kind regards
Remo Jongeneelen | Architect for Group Technology and Innovation | SDL | (t) +1 310 944 1904

</pre><font face="arial" size="2" color="#736F6E">

<a href="http://www.sdl.com/?utm_source=Email&utm_medium=Email%2BSignature&utm_campaign=SDL%2BStandard%2BEmail%2BSignature">
<img src="http://www.sdl.com/Content/images/SDLlogo2014.png" border=0><br><br>www.sdl.com
</a><br><br>

<font face="arial" size="1" color="#736F6E">

<b>SDL PLC confidential, all rights reserved.</b>

If you are not the intended recipient of this mail SDL requests and requires that you delete it without acting upon or copying any of its contents, 
and we further request that you advise us.<BR><BR>
SDL Enterprise Technologies, Inc. - all rights reserved.  The information contained in this email may be confidential and/or legally privileged. It has been sent for the sole use of the intended recipient(s). If you are not the intended recipient of this mail, you are hereby notified that any unauthorized review, use, disclosure, dissemination, distribution, or copying of this communication, or any of its contents, is strictly prohibited. If you have received this communication in error, please reply to the sender and destroy all copies of the message.
<BR>Registered address: 201 Edgewater Drive, Suite 225, Wakefield, MA 01880, USA
</font>

This message has been scanned for malware by Websense. www.websense.com

---

From: Phil Hunt <[email-masked]>
Date: Mon, 10 Nov 2014 15:21:02 -1000

Remo,

Sorry for the delay in replying. 

It is supposed to be a single String value in the example.

I will add the example to the nit list for the next draft.

Phil

@independentid
www.independentid.com
[email-masked]

> On Nov 10, 2014, at 8:43 AM, Remo Jongeneelen <[email-masked]> wrote:
> 
> Hi,
>  
> In draft-scim-core-schema-12 <https://tools.ietf.org/html/draft-ietf-scim-core-schema-12> there seems to be an inconsistency between the description of the Common Attribute ‘externalId’ and the example making use of it.
>  
>       provisioning client. …
>    …
> www.sdl.com  <http://www.sdl.com/?utm_source=Email&utm_medium=Email%2BSignature&utm_campaign=SDL%2BStandard%2BEmail%2BSignature>
> 
> SDL PLC confidential, all rights reserved. If you are not the intended recipient of this mail SDL requests and requires that you delete it without acting upon or copying any of its contents, and we further request that you advise us.
> 
> Registered address: 201 Edgewater Drive, Suite 225, Wakefield, MA 01880, USA 
> 
> This message has been scanned for malware by Websense. www.websense.com <http://www.websense.com/>_______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Remo Jongeneelen <[email-masked]>
Date: Tue, 11 Nov 2014 20:14:04 +0000

Thanks Phil for the quick and clear answer. Currently we are actively inplementing a SCIM 2 service within SDL; I will try to collect some of the questions/unclarities we ran into and will send them to this mailing list soon.

If we have ideas for improvement, can I send them to this mailinglist also?

Kind regards

Remo

On Nov 10, 2014, at 5:21 PM, "Phil Hunt" <[email-masked]<mailto:[email-masked]>> wrote:

Remo,

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On Nov 10, 2014, at 8:43 AM, Remo Jongeneelen <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

In draft-scim-core-schema-12<https://tools.ietf.org/html/draft-ietf-scim-core-schema-12> there seems to be an inconsistency between the description of the Common Attribute ‘externalId’ and the example making use of it.

{

Thanks in advance.

Kind regards

[http://www.sdl.com/Content/images/SDLlogo2014.png]

This message has been scanned for malware by Websense. www.websense.com<http://www.websense.com/>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

Click here<https://www.mailcontrol.com/sr/4ZTwEdL4+VjGX2PQPOmvUuVVUPRNd!I!Hpd7pCF3vG0JMu4sBgimuTxU6k!vMRdR+pKcdHXFkgnX405xsHCs!A==> to report this email as spam.
</pre><font face="arial" size="2" color="#736F6E">