Subject: [scim] Nested Complex Filters Correction

From: Phil Hunt <[email-masked]>
Date: Fri, 12 Dec 2014 08:09:58 -0800

It has been pointed out that the core-schema and api drafts are in slight conflict regarding the definition of Complex attributes.

In the API draft, we had filter ABNF that supports nested complex attributes enabling a search filter of:
ABNF:
 FILTER    = attrExp / logExp / valuePath / *1"not" "(" FILTER ")"

 valuePath = attrPath "[" FILTER "]"

Nested complex attribute filter example:
filter=addresses[state eq "CA" and rooms[type eq "bedroom" and
  number gt 2]]

Yet the core-schema draft defines a complex attribute as containing only simple attributes:

Complex Attribute
      A singular or multi-valued attribute whose value is a composition
      of one or more simple attributes; e.g. "addresses".

PROPOSED CORECTION:
Since nobody appears to be using this feature and no core schema is defined with nested complex attributes, the api draft will be amended to change the ABNF to not allow nested valuePath elements and to remove the above filter example from the text.

New ABNF:
 FILTER    = attrExp / logExp / valuePath / *1"not(" FILTER ")"
 valFilter = attrExp / logExp / *1"not(" valFilter ")"
 valuePath = attrPath "[" valFilter "]"

If possible please provide any objections or comments to this correction by Tuesday.

Regards,
 
Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 15 Dec 2014 21:11:08 +0000

+1 for changing this to not support nested complex attributes.

One minor suggestion.  To make the ABNF more readable, it might help to define valuePath before valFilter (this defines them in the order in which they are referenced):

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Friday, December 12, 2014 10:10 AM
To: SCIM WG
Subject: [scim] Nested Complex Filters Correction

  number gt 2]]

Complex Attribute

PROPOSED CORECTION:

New ABNF:

Regards,

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>