Subject: Re: [scim] group sample not valid for provided schema

From: Michael Frost <[email-masked]>
Date: Thu, 12 Feb 2015 12:53:43 -0800 (PST)

Since the barn door is open, shouldn't we fix this one?

-mrf

From: Michael Frost 
Sent: Thursday, January 22, 2015 7:41 PM
To: [email-masked]
Cc: idaas_dev_ww_grp
Subject: [scim] group sample not valid for provided schema

It appears that the schema representation for groups (page 53-54) is missing the "display" sub-attribute definition from the "members" attribute.  This makes the sample group json in section 8.4 (page 31) invalid.  Also the sample in section 8.4 should probably include the optional "type" sub-attribute in "members".

Here is the sample group from page 32

{

  "schemas": [

    "urn:ietf:params:scim:schemas:core:2.0:Group"

  ],

  "id": "e9e30dba-f08f-4109-8486-d5c6a331660a",

  "displayName": "Tour Guides",

  "members": [

    {

      "value": "2819c223-7f76-453a-919d-413861904646",

      "$ref": "https://example.com/v2/Users/2819c223-7f76-453a-919d-413861904646",

      "display": "Babs Jensen"

    },

    {

      "value": "902c246b-6245-4190-8e05-00816be7344a",

      "$ref": "https://example.com/v2/Users/902c246b-6245-4190-8e05-00816be7344a",

      "display": "Mandy Pepperidge"

    }

  ],

  "meta": {

    "resourceType": "Group",

    "created": "2010-01-23T04:56:22Z",

    "lastModified": "2011-05-13T04:42:34Z",

    "version": "W/\"3694e05e9dff592\"",

    "location": "https://example.com/v2/Groups/e9e30dba-f08f-4109-8486-d5c6a331660a"

  }

}

Here is the schema for members, defined sub-attributes are value, $ref, and type

{

  "name": "members",

  "type": "complex",

  "multiValued": true,

  "description": "A list of members of the Group.",

  "required": false,

  "caseExact": false,

  "subAttributes": [

    {

      "name": "value",

      "type": "string",

      "multiValued": false,

      "description": "Identifier of the member of this Group.",

      "required": false,

      "caseExact": false,

      "mutability": "immutable",

      "returned": "default",

      "uniqueness": "none"

    },

    {

      "name": "$ref",

      "type": "string",

      "multiValued": false,

      "description": "The URI of the corresponding to the member resource of this Group.",

      "required": false,

      "caseExact": false,

      "mutability": "immutable",

      "returned": "default",

      "uniqueness": "none"

    },

    {

      "name": "type",

      "type": "string",

      "multiValued": false,

      "description": "A label indicating the type of resource; e.g., 'User' or 'Group'.",

      "required": false,

      "caseExact": false,

      "canonicalValues": [

        "User",

        "Group"

      ],

      "mutability": "immutable",

      "returned": "default",

      "uniqueness": "none"

    }

  ],

  "mutability": "readWrite",

  "returned": "default",

  "uniqueness": "none"

}

-mrf

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 13 Feb 2015 14:58:17 +0000

Agree on both.  The schema should definitely be fixed.  While technically not required, it would be nice to make the example include a type also.

From: scim [mailto:[email-masked]] On Behalf Of Michael Frost
Sent: Thursday, February 12, 2015 2:54 PM
To: [email-masked]
Subject: Re: [scim] group sample not valid for provided schema

-mrf

From: Michael Frost
Sent: Thursday, January 22, 2015 7:41 PM
To: [email-masked]<mailto:[email-masked]>
Cc: idaas_dev_ww_grp
Subject: [scim] group sample not valid for provided schema

{
  "schemas": [

{
  "name": "members",
  "type": "complex",
  "multiValued": true,

-mrf