Subject: [scim] Date vs. dateTime

From: Keith Hazelton <[email-masked]>
Date: Tue, 17 Feb 2015 21:41:21 +0000

dateTime is one of the eight defined SCIM data types. Does the SCIM WG have a recommendation on how to represent just a date without the time?  There are lots of options, just wondered if there is a recomended practice.  I searched the IETF SCIM mail archives without finding any discussion of this issue.

          -Keith Hazelton

---

From: Erik Wahlström neXus <[email-masked]>
Date: Fri, 20 Feb 2015 10:56:24 +0000

Hi Keith,

Agree that there are a lot of options, but how about something like this?

{
   "name" : “birthDate",
   "type" : "string",
   "multiValued" : false,
   "description" : “Birthdate of User. The attribute value MUST be encoded as a valid xsd:date as specified in XML-Schema. REQUIRED",
   "required" : true,
   "caseExact" : false,
   "mutability" : "readWrite",
   "returned" : "default”,
   "uniqueness" : “server"
}

Cheers
Erik

On 17 Feb 2015, at 22:41, Keith Hazelton <[email-masked]<mailto:[email-masked]>> wrote:

          —Keith Hazelton
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Keith Hazelton <[email-masked]>
Date: Fri, 20 Feb 2015 15:40:11 +0000

Thanks, Eric (examples always especially welcome).

We've been calling this general approach 'constrained strings'.  Your example suggests that the description attribute can be used to spell out the constraints, and can include MUSTs.  It seems like a good way to communicate attribute profiles to relevant parties.

          Regards,   -Keith

________________________________
From: Erik Wahlström neXus <[email-masked]>
Sent: Friday, February 20, 2015 4:56 AM
To: Keith Hazelton
Cc: SCIM WG
Subject: Re: [scim] Date vs. dateTime

Hi Keith,

{
   "name" : "birthDate",
   "type" : "string",
   "multiValued" : false,
   "description" : "Birthdate of User. The attribute value MUST be encoded as a valid xsd:date as specified in XML-Schema. REQUIRED",
   "required" : true,
   "caseExact" : false,
   "mutability" : "readWrite",
   "returned" : "default",
   "uniqueness" : "server"
}

Cheers
Erik

          -Keith Hazelton