Subject: [scim] Minor nits and some clarification in the API spec

From: Erik Wahlström neXus <[email-masked]>
Date: Sun, 15 Feb 2015 19:17:02 +0000

Under the section “Modifying with PATCH” https://tools.ietf.org/html/draft-ietf-scim-api-15#section-3.3.2 we are missing a good example on how to have an extension in a path.

The examples have also been removed somewhere down the line under filtering. Right now we only state this text:

"The following are examples of valid filters.  Some attributes (e.g. rooms and rooms.number) are hypothetical extensions and are not part of SCIM core schema:"

But there are no examples of rooms and rooms.number extensions. We should add one example using the enterprise user extension and maybe even an hypothetical one to display how it works.

------------------

We should also remove an tag on DELETE requests. It’s not used and might stir up confusion.

------------------

When reading the spec, I’ve also found a couple of formatting things that we need fixing.

-  Page 23, and page 26, and 30, 34, 35, HTTP request missing new lines. Example:

   A query response is shown with the first page of results.  For
   brevity reasons, only two matches are shown: one User and one Group.

   HTTP/1.1 200 OK
   Content-Type: application/scim+json
   Location: 
https://example.com/.search

   {
     "schemas": ["urn:ietf:params:scim:api:messages:2.0:ListResponse"],
     "totalResults":100,

- Page 27, JSON pritty print needed :)

 { "schemas": ["urn:ietf:params:scim:api:messages:2.0:PatchOp"],
   "Operations":[
     {

---

From: Phil Hunt <[email-masked]>
Date: Sun, 15 Feb 2015 14:25:55 -0800

Thanks Erik. Will add to the next draft. See comment below

Phil

> On Feb 15, 2015, at 11:17, Erik Wahlström neXus <[email-masked]> wrote:
> 

<ph>The above sentence should be removed. The group decided not to have nested value paths which is why it was removed from the abnf and examples. 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim