Subject: [scim] Manager attribute wording suggestion

From: Patrick Radtke <[email-masked]>
Date: Fri, 24 Apr 2015 22:47:18 +0000

There are a couple aspects of the “manager” attribute that seem inconsistent.

In 4.3 Enterprise User Schema extension it says
"manager

      The user's manager.  A complex type that optionally allows service
      providers to represent organizational hierarchy by referencing the
      "id" attribute of another User.

      value  The "id" of the SCIM resource representing the user's
         manager.  RECOMMENDED.

      $ref  The URI of the SCIM resource representing the User's
         manager.  RECOMMENDED.

“
To me that says that a user may have a single manager, and ‘value’ and ‘$ref’ attributes are not required.

However in the Schema section, manager is listed as "multiValued: true” and though subAttributes of “$ref” and “value” have “required:false” the description attribute says each is required.

If “value” and “$ref” aren’t required, can the Manager schema description be adjusted?
Since manager is multi-valued, can section 4.3 be updated to say. "The user's managers.  A multi-valued complex type that…”  Otherwise, at first read (or for anyone coming from SCIM 1.1) it is not obvious that it has become multi-valued.

Thanks,

Patrick

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 29 Apr 2015 23:06:34 +0000

Patrick ... thanks for the feedback.

I think that the schema section is incorrect.  The $ref and value are required and manager is still single valued.  I think the text in 4.3 should say:

manager

Phil, do you agree?

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Patrick Radtke
Sent: Friday, April 24, 2015 5:47 PM
To: SCIM WG
Subject: [scim] Manager attribute wording suggestion

There are a couple aspects of the "manager" attribute that seem inconsistent.

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
"
To me that says that a user may have a single manager, and 'value' and '$ref' attributes are not required.

However in the Schema section, manager is listed as "multiValued: true" and though subAttributes of "$ref" and "value" have "required:false" the description attribute says each is required.

If "value" and "$ref" aren't required, can the Manager schema description be adjusted?
Since manager is multi-valued, can section 4.3 be updated to say. "The user's managers.  A multi-valued complex type that..."  Otherwise, at first read (or for anyone coming from SCIM 1.1) it is not obvious that it has become multi-valued.

Thanks,

Patrick

---

From: Phil Hunt <[email-masked]>
Date: Wed, 29 Apr 2015 16:41:15 -0700

I believe I raised this issue before and the consensus was to leave it.  Maybe I am mistaken?

Phil

@independentid
www.independentid.com
[email-masked]

> On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <[email-masked]> wrote:
> 
> Patrick … thanks for the feedback.
>

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 30 Apr 2015 13:41:36 +0000

I had forgotten about that.  The most discussion that I found was in this email - http://www.ietf.org/mail-archive/web/scim/current/msg02007.html.

   Note, the schema also needs to be updated. It looks like it should be multi-valued
  since many orgs have people with multiple reporting relationships.

I don’t remember ever discussing this any further or if we achieved consensus on changing this.  The email thread doesn’t have any more discussion.

I’m not sure that I agree that this should be multivalued.  If anything else, I would never wish multiple managers upon anyone. ;)  Being serious, though, this might fit better as a second attribute that describes other reporting relationships.

Anyone else remember this?

From: Phil Hunt [mailto:[email-masked]]
Sent: Wednesday, April 29, 2015 6:41 PM
To: Kelly Grizzle
Cc: Patrick Radtke; SCIM WG
Subject: Re: Manager attribute wording suggestion

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

---

From: Phil Hunt <[email-masked]>
Date: Thu, 30 Apr 2015 08:28:05 -0700

I recall your comment and given lack of input at the time, it was clear there was no consensus for change. I had to leave it as is despite thinking it needed to be multi-valued. 

Phil

> On Apr 30, 2015, at 06:41, Kelly Grizzle <[email-masked]> wrote:
>

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 30 Apr 2015 17:28:21 +0000

Does anyone have any strong opinions about making manager multi-valued or leaving it as-is?

Either way we should probably clean up the text in section 4.3 and the schema definition.

From: Phil Hunt [mailto:[email-masked]]
Sent: Thursday, April 30, 2015 10:28 AM
To: Kelly Grizzle
Cc: Patrick Radtke; SCIM WG
Subject: Re: Manager attribute wording suggestion

Phil

On Apr 30, 2015, at 06:41, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:
I had forgotten about that.  The most discussion that I found was in this email - http://www.ietf.org/mail-archive/web/scim/current/msg02007.html.

Phil

@independentid

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

---

From: Michael Frost <[email-masked]>
Date: Thu, 30 Apr 2015 11:42:06 -0700 (PDT)

It is multi-valued in the example in 8.3 and in the schema on page 60, and in our implementation.  I think only the text in section 4.3 refers to manager as singular.

-mrf

From: Kelly Grizzle [mailto:[email-masked]] 
Sent: Thursday, April 30, 2015 10:28 AM
To: Phil Hunt
Cc: Patrick Radtke; SCIM WG
Subject: Re: [scim] Manager attribute wording suggestion

 

Phil

On Apr 30, 2015, at 06:41, Kelly Grizzle <HYPERLINK "mailto:[email-masked]"[email-masked]> wrote:

Phil

@independentid

HYPERLINK "http://www.independentid.com"www.independentid.com

HYPERLINK "mailto:[email-masked]"[email-masked]

On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <HYPERLINK "mailto:[email-masked]"[email-masked]> wrote:

manager

Phil, do you agree?

--Kelly

"manager

 

“

Thanks,

Patrick

---

From: Phil Hunt <[email-masked]>
Date: Thu, 30 Apr 2015 12:20:36 -0700

Agreed.

Will need consensus/direction from the chairs on this and along with the other issue (401/403/501 status code clarification).

Phil

@independentid
www.independentid.com
[email-masked]

> On Apr 30, 2015, at 11:42 AM, Michael Frost <[email-masked]> wrote:
> 
> From: Phil Hunt [mailto:[email-masked] <mailto:[email-masked]>] 
> On Apr 30, 2015, at 06:41, Kelly Grizzle <[email-masked] <mailto:[email-masked]>> wrote:
> 
> I had forgotten about that.  The most discussion that I found was in this email - http://www.ietf.org/mail-archive/web/scim/current/msg02007.html <http://www.ietf.org/mail-archive/web/scim/current/msg02007.html>.
>  
> From: Phil Hunt [mailto:[email-masked] <mailto:[email-masked]>] 
> www.independentid.com <http://www.independentid.com/>
> [email-masked] <mailto:[email-masked]>
>  
> On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <[email-masked] <mailto:[email-masked]>> wrote:
>  
> From: scim [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Patrick Radtke
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Kelly Grizzle <[email-masked]>
Date: Thu, 30 Apr 2015 20:50:38 +0000

It looks like this got changed back in October in revision 12 of the core schema doc.

   Draft 12 - PH - Nits / Corrections

      ...

      Corrected enterprise User manager attribute to use sub-attribute
      value and make multi-valued

I hadn’t realized that this change went in.  Up until then manager had been single-valued since SCIM 1.0.  If there is consensus that this change should stay, then it seems like we need to update section 4.3.

Regarding the fact that “required” is false for the “value” and “$ref” sub-attributes, this is consistent with the rest of the attribute definitions that are references.  I agree with you, Patrick, that these should be required.

--Kelly

From: Phil Hunt [mailto:[email-masked]]
Sent: Thursday, April 30, 2015 2:21 PM
To: Michael Frost
Cc: Kelly Grizzle; Patrick Radtke; SCIM WG
Subject: Re: [scim] Manager attribute wording suggestion

Agreed.

Phil

@independentid

On Apr 30, 2015, at 11:42 AM, Michael Frost <[email-masked]<mailto:[email-masked]>> wrote:

-mrf

Phil

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim