Subject: [scim] Standard security response

From: Grahame Grieve <[email-masked]>
Date: Thu, 30 Apr 2015 12:31:29 +1000

If a client tries to use a SCIM (2.0) interface, and it must use
authenticate to the service first, is there a standard response to tell
clients how to go about doing that?

thanks
Grahame

-- 
-----
http://www.healthintersections.com.au / [email-masked]
/ +61 411 867 065

---

From: Phil Hunt <[email-masked]>
Date: Wed, 29 Apr 2015 19:41:35 -0700

The spec follows 7235 which means status 401 is returned with www-authenticate headers listing supported authen schemes. 

Phil

> On Apr 29, 2015, at 19:31, Grahame Grieve <[email-masked]> wrote:
> 
> If a client tries to use a SCIM (2.0) interface, and it must use authenticate to the service first, is there a standard response to tell clients how to go about doing that? 
> 
> thanks
> Grahame
> 
> 
> -- 
> -----
> http://www.healthintersections.com.au / [email-masked] / +61 411 867 065
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Grahame Grieve <[email-masked]>
Date: Thu, 30 Apr 2015 12:57:08 +1000

thanks. This was my real question:
http://stackoverflow.com/questions/940206/what-should-i-pass-for-the-www-authenticate-header-on-401s-if-im-only-using-ope

..and whether there is a SCIM specific answer for this. But it's probably
the wrong place to ask this. sorry

Grahame

On Thu, Apr 30, 2015 at 12:41 PM, Phil Hunt <[email-masked]> wrote:

> The spec follows 7235 which means status 401 is returned with
> www-authenticate headers listing supported authen schemes.
>
> Phil
>
> On Apr 29, 2015, at 19:31, Grahame Grieve <
> [email-masked]> wrote:
>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 29 Apr 2015 20:14:54 -0700

Yes. That would be defined by the OIDC specs. 

Phil

> On Apr 29, 2015, at 19:57, Grahame Grieve <[email-masked]> wrote:
> 
> thanks. This was my real question: http://stackoverflow.com/questions/940206/what-should-i-pass-for-the-www-authenticate-header-on-401s-if-im-only-using-ope
> 
> ..and whether there is a SCIM specific answer for this. But it's probably the wrong place to ask this. sorry
> 
> Grahame
> 
> 
> 
>