Subject: [scim] Schema definition and representation inconsistency

From: Steve Moyer <[email-masked]>
Date: Sat, 25 Apr 2015 15:28:15 -0400

The Schema Definition in section 7 (page 27) states that the "name"
attribute is optional, but the Schema representation in section 8.7.2
defines this attribute (page 69) with:

"required" : true,

Steve

---

From: Phil Hunt <[email-masked]>
Date: Sat, 25 Apr 2015 12:53:53 -0700

8.7.2 is just a representation. The service provider can alter optionality if optional in the normative text. 

Phil

> On Apr 25, 2015, at 12:28, Steve Moyer <[email-masked]> wrote:
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Steve Moyer <[email-masked]>
Date: Sat, 25 Apr 2015 20:42:16 -0400

Phil,

Sorry for the SPAM ... I see now that all the examples are marked
non-normative and will make sure the rest of my development is based on
the parts of the specification that are considered normative.

Thanks for setting me straight!

Steve

-- 
"One longs, in reading your code, to walk on all fours" - Voltaire

---

From: Phil Hunt <[email-masked]>
Date: Sat, 25 Apr 2015 18:33:13 -0700

Happy to help!

Cheers

Phil

> On Apr 25, 2015, at 17:42, Steve Moyer <[email-masked]> wrote:
> 
> Phil,
>