Subject: [scim] User templates

From: Grahame Grieve <[email-masked]>
Date: Fri, 1 May 2015 21:02:59 +1000

hi

I've just been working on my scim implementation. One of the things I ran
into is that my system - and others I've worked on - have the concept of
user Templates - the shell of a valid user that you copy and fill out when
creating a real user. Some systems make these a different kind of entity,
some make them a special kind of user, and others just give a standard user
a special name.

I also have an account for 'anonymous' - that's something different again.

Has this kind of differentiation been discussed? Note: in some ways, you
could achieve some of this using schema, but not other parts of it.

Grahame

-- 
-----
http://www.healthintersections.com.au / [email-masked]
/ +61 411 867 065

---

From: Kelly Grizzle <[email-masked]>
Date: Fri, 1 May 2015 20:30:38 +0000

Graham ... I don’t remember hearing any discussions around this.  The first solution that pops to my mind is to create a new resource type for user templates, but use the same user schema that you use for the Users resource.  This would keep the fake template users separated (when searching, etc…) from the real users.

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Grahame Grieve
Sent: Friday, May 01, 2015 6:03 AM
To: [email-masked]
Subject: [scim] User templates

hi

I've just been working on my scim implementation. One of the things I ran into is that my system - and others I've worked on - have the concept of user Templates - the shell of a valid user that you copy and fill out when creating a real user. Some systems make these a different kind of entity, some make them a special kind of user, and others just give a standard user a special name.

Has this kind of differentiation been discussed? Note: in some ways, you could achieve some of this using schema, but not other parts of it.

Grahame

--
-----
http://www.healthintersections.com.au / [email-masked]<mailto:[email-masked]> / +61 411 867 065

---

From: Grahame Grieve <[email-masked]>
Date: Sat, 2 May 2015 08:10:45 +1000

Hi Kelly

You could achieve the same by adding a enumerated field type to the
existing resource : { normal, proxy, template }. (though I'm not
necessarily advocating for that - there's pros and cons).

I think that this will come up often enough to be justified addressing in a
future version

Grahame

On Sat, May 2, 2015 at 6:30 AM, Kelly Grizzle <[email-masked]>
wrote:

>  Graham ... I don’t remember hearing any discussions around this.  The
> first solution that pops to my mind is to create a new resource type for
> user templates, but use the same user schema that you use for the Users
> resource.  This would keep the fake template users separated (when
> searching, etc…) from the real users.
>
>
>
> --Kelly
>
>
>
> *From:* scim [mailto:[email-masked]] *On Behalf Of *Grahame Grieve
> *Sent:* Friday, May 01, 2015 6:03 AM
> *To:* [email-masked]
> *Subject:* [scim] User templates
>
>
>
> hi
>
>
>