Subject: Re: [scim] Manager attribute wording suggestion

From: Phil Hunt <[email-masked]>
Date: Mon, 4 May 2015 16:04:14 -0700

There are a couple of changes from the IESG review coming to core-schema (for other reasons - emails to follow).

With regards to this issue, I propose that the next update make “manager” a multi-valued attribute so that it is consistent with the examples and to correct the apparent inconsistency in the draft.

If there are any strong objections, please respond and discuss.

Thanks,

Phil

@independentid
www.independentid.com
[email-masked]

> On Apr 30, 2015, at 1:50 PM, Kelly Grizzle <[email-masked]> wrote:
> 
> It looks like this got changed back in October in revision 12 of the core schema doc.
>  
>    Draft 12 - PH - Nits / Corrections
>  
>       ...
>  
>       Corrected enterprise User manager attribute to use sub-attribute
>       value and make multi-valued
>  
> I hadn’t realized that this change went in.  Up until then manager had been single-valued since SCIM 1.0.  If there is consensus that this change should stay, then it seems like we need to update section 4.3.
>  
> Regarding the fact that “required” is false for the “value” and “$ref” sub-attributes, this is consistent with the rest of the attribute definitions that are references.  I agree with you, Patrick, that these should be required.
>  
> --Kelly
>  
> From: Phil Hunt [mailto:[email-masked]] 
> Sent: Thursday, April 30, 2015 2:21 PM
> To: Michael Frost
> Cc: Kelly Grizzle; Patrick Radtke; SCIM WG
> Subject: Re: [scim] Manager attribute wording suggestion
>  
> Agreed.
>  
> Will need consensus/direction from the chairs on this and along with the other issue (401/403/501 status code clarification).
>  
> Phil
>  
> @independentid
> www.independentid.com <http://www.independentid.com/>
> [email-masked] <mailto:[email-masked]>
>  
> On Apr 30, 2015, at 11:42 AM, Michael Frost <[email-masked] <mailto:[email-masked]>> wrote:
>  
> It is multi-valued in the example in 8.3 and in the schema on page 60, and in our implementation.  I think only the text in section 4.3 refers to manager as singular.
>  
> -mrf
>  
> From: Kelly Grizzle [mailto:[email-masked] <mailto:[email-masked]>] 
> Sent: Thursday, April 30, 2015 10:28 AM
> To: Phil Hunt
> Cc: Patrick Radtke; SCIM WG
> Subject: Re: [scim] Manager attribute wording suggestion
>  
> Does anyone have any strong opinions about making manager multi-valued or leaving it as-is?
> 
> Either way we should probably clean up the text in section 4.3 and the schema definition.
>  
>  
> From: Phil Hunt [mailto:[email-masked] <mailto:[email-masked]>] 
> Sent: Thursday, April 30, 2015 10:28 AM
> To: Kelly Grizzle
> Cc: Patrick Radtke; SCIM WG
> Subject: Re: Manager attribute wording suggestion
>  
> I recall your comment and given lack of input at the time, it was clear there was no consensus for change. I had to leave it as is despite thinking it needed to be multi-valued. 
> 
> Phil
> 
> On Apr 30, 2015, at 06:41, Kelly Grizzle <[email-masked] <mailto:[email-masked]>> wrote:
> 
> I had forgotten about that.  The most discussion that I found was in this email - http://www.ietf.org/mail-archive/web/scim/current/msg02007.html <http://www.ietf.org/mail-archive/web/scim/current/msg02007.html>.
>  
>    Note, the schema also needs to be updated. It looks like it should be multi-valued
>   since many orgs have people with multiple reporting relationships.
>  
> I don’t remember ever discussing this any further or if we achieved consensus on changing this.  The email thread doesn’t have any more discussion.
>  
> I’m not sure that I agree that this should be multivalued.  If anything else, I would never wish multiple managers upon anyone. ;)  Being serious, though, this might fit better as a second attribute that describes other reporting relationships.
>  
> Anyone else remember this?
>  
> From: Phil Hunt [mailto:[email-masked] <mailto:[email-masked]>] 
> Sent: Wednesday, April 29, 2015 6:41 PM
> To: Kelly Grizzle
> Cc: Patrick Radtke; SCIM WG
> Subject: Re: Manager attribute wording suggestion
>  
> I believe I raised this issue before and the consensus was to leave it.  Maybe I am mistaken?
>  
> Phil
>  
> @independentid
> www.independentid.com <http://www.independentid.com/>
> [email-masked] <mailto:[email-masked]>
>  
> On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Patrick … thanks for the feedback.
>  
> I think that the schema section is incorrect.  The $ref and value are required and manager is still single valued.  I think the text in 4.3 should say:
>  
> manager
>       The user's manager.  A complex type that optionally allows service
>       providers to represent organizational hierarchy by referencing the
>       "id" attribute of another User.
>  
> Phil, do you agree?
>  
> --Kelly
>  
> From: scim [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Patrick Radtke
> Sent: Friday, April 24, 2015 5:47 PM
> To: SCIM WG
> Subject: [scim] Manager attribute wording suggestion
>  
> There are a couple aspects of the “manager” attribute that seem inconsistent.
>  
> In 4.3 Enterprise User Schema extension it says
> "manager
>       The user's manager.  A complex type that optionally allows service
>       providers to represent organizational hierarchy by referencing the
>       "id" attribute of another User.
>  
>       value  The "id" of the SCIM resource representing the user's
>          manager.  RECOMMENDED.
>  
>       $ref  The URI of the SCIM resource representing the User's
>          manager.  RECOMMENDED.
> “
> To me that says that a user may have a single manager, and ‘value’ and ‘$ref’ attributes are not required.
>  
> However in the Schema section, manager is listed as "multiValued: true” and though subAttributes of “$ref” and “value” have “required:false” the description attribute says each is required.
>  
> If “value” and “$ref” aren’t required, can the Manager schema description be adjusted?
> Since manager is multi-valued, can section 4.3 be updated to say. "The user's managers.  A multi-valued complex type that…”  Otherwise, at first read (or for anyone coming from SCIM 1.1) it is not obvious that it has become multi-valued.
>  
> Thanks,
>  
> Patrick
>  
>  
>  
>  
>  
> _______________________________________________
> scim mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>
>

---

From: Patrick Radtke <[email-masked]>
Date: Mon, 4 May 2015 23:10:12 +0000

Is it too late in the process to make the attribute name plural (“managers”)? All the other multiValued attributes I saw in core-schema use the plural form for the attribute name.

From: Phil Hunt <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 4, 2015 at 4:04 PM
To: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Cc: Michael Frost <[email-masked]<mailto:[email-masked]>>, Jive IT <[email-masked]<mailto:[email-masked]>>, SCIM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Manager attribute wording suggestion

Thanks,

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On Apr 30, 2015, at 1:50 PM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

      ...

--Kelly

Agreed.

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

On Apr 30, 2015, at 11:42 AM, Michael Frost <[email-masked]<mailto:[email-masked]>> wrote:

-mrf

From: Kelly Grizzle [mailto:[email-masked]]
Sent: Thursday, April 30, 2015 10:28 AM
To: Phil Hunt
Cc: Patrick Radtke; SCIM WG
Subject: Re: [scim] Manager attribute wording suggestion

Phil

On Apr 30, 2015, at 06:41, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:
I had forgotten about that.  The most discussion that I found was in this email - http://www.ietf.org/mail-archive/web/scim/current/msg02007.html.

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

manager

Phil, do you agree?

--Kelly

From: scim [mailto:[email-masked]] On Behalf Of Patrick Radtke
Sent: Friday, April 24, 2015 5:47 PM
To: SCIM WG
Subject: [scim] Manager attribute wording suggestion

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Tue, 5 May 2015 21:14:52 +0000

Speaking as an individual – I am not aware of any IdM system that has multivalued “manager”. In addition in many cases a multivalued manager brakes many applications as the reporting hierarchy is assumed to be a tree structure with a one to many relationship not many to many. Unless someone has a solid use case for turning this into a multivalued attribute, my vote as one of the implementors is to fix the example and leave it as single valued.

Cheers,
Morteza

From: Patrick Radtke <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 4, 2015 at 4:10 PM
To: Phil Hunt <[email-masked]<mailto:[email-masked]>>, Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Michael Frost <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Manager attribute wording suggestion

Thanks,

Phil

@independentid

      ...

--Kelly

Agreed.

Phil

@independentid

-mrf

Phil

Phil

@independentid

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

---

From: Phil Hunt <[email-masked]>
Date: Tue, 5 May 2015 15:24:42 -0700

<As Individual>
My understanding is that we do.  Dotted line and multi-reporting relationships are a reality for many enterprise organizations.  At least one (or more) of our implementations is multi-valued. This was also raised to me as an issue.

<As Editor>
I think the reality is that we’ll all run into enterprises wanting multi-valued managers sooner or later.  Having it multi-valued doesn’t mean you have to support multiple values.  But the important thing is that SCIM parsers will need to expect an array.

Maybe we need a general note that parsers should accept a single value JSON object even when an attribute is multi-valued (for any multi-valued attribute).  This would make the issue non-breaking for clients (who think any attribute is single-valued).  As for servers, it seems to me we have a compatibility issue due to the spec inconsistency (while definition is single-value, examples are multi-valued). That means regardless of our decisions some servers will have to be updated.

Phil

@independentid
www.independentid.com
[email-masked]

> On May 5, 2015, at 2:14 PM, Morteza Ansari (moransar) <[email-masked]> wrote:
> 
> From: Patrick Radtke <[email-masked] <mailto:[email-masked]>>
> To: Phil Hunt <[email-masked] <mailto:[email-masked]>>, Kelly Grizzle <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, Michael Frost <[email-masked] <mailto:[email-masked]>>
> From: Phil Hunt <[email-masked] <mailto:[email-masked]>>
> To: Kelly Grizzle <[email-masked] <mailto:[email-masked]>>
> Cc: Michael Frost <[email-masked] <mailto:[email-masked]>>, Jive IT <[email-masked] <mailto:[email-masked]>>, SCIM WG <[email-masked] <mailto:[email-masked]>>
> www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>
>> On Apr 30, 2015, at 1:50 PM, Kelly Grizzle <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Ian Glazer <[email-masked]>
Date: Wed, 6 May 2015 17:43:33 +0200

I am against changing manager to be multi-valued. I've built 3 user
provisioning engines and have never seen a case where manager is
multi-valued. If you have a matrix-ed organization where there are dotted
line relationships, then I recommend an extension. But we ought to keep
SCIM focused on the mainstream scenario where a person has a single manager.

On Wed, May 6, 2015 at 12:24 AM, Phil Hunt <[email-masked]> wrote:

> <As Individual>
> My understanding is that we do.  Dotted line and multi-reporting
> relationships are a reality for many enterprise organizations.  At least
> one (or more) of our implementations is multi-valued. This was also raised
> to me as an issue.
>
> <As Editor>
> I think the reality is that we’ll all run into enterprises wanting
> multi-valued managers sooner or later.  Having it multi-valued doesn’t mean
> you have to support multiple values.  But the important thing is that SCIM
> parsers will need to expect an array.
>
> *Maybe we need a general note that parsers should accept a single value
> JSON object even when an attribute is multi-valued (for any multi-valued
> attribute)*.  This would make the issue non-breaking for clients (who
> think any attribute is single-valued).  As for servers, it seems to me we
> have a compatibility issue due to the spec inconsistency (while definition
> is single-value, examples are multi-valued). That means regardless of our
> decisions some servers will have to be updated.
>
> Phil
>
> @independentid
> www.independentid.com
> [email-masked]
>
>  Speaking as an individual – I am not aware of any IdM system that has
> multivalued “manager”. In addition in many cases a multivalued manager
> brakes many applications as the reporting hierarchy is assumed to be a tree
> structure with a one to many relationship not many to many. Unless someone
> has a solid use case for turning this into a multivalued attribute, my vote
> as one of the implementors is to fix the example and leave it as single
> valued.
>
>
>  Cheers,
> Morteza
>
>   From: Patrick Radtke <[email-masked]>
> To: Phil Hunt <[email-masked]>, Kelly Grizzle <
> [email-masked]>
> Cc: "[email-masked]" <[email-masked]>, Michael Frost <
> [email-masked]>
>   Is it too late in the process to make the attribute name plural
> (“managers”)? All the other multiValued attributes I saw in core-schema use
> the plural form for the attribute name.
>
>   From: Phil Hunt <[email-masked]>
> To: Kelly Grizzle <[email-masked]>
> Cc: Michael Frost <[email-masked]>, Jive IT <
> [email-masked]>, SCIM WG <[email-masked]>
>   There are a couple of changes from the IESG review coming to
> core-schema (for other reasons - emails to follow).
>
>  With regards to this issue, I propose that the next update make
> “manager” a multi-valued attribute so that it is consistent with the
> examples and to correct the apparent inconsistency in the draft.
>
> I hadn’t realized that this change went in.  Up until then manager had
> been single-valued since SCIM 1.0.  If there is consensus that this change
> should stay, then it seems like we need to update section 4.3.
>
> Regarding the fact that “required” is false for the “value” and “$ref”
> sub-attributes, this is consistent with the rest of the attribute
> definitions that are references.  I agree with you, Patrick, that these
> should be required.
>
> --Kelly
>
>  *From:* Phil Hunt [mailto:[email-masked] <[email-masked]>]
> *Sent:* Thursday, April 30, 2015 2:21 PM
> *To:* Michael Frost
> *Cc:* Kelly Grizzle; Patrick Radtke; SCIM WG
> *Subject:* Re: [scim] Manager attribute wording suggestion
>
> Agreed.
>
>  Will need consensus/direction from the chairs on this and along with the
> other issue (401/403/501 status code clarification).
>
>      Phil
>
>  @independentid
>  www.independentid.com
>  [email-masked]
>
>
> On Apr 30, 2015, at 11:42 AM, Michael Frost <[email-masked]>
> wrote:
>
>  It is multi-valued in the example in 8.3 and in the schema on page 60,
> and in our implementation.  I think only the text in section 4.3 refers to
> manager as singular.
>
> -mrf
>
>  *From:* Kelly Grizzle [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* Thursday, April 30, 2015 10:28 AM
> *To:* Phil Hunt
> *Cc:* Patrick Radtke; SCIM WG
> *Subject:* Re: [scim] Manager attribute wording suggestion
>
>  *From:* Phil Hunt [mailto:[email-masked] <[email-masked]>]
> *Sent:* Thursday, April 30, 2015 10:28 AM
> *To:* Kelly Grizzle
> *Cc:* Patrick Radtke; SCIM WG
> *Subject:* Re: Manager attribute wording suggestion
>
> I recall your comment and given lack of input at the time, it was clear
> there was no consensus for change. I had to leave it as is despite thinking
> it needed to be multi-valued.
>
> Phil
>
>
> On Apr 30, 2015, at 06:41, Kelly Grizzle <[email-masked]>
> wrote:
>
> I had forgotten about that.  The most discussion that I found was in this
> email - http://www.ietf.org/mail-archive/web/scim/current/msg02007.html.
>
> I don’t remember ever discussing this any further or if we achieved
> consensus on changing this.  The email thread doesn’t have any more
> discussion.
>
> I’m not sure that I agree that this should be multivalued.  If anything
> else, I would never wish multiple managers upon anyone. ;)  Being serious,
> though, this might fit better as a second attribute that describes other
> reporting relationships.
>
>  *From:* Phil Hunt [mailto:[email-masked] <[email-masked]>]
> *Sent:* Wednesday, April 29, 2015 6:41 PM
> *To:* Kelly Grizzle
> *Cc:* Patrick Radtke; SCIM WG
> *Subject:* Re: Manager attribute wording suggestion
>
> On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <[email-masked]>
> wrote:
>
> I think that the schema section is incorrect.  The $ref and value are
> required and manager is still single valued.  I think the text in 4.3
> should say:
>
> manager
>
>  *From:* scim [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Patrick Radtke
> *Sent:* Friday, April 24, 2015 5:47 PM
> *To:* SCIM WG
> *Subject:* [scim] Manager attribute wording suggestion
>
>  However in the Schema section, manager is listed as "multiValued: true”
> and though subAttributes of “$ref” and “value” have “required:false” the
> description attribute says each is required.
>
>  Since manager is multi-valued, can section 4.3 be updated to say. "The
> user's managers.  A multi-valued complex type that…”  Otherwise, at first
> read (or for anyone coming from SCIM 1.1) it is not obvious that it has
> become multi-valued.
>
>  Thanks,
>
>  Patrick
>
>
>
>
>
>
>
> [email-masked]
> [email-masked]

-- 
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer <https://twitter.com/iglazer>

---

From: Leif Johansson <[email-masked]>
Date: Wed, 6 May 2015 17:55:21 +0200

> 6 maj 2015 kl. 17:43 skrev Ian Glazer <[email-masked]>:
> 
> I am against changing manager to be multi-valued. I've built 3 user provisioning engines and have never seen a case where manager is multi-valued. If you have a matrix-ed organization where there are dotted line relationships, then I recommend an extension. But we ought to keep SCIM focused on the mainstream scenario where a person has a single manager.

+1 (as individual)

>>> To: Phil Hunt <[email-masked]>, Kelly Grizzle <[email-masked]>
>>> Cc: "[email-masked]" <[email-masked]>, Michael Frost <[email-masked]>
>>> Cc: Michael Frost <[email-masked]>, Jive IT <[email-masked]>, SCIM WG <[email-masked]>
>>>>> On Apr 30, 2015, at 11:42 AM, Michael Frost <[email-masked]> wrote:
>>>>>  
>>>>>> On Apr 30, 2015, at 06:41, Kelly Grizzle <[email-masked]> wrote:
>>>>>> 
>>>>>>> On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <[email-masked]> wrote:
>>>>>>>  
> @iglazer

---

From: Kelly Grizzle <[email-masked]>
Date: Wed, 6 May 2015 16:05:12 +0000

I agree with Ian.  While multiple managers is possible, I have never seen it in any system that I have dealt with … and I have seen a lot.  It feels like we would be penalizing the majority by making clients have to deal with multiple values when they will almost never be multi-valued.

I agree that we should keep manager single-valued, and if a server requires multiple manager relationships this could be added as an extension.  The single-valued manager would be their primary and the extended attribute would be all of the dotted line managers.  In fact, if there are multiple managers it might make sense to make this a complex attribute that can further describe the relationship.
To me this feels like it is line with the 80/20 rule of thumb that we have been using when coming up with this spec.

From: Leif Johansson [mailto:[email-masked]]
Sent: Wednesday, May 06, 2015 10:55 AM
To: Ian Glazer
Cc: Phil Hunt; Patrick Radtke; SCIM WG; Morteza Ansari; Michael Frost; Kelly Grizzle
Subject: Re: [scim] Manager attribute wording suggestion

6 maj 2015 kl. 17:43 skrev Ian Glazer <[email-masked]<mailto:[email-masked]>>:
I am against changing manager to be multi-valued. I've built 3 user provisioning engines and have never seen a case where manager is multi-valued. If you have a matrix-ed organization where there are dotted line relationships, then I recommend an extension. But we ought to keep SCIM focused on the mainstream scenario where a person has a single manager.

+1 (as individual)

On Wed, May 6, 2015 at 12:24 AM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
<As Individual>
My understanding is that we do.  Dotted line and multi-reporting relationships are a reality for many enterprise organizations.  At least one (or more) of our implementations is multi-valued. This was also raised to me as an issue.

<As Editor>

Phil

@independentid

On May 5, 2015, at 2:14 PM, Morteza Ansari (moransar) <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,
Morteza

Thanks,

Phil

@independentid

      ...

--Kelly

Agreed.

Phil

@independentid

-mrf

Phil

Phil

@independentid

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

@iglazer<https://twitter.com/iglazer>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 6 May 2015 09:32:06 -0700

We can use an extension (TBD) to support multiple relation types. 

I just worry that others will have to support it. 

Phil

> On May 6, 2015, at 09:05, Kelly Grizzle <[email-masked]> wrote:
>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 6 May 2015 10:41:15 -0700

<editor hat>

Do I have direction to correct the examples and align them with a single-value definition?

Phil

@independentid
www.independentid.com
[email-masked]

> On May 6, 2015, at 9:32 AM, Phil Hunt <[email-masked]> wrote:
> 
>  
> On May 6, 2015, at 09:05, Kelly Grizzle <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> From: Leif Johansson [mailto:[email-masked] <mailto:[email-masked]>] 
>> 6 maj 2015 kl. 17:43 skrev Ian Glazer <[email-masked] <mailto:[email-masked]>>:
>> 
>> On Wed, May 6, 2015 at 12:24 AM, Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
>> <As Individual>
>> On May 5, 2015, at 2:14 PM, Morteza Ansari (moransar) <[email-masked] <mailto:[email-masked]>> wrote:
>>  
>> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>_______________________________________________
> scim mailing list
> [email-masked]

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Wed, 6 May 2015 17:49:32 +0000

I definitely think we should make the examples & definition consistent. But before making the change, I would like to give Michael & Patrick a chance to chime in with the discussion.

Michael & Patrick, thoughts?

Cheers,
Morteza

From: Phil Hunt <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 6, 2015 at 10:41 AM
To: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Cc: Michael Frost <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ian Glazer <[email-masked]<mailto:[email-masked]>>, Patrick Radtke <[email-masked]<mailto:[email-masked]>>, Leif Johansson <[email-masked]<mailto:[email-masked]>>, Morteza Ansari <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Manager attribute wording suggestion

<editor hat>

Phil

@independentid

On May 6, 2015, at 9:32 AM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:

Phil

On May 6, 2015, at 09:05, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:

+1 (as individual)

<As Editor>

Phil

@independentid

Cheers,
Morteza

Thanks,

Phil

@independentid

      ...

--Kelly

Agreed.

Phil

@independentid

-mrf

Phil

Phil

@independentid

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

---

From: Michael Frost <[email-masked]>
Date: Wed, 6 May 2015 11:12:18 -0700 (PDT)

Our current implementation is multi-valued.  But it is no big deal to dial it back to single valued.  We implemented multi-valued purely to be spec compliant, there is no other internal requirement driving the feature for us.  So I am OK with a single value definition.

-mrf

From: Morteza Ansari (moransar) [mailto:[email-masked]] 
Sent: Wednesday, May 06, 2015 10:50 AM
To: Patrick Radtke; Phil Hunt; Michael Frost
Cc: SCIM WG; Ian Glazer; Leif Johansson; Kelly Grizzle
Subject: Re: [scim] Manager attribute wording suggestion

 

Cheers,

Morteza

From: Phil Hunt <HYPERLINK "mailto:[email-masked]"[email-masked]>
Date: Wednesday, May 6, 2015 at 10:41 AM
To: Kelly Grizzle <HYPERLINK "mailto:[email-masked]"[email-masked]>
Cc: Michael Frost <HYPERLINK "mailto:[email-masked]"[email-masked]>, "HYPERLINK "mailto:[email-masked]"[email-masked]" <HYPERLINK "mailto:[email-masked]"[email-masked]>, Ian Glazer <HYPERLINK "mailto:[email-masked]"[email-masked]>, Patrick Radtke <HYPERLINK "mailto:[email-masked]"[email-masked]>, Leif Johansson <HYPERLINK "mailto:[email-masked]"[email-masked]>, Morteza Ansari <HYPERLINK "mailto:[email-masked]"[email-masked]>
Subject: Re: [scim] Manager attribute wording suggestion

<editor hat> 

Phil

@independentid

HYPERLINK "http://www.independentid.com"www.independentid.com

HYPERLINK "mailto:[email-masked]"[email-masked]

On May 6, 2015, at 9:32 AM, Phil Hunt <HYPERLINK "mailto:[email-masked]"[email-masked]> wrote:

Phil

On May 6, 2015, at 09:05, Kelly Grizzle <HYPERLINK "mailto:[email-masked]"[email-masked]> wrote:

I agree with Ian.  While multiple managers is possible, I have never seen it in any system that I have dealt with . and I have seen a lot.  It feels like we would be penalizing the majority by making clients have to deal with multiple values when they will almost never be multi-valued.

 

6 maj 2015 kl. 17:43 skrev Ian Glazer <HYPERLINK "mailto:[email-masked]"[email-masked]>:

+1 (as individual)

On Wed, May 6, 2015 at 12:24 AM, Phil Hunt <HYPERLINK "mailto:[email-masked]" \[email-masked]> wrote:

<As Individual>

<As Editor>

I think the reality is that we'll all run into enterprises wanting multi-valued managers sooner or later.  Having it multi-valued doesn't mean you have to support multiple values.  But the important thing is that SCIM parsers will need to expect an array.

Phil

@independentid

HYPERLINK "http://www.independentid.com/" \nwww.independentid.com

HYPERLINK "mailto:[email-masked]" \[email-masked]

On May 5, 2015, at 2:14 PM, Morteza Ansari (moransar) <HYPERLINK "mailto:[email-masked]" \[email-masked]> wrote:

Speaking as an individual - I am not aware of any IdM system that has multivalued "manager". In addition in many cases a multivalued manager brakes many applications as the reporting hierarchy is assumed to be a tree structure with a one to many relationship not many to many. Unless someone has a solid use case for turning this into a multivalued attribute, my vote as one of the implementors is to fix the example and leave it as single valued.

Cheers,

Morteza

From: Patrick Radtke <HYPERLINK "mailto:[email-masked]" \[email-masked]>
Date: Monday, May 4, 2015 at 4:10 PM
To: Phil Hunt <HYPERLINK "mailto:[email-masked]" \[email-masked]>, Kelly Grizzle <HYPERLINK "mailto:[email-masked]" \[email-masked]>
Cc: "HYPERLINK "mailto:[email-masked]" \[email-masked]" <HYPERLINK "mailto:[email-masked]" \[email-masked]>, Michael Frost <HYPERLINK "mailto:[email-masked]" \[email-masked]>
Subject: Re: [scim] Manager attribute wording suggestion

Is it too late in the process to make the attribute name plural ("managers")? All the other multiValued attributes I saw in core-schema use the plural form for the attribute name.

From: Phil Hunt <HYPERLINK "mailto:[email-masked]" \[email-masked]>
Date: Monday, May 4, 2015 at 4:04 PM
To: Kelly Grizzle <HYPERLINK "mailto:[email-masked]" \[email-masked]>
Cc: Michael Frost <HYPERLINK "mailto:[email-masked]" \[email-masked]>, Jive IT <HYPERLINK "mailto:[email-masked]" \[email-masked]>, SCIM WG <HYPERLINK "mailto:[email-masked]" \[email-masked]>
Subject: Re: [scim] Manager attribute wording suggestion

With regards to this issue, I propose that the next update make "manager" a multi-valued attribute so that it is consistent with the examples and to correct the apparent inconsistency in the draft.

Thanks,

Phil

@independentid

HYPERLINK "http://www.independentid.com/" \nwww.independentid.com

HYPERLINK "mailto:[email-masked]" \[email-masked]

On Apr 30, 2015, at 1:50 PM, Kelly Grizzle <HYPERLINK "mailto:[email-masked]" \[email-masked]> wrote:

      ...

I hadn't realized that this change went in.  Up until then manager had been single-valued since SCIM 1.0.  If there is consensus that this change should stay, then it seems like we need to update section 4.3. 

Regarding the fact that "required" is false for the "value" and "$ref" sub-attributes, this is consistent with the rest of the attribute definitions that are references.  I agree with you, Patrick, that these should be required.

--Kelly 

Agreed.

Phil

@independentid

HYPERLINK "http://www.independentid.com/" \nwww.independentid.com

HYPERLINK "mailto:[email-masked]" \[email-masked]

On Apr 30, 2015, at 11:42 AM, Michael Frost <HYPERLINK "mailto:[email-masked]" \[email-masked]> wrote:

-mrf

 

Phil

On Apr 30, 2015, at 06:41, Kelly Grizzle <HYPERLINK "mailto:[email-masked]" \[email-masked]> wrote:

I don't remember ever discussing this any further or if we achieved consensus on changing this.  The email thread doesn't have any more discussion.

I'm not sure that I agree that this should be multivalued.  If anything else, I would never wish multiple managers upon anyone. ;)  Being serious, though, this might fit better as a second attribute that describes other reporting relationships.

Phil

@independentid

HYPERLINK "http://www.independentid.com/" \nwww.independentid.com

HYPERLINK "mailto:[email-masked]" \[email-masked]

On Apr 29, 2015, at 4:06 PM, Kelly Grizzle <HYPERLINK "mailto:[email-masked]" \[email-masked]> wrote:

Patrick . thanks for the feedback.

manager

Phil, do you agree?

--Kelly

There are a couple aspects of the "manager" attribute that seem inconsistent.

"manager

 

"

To me that says that a user may have a single manager, and 'value' and '$ref' attributes are not required.

However in the Schema section, manager is listed as "multiValued: true" and though subAttributes of "$ref" and "value" have "required:false" the description attribute says each is required.

If "value" and "$ref" aren't required, can the Manager schema description be adjusted?

Since manager is multi-valued, can section 4.3 be updated to say. "The user's managers.  A multi-valued complex type that."  Otherwise, at first read (or for anyone coming from SCIM 1.1) it is not obvious that it has become multi-valued.

Thanks,

Patrick

 

_______________________________________________
scim mailing list
HYPERLINK "mailto:[email-masked]" \[email-masked]
https://www.ietf.org/mailman/listinfo/scim

_______________________________________________
scim mailing list
HYPERLINK "mailto:[email-masked]"[email-masked]
https://www.ietf.org/mailman/listinfo/scim

-- 

Ian Glazer

+1 202 255 3166

HYPERLINK "https://twitter.com/iglazer" \n@iglazer

_______________________________________________
scim mailing list
HYPERLINK "mailto:[email-masked]"[email-masked]
https://www.ietf.org/mailman/listinfo/scim

_______________________________________________
scim mailing list
HYPERLINK "mailto:[email-masked]"[email-masked]
https://www.ietf.org/mailman/listinfo/scim

---

From: Patrick Radtke <[email-masked]>
Date: Wed, 6 May 2015 20:54:53 +0000

We also only implemented multi-valued to be spec compliant. We ignore everything after the first/primary manager.
I’m good with it becoming single valued again.

-Patrick

From: Michael Frost <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 6, 2015 at 11:12 AM
To: "Morteza Ansari (moransar)" <[email-masked]<mailto:[email-masked]>>, Jive IT <[email-masked]<mailto:[email-masked]>>, Phil Hunt <[email-masked]<mailto:[email-masked]>>
Cc: SCIM WG <[email-masked]<mailto:[email-masked]>>, Ian Glazer <[email-masked]<mailto:[email-masked]>>, Leif Johansson <[email-masked]<mailto:[email-masked]>>, Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Subject: RE: [scim] Manager attribute wording suggestion

-mrf

Cheers,
Morteza

<editor hat>

Phil

@independentid

Phil

+1 (as individual)

<As Editor>

Phil

@independentid

Cheers,
Morteza

Thanks,

Phil

@independentid

      ...

--Kelly

Agreed.

Phil

@independentid

-mrf

Phil

Phil

@independentid

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Wed, 6 May 2015 22:21:23 +0000

Thanks Patrick & Michael. I think we are good to go now.

Phil, please fix the examples to match the specification.

Cheers,
Morteza

From: Patrick Radtke <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 6, 2015 at 1:54 PM
To: Michael Frost <[email-masked]<mailto:[email-masked]>>, Morteza Ansari <[email-masked]<mailto:[email-masked]>>, Phil Hunt <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ian Glazer <[email-masked]<mailto:[email-masked]>>, Leif Johansson <[email-masked]<mailto:[email-masked]>>, Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Manager attribute wording suggestion

-Patrick

-mrf

Cheers,
Morteza

<editor hat>

Phil

@independentid

Phil

+1 (as individual)

<As Editor>

Phil

@independentid

Cheers,
Morteza

Thanks,

Phil

@independentid

      ...

--Kelly

Agreed.

Phil

@independentid

-mrf

Phil

Phil

@independentid

manager

Phil, do you agree?

--Kelly

         manager.  RECOMMENDED.

         manager.  RECOMMENDED.
“

Thanks,

Patrick