Subject: [scim] Clarrifying about SCIM filtering operation when filter value includes *

From: Chamila Wijayarathna <[email-masked]>
Date: Tue, 14 Jul 2015 16:58:27 +0530

Hi all,

I'm sending following request to a SCIM provider.

localhost:9443/wso2/scim/Users?filter=userName+Eq+%22a*a%22

As result should I get only a user with 'a*a' user name or should I get
list of all users who has userNames match the regex 'a*a'?

Thank You!

-- 
*Chamila Dilshan Wijayarathna,*
Software Engineer
Mobile:(+94)788193620
WSO2 Inc., http://wso2.com/

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 14 Jul 2015 14:09:13 +0000

The SCIM filter language does not support wildcards, so this would only match a user with the name “a*a”.  If you wanted to perform this you would need to use filter=userName sw a and userName ew a.

From: scim [mailto:[email-masked]] On Behalf Of Chamila Wijayarathna
Sent: Tuesday, July 14, 2015 6:28 AM
To: [email-masked]
Subject: [scim] Clarrifying about SCIM filtering operation when filter value includes *

Hi all,

As result should I get only a user with 'a*a' user name or should I get list of all users who has userNames match the regex 'a*a'?

Thank You!

--
Chamila Dilshan Wijayarathna,
Software Engineer
Mobile:(+94)788193620
WSO2 Inc., http://wso2.com/