Subject: [scim] Interop at CIS!

From: Ian Glazer <[email-masked]>
Date: Fri, 19 Feb 2016 09:33:51 -0500

All -

The fine folks at the Cloud Identity Summit have given us an opportunity to
do a SCIM v2 interop at CIS in New Orleans in June. We'll get a few hours
to run the interop on the first day and a session during the main
conference to report out our findings.

I assume we want to take this opportunity. I know that Salesforce and
SailPoint have discussed a desire to interop. But before confirming with
CIS, I'd like to hear from the group that we are in.

i

-- 
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer <https://twitter.com/iglazer>

---

From: Anthony Nadalin <[email-masked]>
Date: Fri, 19 Feb 2016 17:02:41 +0000

I’m not sure what you are going to interop against (configurations, scenarios, etc), also July at IETF may be a alternative choice

From: scim [mailto:[email-masked]] On Behalf Of Ian Glazer
Sent: Friday, February 19, 2016 6:34 AM
To: [email-masked] WG <[email-masked]>
Subject: [scim] Interop at CIS!

All -

The fine folks at the Cloud Identity Summit have given us an opportunity to do a SCIM v2 interop at CIS in New Orleans in June. We'll get a few hours to run the interop on the first day and a session during the main conference to report out our findings.

I assume we want to take this opportunity. I know that Salesforce and SailPoint have discussed a desire to interop. But before confirming with CIS, I'd like to hear from the group that we are in.

i

--
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2figlazer&data=01%7c01%7ctonynad%40microsoft.com%7c9032ff9a10404dd17cd308d33939bdda%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=0tsoMBgVW1bUl9kKpGkLCW%2bHpDIujgBS7D8YTuu75k8%3d>

---

From: Ian Glazer <[email-masked]>
Date: Fri, 19 Feb 2016 12:17:58 -0500

I was treating CIS as a forcing function to put interop configs, scenarios,
etc together. First thing first, we need to indicate to CIS whether we want
the time or not.

On Fri, Feb 19, 2016 at 12:02 PM, Anthony Nadalin <[email-masked]>
wrote:

> I’m not sure what you are going to interop against (configurations,
> scenarios, etc), also July at IETF may be a alternative choice
>
>
>
> *From:* scim [mailto:[email-masked]] *On Behalf Of *Ian Glazer
> *Sent:* Friday, February 19, 2016 6:34 AM
> *To:* [email-masked] WG <[email-masked]>
> *Subject:* [scim] Interop at CIS!
>
>
>
> All -
>
>
>
> The fine folks at the Cloud Identity Summit have given us an opportunity
> to do a SCIM v2 interop at CIS in New Orleans in June. We'll get a few
> hours to run the interop on the first day and a session during the main
> @iglazer
> <https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2figlazer&data=01%7c01%7ctonynad%40microsoft.com%7c9032ff9a10404dd17cd308d33939bdda%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=0tsoMBgVW1bUl9kKpGkLCW%2bHpDIujgBS7D8YTuu75k8%3d>
>

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Fri, 19 Feb 2016 10:44:25 -0700

Iiw is best for us 

Phil

> On Feb 19, 2016, at 10:17, Ian Glazer <[email-masked]> wrote:
> 
> I was treating CIS as a forcing function to put interop configs, scenarios, etc together. First thing first, we need to indicate to CIS whether we want the time or not.
> 
>> On Fri, Feb 19, 2016 at 12:02 PM, Anthony Nadalin <[email-masked]> wrote:
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Sat, 20 Feb 2016 02:32:34 +0000

Great idea!  IIW might be a bit pushing it, but I should be able to participate in an interop by CIS time with at least a partial implementation (patch might be implemented by then).  I suggest we get a list of interested parties and have a session or two on logistics and test scenarios we want to cover.

Cheers,
Morteza

From: scim <[email-masked]<mailto:[email-masked]>> on behalf of Phil Hunt <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 19, 2016 at 9:44 AM
To: Ian Glazer <[email-masked]<mailto:[email-masked]>>
Cc: Anthony Nadalin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Interop at CIS!

Iiw is best for us

Phil

On Feb 19, 2016, at 10:17, Ian Glazer <[email-masked]<mailto:[email-masked]>> wrote:

On Fri, Feb 19, 2016 at 12:02 PM, Anthony Nadalin <[email-masked]<mailto:[email-masked]>> wrote:
I'm not sure what you are going to interop against (configurations, scenarios, etc), also July at IETF may be a alternative choice

From: scim [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ian Glazer
Sent: Friday, February 19, 2016 6:34 AM
To: [email-masked]<mailto:[email-masked]> WG <[email-masked]<mailto:[email-masked]>>
Subject: [scim] Interop at CIS!

All -

i

--
Ian Glazer
Senior Director, Identity
+1 202 255 3166<tel:%2B1%20202%20255%203166>
@iglazer<https://na01.safelinks.protection.outlook.com/?url=https%3a%2f%2ftwitter.com%2figlazer&data=01%7c01%7ctonynad%40microsoft.com%7c9032ff9a10404dd17cd308d33939bdda%7c72f988bf86f141af91ab2d7cd011db47%7c1&sdata=0tsoMBgVW1bUl9kKpGkLCW%2bHpDIujgBS7D8YTuu75k8%3d>

--
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer<https://twitter.com/iglazer>
_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim

---

From: Ian Glazer <[email-masked]>
Date: Mon, 22 Feb 2016 09:58:16 -0500

Sounds good Morteza. (I've got patch mostly implemented and very much want
to test it.)

So we've got me and Morteza. Kelly, you in?

On Fri, Feb 19, 2016 at 9:32 PM, Morteza Ansari (moransar) <
[email-masked]> wrote:

> Great idea!  IIW might be a bit pushing it, but I should be able to
> participate in an interop by CIS time with at least a partial
> implementation (patch might be implemented by then).  I suggest we get a
> list of interested parties and have a session or two on logistics and test
> scenarios we want to cover.
>
>
> Cheers,
> Morteza
>
> From: scim <[email-masked]> on behalf of Phil Hunt <
> [email-masked]>
> To: Ian Glazer <[email-masked]>
> Cc: Anthony Nadalin <[email-masked]>, "[email-masked]" <
> [email-masked]>
> I was treating CIS as a forcing function to put interop configs,
> scenarios, etc together. First thing first, we need to indicate to CIS
> whether we want the time or not.
>

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 22 Feb 2016 16:38:08 +0000

Yes – SailPoint is in with at least a server and hopefully a client.  Although, PATCH support is not likely.  CIS works well for us.

From: scim [mailto:[email-masked]] On Behalf Of Ian Glazer
Sent: Monday, February 22, 2016 8:58 AM
To: Morteza Ansari (moransar) <[email-masked]>
Cc: Anthony Nadalin <[email-masked]>; [email-masked] WG <[email-masked]>; Phil Hunt (IDM) <[email-masked]>
Subject: Re: [scim] Interop at CIS!

Sounds good Morteza. (I've got patch mostly implemented and very much want to test it.)

On Fri, Feb 19, 2016 at 9:32 PM, Morteza Ansari (moransar) <[email-masked]<mailto:[email-masked]>> wrote:
Great idea!  IIW might be a bit pushing it, but I should be able to participate in an interop by CIS time with at least a partial implementation (patch might be implemented by then).  I suggest we get a list of interested parties and have a session or two on logistics and test scenarios we want to cover.

Cheers,
Morteza

Iiw is best for us

Phil

All -

i

---

From: Ian Glazer <[email-masked]>
Date: Mon, 22 Feb 2016 11:47:22 -0500

We may end up with a whole lot of servers... but we'll figure it out

On Mon, Feb 22, 2016 at 11:38 AM, Kelly Grizzle <[email-masked]

> Yes – SailPoint is in with at least a server and hopefully a client.
> Although, PATCH support is not likely.  CIS works well for us.
>
>
>
> *Sent:* Monday, February 22, 2016 8:58 AM
> *To:* Morteza Ansari (moransar) <[email-masked]>
> *Cc:* Anthony Nadalin <[email-masked]>; [email-masked] WG <
> [email-masked]>; Phil Hunt (IDM) <[email-masked]>
>
> *Subject:* Re: [scim] Interop at CIS!
>
>
>
> *From: *scim <[email-masked]> on behalf of Phil Hunt <
> [email-masked]>
> *Date: *Friday, February 19, 2016 at 9:44 AM
> *To: *Ian Glazer <[email-masked]>
> *Cc: *Anthony Nadalin <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: [scim] Interop at CIS!
>
>
>
> Iiw is best for us
>
> Phil
>
>

---

From: Kelly Grizzle <[email-masked]>
Date: Mon, 22 Feb 2016 16:54:34 +0000

We have written a SCIM library that will make it trivial to create a SCIM client.  So … even if we don’t have an official one by that point, I can slap something together.

From: scim [mailto:[email-masked]] On Behalf Of Ian Glazer
Sent: Monday, February 22, 2016 10:47 AM
To: Kelly Grizzle <[email-masked]>
Cc: Anthony Nadalin <[email-masked]>; Phil Hunt (IDM) <[email-masked]>; Morteza Ansari (moransar) <[email-masked]>; [email-masked] WG <[email-masked]>
Subject: Re: [scim] Interop at CIS!

On Mon, Feb 22, 2016 at 11:38 AM, Kelly Grizzle <[email-masked]<mailto:[email-masked]>> wrote:
Yes – SailPoint is in with at least a server and hopefully a client.  Although, PATCH support is not likely.  CIS works well for us.

From: scim [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Ian Glazer
Sent: Monday, February 22, 2016 8:58 AM
To: Morteza Ansari (moransar) <[email-masked]<mailto:[email-masked]>>
Cc: Anthony Nadalin <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> WG <[email-masked]<mailto:[email-masked]>>; Phil Hunt (IDM) <[email-masked]<mailto:[email-masked]>>

Cheers,
Morteza

Iiw is best for us

Phil

All -

i

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Mon, 22 Feb 2016 19:31:59 +0000

That would be great as ours will also be a server!

From: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 22, 2016 at 8:54 AM
To: Ian Glazer <[email-masked]<mailto:[email-masked]>>
Cc: Anthony Nadalin <[email-masked]<mailto:[email-masked]>>, Phil Hunt <[email-masked]<mailto:[email-masked]>>, Morteza <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [scim] Interop at CIS!

From: scim [mailto:[email-masked]] On Behalf Of Ian Glazer
Sent: Monday, February 22, 2016 10:47 AM
To: Kelly Grizzle <[email-masked]<mailto:[email-masked]>>
Cc: Anthony Nadalin <[email-masked]<mailto:[email-masked]>>; Phil Hunt (IDM) <[email-masked]<mailto:[email-masked]>>; Morteza Ansari (moransar) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [scim] Interop at CIS!

Cheers,
Morteza

Iiw is best for us

Phil

All -

i