Subject: [scim] [Technical Errata Reported] RFC7644 (4670)

From: RFC Errata System <[email-masked]>
Date: Fri, 15 Apr 2016 13:20:27 -0700 (PDT)

The following errata report has been submitted for RFC7644,
"System for Cross-domain Identity Management: Protocol".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7644&eid=4670

--------------------------------------
Type: Technical
Reported by: Vassilis Michalitsis <[email-masked]>

Section: 3.4.2.2

Original Text
-------------
Filters MUST be evaluated using the following order of operations, in
   order of precedence:

   1.  Grouping operators

   2.  Logical operators - where "not" takes precedence over "and",
       which takes precedence over "or"

   3.  Attribute operators

Corrected Text
--------------
Filters MUST be evaluated using the following order of operations, in
   order of precedence:

   1.  Grouping operators

   2.  Attribute operators

   3.  Logical operators - where "not" takes precedence over "and",
       which takes precedence over "or"

Notes
-----
It seems that the precedence of logical and attribute precedence is reversed? The filter filter=title sw "M" and userType eq "Employee" is meant to be interpreted as filter=(title sw "M") and (userType eq "Employee"). 
This is also the "expected" behaviour consistent with most other languages - with the notable exception of unary "or" which in SCIM is disambiguated as it can only apply to a parenthesized filter expression.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7644 (draft-ietf-scim-api-19)
--------------------------------------
Title               : System for Cross-domain Identity Management: Protocol
Publication Date    : September 2015
Author(s)           : P. Hunt, Ed., K. Grizzle, M. Ansari, E. Wahlstroem, C. Mortimore
Category            : PROPOSED STANDARD
Source              : System for Cross-domain Identity Management
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: "Leif Johansson" <[email-masked]>
Date: Sun, 17 Apr 2016 22:06:26 +0200

Somebody want to venture an opinion on this?

Skickat från min iPhone

> 15 apr. 2016 kl. 22:21 skrev RFC Errata System <[email-masked]>:
>

---

From: Phil Hunt <[email-masked]>
Date: Sun, 17 Apr 2016 14:21:54 -0700

Need to check the history. I recall it was changed during IESG review. 

Phil

> On Apr 17, 2016, at 13:06, Leif Johansson <[email-masked]> wrote:
>

---

From: Phil Hunt <[email-masked]>
Date: Mon, 18 Apr 2016 10:48:29 -0700

Just confirming that the text was changed between drafts 17-19 during the IESG review process based on feedback that we had a normative reference to wikipedia which wasn’t valid.

The order of the list really depends on how you interpret the overall sentence structure. At present I do find it somewhat awkward.

For example, if you are taking a parser perspective, you are breaking down the filter based on the order specified.  However, if you are saying which rule is more important than the other, than the proposed text is correct.

Would appreciate other comments.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Apr 17, 2016, at 1:06 PM, Leif Johansson <[email-masked]> wrote:
>