Subject: [scim] next steps for scim

From: Leif Johansson <[email-masked]>
Date: Wed, 6 Apr 2016 15:33:46 +0200

Folks,

We've done this a couple of times already ... this will be the
last attempt to judge interest for next steps in the SCIM WG.

We will now generate a definitive list of possible work for SCIM
going forward *excluding* the ID events stuff that will probably
spin up its own WG.

Please respond to this email no later than EOB April 30 with a
link to a current (non-expired) I-D describing work that would
(in your opinion) fit in the SCIM WG.

On May 1:st (or thereabouts) the WG will be asked to +1/-1 the
proposed I-Ds in an attempt to judge interest in continuing work
on them in the SCIM wg.

If there is insufficient interest at this time we will close
SCIM (the WG, not the list) while we wait for SCIMEXT to emerge
from the ashes at some point in the future.

	Cheers Leif

---

From: Phil Hunt <[email-masked]>
Date: Wed, 6 Apr 2016 10:43:01 -0300

Few topics for the charter (I’ll think of more):

*  SCIM Events to be done in parallel with id-events
*  SCIM Discovery following resolution of the OAuth WG drafts for discovery
*  Schema extensions - getting a log of requests for having SCIM resource types like OAuthClient — maybe this doesn’t have to be done as a WG charter item?

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Apr 6, 2016, at 10:33 AM, Leif Johansson <[email-masked]> wrote:
> 
> 
> Folks,
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Leif Johansson <[email-masked]>
Date: Wed, 6 Apr 2016 15:43:59 +0200

On 2016-04-06 15:43, Phil Hunt wrote:
> *  Schema extensions - getting a log of requests for having SCIM
> resource types like OAuthClient — maybe this doesn’t have to be done as
> a WG charter item?

Can you provide current I-D links to those?

> 
> Phil
> 
> @independentid
> www.independentid.com <http://www.independentid.com>
> [email-masked] <mailto:[email-masked]>
> 
> 
> 
> 
> 
>> On Apr 6, 2016, at 10:33 AM, Leif Johansson <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>
>> Folks,
>>
>> [email-masked] <mailto:[email-masked]>

---

From: Phil Hunt <[email-masked]>
Date: Wed, 6 Apr 2016 10:52:27 -0300

in line...
Phil

@independentid

> On Apr 6, 2016, at 10:43 AM, Leif Johansson <[email-masked]> wrote:
> 
[ph]
https://tools.ietf.org/html/draft-hunt-idevent-scim-00
>> *  SCIM Discovery following resolution of the OAuth WG drafts for discovery
[ph]
https://tools.ietf.org/html/draft-hunt-scim-discovery-00 <https://tools.ietf.org/html/draft-hunt-scim-discovery-00>  - (this needs more work)

>> resource types like OAuthClient — maybe this doesn’t have to be done as
[ph] No draft yet, but for example, look to:
https://tools.ietf.org/html/rfc7591 <https://tools.ietf.org/html/rfc7591>  Section 2

I’m not sure there is a strong “interop” need here. But what I’m hearing is that a lot of people are doing it for their own needs. Seems worth while to register it.
>> www.independentid.com <http://www.independentid.com/> <http://www.independentid.com <http://www.independentid.com/>>
>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>> 
>> 
>> 
>> 
>> 
>>> On Apr 6, 2016, at 10:33 AM, Leif Johansson <[email-masked] <mailto:[email-masked]>
>>> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>>> 
>>> 
>>> Folks,
>>> 
>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>>> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>
>> 
> 
> 
> https://www.ietf.org/mailman/listinfo/scim <https://www.ietf.org/mailman/listinfo/scim>

---

From: Leif Johansson <[email-masked]>
Date: Wed, 6 Apr 2016 15:53:36 +0200

> Phil

thx!

>> On Apr 6, 2016, at 10:43 AM, Leif Johansson <[email-masked]
> https://tools.ietf.org/html/draft-hunt-scim-discovery-00  - (this needs
> more work)
> 
> https://tools.ietf.org/html/rfc7591  Section 2
> 
> I’m not sure there is a strong “interop” need here. But what I’m hearing
> is that a lot of people are doing it for their own needs. Seems worth
> while to register it.
>>
>>> www.independentid.com
>>> <http://www.independentid.com/> <http://www.independentid.com
>>> <http://www.independentid.com/>>
>>> [email-masked]
>>> <mailto:[email-masked]> <mailto:[email-masked]>
>>>
>>>
>>>
>>>
>>>
>>>> <mailto:[email-masked]>
>>>> [email-masked] <mailto:[email-masked]> <mailto:[email-masked]>

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Wed, 6 Apr 2016 14:07:19 +0000

SCIM Soft Delete 
https://tools.ietf.org/html/draft-ansari-scim-soft-delete-00 (though it is
not current, but I can easily resubmit it if that makes a difference).

Cheers,
Morteza

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Wed, 13 Apr 2016 19:44:37 +0000

Any other extensions/drafts/Š?  Or thoughts about next steps for SCIM WG?

Cheers,
Morteza

---

From: Mark Wahl <[email-masked]>
Date: Wed, 13 Apr 2016 20:12:29 +0000

Extensions for use by polling clients? https://datatracker.ietf.org/doc/draft-mcmurtry-scim-polling/ 
Profiles for SCIM alongside OpenID Connect? E.g.,  https://tools.ietf.org/id/draft-wahl-scim-jit-profile-02.txt 

Mark Wahl
Microsoft Corporation

-----Original Message-----
From: Morteza Ansari (moransar) [mailto:[email-masked]] 
Sent: Wednesday, April 13, 2016 12:45 PM
To: Morteza Ansari (moransar) <[email-masked]>; Leif Johansson <[email-masked]>; [email-masked]
Subject: Re: [scim] next steps for scim

Cheers,
Morteza

On 4/6/16, 11:07 AM, "scim on behalf of Morteza Ansari (moransar)"
<[email-masked] on behalf of [email-masked]> wrote:

>SCIM Soft Delete
>https://tools.ietf.org/html/draft-ansari-scim-soft-delete-00 (though it 
>is not current, but I can easily resubmit it if that makes a difference).
>
>
>Cheers,
>Morteza
>
>>We've done this a couple of times already ... this will be the last 
>>attempt to judge interest for next steps in the SCIM WG.
>>
>>We will now generate a definitive list of possible work for SCIM going 
>>forward *excluding* the ID events stuff that will probably spin up its 
>>own WG.
>>
>>Please respond to this email no later than EOB April 30 with a link to 
>>a current (non-expired) I-D describing work that would (in your 
>>opinion) fit in the SCIM WG.
>>
>>proposed I-Ds in an attempt to judge interest in continuing work on 
>>them in the SCIM wg.
>>
>>If there is insufficient interest at this time we will close SCIM (the 
>>WG, not the list) while we wait for SCIMEXT to emerge from the ashes 
>>at some point in the future.
>>
>>	Cheers Leif
>>

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Wed, 13 Apr 2016 15:07:08 -0700

I spoke with Craig and Tony and it looks like this could be folded into the identity events work possibly with a scim specific profile. 

Phil

> On Apr 13, 2016, at 13:12, Mark Wahl <[email-masked]> wrote:
>